Bug 8090 - forcedeth driver with 2.6.21-rc1 changes fails to handle packets
Summary: forcedeth driver with 2.6.21-rc1 changes fails to handle packets
Status: CLOSED PATCH_ALREADY_AVAILABLE
Alias: None
Product: Drivers
Classification: Unclassified
Component: Network (show other bugs)
Hardware: i386 Linux
: P2 high
Assignee: Jeff Garzik
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-02-26 11:03 UTC by David P. Reed
Modified: 2007-02-27 13:53 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.21-rc1
Tree: Mainline
Regression: ---


Attachments

Description David P. Reed 2007-02-26 11:03:11 UTC
Most recent kernel where this bug did *NOT* occur: 2.6.20
Distribution: fedora core 6, new kernel
Hardware Environment: HP dv9000z laptop (AMD 64x2 SMP, nforce chipset, 2 GB ram)
Software Environment: kernel 2.6.21-rc1 built using FC6 .config options.

Problem Description:
after boot, eth0 stops working

Steps to reproduce:
build kernel, install, boot.   driver loads, but after about 7 packets, stops
working - no packets getting through.

back out just the forcedeth.c diffs, kernel works as well as 2.6.20 (better,
actually, since sata_nv seems to be less buggy), in particular eth0 works.
Comment 1 Ayaz Abdulla 2007-02-26 23:17:14 UTC
Did you try the following patch set?
http://marc.theaimsgroup.com/?l=linux-netdev&m=117199770027017&w=2
Comment 2 David P. Reed 2007-02-27 07:45:47 UTC
Ayaz - the patch you mention here does fix this problem for me. Thanks!
Comment 3 Adrian Bunk 2007-02-27 13:53:43 UTC
The patch that fixes this bug is now in Linus' tree.

Note You need to log in before you can comment on or make changes to this bug.