Bug 8082 - kernel doesn't link properly because of net/built-in.o
Summary: kernel doesn't link properly because of net/built-in.o
Status: REJECTED DUPLICATE of bug 8050
Alias: None
Product: Networking
Classification: Unclassified
Component: IPV6 (show other bugs)
Hardware: i386 Linux
: P2 blocking
Assignee: Hideaki YOSHIFUJI
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-02-25 14:57 UTC by Mircea Bardac
Modified: 2007-02-25 16:44 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.21-rc1-git1
Tree: Mainline
Regression: ---


Attachments

Description Mircea Bardac 2007-02-25 14:57:15 UTC
Most recent kernel where this bug did *NOT* occur: probably 2.6.20
Distribution: ArchLinux
Hardware Environment: irrelevant
Software Environment: irrelevant
Problem Description: kernel doesn't link properly because of net/built-in.o

Steps to reproduce:

I'm trying to compile a distribution kernel (with lots of modules enabled, using
the previous config* but on the latest kernel)


Config:
http://cvs.archlinux.org/cgi-bin/viewcvs.cgi/*checkout*/kernels/kernel26/config?rev=1.89&cvsroot=Current&only_with_tag=CURRENT


Last output:

  CHK     include/linux/compile.h
  UPD     include/linux/compile.h
  CC      init/version.o
  LD      init/built-in.o
  LD      .tmp_vmlinux1
net/built-in.o: In function `svc_udp_recvfrom':
svcsock.c:(.text+0x7ada4): undefined reference to `__ipv6_addr_type'
make: *** [.tmp_vmlinux1] Error 1
Comment 1 Adrian Bunk 2007-02-25 16:44:05 UTC
Fix will be in 2.6.21-rc2.

*** This bug has been marked as a duplicate of 8050 ***

Note You need to log in before you can comment on or make changes to this bug.