Bug 8080 - First battery is not detected - regression vs 2.6.20 - Asus M6Ne
First battery is not detected - regression vs 2.6.20 - Asus M6Ne
Status: REJECTED DUPLICATE of bug 8066
Product: ACPI
Classification: Unclassified
Component: Power-Battery
i386 Linux
: P2 normal
Assigned To: acpi_power-battery
:
Depends on: 7907
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-25 06:07 UTC by Janosch Machowinski
Modified: 2007-03-08 15:37 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.21-rc1
Tree: Mainline
Regression: ---


Attachments
ACPI dump (118.64 KB, application/octet-stream)
2007-02-25 06:08 UTC, Janosch Machowinski
Details
output of dmesg -s 64000 (15.32 KB, text/plain)
2007-02-25 06:10 UTC, Janosch Machowinski
Details
dmesg from 2.6.21-rc3 (25.13 KB, text/plain)
2007-03-07 14:41 UTC, Janosch Machowinski
Details

Description Janosch Machowinski 2007-02-25 06:07:46 UTC
Most recent kernel where this bug did *NOT* occur: 2.6.20
Distribution: Gentoo
Hardware Environment: Asus M6Ne
Software Environment: -
Problem Description:
The first battery is not detected. If I boot 2.6.21-rc1, only the second 
battery is detected (this notebook can hold an optional second battery in the 
cdrom bay). There are also some strange looking ACPI errors during hdd 
detection.

Steps to reproduce:
boot the kernel
Comment 1 Janosch Machowinski 2007-02-25 06:08:48 UTC
Created attachment 10527 [details]
ACPI dump
Comment 2 Janosch Machowinski 2007-02-25 06:10:21 UTC
Created attachment 10528 [details]
output of dmesg -s 64000
Comment 3 Vladimir Lebedev 2007-03-01 11:49:50 UTC
Sorry, but dmesg is not full.
 
Comment 4 Len Brown 2007-03-06 22:05:02 UTC
[   21.038694] ata_piix 0000:00:1f.1: version 2.00ac7
[   21.038710] PCI: Enabling device 0000:00:1f.1 (0005 -> 0007)
[   21.038775] ACPI: PCI Interrupt 0000:00:1f.1[A] -> Link [LNKC] -> GSI 10 
(level, low) -> IRQ 10
[   21.038953] PCI: Setting latency timer of device 0000:00:1f.1 to 64
[   21.039026] ata1: PATA max UDMA/100 cmd 0x000101f0 ctl 0x000103f6 bmdma 
0x0001ffa0 irq 14
[   21.039136] ata2: PATA max UDMA/100 cmd 0x00010170 ctl 0x00010376 bmdma 
0x0001ffa8 irq 15
[   21.039234] scsi0 : ata_piix
[   21.212786] ACPI Error (dsopcode-0481): Attempt to CreateField of length 
zero [20070126]
[   21.212952] ACPI Error (psparse-0537): Method parse/execution failed 
[\_SB_.PCI0.IDE0.RATA] (Node c14776d0), AE_AML_OPERAND_VALUE
[   21.213273] ACPI Error (psparse-0537): Method parse/execution failed 
[\_SB_.PCI0.IDE0.CHN0.DRV0._GTF] (Node c1479d9c), AE_AML_OPERAND_VALUE
[   21.213586] ata1.00: ATA-6: IC25N060ATMR04-0, MO3OAD4A, max UDMA/100
[   21.213649] ata1.00: 117210240 sectors, multi 16: LBA48 
[   21.232677] ACPI Error (dsopcode-0481): Attempt to CreateField of length 
zero [20070126]
[   21.232841] ACPI Error (psparse-0537): Method parse/execution failed 
[\_SB_.PCI0.IDE0.RATA] (Node c14776d0), AE_AML_OPERAND_VALUE
[   21.233149] ACPI Error (psparse-0537): Method parse/execution failed 
[\_SB_.PCI0.IDE0.CHN0.DRV0._GTF] (Node c1479d9c), AE_AML_OPERAND_VALUE


This appers to be the known _GTF before _STM bug.
Please boot with "libata.ata_acpi=0"
and verify that these messages go away,
and report if it has any effect on the battery problem.
Comment 5 Janosch Machowinski 2007-03-07 14:41:10 UTC
Created attachment 10645 [details]
dmesg from 2.6.21-rc3

Full dmesg of 2.6.21-rc3
Comment 6 Janosch Machowinski 2007-03-07 14:58:26 UTC
> This appers to be the known _GTF before _STM bug.
> Please boot with "libata.ata_acpi=0"
> and verify that these messages go away,
> and report if it has any effect on the battery problem.

2.6.21-rc3 says, that libata.ata_acpi=0 is an unknown boot parameter. Checked 
for typos 3 times. Any ideas ?
Comment 7 Len Brown 2007-03-07 22:22:17 UTC
hmmm, apparently that hook was distro specific.
Looks like the upstream one should be libata.noacpi=1
If that doesn't work, build with CONFIG_SATA_ACPI=n
Comment 8 Len Brown 2007-03-07 22:31:21 UTC
I expect the SATA error messages are independent of the battery issue,
which is surely related to this:

[   20.532202] ACPI Exception (evregion-0420): AE_NOT_FOUND, Returned by 
Handler for [EmbeddedControl] [20070126]
[   20.532376] ACPI Error (psparse-0537): Method parse/execution failed 
[\_SB_.PCI0.SBRG.EC0_.ACS_] (Node c147cf2c), AE_NOT_FOUND
[   20.532691] ACPI Error (psparse-0537): Method parse/execution failed 
[\_SB_.AC__._INI] (Node c147a75c), AE_NOT_FOUND

which may be related to bug #8066 -- can you try the patch there?
Comment 9 Janosch Machowinski 2007-03-08 15:31:09 UTC
libata.noacpi=1 removed the ATA errors and
the patch from comment #9 (id=10582) from bug 8066 resolved 
the battery issue. The systems seems to work now.
How do I close this bug in a correct way ? ;-)
Comment 10 Len Brown 2007-03-08 15:37:21 UTC
Thanks for testing.

The battery issue reported is thus a duplicate of bug #8066

The libata.noacpi=1 issue is handled in bug #7907




*** This bug has been marked as a duplicate of 8066 ***

Note You need to log in before you can comment on or make changes to this bug.