Bug 8050 - 2.6.21-rc1 build errors on x86/ARM with built-in NFS / modular IPV6
2.6.21-rc1 build errors on x86/ARM with built-in NFS / modular IPV6
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: File System
Classification: Unclassified
Component: NFS
i386 Linux
: P2 high
Assigned To: Neil Brown
:
: 8082 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-21 10:56 UTC by Michael-Luke Jones
Modified: 2007-02-25 16:44 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.21-rc1
Tree: Mainline
Regression: ---


Attachments
Config leading to compile failure (43.57 KB, text/plain)
2007-02-21 10:58 UTC, Michael-Luke Jones
Details
x86 config leading to second compile error (29.96 KB, text/plain)
2007-02-22 09:23 UTC, Michael-Luke Jones
Details

Description Michael-Luke Jones 2007-02-21 10:56:19 UTC
Most recent kernel where this bug did *NOT* occur: 2.6.20.1
Distribution: NSLU2-Linux
Software Environment: GCC 4.1.1 ARM Cross Compiler
Problem Description:
  GEN     .version
  CHK     include/linux/compile.h
  UPD     include/linux/compile.h
  CC      init/version.o
  LD      init/built-in.o
  LD      .tmp_vmlinux1
net/built-in.o: In function `svc_udp_recvfrom':
sysctl_net.c:(.text+0x79fb4): undefined reference to `__ipv6_addr_type'
make[1]: *** [.tmp_vmlinux1] Error 1

Steps to reproduce:
Compile kernel with attached defconfig
Comment 1 Michael-Luke Jones 2007-02-21 10:58:34 UTC
Created attachment 10485 [details]
Config leading to compile failure
Comment 2 Michael-Luke Jones 2007-02-21 10:59:10 UTC
Also see http://lkml.org/lkml/2007/2/21/76 (NB: I meant 2.6.21-rc1 not 2.6.20-rc1)
Comment 3 Michael-Luke Jones 2007-02-22 09:10:18 UTC
Apparently 'svc_udp_recvfrom' is an NFS function, so it looks like an NFS rather than an IPV6 issue.
Comment 4 Michael-Luke Jones 2007-02-22 09:22:45 UTC
Similar (but not identical) error on x86 with new defconfig (attached above)

New Error:
  GEN     .version
  CHK     include/linux/compile.h
  UPD     include/linux/compile.h
  CC      init/version.o
  LD      init/built-in.o
  LD      .tmp_vmlinux1
net/built-in.o: In function `svc_udp_get_sender_address':
svcsock.c:(.text+0x79754): undefined reference to `__ipv6_addr_type'
make: *** [.tmp_vmlinux1] Error 1
Comment 5 Michael-Luke Jones 2007-02-22 09:23:42 UTC
Created attachment 10495 [details]
x86 config leading to second compile error

NFS Built In / IPV6 Modular
Comment 6 Trond Myklebust 2007-02-22 12:18:47 UTC
This is a server issue, so I'm reassigning to Neil. I do believe I saw a report
for this problem fly by on lkml yesterday, though, so I assume that a patch
is forthcoming.
Comment 7 Michael-Luke Jones 2007-02-25 15:10:14 UTC
Problem appears to be fixed upstream in net-2.6 tree.

For reference, here are the patches against 2.6.21-rc1 that fixed the MODPOST problem for us:
http://trac.nslu2-linux.org/kernel/changeset/762

Thanks for help,
Michael-Luke Jones
Comment 8 Adrian Bunk 2007-02-25 16:44:08 UTC
*** Bug 8082 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.