Bug 793 - Thinkpad T30, new BIOS, and ACPI
Summary: Thinkpad T30, new BIOS, and ACPI
Status: REJECTED DUPLICATE of bug 1038
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Battery (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Shaohua
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-06-09 12:17 UTC by Peter Johanson
Modified: 2004-03-03 21:38 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.5.70-mm6
Tree: Mainline
Regression: ---


Attachments
dmesg before closing lid (11.14 KB, text/plain)
2003-06-09 12:18 UTC, Peter Johanson
Details

Description Peter Johanson 2003-06-09 12:17:49 UTC
Distribution: gentoo
Hardware Environment: T30 with BIOS v2.04 and EC v1.03
Software Environment:
Problem Description: I recently upgraded the BIOS and embedded controller on my
thinkpad T30 to the latest released by IBM. This has fixed the invalid ECDT
table, which had forced me to use the small patch from 
http://www.poupinou.org/acpi/ibm_ecdt.html
to get ACPI working. Now the table passes the test, and a lot of the ACPI stuff
works. the problem is now when i close and re-open the lid on my laptop. the
system turns nearly unresponsive, and dmesg shows a *ton* of lines:

 ACPI-0295: *** Error: AE_TIME while evaluating method [_L18] for GPE[ 0]
    ACPI-0345: *** Error: Handler for [EmbeddedControl] returned AE_TIME
    ACPI-1121: *** Error: Method execution failed [\_GPE._L18] (Node c1ae74c0), 
AE_TIME
    ACPI-0295: *** Error: AE_TIME while evaluating method [_L18] for GPE[ 0]
    ACPI-0345: *** Error: Handler for [EmbeddedControl] returned AE_TIME
    ACPI-1121: *** Error: Method execution failed [\_GPE._L18] (Node c1ae74c0), 
AE_TIME

and top shows events/0 taking about 10% of the CPU. i will attach my dmesg
output from the system before closing the lid.

Steps to reproduce: close lid  & reopen it.
Comment 1 Peter Johanson 2003-06-09 12:18:53 UTC
Created attachment 403 [details]
dmesg before closing lid

dmesg from before closing the lid
Comment 2 Peter Johanson 2003-08-31 09:52:26 UTC
applying the fix for the embedded controller found on redhat's bugzilla found at
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=98849

makes all the load errors go away, and i can actually close the lid of my T30
and not have it freak out... suspend seems to almost work, as echoing things to
/sys/power/state causes momentary blanks, and dmesg shows it shutting things
down and starting again... not sure what isn't stopping properly... 
Comment 3 Ruben Puettmann 2003-09-18 07:12:32 UTC
Please take a look at :

http://bugme.osdl.org/show_bug.cgi?id=1038
Comment 4 Peter Johanson 2003-09-23 08:04:18 UTC
i've applied the battery patch from that bug, and that helps. Shall i mark this
as duplicate of bug#1038 and just follow that bug?
Comment 5 Shaohua 2003-11-04 03:07:09 UTC

*** This bug has been marked as a duplicate of 1038 ***

Note You need to log in before you can comment on or make changes to this bug.