Bug 7920 - platinumfb - video display problem
platinumfb - video display problem
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: Drivers
Classification: Unclassified
Component: Console/Framebuffers
i386 Linux
: P2 blocking
Assigned To: Benjamin Herrenschmidt
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-01 16:36 UTC by Tomasz Grzegurzko
Modified: 2008-02-14 21:22 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.17-rc4, 2.6.16, 2.6.15, 2.6.14
Tree: Mainline
Regression: ---


Attachments
platinumfb fixes extracted from 2.6.22-git1 (17.43 KB, patch)
2007-10-12 04:33 UTC, Tomasz Grzegurzko
Details | Diff

Description Tomasz Grzegurzko 2007-02-01 16:36:24 UTC
Hi all,

I managed to get my hands on a PowerMac 7200 and am
trying to boot. I (cross) compiled a kernel of
2.6.16.16 from a gentoo x86 box, and serially connected
the machine to view the console output results. I have
stripped out basically everything (no IDE, SCSI, USB)
except serial, framebuffer, console and ADB.

The framebuffer won't enable using the platinumfb for
the life of me when using BootX from a MacOS 7.6.1
installation on another hard drive. I've dropped a new
AHA2940 (bios flashed to OpenFirmware) SCSI card with
another attached hard drive to it (8GB of SCSI
goodness) so I can hack away to my hearts
content.

I have a successful installation of Debian 3.1 on this
HDD from a previously successful attempt some months
ago using the miboot boot/root install set from:
http://people.debian.org/~luther/d-i/sid/images/daily/
The daily builds I tried were 18-20 May 2006, and while
I believe the kernel has booted okay (since I can
insert the root floppy and hit enter and it does
something) I can't see anything on the screen.

I have a native mac monitor, MacOS runs at 640x480
happily. I can boot the debian/woody kernel (2.2)
series with the platinumfb driver, and zapola
everything is okay. I get screen output. I can boot off
one of my custom built 2.6.x kernels, specifying the
serial console as a the console=... parameter and sure
enough the system comes up without a hitch except that
the monitor is in 'off' mode. I have tried kernels
2.6.17-rc4, 2.6.16, 2.6.15, 2.6.14 (cross-)compiled
from sources without any luck.

Using
http://www.jonh.net/lppcfom-serve/cache/1043.html, I
have tried to give also several boot paramters
(thankfully I'm using BootX to try this stuff out now,
because trying to recreate the miboot debian floppies
would not have made for easy testing), also without
luck. Some examples of failed boots follow:
video=platinumfb
video=platinumfb:vmode:6,cmode:8
video=platinumfb:vmode:13,cmode:8
.. all with the same end result: no video.

Can I work with anyone on fixing this? It would be nice
to have some working miboots again, but unfortunately I
can't remember which daily build I downloaded when I
actually installed sarge some months ago. I *think* it
was 2.6.15, but I can't follow the same steps now
because the other modules can't be downloaded from
package repositories as sid is in 2.6.16-land now. I
have also tried the video=ofonly options when that
option is compiled in to the kernel (by the way, I am
always statically compiling the fb devices in), the
ofonlyboot image from the miboot series, also without
any joy. In my own compilations, I only ever use either
the platinumfb or the ofonly framebuffer devices
compiled in, not both at once.

I know (specifically) with the 2.6.17-rc4 kernel, the output
is there (sorta), but kind of skewed. So a line is kind of
skewed across the screen, and you can see dots coming up but
they're all with a very deep slant.
So a normal line would look like this:
..................................
What I get is this:
                      ..........
                  ...........
          ...............
       ..............
I didn't think to mention it before because its darn hard to
explain =)

-Tomasz
Comment 1 Anonymous Emailer 2007-02-01 17:11:50 UTC
Reply-To: akpm@linux-foundation.org

On Thu, 1 Feb 2007 16:45:15 -0800
bugme-daemon@bugzilla.kernel.org wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=7920
> 
>            Summary: platinumfb - video display problem
>     Kernel Version: 2.6.17-rc4, 2.6.16, 2.6.15, 2.6.14
>             Status: NEW
>           Severity: blocking
>              Owner: jsimmons@infradead.org
>          Submitter: tomasz89@gmail.com
> 
> 
> Hi all,
> 
> I managed to get my hands on a PowerMac 7200 and am
> trying to boot. I (cross) compiled a kernel of
> 2.6.16.16 from a gentoo x86 box, and serially connected
> the machine to view the console output results. I have
> stripped out basically everything (no IDE, SCSI, USB)
> except serial, framebuffer, console and ADB.
> 
> The framebuffer won't enable using the platinumfb for
> the life of me when using BootX from a MacOS 7.6.1
> installation on another hard drive. I've dropped a new
> AHA2940 (bios flashed to OpenFirmware) SCSI card with
> another attached hard drive to it (8GB of SCSI
> goodness) so I can hack away to my hearts
> content.
> 
> I have a successful installation of Debian 3.1 on this
> HDD from a previously successful attempt some months
> ago using the miboot boot/root install set from:
> http://people.debian.org/~luther/d-i/sid/images/daily/
> The daily builds I tried were 18-20 May 2006, and while
> I believe the kernel has booted okay (since I can
> insert the root floppy and hit enter and it does
> something) I can't see anything on the screen.
> 
> I have a native mac monitor, MacOS runs at 640x480
> happily. I can boot the debian/woody kernel (2.2)
> series with the platinumfb driver, and zapola
> everything is okay. I get screen output. I can boot off
> one of my custom built 2.6.x kernels, specifying the
> serial console as a the console=... parameter and sure
> enough the system comes up without a hitch except that
> the monitor is in 'off' mode. I have tried kernels
> 2.6.17-rc4, 2.6.16, 2.6.15, 2.6.14 (cross-)compiled
> from sources without any luck.
> 
> Using
> http://www.jonh.net/lppcfom-serve/cache/1043.html, I
> have tried to give also several boot paramters
> (thankfully I'm using BootX to try this stuff out now,
> because trying to recreate the miboot debian floppies
> would not have made for easy testing), also without
> luck. Some examples of failed boots follow:
> video=platinumfb
> video=platinumfb:vmode:6,cmode:8
> video=platinumfb:vmode:13,cmode:8
> .. all with the same end result: no video.
> 
> Can I work with anyone on fixing this? It would be nice
> to have some working miboots again, but unfortunately I
> can't remember which daily build I downloaded when I
> actually installed sarge some months ago. I *think* it
> was 2.6.15, but I can't follow the same steps now
> because the other modules can't be downloaded from
> package repositories as sid is in 2.6.16-land now. I
> have also tried the video=ofonly options when that
> option is compiled in to the kernel (by the way, I am
> always statically compiling the fb devices in), the
> ofonlyboot image from the miboot series, also without
> any joy. In my own compilations, I only ever use either
> the platinumfb or the ofonly framebuffer devices
> compiled in, not both at once.
> 
> I know (specifically) with the 2.6.17-rc4 kernel, the output
> is there (sorta), but kind of skewed. So a line is kind of
> skewed across the screen, and you can see dots coming up but
> they're all with a very deep slant.
> So a normal line would look like this:
> ..................................
> What I get is this:
>                       ..........
>                   ...........
>           ...............
>        ..............
> I didn't think to mention it before because its darn hard to
> explain =)
> 
> -Tomasz
> 
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug, or are watching someone who is.

Comment 2 Benjamin Herrenschmidt 2007-02-04 18:58:15 UTC
Got myself a 7200, about to dig...
Comment 3 Benjamin Herrenschmidt 2007-02-04 20:39:43 UTC
I've reproduced all sort of breakage on this venerable 7200... platinumfb seems
to be a victim of over zealous region checking (the firmware sends too bogus
addresses and we fail a request_mem_region or two) and the 53c94 scsi driver is
having some serious vapours too. I'm trying to track all of that down but It may
take some time as I have one other higher priority thing to do. Hopefully, I
should have the 7200 back in shape before 2.6.21 is over tho :-)
Comment 4 Tomasz Grzegurzko 2007-02-04 20:42:26 UTC
Champion -- glad to see you've managed to reproduce. Was sifting through the
source myself but without better working knowledge I was down to comparing 2.2.x
(debian woody) diffs against 2.6.x -- suffice to say, many changes. If I can
help in any way though, I am happy to...
Comment 5 Natalie Protasevich 2007-07-04 12:30:11 UTC
Any update on this problem?
Thanks.
Comment 6 Tomasz Grzegurzko 2007-08-06 00:18:15 UTC
I've heard nothing on this for a while either.. Still got the 7200 on stand by for the proposed fixes..
Comment 7 Tomasz Grzegurzko 2007-10-12 01:20:26 UTC
commit 4c2a54b09ba35a409afc34bd331a57a994921664
Author: Benjamin Herrenschmidt <benh@kernel.crashing.org>
Date:   Wed Sep 19 14:50:22 2007 +1000

    [POWERPC] Fix platinumfb framebuffer
    
    Current kernels have a non-working platinumfb due to some resource
    management issues.  This fixes it.
    
    Signed-off-by: Benjamin Herrenschmidt <benh@kernel.crashing.org>
    Signed-off-by: Paul Mackerras <paulus@samba.org>

Is this what I think it is? :)
Either way, I'm going to test this out tonight!

Tomasz
Comment 8 Benjamin Herrenschmidt 2007-10-12 01:46:10 UTC
I got a 7200 booting recently with that fix plus a couple of other 601 related fixes. Hopefully .24 will work fine and the patch you pointed out should apply fine to 2.6.23 and also fix it.
Comment 9 Tomasz Grzegurzko 2007-10-12 04:33:27 UTC
Created attachment 13127 [details]
platinumfb fixes extracted from 2.6.22-git1

Good news: the -git1 version works for me (well not the whole patch, it doesn't compile, just the platinumfb changes)! See attached for what works for me against 2.6.22.

Note You need to log in before you can comment on or make changes to this bug.