Bug 7915 - Kernel OOPS while I/O scheduling
Summary: Kernel OOPS while I/O scheduling
Status: REJECTED DUPLICATE of bug 7727
Alias: None
Product: Other
Classification: Unclassified
Component: Other (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: David Howells
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-02-01 01:42 UTC by Sascha Willuweit
Modified: 2007-05-23 14:09 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.18.2
Tree: Mainline
Regression: ---


Attachments

Description Sascha Willuweit 2007-02-01 01:42:30 UTC
Most recent kernel where this bug did *NOT* occur:
Distribution: Gentoo 2006.1
Hardware Environment: IBM x235 (dual Xeon model 2, stepping 9)
Software Environment: gcc 3.4.6 w/ glibc 2.3.6 (nptl)
Problem Description: Kernel OOPS while scheduling (Anticipatory using Red Black
Tree)

Steps to reproduce: Run samba/ldap as PDC on a mid-sized domain (<100 workstations)

Kernel OOPS:
BUG: unable to handle kernel NULL pointer dereference at virtual address 00000008
 printing eip:
c10d61bc
*pde = 00000000
Oops: 0000 [#1]
SMP
Modules linked in: netconsole fat nfsd exportfs lockd nfs_acl sunrpc usb_storage
smbfs raid456 md_mod xor eeprom i2c_piix4 i2c_core parport_pc parport floppy
r8169 cfi_probe gen_probe scb2_flash mtdcore chipreg map_funcs tg3
CPU:    2
EIP:    0060:[<c10d61bc>]    Not tainted VLI
EFLAGS: 00010282   (2.6.18-gentoo-r2 #1)
EIP is at __rb_rotate_left+0xc/0x50
eax: f6e667c8   ebx: f6e667c8   ecx: 00000000   edx: 00000000
esi: f6e660c8   edi: c13c0ce0   ebp: c13c0ce0   esp: d5dbbecc
ds: 007b   es: 007b   ss: 0068
Process smbd (pid: 24872, ti=d5dba000 task=ed0d7000 task.ti=d5dba000)
Stack: da084148 f6e667c8 da0840c8 c10d62e1 da0840d0 00000000 da084194 f76c1600
       c10c12bd 0000001a da084140 000003f4 c12ddbc0 d5dbbf48 da0840c0 f6efa200
       ed0d7000 c10c1c9c ffffffff ed0d7000 1f3f0000 00000000 d5dbbf48 da0840c0 
                                 
Call Trace:                                                 
 [<c10d62e1>] rb_insert_color+0x91/0xa7                                        
        
 [<c10c12bd>] key_alloc+0x262/0x308                                                 
 [<c10c1c9c>] keyring_alloc+0x1e/0x4f                                          
      
 [<c10c32c7>] alloc_uid_keyring+0x5b/0x82                                      
          
 [<c124e2a7>] schedule+0x5ab/0x64c                                                 
 [<c102750b>] alloc_uid+0xc3/0x146                                                 
 [<c102aa16>] set_user+0xb/0x90                                                 
 [<c102ae78>] sys_setresuid+0x119/0x1d8                                        
        
 [<c1002c49>] sysenter_past_esp+0x56/0x79                                      
          
Code: e8 7c 63 f8 ff 8b 03 c7 04 83 00 00 00 00 48 85 c0 89 03 eb df b8 01 00 00
00 5b c3 90 90 90 57 89 d7 56 53 89 c3 8b 50 04 8b 30 <8b> 4a 08 83 e6 fc 85 c9
89 48 04 74 09 8b 01 83 e0 03 09 d8 89
EIP: [<c10d61bc>] __rb_rotate_left+0xc/0x50 SS:ESP 0068:d5dbbecc
Comment 1 Andrew Morton 2007-02-01 01:52:58 UTC
On Thu, 1 Feb 2007 01:51:17 -0800 bugme-daemon@bugzilla.kernel.org wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=7915

This bug is in the keyring management code, not the IO scheduler.

David, you don't appear to have a bugzilla account.

This appears to be the same bug as
http://bugzilla.kernel.org/show_bug.cgi?id=7727.  Can we fix it please?

Sascha, is this repeatable?  (Please respond via emailed reply-to-all)

Comment 2 Sascha Willuweit 2007-02-01 02:11:08 UTC
> On Thu, 1 Feb 2007 01:51:17 -0800 bugme-daemon@bugzilla.kernel.org wrote:
>
>> http://bugzilla.kernel.org/show_bug.cgi?id=7915
>
> This bug is in the keyring management code, not the IO scheduler.
>
> David, you don't appear to have a bugzilla account.
>
> This appears to be the same bug as
> http://bugzilla.kernel.org/show_bug.cgi?id=7727.  Can we fix it please?
>
> Sascha, is this repeatable?  (Please respond via emailed reply-to-all)
>

Hi,

I'm afraid, it is repeatable. Once in a week this happens.
And when I'm trying to make a local backup (using tar -czf to an local
disk) this produces the oops too. So, I think this is somehow connected to
IO.

-Sascha

Comment 3 Anonymous Emailer 2007-02-01 03:11:37 UTC
Reply-To: dhowells@redhat.com

Andrew Morton <akpm@osdl.org> wrote:

> This bug is in the keyring management code, not the IO scheduler.
> 
> David, you don't appear to have a bugzilla account.

No, it seems not.

I'll have a look at the bug anyway.  I'm sure it's also got a Fedora BZ #, but
I can't seem to find it.

David

Comment 4 Natalie Protasevich 2007-05-23 13:37:58 UTC
David,
Can you confirm that fix to http://bugzilla.kernel.org/show_bug.cgi?id=7727 also
applies to this bug?
Thanks,
--Natalie
Comment 5 David Howells 2007-05-23 14:09:51 UTC

*** This bug has been marked as a duplicate of 7727 ***

Note You need to log in before you can comment on or make changes to this bug.