Bug 7914 - Moto Q error with cdc-acm
Moto Q error with cdc-acm
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: USB
i386 Linux
: P2 blocking
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: USB
  Show dependency treegraph
 
Reported: 2007-01-31 19:51 UTC by Ted Logan
Modified: 2008-09-22 11:38 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.19
Tree: Mainline
Regression: ---


Attachments

Description Ted Logan 2007-01-31 19:51:34 UTC
drivers/usb/class/cdc-acm.c: Zero length descriptor references

cdc_acm: probe of 5-5.4:1.0 failed with error -22
usb 5-5.4: device_add(5-5.4:1.0) --> -22

lsusb reveals:
Bus 005 Device 022: ID 22b8:7001 Motorola PCS 

Same error as 
http://www.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=91a9c9214e34c364bf15406aadb922787ae7129b
Comment 1 Greg Kroah-Hartman 2007-01-31 20:52:11 UTC
On Wed, Jan 31, 2007 at 08:00:17PM -0800, bugme-daemon@bugzilla.kernel.org wrote:
> drivers/usb/class/cdc-acm.c: Zero length descriptor references
> 
> cdc_acm: probe of 5-5.4:1.0 failed with error -22
> usb 5-5.4: device_add(5-5.4:1.0) --> -22
> 
> lsusb reveals:
> Bus 005 Device 022: ID 22b8:7001 Motorola PCS 
> 
> Same error as 
> http://www.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=91a9c9214e34c364bf15406aadb922787ae7129b

Care to submit a patch much like the above so we can add it to the tree
with the proper credit?

Comment 2 Natalie Protasevich 2007-06-13 20:34:15 UTC
It looks like the patch is in - the bugzilla can be closed.


Note You need to log in before you can comment on or make changes to this bug.