Bug 7886 - sdhci or mmc suspend/resume problem
sdhci or mmc suspend/resume problem
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Flash/Memory Technology Devices
i386 Linux
: P2 low
Assigned To: Rafael J. Wysocki
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2007-01-25 12:41 UTC by Felix Triebel
Modified: 2007-06-24 13:53 UTC (History)
0 users

See Also:
Kernel Version: 2.6.19.2-grsec
Tree: Mainline
Regression: ---


Attachments

Description Felix Triebel 2007-01-25 12:41:18 UTC
Most recent kernel where this bug did *NOT* occur:
Distribution: Ubuntu Edgy
Hardware Environment: Dell Inspiron 630m
Software Environment: ?
Problem Description:
it is no problem for me, really, because I don't use MMC cards, but I thought it
might help. I did send a report to the address in the log, but they directed me
to report it here...

this appears in the logs when suspending the machine.

Jan 24 22:14:21 localhost kernel: mmc0: Got command interrupt even though no
command operation was in progress.
Jan 24 22:14:21 localhost kernel: mmc0: Please report this to
<sdhci-devel@list.drzeus.cx>.
Jan 24 22:14:21 localhost kernel: sdhci: ============== REGISTER DUMP ==============
Jan 24 22:14:21 localhost kernel: sdhci: Sys addr: 0xffffffff | Version:  0x0000ffff
Jan 24 22:14:21 localhost kernel: sdhci: Blk size: 0x0000ffff | Blk cnt:  0x0000ffff
Jan 24 22:14:21 localhost kernel: sdhci: Argument: 0xffffffff | Trn mode: 0x0000ffff
Jan 24 22:14:21 localhost kernel: sdhci: Present:  0xffffffff | Host ctl: 0x000000ff
Jan 24 22:14:21 localhost kernel: sdhci: Power:    0x000000ff | Blk gap:  0x000000ff
Jan 24 22:14:21 localhost kernel: sdhci: Wake-up:  0x000000ff | Clock:    0x0000ffff
Jan 24 22:14:21 localhost kernel: sdhci: Timeout:  0x000000ff | Int stat: 0xffffffff
Jan 24 22:14:21 localhost kernel: sdhci: Int enab: 0xffffffff | Sig enab: 0xffffffff
Jan 24 22:14:21 localhost kernel: sdhci: AC12 err: 0x0000ffff | Slot int: 0x0000ffff
Jan 24 22:14:21 localhost kernel: sdhci: Caps:     0xffffffff | Max curr: 0xffffffff
Jan 24 22:14:21 localhost kernel: sdhci: ===========================================
Jan 24 22:14:21 localhost kernel: mmc0: Card is consuming too much power!
Jan 24 22:14:21 localhost kernel: mmc0: Unexpected interrupt 0x00800000. Please
report this to <sdhci-devel@list.drzeus.cx>.
Jan 24 22:14:21 localhost kernel: sdhci: ============== REGISTER DUMP ==============
Jan 24 22:14:21 localhost kernel: sdhci: Sys addr: 0xffffffff | Version:  0x0000ffff
Jan 24 22:14:21 localhost kernel: sdhci: Blk size: 0x0000ffff | Blk cnt:  0x0000ffff
Jan 24 22:14:21 localhost kernel: sdhci: Argument: 0xffffffff | Trn mode: 0x0000ffff
Jan 24 22:14:21 localhost kernel: sdhci: Present:  0xffffffff | Host ctl: 0x000000ff
Jan 24 22:14:21 localhost kernel: sdhci: Power:    0x000000ff | Blk gap:  0x000000ff
Jan 24 22:14:21 localhost kernel: sdhci: Wake-up:  0x000000ff | Clock:    0x0000ffff
Jan 24 22:14:21 localhost kernel: sdhci: Timeout:  0x000000ff | Int stat: 0xffffffff
Jan 24 22:14:21 localhost kernel: sdhci: Int enab: 0xffffffff | Sig enab: 0xffffffff
Jan 24 22:14:21 localhost kernel: sdhci: AC12 err: 0x0000ffff | Slot int: 0x0000ffff
Jan 24 22:14:21 localhost kernel: sdhci: Caps:     0xffffffff | Max curr: 0xffffffff
Jan 24 22:14:21 localhost kernel: sdhci: ===========================================


Steps to reproduce:
every time on suspend/resume
Comment 1 Rafael J. Wysocki 2007-06-18 10:08:28 UTC
Can you please check if the problem is still present in the 2.6.22-rc5 kernel?
Comment 2 Felix Triebel 2007-06-24 02:18:28 UTC
Subject: Re:  sdhci or mmc suspend/resume problem

bugme-daemon@bugzilla.kernel.org wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=7886
> 
> 
> rjwysocki@sisk.pl changed:
> 
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>          AssignedTo|acpi_power-sleep-           |rjwysocki@sisk.pl
>                    |wake@kernel-bugs.osdl.org   |
>              Status|NEW                         |ASSIGNED
> 
> 
> 
> 
> ------- Comment #1 from rjwysocki@sisk.pl  2007-06-18 10:08 -------
> Can you please check if the problem is still present in the 2.6.22-rc5 kernel?

Hi Rafael,

my setup has changed a little since I reported the issue above. I now use
Debian instead of Ubuntu, with kernel version 2.6.22-rc4, no grsec patch.
During suspend&resume, the mmc and sdhci give no messages on the kernel
log, but just work fine.

If the bug was not related to grsec, then it could be fixed already.

Thank you for your commitment!

Felix Triebel
Comment 3 Rafael J. Wysocki 2007-06-24 13:53:13 UTC
OK, thanks for the information.

I'm closing the bug, then.

Note You need to log in before you can comment on or make changes to this bug.