Bug 7857 - S3: no wake - HP NC8230 notebook
S3: no wake - HP NC8230 notebook
Status: CLOSED DUPLICATE of bug 7225
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake
i386 Linux
: P2 normal
Assigned To: Rafael J. Wysocki
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2007-01-21 04:49 UTC by Olof Wolgast
Modified: 2008-10-30 08:00 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.19-2
Tree: Mainline
Regression: ---


Attachments
acpidump (152.58 KB, text/plain)
2007-01-21 04:52 UTC, Olof Wolgast
Details
cat /proc/interrupts (550 bytes, text/plain)
2007-01-21 04:53 UTC, Olof Wolgast
Details
dmesg -s40000 (13.38 KB, text/plain)
2007-01-21 04:54 UTC, Olof Wolgast
Details
dmidecode (7.77 KB, text/plain)
2007-01-21 04:55 UTC, Olof Wolgast
Details
lspci -vv (18.12 KB, text/plain)
2007-01-21 04:57 UTC, Olof Wolgast
Details

Description Olof Wolgast 2007-01-21 04:49:47 UTC
Most recent kernel where this bug did *NOT* occur: Unknown
Distribution: Debian unstable

Hardware Environment:
HP NC8230 notebook

Problem Description:

Fails to wake up after S3 power down. It powers down correctly. When pushing the
button to power up, the fans go on, it reads from the HD for approx 10 seconds
but that's it. Commands such as "reboot" doesn't work, so it isn't a video problem.

S3 suspend works correctly under Windows XP.

I've tried to remove modules for sound, usb etc before suspending, also using a
plain text console without any X active, but no success. I'm eager to resolve
this issue, and I am an embedded real-time developer by profession, so I might
be able to help with some guidance.

Steps to reproduce:
echo mem > /sys/power/state
Comment 1 Olof Wolgast 2007-01-21 04:52:36 UTC
Created attachment 10137 [details]
acpidump
Comment 2 Olof Wolgast 2007-01-21 04:53:42 UTC
Created attachment 10138 [details]
cat /proc/interrupts
Comment 3 Olof Wolgast 2007-01-21 04:54:39 UTC
Created attachment 10139 [details]
dmesg -s40000
Comment 4 Olof Wolgast 2007-01-21 04:55:52 UTC
Created attachment 10140 [details]
dmidecode
Comment 5 Olof Wolgast 2007-01-21 04:57:04 UTC
Created attachment 10141 [details]
lspci -vv
Comment 6 Luming Yu 2007-01-23 07:13:25 UTC
Please try the beep code at bug# 7860 to see how far the S3 resume could get.
Comment 7 Olof Wolgast 2007-01-23 13:06:25 UTC
I've modified wakeup.S so that the start looks like the code at the end of this
comment. The computer doesn't beep when woken up. I'm not too familiar with
x86-assembler, so I might have done something wrong.

I actually don't know if my laptop is equipped with a PC-speaker (how does one
check?, beep in ncurses doesn't work) but Windows XP reports a "System speaker"
device.

.text
#include <linux/linkage.h>
#include <asm/segment.h>
#include <asm/page.h>

#define BEEP \
       inb     $97, %al;       \
       outb    %al, $0x80;     \
       movb    $3, %al;        \
       outb    %al, $97;       \
       outb    %al, $0x80;     \
       movb    $-74, %al;      \
       outb    %al, $67;       \
       outb    %al, $0x80;     \
       movb    $-119, %al;     \
       outb    %al, $66;       \
       outb    %al, $0x80;     \
       movb    $15, %al;       \
       outb    %al, $66;



#
# wakeup_code runs in real mode, and at unknown address (determined at run-time).
# Therefore it must only use relative jumps/calls. 
#
# Do we need to deal with A20? It is okay: ACPI specs says A20 must be enabled
#
# If physical address of wakeup_code is 0x12345, BIOS should call us with
# cs = 0x1234, eip = 0x05
# 

ALIGN
	.align	4096
ENTRY(wakeup_start)
wakeup_code:
	wakeup_code_start = .
	.code16

	BEEP

 	movw	$0xb800, %ax
Comment 8 Len Brown 2007-09-06 15:38:15 UTC
Still a problem with linux-2.6.22.stable or later?
Comment 9 Olof Wolgast 2007-09-07 23:34:33 UTC
Can't tell.

I downloaded and compiled 2.6.22.6 (latest stable), but that one didn't boot. Used the .config from my old kernel (2.6.20-16, ubuntu fiesty fawn generic) when compiling the new one.

Starting up...
Uncompressing Linux...Ok, booting the kernel
00:03 SMCf010 not responding at SIR 0x3E8, FIR 0x100;auto-configuring
00:03 response at SIR 0x3E8, FIR 0x100
PCI: Cannot allocate resource region 7 of bridge 0000:00:101
PCI: Cannot allocate resource region 8 of bridge 0000:00:101
PCI: Cannot allocate resource region 9 of bridge 0000:00:101
VFS kernel panic, unable to mount root....
Comment 10 Olof Wolgast 2007-09-14 09:05:33 UTC
Yes, still a problem. I've resolved my general problems with 2.6.22.6, but the wakeup still doesn't work.
Comment 11 Rafael J. Wysocki 2007-09-23 03:02:19 UTC
It looks like s2ram might help you (http://en.opensuse.org/s2ram).  Can you please try it?
Comment 12 Olof Wolgast 2007-09-23 12:40:06 UTC
Yes, that worked right out of the box.

root@olof-laptop:/home/olof# s2ram -i
This machine can be identified by:
    sys_vendor   = "Hewlett-Packard"
    sys_product  = "HP Compaq nc8230 (PV406AW#AK8)"
    sys_version  = "F.04"
    bios_version = "68DTV Ver. F.04"
See http://en.opensuse.org/S2ram for details.
Comment 13 Rafael J. Wysocki 2007-09-23 12:46:55 UTC
Thanks!
Comment 14 Rafael J. Wysocki 2007-09-23 12:48:29 UTC
I'm marking this as a duplicate of Bug #7225.


*** This bug has been marked as a duplicate of bug 7225 ***
Comment 15 Matthias-Christian Ott 2008-10-30 08:00:05 UTC
*** Bug 11888 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.