Bug 7851 - cpufreq shows bad/incomplete infos
Summary: cpufreq shows bad/incomplete infos
Status: REJECTED INVALID
Alias: None
Product: Power Management
Classification: Unclassified
Component: cpufreq (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: cpufreq
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-01-19 06:58 UTC by Patrizio Bassi
Modified: 2007-01-22 00:47 UTC (History)
0 users

See Also:
Kernel Version: 2.6.19.1
Tree: Mainline
Regression: ---


Attachments

Description Patrizio Bassi 2007-01-19 06:58:36 UTC
Most recent kernel where this bug did *NOT* occur:
Distribution: Gentoo
Hardware Environment: Asus P5B Deluxe (P965 chipset), Core 2 Duo E6300
Software Environment: Gentoo 64bit
Problem Description:
cpufreq-info shows

limiti hardware: 1.60 GHz - 1.86 GHz
frequenze disponibili: 1.86 GHz, 1.86 GHz, 1.86 GHz, 1.86 GHz, 1.86 GHz, 1.86
GHz, 1.86 GHz, 1.86 GHz, 1.86 GHz, 1.60 GHz

while it should go down until 1 ghz. 

/sys/devices/system/cpu/cpu{0,1}/cpufreq/scaling_available_frequencies
says the same.

i'm using the centrino /speedstep module.
i tried acpi-speedstep but it does't detect anything and i have no freq scaling.

according to http://forums.gentoo.org/viewtopic-p-3837305.html#3837305
an mm patch should be in place. if so, just tell me i'll be happy to test next week

Steps to reproduce:
run
cpufreq-info
Comment 1 Alexey Starikovskiy 2007-01-19 07:14:43 UTC
E6300 lowest frequency multiplier is 6. This means that if you have FSB at 
1066MHz, base CPU frequency is 1066/4=266, and lowest frequency your CPU may 
appear at is 266*6=1.6Ghz, exactly what you see. 
Comment 2 Patrizio Bassi 2007-01-21 23:48:50 UTC
i'm quite surprised of this as another user reported me from 1.8 to 1.0 ghz.

is speedstep implementation cutting only 200mhz on e6300?
Comment 3 Alexey Starikovskiy 2007-01-22 00:47:17 UTC
You can get 1.0G on mobile Core (2) Duo, just because it uses 166x4 FSB. E6300 
is _not_ mobile part.  

Note You need to log in before you can comment on or make changes to this bug.