Bug 7841 - Multimedia key scancodes not recognised by kernel
Multimedia key scancodes not recognised by kernel
Status: RESOLVED DOCUMENTED
Product: Drivers
Classification: Unclassified
Component: USB
i386 Linux
: P2 high
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: USB
  Show dependency treegraph
 
Reported: 2007-01-17 06:28 UTC by John
Modified: 2009-07-28 16:46 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.27
Tree: Mainline
Regression: No


Attachments

Description John 2007-01-17 06:28:31 UTC
Most recent kernel where this bug did *NOT* occur: N/A
Distribution: Gentoo
Hardware Environment: x86 Athlon 2600
Software Environment: Gentoo Linux
Problem Description: The usb drivers in the 2.6 kernel dont seem to pick up 
scancodes from USB multimedia keyboards, including but not limited to the 
logitech LX710. Only half of the extra keys are picked up, which i am told is 
due to the USB keyboard driver only accepting scancodes within a given range. 

Steps to reproduce: Use a USB keyboard with multimedia keys :)
Comment 1 Natalie Protasevich 2008-02-14 19:27:59 UTC
John,
Is the keyboard working for you with recent kernels?
Thanks.
Comment 2 Pasi Sakala 2008-10-21 12:14:58 UTC
I'm also experiencing this issue with Ione Scorpius N1AM and 2.6.27 kernel. Keyboard is working, but all multimedia keys aren't picked up by kernel.
Comment 3 Greg Kroah-Hartman 2009-07-28 16:46:55 UTC
This is a userspace issue, look at your xorg keyboard configuration please.

Note You need to log in before you can comment on or make changes to this bug.