Bug 7840 - HP Compaq nc6320 Softlocks on boot when powered by Battery
Summary: HP Compaq nc6320 Softlocks on boot when powered by Battery
Status: REJECTED INVALID
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Processor (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Venkatesh Pallipadi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-01-17 06:02 UTC by Peter Clifton
Modified: 2007-06-08 17:45 UTC (History)
2 users (show)

See Also:
Kernel Version: Ubuntu 2.6.17-10.34-generic
Tree: Mainline
Regression: ---


Attachments
dmesg output from normal good boot (30.83 KB, application/octet-stream)
2007-01-17 06:03 UTC, Peter Clifton
Details
dmesg output with acpi=off (24.19 KB, application/octet-stream)
2007-01-17 06:03 UTC, Peter Clifton
Details
dmesg output with apm=off (31.03 KB, application/octet-stream)
2007-01-17 06:04 UTC, Peter Clifton
Details
acpidump output from this laptop with a clean boot on ac. (293.59 KB, application/octet-stream)
2007-01-17 06:05 UTC, Peter Clifton
Details

Description Peter Clifton 2007-01-17 06:02:21 UTC
Most recent kernel where this bug did *NOT* occur:
Unknown
Distribution:
Ubuntu
Hardware Environment:
HP Compaq nc6320
Software Environment:
Ubuntu, boot time
Problem Description:
When booting using only battery power, the laptop often expereinces a softlock
on CPU#0. Plugging AC in and rebooting seems to be the only cure.
Steps to reproduce:
Computer off
No AC adapter plugged in
Power up computer.

Bug seems to still occur if the AC is plugged in after initial powerup, but
before the softlock.

Does not appear to occur with either acpi=off, or apm=off.

Booting with acpi=off causes other problems though - see dmesg output for an
IRQ11 which noone cared about. Also, the sound card went slightly barmy and
repeated the ubuntu startup sound sample over and over.
Comment 1 Peter Clifton 2007-01-17 06:03:14 UTC
Created attachment 10101 [details]
dmesg output from normal good boot
Comment 2 Peter Clifton 2007-01-17 06:03:54 UTC
Created attachment 10102 [details]
dmesg output with acpi=off
Comment 3 Peter Clifton 2007-01-17 06:04:25 UTC
Created attachment 10103 [details]
dmesg output with apm=off
Comment 4 Peter Clifton 2007-01-17 06:05:25 UTC
Created attachment 10104 [details]
acpidump output from this laptop with a clean boot on ac.
Comment 5 Peter Clifton 2007-01-17 07:45:57 UTC
Bug is actually still present with apm=off.
Comment 6 Len Brown 2007-01-17 19:14:26 UTC
Please replace "quiet" on the cmdline with "debug"
boot on battery to reproduce the failure
and take a screen shot with a digital camera
and attach the .JPG

Also, Please try to reproduce the failure with CONFIG_CPU_FREQ=n
Comment 7 Peter Clifton 2007-02-06 12:06:52 UTC
It turns out that this softlock is caused by the Intel Wireless driver, and the
bug is known:

http://bughost.org/bugzilla/show_bug.cgi?id=1096

If powered up with the Wireless radio switched off, the driver would spin trying
to get a response from some thermal sensor on the card, which appears to be
powered down with the radio off, and the laptop in battery mode.

Seems odd that it powers down different bits / behaves differently in battery
mode, but thats life.

How do I / we close this bug?

Note You need to log in before you can comment on or make changes to this bug.