Bug 7818 - no keyboard activity after successful boot
no keyboard activity after successful boot
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Input Devices
i386 Linux
: P2 blocking
Assigned To: drivers_input-devices
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-13 14:25 UTC by sebastienBRICE
Modified: 2007-11-15 13:50 UTC (History)
6 users (show)

See Also:
Kernel Version: 2.6.20rc5
Tree: Mainline
Regression: ---


Attachments
var/log/dmesg (15.22 KB, text/plain)
2007-02-24 07:09 UTC, sebastienBRICE
Details
dmesg2 (15.98 KB, text/plain)
2007-02-24 16:19 UTC, sebastienBRICE
Details
dmesg3 (39.32 KB, text/plain)
2007-02-25 02:19 UTC, sebastienBRICE
Details

Description sebastienBRICE 2007-01-13 14:25:10 UTC
Most recent kernel where this bug did *NOT* occur:2.6.18.1
Distribution:debian unstable
Hardware Environment:laptop fujitsu siemens A7620 
Software Environment: GNU bash, version 3.1.17(1)-release (i486-pc-linux-gnu)
Problem Description: hitting key product no effect 

Steps to reproduce: compiling a release candidate 2.6.20 precursor kernel
Comment 1 Adrian Bunk 2007-01-13 20:07:25 UTC
Is this issue also present in kernel 2.6.19?
Comment 2 sebastienBRICE 2007-01-22 13:02:47 UTC
this issue is also present in 2.6.19, only 2.6.18-1 works well
Comment 3 Dmitry Torokhov 2007-02-19 05:55:39 UTC
Can I please get full dmesg of boot with i8042.debug=1 on the kernel command 
line? Thanks!
Comment 4 sebastienBRICE 2007-02-24 07:09:04 UTC
Created attachment 10521 [details]
var/log/dmesg
Comment 5 sebastienBRICE 2007-02-24 07:11:30 UTC
http://tech.groups.yahoo.com/group/amilo/message/974  
can perhaps help any body
Comment 6 Dmitry Torokhov 2007-02-24 10:51:43 UTC
Unfortunately the dmesg seems to be truncated. Please try booting with 
log_buf_len=131072 to allocate bigger buffer. Thanks!
Comment 7 sebastienBRICE 2007-02-24 16:19:13 UTC
Created attachment 10523 [details]
dmesg2
Comment 8 Dmitry Torokhov 2007-02-24 19:35:54 UTC
That was a complete dmesg, unfortunately it did not have any debug 
information ;) Could you please try generating it once more, this time using 
both log_buf_len and i8042.debug options? Thanks! 
Comment 9 sebastienBRICE 2007-02-25 02:19:59 UTC
Created attachment 10525 [details]
dmesg3
Comment 10 Dmitry Torokhov 2007-02-26 07:55:42 UTC
Does it help if you boot with i8042.nomux?
Comment 11 Thomas Riedel 2007-05-15 01:06:43 UTC
I have this problem too with 2.6.19-gentoo-rx, 2.6.20-gentoo-rx and
2.6.21-gentoo-rx.
Last working version is 2.6.18-gentoo-r7 (based on 2.6.18.8).
Distribution is Gentoo.
Hardware is an Amilo A 7600 with an PS2-keyboard connected.
The problem does not occur on every boot, only sometimes.
Both keyboards do not work when it happens (not the internal one from the laptop
and not the external PS2).
Tried all options with i8042 including i8042.nomux but it does not help.
Comment 12 Natalie Protasevich 2007-06-23 01:45:22 UTC
Any update on the problem?
Thanks.
Comment 13 Philippe Coval 2007-07-01 17:50:59 UTC
Hi,

Debian is running on my amiloa cy26 and have no such issue.

I use 2.6.20 patched kernel ( rt and dsdt )

$ uname -a
Linux nrv 2.6.20-k7-amiloa-rt #1 PREEMPT Sat Mar 10 13:02:49 CET 2007 i686 GNU/Linux

$ cat /proc/cmdline
root=/dev/hda6 ro  lapic

Have you patched the DSDT ? , which version of BIOS ? tell us more please

Else, fell free to use my debian kernel package and/or .config soon at 
  http://rzr.online.fr/q/AmiloA

Regards

Note You need to log in before you can comment on or make changes to this bug.