Bug 7813 - Slow boot if shutdown w/ psmouse loaded - HP Compaq nc6320
Slow boot if shutdown w/ psmouse loaded - HP Compaq nc6320
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Input Devices
i386 Linux
: P2 normal
Assigned To: acpi_bios
:
Depends on:
Blocks: 56331
  Show dependency treegraph
 
Reported: 2007-01-12 08:25 UTC by Peter Clifton
Modified: 2013-04-09 06:23 UTC (History)
1 user (show)

See Also:
Kernel Version: Linux version 2.6.17 (Ubuntu 2.6.17-10.34-generic)
Tree: Mainline
Regression: ---


Attachments
dmesg output from the bad bootup (30.83 KB, application/octet-stream)
2007-01-16 04:00 UTC, Peter Clifton
Details
dmesg output from the good bootup (30.83 KB, application/octet-stream)
2007-01-16 04:00 UTC, Peter Clifton
Details
acpidump output from the bad bootup (293.59 KB, application/octet-stream)
2007-01-16 04:01 UTC, Peter Clifton
Details
acpidump output from the good bootup (293.59 KB, application/octet-stream)
2007-01-16 04:02 UTC, Peter Clifton
Details

Description Peter Clifton 2007-01-12 08:25:56 UTC
Most recent kernel where this bug did *NOT* occur:
Unknown

Distribution:
Ubuntu

Hardware Environment:
HP Compaq nc6320

Software Environment:
Any

Problem Description:
After a shutdown or reboot in linux with psmouse loaded, the system is very slow
to boot, and when booted does not present the second SSDT table needed for CPU
frequency scaling.

Rebooting (Urgh...) Windows, executing "rmmod psmouse" before reboot or shutdown
, or unplugging the battery for a minute or so, gives a nice quick bootup and
proper CPU scaling on the next boot.

Steps to reproduce:
Shutdown linux with psmouse loaded, reboot.

Probably unrelated, but when booting the laptop on Battery, the laptop often
reports:

BUG: soft lockup detected on CPU#0

Most reliable cure is plugging in the AC. I will file a separate bug if someone
can suggest a category for it.
Comment 1 Zhang Rui 2007-01-16 00:57:28 UTC
Please attach the acpidump && dmesg output of the good state and bad state.
Comment 2 Peter Clifton 2007-01-16 04:00:15 UTC
Created attachment 10094 [details]
dmesg output from the bad bootup
Comment 3 Peter Clifton 2007-01-16 04:00:54 UTC
Created attachment 10095 [details]
dmesg output from the good bootup
Comment 4 Peter Clifton 2007-01-16 04:01:43 UTC
Created attachment 10096 [details]
acpidump output from the bad bootup
Comment 5 Peter Clifton 2007-01-16 04:02:20 UTC
Created attachment 10097 [details]
acpidump output from the good bootup
Comment 6 Peter Clifton 2007-01-16 04:05:45 UTC
Just to confirm a point in my original posting, the AC / Battery status does not
update when booted in a "bad" mode (psmouse loaded before the reboot).

Can someone suggest where to open the bug about the Softlockup issue? Seems that
ACPI is the real difference when on AC / Battery, but it is so hard to persuede
the machine to boot on Battery - I can't get a dmesg / acpidump to compare.
Comment 7 Luming Yu 2007-01-16 19:02:16 UTC
Please also test the latest base kernel, and post dmesg of that kernel.
Comment 8 Len Brown 2007-01-17 19:22:30 UTC
The failure to boot on battery issue is moved to bug 7840.
So lets focus this bug only on issues booting in A/C mode.

Does the system have any USB devices connected?
If yes, can you disconnect them to see if that helps?

Also, see if BIOS Setup has any options related to
Legacy emulation for USB devices, can you see if
disabling them helps?

Also, see if building the kernel with CONFIG_CPU_FREQ=n
makes a difference.
Comment 9 Fu Michael 2007-11-06 05:29:43 UTC
Peter, do you still have this issue?  Does the "slow boot" problem exist when using AC adapter? thanks.
Comment 10 Peter Clifton 2007-11-06 05:48:51 UTC
Appolosies for not following up, I believe this was fixed in the psmouse driver, and I no longer see the problem. I guess the bug should be closed.


commit a1cec06177386ecc320af643de11cfa77e8945bd
Author: Dmitry Torokhov <dtor@insightbb.com>
Date:   Sun Feb 18 01:40:24 2007 -0500

    Input: psmouse - properly reset mouse on shutdown/suspend
    
    Some people report that they need psmouse module unloaded
    for suspend to ram/disk to work properly. Let's make port
    cleanup behave the same way as driver unload.
    
    This fixes "bad state" roblem on various HP laptops, such
    as nx7400.
    
    Signed-off-by: Dmitry Torokhov <dtor@mail.ru>
Comment 11 Peter Clifton 2007-11-06 05:50:11 UTC
The (it turns out unrelated) issue, with:

BUG: soft lockup detected on CPU#0

Was due to a bug in the ipw3945 driver trying to access some thermal sensor on the wireless card which isn't powered up at boot if running on battery.

Note You need to log in before you can comment on or make changes to this bug.