Bug 7788 - System freeze as soon as PCMCIA card is inserted
System freeze as soon as PCMCIA card is inserted
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: PCMCIA
i386 Linux
: P2 normal
Assigned To: linux-pcmcia
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-08 01:12 UTC by Gautam Iyer
Modified: 2009-03-18 09:08 UTC (History)
6 users (show)

See Also:
Kernel Version: 2.6.20
Tree: Mainline
Regression: ---


Attachments

Description Gautam Iyer 2007-01-08 01:12:56 UTC
Distribution:

    Gentoo

Hardware Environment:

    00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express
Processor to DRAM Controller (rev 04)
    00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML
Express Graphics Controller (rev 04)
    00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML
Express Graphics Controller (rev 04)
    00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6
Family) USB UHCI #1 (rev 04)
    00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6
Family) USB UHCI #2 (rev 04)
    00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6
Family) USB UHCI #3 (rev 04)
    00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6
Family) USB UHCI #4 (rev 04)
    00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6
Family) USB2 EHCI Controller (rev 04)
    00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d4)
    00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW
(ICH6 Family) AC'97 Audio Controller (rev 04)
    00:1e.3 Modem: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97
Modem Controller (rev 04)
    00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge
(rev 04)
    00:1f.2 IDE interface: Intel Corporation 82801FBM (ICH6M) SATA Controller
(rev 04)
    00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus
Controller (rev 04)
    01:03.0 CardBus bridge: Texas Instruments PCI1410 PC card Cardbus Controller
(rev 02)
    01:07.0 Network controller: Intel Corporation PRO/Wireless 2915ABG Network
Connection (rev 05)
    01:0a.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000
Controller (PHY/Link)
    01:0c.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)

Software Environment:

    pcmciautils-014 with firmware pcmcia-cs-cis-3.2.8
    udev-103

Problem Description:

    Complete and immediate system freeze. No log or device messages are
    generated.

Steps to reproduce:

    Load the yenta_socket module, and insert a PCMCIA card into the PC Card
    slot. (If it makes any difference, I inserted a Sandisk Compact flash to PC
    Card [16bit] adapter).

Nieve thoughts:

    I read in passing (in a link I can't seem to locate again) that the PNP
resources that the kernel assigns to the PC Card are in use by the mother board,
and hence the crash. I don't know how to fix this though...
Comment 1 James Lee 2007-02-04 22:25:40 UTC
I have the same problem with a wireless card (senao with prism chipset). 
Immediate system freeze upon insertion, no logs anywhere that I can find. I too
am running Gentoo.

pcmciautils-014-r1
udev-103

Comment 2 James Lee 2007-02-04 22:36:35 UTC
Sorry i forgot to add this in my previous post.

When the card is inserted while the machine is off, at boot time the system
hangs at the "Letting udev process events" step.
Comment 3 Natalie Protasevich 2007-07-06 11:45:11 UTC
Any updates on this probelms? Still present in latest kernels?
Thanks.
Comment 4 Denis Zalewsky 2007-07-14 04:22:15 UTC
My system freezes when I am inserting any pcmcia card into slot and unfreezes after I remove it. 

I see it both on 2.6.18 and 2.6.20 kernels.

# uname -a
Linux localhost 2.6.20-gentoo #5 PREEMPT Sat Jul 14 12:20:35 MSD 2007 i686 Intel(R) Pentium(R) M processor 1.60GHz GenuineIntel GNU/Linux

#dmesg
...
pccard: card ejected from slot 0
MCE: The hardware reports a non fatal, correctable incident occurred on CPU 0.
Bank 0: b200004000000800
pccard: CardBus card inserted into slot 0
PCI: Error while updating region 0000:03:00.0/0 (6c000000 != ffffffff)
PCI: Error while updating region 0000:03:00.1/0 (6c001000 != ffffffff)
PCI: Error while updating region 0000:03:00.3/0 (6c002000 != ffffffff)
ACPI: PCI Interrupt 0000:03:00.3[A] -> Link [LNKB] -> GSI 10 (level, low) -> IRQ 10
ehci_hcd 0000:03:00.3: EHCI Host Controller
ehci_hcd 0000:03:00.3: new USB bus registered, assigned bus number 5
PCI: cache line size of 32 is not supported by device 0000:03:00.3
ehci_hcd 0000:03:00.3: irq 10, io mem 0x6c002000
ehci_hcd 0000:03:00.3: startup error -19
ehci_hcd 0000:03:00.3: USB bus 5 deregistered
ACPI: PCI interrupt for device 0000:03:00.3 disabled
ehci_hcd 0000:03:00.3: init 0000:03:00.3 fail, -19
pccard: card ejected from slot 0
...
Comment 5 Natalie Protasevich 2007-07-15 12:48:44 UTC
Denis,
Please try the latest-latest (2.6.22+) because there were fixes to register/unregister driver in USB area as well as device insertion/removal.
Thanks.
Comment 6 Andrew Morton 2007-07-25 14:33:45 UTC
Bjorn, could you please take a look at this one?  The theory
is that the motherboard PNP resource management has claimed
resources which the caddbus device wants to use.

Probably it'd be helpful if the repprters could attach their
full dmesg output and /proc/iomem and /proc/ioports output, thanks.
Comment 7 Gautam Iyer 2007-08-04 02:15:46 UTC
Hi,

Sorry for disappearing on you guys. I was traveling for a month, and had no
access to a PC Card reader.

But yes, I got back this week and plugged the same PC Card reader into my system. (I naturally braced my self for a complete system freeze). But surprisingly, it worked *perfectly*. It mounted my memory card as a IDE hard disk, after which I could happily copy pictures to my hearts content.

I'm now using 2.6.21. I presume the original bug is now fixed in 2.6.21 :).

Do you still see any issues in 2.6.21 Denis?

Thanks,

GI
Comment 8 Bjorn Helgaas 2008-01-02 10:57:40 UTC
CardBus resource management is not well-integrated with the rest of the system, so I'm sure there are still problems lurking here.  If somebody could (1) verify that there's still a problem, and (2) start collecting information like the dmesg log and /proc/{iomem,ioports} contents, we could start looking at it.
Comment 9 Bjorn Helgaas 2008-01-02 13:40:22 UTC
Oops, I should have said PCMCIA resource management, not CardBus.  I was thinking of the PCMCIA resource database, which tells the kernel which resources are available for use by PCMCIA.  That information really ought to come from PNPBIOS or ACPI, not a user-supplied configuration file.

The lspci says "CardBus bridge", so I guess this problem should be CardBus-related, and the PCMCIA resource database shouldn't be involved at all.  Sorry for muddying the waters.

If we think there's a PNP/CardBus conflict, the dmesg and /proc/iomem and ioports info still might shed some light.

Note You need to log in before you can comment on or make changes to this bug.