Bug 7785 - BUG: at fs/inotify.c:172 set_dentry_child_flags()
BUG: at fs/inotify.c:172 set_dentry_child_flags()
Status: CLOSED CODE_FIX
Product: File System
Classification: Unclassified
Component: Other
i386 Linux
: P2 high
Assigned To: John McCutchan
:
: 8422 8682 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-07 05:29 UTC by Cijoml Cijomlovic Cijomlov
Modified: 2008-04-24 11:58 UTC (History)
16 users (show)

See Also:
Kernel Version: 2.6.24
Tree: Mainline
Regression: Yes


Attachments
inotify tester (2.29 KB, text/plain)
2007-01-24 21:23 UTC, Nick Piggin
Details
config.gz 2.6.20-rc5 (12.90 KB, application/gzip)
2007-01-25 00:50 UTC, Cijoml Cijomlovic Cijomlov
Details
more debugging output (2.26 KB, patch)
2007-01-28 20:16 UTC, Nick Piggin
Details | Diff
possible fix (1.80 KB, patch)
2007-07-30 01:22 UTC, Nick Piggin
Details | Diff
dmesg output from Ubuntu 2.6.24-8-generic (47.22 KB, text/plain)
2008-02-25 23:02 UTC, Luka Renko
Details

Description Cijoml Cijomlovic Cijomlov 2007-01-07 05:29:32 UTC
Most recent kernel where this bug did *NOT* occur: 2.6.20-rc3
Distribution: Debian testing
Hardware Environment: Acer TravelMate 240
Software Environment: Debian testing
Problem Description:

Hi,

today I got following bug on my 2.6.20-rc3 vanilla kernel's dmesg 2 times:

BUG: at fs/inotify.c:172 set_dentry_child_flags()
[<c0179b74>] set_dentry_child_flags+0x5e/0x149
[<c0179cb2>] remove_watch_no_event+0x53/0x5f
[<c0179da0>] inotify_remove_watch_locked+0x12/0x3e
[<c0179ee2>] inotify_rm_wd+0x6c/0x89
[<c017a58a>] sys_inotify_rm_watch+0x38/0x4f
[<c0102cc8>] syscall_call+0x7/0xb
[<c02d0033>] fib_validate_source+0x1d8/0x22d
=======================
BUG: at fs/inotify.c:172 set_dentry_child_flags()
[<c0179b74>] set_dentry_child_flags+0x5e/0x149
[<c017a151>] inotify_add_watch+0xb8/0xff
[<c017abc4>] sys_inotify_add_watch+0x10b/0x147
[<c0179e59>] put_inotify_watch+0x21/0x3e
[<c0179ef7>] inotify_rm_wd+0x81/0x89
[<c0102cc8>] syscall_call+0x7/0xb
[<c02d0033>] fib_validate_source+0x1d8/0x22d
=======================

Distro Debian testing

# uname -a
Linux notas 2.6.20-rc3 #3 PREEMPT Thu Jan 4 11:28:04 CET 2007 i686 GNU/Linux

Thanks for fixing!

Michal

Steps to reproduce:

not known
Comment 1 John McCutchan 2007-01-08 21:41:32 UTC
How do you reproduce?
Comment 2 Cijoml Cijomlovic Cijomlov 2007-01-09 01:29:12 UTC
Hi, no reproduction known. It just appears in my dmesg - yesterday 3 times when 
normally working on my laptop (mozilla, kmail, eclipse, sim-im)...
Comment 3 John McCutchan 2007-01-10 21:48:44 UTC
I can't reproduce
Comment 4 Adrian Bunk 2007-01-10 22:01:13 UTC
It's normal that not everyone can reproduce every issue - life was too easy if
everyone could reproduce every bug.  ;-)

As long as a responsive submitter is able to reproduce it it's reproducible.
Comment 5 Cijoml Cijomlovic Cijomlov 2007-01-11 00:32:44 UTC
Hi, 

yes I see this bug at least 1 times a day :( I wish I would not see it... :(

And it is not hw problem, I have booted 2.6.18 (also 2.6.19) and they were fine.
Comment 6 Cijoml Cijomlovic Cijomlov 2007-01-12 14:43:28 UTC
Today I got little bit different error:

BUG: at fs/inotify.c:172 set_dentry_child_flags()
 [<c0179b74>] set_dentry_child_flags+0x5e/0x149
 [<c0179cb2>] remove_watch_no_event+0x53/0x5f
 [<c0179da0>] inotify_remove_watch_locked+0x12/0x3e
 [<c0179ee2>] inotify_rm_wd+0x6c/0x89
 [<c017a58a>] sys_inotify_rm_watch+0x38/0x4f
 [<c0102cc8>] syscall_call+0x7/0xb
 =======================
BUG: at fs/inotify.c:172 set_dentry_child_flags()
 [<c0179b74>] set_dentry_child_flags+0x5e/0x149
 [<c017a151>] inotify_add_watch+0xb8/0xff
 [<c017abc4>] sys_inotify_add_watch+0x10b/0x147
 [<c0179e59>] put_inotify_watch+0x21/0x3e
 [<c0179ef7>] inotify_rm_wd+0x81/0x89
 [<c0102cc8>] syscall_call+0x7/0xb
 =======================
Comment 7 Cijoml Cijomlovic Cijomlov 2007-01-15 08:53:39 UTC
Hi, maybe this would help track issue down.
Today I was making final cleanups in my Diploma thesis and was many times
recompiling Latex source. I got this error 11times a day!
Comment 8 Nick Piggin 2007-01-24 21:23:25 UTC
Created attachment 10180 [details]
inotify tester

Can you compile and run this inotify tester and see if it reproduces the
problem?

What's happening is that a negative dentry has this inotify flag set in it when

it should have.

Are you using PREEMPT? SMP? What filesystems? (can you send .config and dmesg)

Thanks
Comment 9 Cijoml Cijomlovic Cijomlov 2007-01-25 00:50:52 UTC
Created attachment 10181 [details]
config.gz 2.6.20-rc5

config.gz 2.6.20-rc5
Comment 10 Cijoml Cijomlovic Cijomlov 2007-01-25 00:58:37 UTC
Hi,

I was running 

while true; do ./inotify-tester;done

for 10 minutes, but no problem in dmesg appeared. Can you please try compile
some latex code with external .tex includes? For me this caused problems.

Michal
Comment 11 Nick Piggin 2007-01-26 04:46:45 UTC
I can't reproduce it by doing that either (if, by external tex includes you mean
\input{blah} or \include{blah}). But if you have a tree for me to test, then I
could. 

You've got FUSE compiled in. Do you have anything mounted with it? Can you
reproduce the problem without the FUSE module loaded?
Comment 12 Cijoml Cijomlovic Cijomlov 2007-01-26 05:56:30 UTC
Hi,

I use fuse for ntfs3g access. YES this error also shows up without fuse module
(I have tested it)

/dev/hda1 on /mnt/c type fuse (rw,nosuid,nodev,noatime,allow_other)

I can share my thesis, but you need czech tex language support

I use this construct:

\include{uvod} %Uvod

and in uvod.tex I have setted chapters like \chapter[
Comment 13 Nick Piggin 2007-01-28 20:16:11 UTC
Created attachment 10213 [details]
more debugging output

Can you try this patch, which produces more debugging output.

I'm not sure that it would be worthwhile sending me your testcase, because I
don't think I have the other required stuff installed (eg. a file monitor that
actually uses inotify).
Comment 14 Nick Piggin 2007-02-02 16:57:41 UTC
Hi,

Any progress with this?

Thanks,
Nick
Comment 15 Cijoml Cijomlovic Cijomlov 2007-02-02 17:07:04 UTC
Hi,

not yet. Need prepare for finish exems and diploma thesis until 14.2. then I can
test whatever you need.
Comment 16 Adrian Bunk 2007-03-10 00:54:57 UTC
Cijoml?
Comment 17 Cijoml Cijomlovic Cijomlov 2007-03-19 00:48:07 UTC
I don't see the bug in 2.6.21 revision. I will reopen if this error occurs
again...strange...
Comment 18 Matheus Izvekov 2007-05-28 09:37:36 UTC
Reopening as i got this recently and reported on lkml.
http://lkml.org/lkml/2007/5/25/346

Got this BUG_ON twice in a row, just found it by scrolling thru my
dmesg.

BUG: at fs/inotify.c:172 set_dentry_child_flags()
[<c01936fc>] set_dentry_child_flags+0x10c/0x1a0
[<c01937e3>] remove_watch_no_event+0x53/0x60
[<c0193b30>] inotify_destroy+0x50/0xb0
[<c01941a4>] inotify_release+0x14/0x60
[<c016a4d3>] __fput+0x93/0x190
[<c01678c7>] filp_close+0x47/0x80
[<c0120b12>] put_files_struct+0x92/0xb0
[<c0121ddc>] do_exit+0x12c/0x870
[<c01168e1>] do_page_fault+0x321/0x610
[<c0122544>] do_group_exit+0x24/0x80
[<c0103f72>] sysenter_past_esp+0x5f/0x85
=======================
this was probably triggered by this small shell script i have:

while true;
do
	ls -1 \$MAIL/new/ | wc -l;
	inotifywait -e CREATE -e DELETE -e MOVE \$MAIL/new/ > /dev/null 2>/dev/null ||
break;
done
$MAIL is mounted from a reiserfs filesystem.
Comment 19 Dmitry Karasik 2007-06-02 00:12:33 UTC
I hit a similar problem but with 2.6.21. The only real filesystem I have mounted
is XFS:

BUG: at fs/inotify.c:182 set_dentry_child_flags()
 [<c0180875>] set_dentry_child_flags+0x118/0x14b
 [<c01808fb>] remove_watch_no_event+0x53/0x5f
 [<c01809ff>] inotify_remove_watch_locked+0x12/0x3e
 [<c03cb3cc>] mutex_lock+0xb/0x1c
 [<c0180ce3>] inotify_rm_wd+0x60/0x8d
 [<c018119b>] sys_inotify_rm_watch+0x38/0x54
 [<c0102712>] sysenter_past_esp+0x5f/0x85
 =======================
Comment 20 Thomas Sattler 2007-06-22 14:21:18 UTC
I upgraded from 2.6.19-ck2 to 2.6.21.5-cfs-v17 three days ago.

Since than I have the following in my /var/log/message, up to
30 times a day:

Jun 22 13:37:18 silver BUG: at fs/inotify.c:172 set_dentry_child_flags()
Jun 22 13:37:18 silver [<c0184b6d>] set_dentry_child_flags+0xc5/0x174
Jun 22 13:37:18 silver [<c0184ccc>] remove_watch_no_event+0x6f/0x71
Jun 22 13:37:18 silver [<c0185255>] inotify_destroy+0x5d/0xa9
Jun 22 13:37:18 silver [<c0185af5>] inotify_release+0x14/0x5c
Jun 22 13:37:18 silver [<c015fd76>] __fput+0x16a/0x17b
Jun 22 13:37:18 silver [<c015e5c6>] filp_close+0x43/0x6d
Jun 22 13:37:18 silver [<c011fe4e>] close_files+0x71/0x80
Jun 22 13:37:18 silver [<c011feba>] put_files_struct+0x27/0x56
Jun 22 13:37:18 silver [<c0120850>] do_exit+0x12a/0x40a
Jun 22 13:37:18 silver [<c015f038>] sys_read+0x47/0x76
Jun 22 13:37:18 silver [<c0120b74>] do_group_exit+0x24/0x75
Jun 22 13:37:18 silver [<c0103f08>] syscall_call+0x7/0xb
Jun 22 13:37:18 silver [<c03f0000>] svcauth_gss_release+0x33d/0x371
Jun 22 13:37:18 silver =======================

The attached inotify tester does not trigger it. Currently I'm compiling a new kernel, 2.6.21.5 + sched-cfs-v2.6.21.5-v17.patch by Ingo Molnar + squashfs3.2-r2-2.6.20-patch + the attached patch for more debugging output.
Comment 21 Thomas Sattler 2007-06-23 05:37:42 UTC
I just found this in dmesg:

BUG: at fs/inotify.c:187 set_dentry_child_flags()
 [<c0184c2d>] set_dentry_child_flags+0x18d/0x192
 [<c0184ce2>] remove_watch_no_event+0x6f/0x71
 [<c018526b>] inotify_destroy+0x5d/0xa9
 [<c0185b0d>] inotify_release+0x14/0x5c
 [<c015fd76>] __fput+0x16a/0x17b
 [<c015e5c6>] filp_close+0x43/0x6d
 [<c011fe4e>] close_files+0x71/0x80
 [<c011feba>] put_files_struct+0x27/0x56
 [<c0120850>] do_exit+0x12a/0x40a
 [<c015f038>] sys_read+0x47/0x76
 [<c0120b74>] do_group_exit+0x24/0x75
 [<c0103f08>] syscall_call+0x7/0xb
 [<c03f0000>] rsi_lookup+0x87/0xb0
 =======================

Is it helpful in any way? Can I do more to help fixing this bug?
Comment 22 Thomas Sattler 2007-06-23 05:53:50 UTC
$ df -hT | grep ^[F/]
Filesystem    Type    Size  Used Avail Use% Mounted on
/dev/hda1     ext3    5.7G  3.2G  2.3G  59% /
/dev/hda2 reiserfs    9.6G  4.1G  5.6G  42% /Reiser
/dev/hda3 reiserfs    4.4G  2.5G  1.9G  57% /Backups
/dev/hda4      xfs    214G  178G   36G  84% /Archive
/dev/hdd2      xfs    369G  274G   96G  75% /data

$ zgrep "^CONFIG.*\(PREEMPT\|SMP\)" /proc/config.gz
CONFIG_BROKEN_ON_SMP=y
CONFIG_PREEMPT=y
CONFIG_PREEMPT_BKL=y
CONFIG_X86_FIND_SMP_CONFIG=y

$ cat /proc/cpuinfo 
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 4
model name      : Intel(R) Celeron(R) CPU 2.66GHz
stepping        : 1
cpu MHz         : 2672.917
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 5
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe constant_tsc pni monitor ds_cpl cid xtpr
bogomips        : 5347.72
clflush size    : 64

inotifywait (inotify-tools-3.9, http://inotify-tools.sourceforge.net/) cmd is:
$ inotifywait -qq -e close_write -e delete 2_cutting 4_checkMe
Comment 23 Nick Piggin 2007-06-25 00:57:56 UTC
Thanks for the report, can you try the patch attached above (attachment #10213 [details])
and then tell me what messages it gives?
Comment 24 Thomas Sattler 2007-06-25 14:23:34 UTC
As promised in comment 20 I'm running a patched kernel ATM. Where do I expect the additional info? Comment 21 is a part of dmesg when running the patched kernel.
Comment 25 Adrian Bunk 2007-06-30 16:48:07 UTC
*** Bug 8422 has been marked as a duplicate of this bug. ***
Comment 26 Adrian Bunk 2007-06-30 16:48:26 UTC
*** Bug 8682 has been marked as a duplicate of this bug. ***
Comment 27 Nick Piggin 2007-07-30 01:22:08 UTC
Created attachment 12196 [details]
possible fix

There is a possible race in flag setting, although it is fairly unlikely to
have hit. Maybe more possible is a harmless race in flag debug checking.

The following patch attempts to fix both. Can you test this?
Comment 28 Ira Cooper 2007-09-20 12:19:34 UTC
I tried the above patch, it's not working:

WARNING: at fs/inotify.c:172 set_dentry_child_flags()

Call Trace:
 [<ffffffff802a9047>] set_dentry_child_flags+0x59/0x11b
 [<ffffffff80243fb2>] autoremove_wake_function+0x0/0x2e
 [<ffffffff802a917c>] remove_watch_no_event+0x73/0x8c
 [<ffffffff802a9295>] inotify_remove_watch_locked+0x18/0x3b
 [<ffffffff802a9406>] inotify_rm_wd+0x7e/0xa1
 [<ffffffff802a9b6b>] sys_inotify_rm_watch+0x46/0x62
 [<ffffffff80209d8e>] system_call+0x7e/0x83
Comment 29 Ralf Hildebrandt 2007-10-28 06:41:42 UTC
I have a similar problem:

[13319516.376747] WARNING: at fs/inotify.c:172 set_dentry_child_flags()
[13319516.376820]  [<c1081ef1>] set_dentry_child_flags+0xc4/0x14b
[13319516.376894]  [<c1081fcb>] remove_watch_no_event+0x53/0x5f
[13319516.376950]  [<c10820cf>] inotify_remove_watch_locked+0x12/0x3e
[13319516.377007]  [<c10823b3>] inotify_rm_wd+0x60/0x8d
[13319516.377054]  [<c108286b>] sys_inotify_rm_watch+0x38/0x54
[13319516.377102]  [<c1003ec2>] sysenter_past_esp+0x5f/0x85
[13319516.377149]  [<c11b0000>] packet_rcv+0x171/0x339
[13319516.377196]  =======================
[13556464.164083] WARNING: at fs/inotify.c:182 set_dentry_child_flags()
[13556464.164147]  [<c1081f45>] set_dentry_child_flags+0x118/0x14b
[13556464.164197]  [<c1081fcb>] remove_watch_no_event+0x53/0x5f
[13556464.164239]  [<c10820cf>] inotify_remove_watch_locked+0x12/0x3e
[13556464.164283]  [<c10823b3>] inotify_rm_wd+0x60/0x8d
[13556464.164328]  [<c108286b>] sys_inotify_rm_watch+0x38/0x54
[13556464.164367]  [<c1003ec2>] sysenter_past_esp+0x5f/0x85
[13556464.164404]  [<c11b0000>] packet_rcv+0x171/0x339
[13556464.164445]  =======================

This is on our main mailbox server (9.000 users), which uses dovecot with inotify() support.

$ uname -a
Linux postamt.charite.de 2.6.23.1 #1 SMP Fri Oct 12 20:19:54 CEST 2007 i686 GNU/Linux
Comment 30 x545 2007-12-12 12:52:50 UTC
WARNING: at fs/inotify.c:172 set_dentry_child_flags()

Call Trace:
[<ffffffff810d2cae>] set_dentry_child_flags+0xee/0x190
[<ffffffff810d2db3>] remove_watch_no_event+0x63/0x80
[<ffffffff810d2f3f>] inotify_remove_watch_locked+0x1f/0x50
[<ffffffff810d32b7>] inotify_rm_wd+0x87/0xd0
[<ffffffff810d3992>] sys_inotify_rm_watch+0x52/0x80

[<ffffffff8100c17e>] system_call+0x7e/0x83

WARNING: at fs/inotify.c:172 set_dentry_child_flags()
Call Trace:
<ffffffff810d2cae>] set_dentry_child_flags+0xee/0x190
[<ffffffff810d3509>] inotify_add_watch+0x119/0x130
[<ffffffff810d428e>] sys_inotify_add_watch+0x1be/0x1f0
[<ffffffff810a7936>] sys_newstat+0x36/0x50
[<ffffffff8100c17e>] system_call+0x7e/0x83

WARNING: at fs/inotify.c:172 set_dentry_child_flags()

Call Trace:
[<ffffffff810d2cae>] set_dentry_child_flags+0xee/0x190
[<ffffffff810d2db3>] remove_watch_no_event+0x63/0x80
[<ffffffff810d2f3f>] inotify_remove_watch_locked+0x1f/0x50
[<ffffffff810d32b7>] inotify_rm_wd+0x87/0xd0
[<ffffffff810d3992>] sys_inotify_rm_watch+0x52/0x80
[<ffffffff8100c17e>] system_call+0x7e/0x83

WARNING: at fs/inotify.c:172 set_dentry_child_flags()

Call Trace:
[<ffffffff810d2cae>] set_dentry_child_flags+0xee/0x190
[<ffffffff810d3509>] inotify_add_watch+0x119/0x130
[<ffffffff810d428e>] sys_inotify_add_watch+0x1be/0x1f0
[<ffffffff810d3207>] put_inotify_watch+0x47/0x70
[<ffffffff812ea769>] _spin_unlock+0x9/0x40
[<ffffffff810d32cf>] inotify_rm_wd+0x9f/0xd0
[<ffffffff8100c17e>] system_call+0x7e/0x83

$ uname -a
Linux x545 2.6.23.9 #3 SMP PREEMPT Tue Nov 27 21:43:04 CET 2007 x86_64 GNU/Linux

$ cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 15
model name      : Intel(R) Core(TM)2 CPU          6600  @ 2.40GHz
stepping        : 6
cpu MHz         : 1600.000
cache size      : 4096 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 2
fpu             : yes
fpu_exception   : yes
cpuid level     : 10
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr lahf_lm
bogomips        : 4802.75
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

processor       : 1
vendor_id       : GenuineIntel
cpu family      : 6
model           : 15
model name      : Intel(R) Core(TM)2 CPU          6600  @ 2.40GHz
stepping        : 6
cpu MHz         : 1600.000
cache size      : 4096 KB
physical id     : 0
siblings        : 2
core id         : 1
cpu cores       : 2
fpu             : yes
fpu_exception   : yes
cpuid level     : 10
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr lahf_lm
Comment 31 Luka Renko 2008-01-18 23:45:03 UTC
This bugs is also reported by several users on Ubuntu:
https://launchpad.net/bugs/104837
Comment 32 Mikko C. 2008-02-09 04:01:09 UTC
I'm also having this warning, but only running KDE4.

WARNING: at fs/inotify.c:172 set_dentry_child_flags()
Pid: 4889, comm: plasma Not tainted 2.6.24-gentoo #6

Call Trace:
 [<ffffffff802b6a7e>] set_dentry_child_flags+0xce/0x150
 [<ffffffff802b6b63>] remove_watch_no_event+0x63/0x80
 [<ffffffff802b6cef>] inotify_remove_watch_locked+0x1f/0x50
 [<ffffffff802b7097>] inotify_rm_wd+0x87/0xd0
 [<ffffffff802b77af>] sys_inotify_rm_watch+0x4f/0x80
 [<ffffffff8020bcce>] system_call+0x7e/0x83

$ uname -a
Linux gentoo 2.6.24-gentoo #6 SMP Fri Feb 8 10:18:14 CET 2008 x86_64 Intel(R) Core(TM)2 CPU T7200 @ 2.00GHz GenuineIntel GNU/Linux


$ cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 15
model name      : Intel(R) Core(TM)2 CPU         T7200  @ 2.00GHz
stepping        : 6
cpu MHz         : 1000.000
cache size      : 4096 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 2
fpu             : yes
fpu_exception   : yes
cpuid level     : 10
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr lahf_lm
bogomips        : 3997.96
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

processor       : 1
vendor_id       : GenuineIntel
cpu family      : 6
model           : 15
model name      : Intel(R) Core(TM)2 CPU         T7200  @ 2.00GHz
stepping        : 6
cpu MHz         : 1000.000
cache size      : 4096 KB
physical id     : 0
siblings        : 2
core id         : 1
cpu cores       : 2
fpu             : yes
fpu_exception   : yes
cpuid level     : 10
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr lahf_lm
bogomips        : 3994.43
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:
Comment 33 Kai Krakow 2008-02-17 03:53:38 UTC
I can confirm this bug. Running 2.6.23 with KDE4. It seems to happen after heavy workloads (like compiling some packages) and using KDE in parallel. I'm running on a laptop with Gentoo and inotify on. No SMP. The BUG lines always seems to appear twice in dmesg (with different numbers though). I wasn't able to reproduce it yet, saw it only one time.
Comment 34 Andrea 2008-02-25 00:31:21 UTC
Hi all,
I've the same warning in my logs:

Feb 25 08:45:59 orodruin kernel: WARNING: at fs/inotify.c:172 set_dentry_child_flags()
Feb 25 08:45:59 orodruin kernel:  [<c0193844>] set_dentry_child_flags+0x6c/0x12a
Feb 25 08:45:59 orodruin kernel:  [<c0193952>] remove_watch_no_event+0x50/0x5c
Feb 25 08:45:59 orodruin kernel:  [<c0193a40>] inotify_remove_watch_locked+0x12/0x3e
Feb 25 08:45:59 orodruin kernel:  [<c02c55ca>] mutex_lock+0xb/0x1a
Feb 25 08:45:59 orodruin kernel:  [<c0193ce9>] inotify_rm_wd+0x6d/0x8a
Feb 25 08:45:59 orodruin kernel:  [<c01941cb>] sys_inotify_rm_watch+0x38/0x4f
Feb 25 08:45:59 orodruin kernel:  [<c0104e22>] sysenter_past_esp+0x6b/0xa9
Feb 25 08:45:59 orodruin kernel:  =======================
Feb 25 08:45:59 orodruin kernel: WARNING: at fs/inotify.c:172 set_dentry_child_flags()
Feb 25 08:45:59 orodruin kernel:  [<c0193844>] set_dentry_child_flags+0x6c/0x12a
Feb 25 08:45:59 orodruin kernel:  [<c0193dc2>] inotify_add_watch+0xb4/0xfb
Feb 25 08:45:59 orodruin kernel:  [<c019481c>] sys_inotify_add_watch+0x10a/0x146
Feb 25 08:45:59 orodruin kernel:  [<c0193c5e>] put_inotify_watch+0x22/0x40
Feb 25 08:45:59 orodruin kernel:  [<c0193cfe>] inotify_rm_wd+0x82/0x8a
Feb 25 08:45:59 orodruin kernel:  [<c0104e22>] sysenter_past_esp+0x6b/0xa9
Feb 25 08:45:59 orodruin kernel:  =======================

I'm running suse 10.3 kernel 2.6.22.17-0.1-default on 

processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 13
model name      : Intel(R) Pentium(R) M processor 1.60GHz
stepping        : 8
cpu MHz         : 800.000
cache size      : 2048 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss tm pbe nx up est tm2
bogomips        : 1597.74
clflush size    : 64

This is the default config: 

zgrep "^CONFIG.*\(PREEMPT\|SMP\)" /proc/config.gz
CONFIG_SMP=y
CONFIG_PREEMPT_VOLUNTARY=y
CONFIG_SUSPEND_SMP=y
CONFIG_X86_FIND_SMP_CONFIG=y
CONFIG_X86_SMP=y

Filesystem is xfs.

For suse, the warning is specific for 2.6.22.17-0.1 kernel. In fact, such warning is reported only after the installation of this kernel. With previous versions (like 2.6.22.16-0.2), logs doesn't contain such warning and file system is the same for both kernels.

Andrea
Comment 35 Nick Piggin 2008-02-25 19:37:11 UTC
On Monday 25 February 2008 19:31, bugme-daemon@bugzilla.kernel.org wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=7785
>
>
>
>
>
> ------- Comment #34 from andrea.turrini@gmail.com  2008-02-25 00:31 -------
> Hi all,
> I've the same warning in my logs:
>
> Feb 25 08:45:59 orodruin kernel: WARNING: at fs/inotify.c:172
> set_dentry_child_flags()
> Feb 25 08:45:59 orodruin kernel:  [<c0193844>]
> set_dentry_child_flags+0x6c/0x12a
> Feb 25 08:45:59 orodruin kernel:  [<c0193952>]
> remove_watch_no_event+0x50/0x5c Feb 25 08:45:59 orodruin kernel: 
> [<c0193a40>]
> inotify_remove_watch_locked+0x12/0x3e
> Feb 25 08:45:59 orodruin kernel:  [<c02c55ca>] mutex_lock+0xb/0x1a
> Feb 25 08:45:59 orodruin kernel:  [<c0193ce9>] inotify_rm_wd+0x6d/0x8a
> Feb 25 08:45:59 orodruin kernel:  [<c01941cb>]
> sys_inotify_rm_watch+0x38/0x4f Feb 25 08:45:59 orodruin kernel: 
> [<c0104e22>] sysenter_past_esp+0x6b/0xa9 Feb 25 08:45:59 orodruin kernel: 
> =======================
> Feb 25 08:45:59 orodruin kernel: WARNING: at fs/inotify.c:172
> set_dentry_child_flags()
> Feb 25 08:45:59 orodruin kernel:  [<c0193844>]
> set_dentry_child_flags+0x6c/0x12a
> Feb 25 08:45:59 orodruin kernel:  [<c0193dc2>] inotify_add_watch+0xb4/0xfb
> Feb 25 08:45:59 orodruin kernel:  [<c019481c>]
> sys_inotify_add_watch+0x10a/0x146
> Feb 25 08:45:59 orodruin kernel:  [<c0193c5e>] put_inotify_watch+0x22/0x40
> Feb 25 08:45:59 orodruin kernel:  [<c0193cfe>] inotify_rm_wd+0x82/0x8a
> Feb 25 08:45:59 orodruin kernel:  [<c0104e22>] sysenter_past_esp+0x6b/0xa9
> Feb 25 08:45:59 orodruin kernel:  =======================

Thanks for reporting... we have fixed these warnings in 2.6.24.

Comment 36 Luka Renko 2008-02-25 23:02:02 UTC
Created attachment 14999 [details]
dmesg output from Ubuntu 2.6.24-8-generic

I still get this warnings on Ubuntu Hardy with 2.6.24 kernel - this is from today's dmesg output:



[25878.649556] WARNING: at /build/buildd/linux-2.6.24/fs/inotify.c:172 set_dentry_child_flags()
[25878.649568] Pid: 6283, comm: kded4 Not tainted 2.6.24-8-generic #1
[25878.649571]
[25878.649572] Call Trace:
[25878.649611]  [<ffffffff802db2de>] set_dentry_child_flags+0xce/0x150
[25878.649622]  [<ffffffff802db3c3>] remove_watch_no_event+0x63/0x80
[25878.649631]  [<ffffffff802db54f>] inotify_remove_watch_locked+0x1f/0x50
[25878.649639]  [<ffffffff802db8f7>] inotify_rm_wd+0x87/0xd0
[25878.649649]  [<ffffffff802dc00f>] sys_inotify_rm_watch+0x4f/0x80
[25878.649659]  [<ffffffff8020c37e>] system_call+0x7e/0x83
[25878.649676]
[25878.651081] WARNING: at /build/buildd/linux-2.6.24/fs/inotify.c:172 set_dentry_child_flags()
[25878.651089] Pid: 6283, comm: kded4 Not tainted 2.6.24-8-generic #1
[25878.651092]
[25878.651093] Call Trace:
[25878.651107]  [<ffffffff802db2de>] set_dentry_child_flags+0xce/0x150
[25878.651117]  [<ffffffff802dbcad>] inotify_add_watch+0x11d/0x130
[25878.651128]  [<ffffffff802dc8bf>] sys_inotify_add_watch+0x1af/0x1e0
[25878.651143]  [<ffffffff802db847>] put_inotify_watch+0x47/0x70
[25878.651150]  [<ffffffff802db90f>] inotify_rm_wd+0x9f/0xd0
[25878.651165]  [<ffffffff8020c37e>] system_call+0x7e/0x83


It looks to me that KDE 4 is triggering this quite often, as I have not seen this before (in KDE 3 session).
Full dmesg output attached.
Comment 37 Nick Piggin 2008-02-25 23:07:21 UTC
On Tuesday 26 February 2008 18:02, bugme-daemon@bugzilla.kernel.org wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=7785
>
>
>
>
>
> ------- Comment #36 from lure@ubuntu.com  2008-02-25 23:02 -------
> Created an attachment (id=14999)
>  --> (http://bugzilla.kernel.org/attachment.cgi?id=14999&action=view)
> dmesg output from Ubuntu 2.6.24-8-generic
>
> I still get this warnings on Ubuntu Hardy with 2.6.24 kernel - this is from
> today's dmesg output:

Ah, sorry, 2.6.25. The git commits are:
d599e36a9ea85432587f4550acc113cd7549d12a
and
0d71bd5993b630a989d15adc2562a9ffe41cd26d


> [25878.649556] WARNING: at /build/buildd/linux-2.6.24/fs/inotify.c:172
> set_dentry_child_flags()
> [25878.649568] Pid: 6283, comm: kded4 Not tainted 2.6.24-8-generic #1
> [25878.649571]
> [25878.649572] Call Trace:
> [25878.649611]  [<ffffffff802db2de>] set_dentry_child_flags+0xce/0x150
> [25878.649622]  [<ffffffff802db3c3>] remove_watch_no_event+0x63/0x80
> [25878.649631]  [<ffffffff802db54f>] inotify_remove_watch_locked+0x1f/0x50
> [25878.649639]  [<ffffffff802db8f7>] inotify_rm_wd+0x87/0xd0
> [25878.649649]  [<ffffffff802dc00f>] sys_inotify_rm_watch+0x4f/0x80
> [25878.649659]  [<ffffffff8020c37e>] system_call+0x7e/0x83
> [25878.649676]
> [25878.651081] WARNING: at /build/buildd/linux-2.6.24/fs/inotify.c:172
> set_dentry_child_flags()
> [25878.651089] Pid: 6283, comm: kded4 Not tainted 2.6.24-8-generic #1
> [25878.651092]
> [25878.651093] Call Trace:
> [25878.651107]  [<ffffffff802db2de>] set_dentry_child_flags+0xce/0x150
> [25878.651117]  [<ffffffff802dbcad>] inotify_add_watch+0x11d/0x130
> [25878.651128]  [<ffffffff802dc8bf>] sys_inotify_add_watch+0x1af/0x1e0
> [25878.651143]  [<ffffffff802db847>] put_inotify_watch+0x47/0x70
> [25878.651150]  [<ffffffff802db90f>] inotify_rm_wd+0x9f/0xd0
> [25878.651165]  [<ffffffff8020c37e>] system_call+0x7e/0x83
>
>
> It looks to me that KDE 4 is triggering this quite often, as I have not
> seen this before (in KDE 3 session).
> Full dmesg output attached.

Yes I think KDE4 is indeed causing this quite frequently...

Thanks,
Nick

Comment 38 Stefaan 2008-03-15 03:46:06 UTC
Same error here, and by coincidence (?) using kde4 and latex quite frequently.  
Gentoo Linux, 2.6.24 kernel.  
Comment 39 Daniel Drake 2008-03-18 03:13:31 UTC
This should be fixed in 2.6.25 with commits d599e36a9ea85432587f4550acc113cd7549d12a and 0d71bd5993b630a989d15adc2562a9ffe41cd26d. Can anyone confirm?
Comment 40 Stefaan 2008-03-25 07:43:25 UTC
Running a 2.6.25-rc6 linux kernel, my x86_64 system doesn't seem to complain about inotify anymore.  
Comment 41 Cijoml Cijomlovic Cijomlov 2008-04-24 11:58:38 UTC
Looks like I am also fixed... :)

Note You need to log in before you can comment on or make changes to this bug.