Bug 7783 - Thinkpad 1161 43G Hangs on boot -IDE interrupt regression
Thinkpad 1161 43G Hangs on boot -IDE interrupt regression
Status: CLOSED DUPLICATE of bug 5637
Product: ACPI
Classification: Unclassified
Component: Config-Interrupts
i386 Linux
: P2 normal
Assigned To: ykzhao
:
Depends on:
Blocks: USB
  Show dependency treegraph
 
Reported: 2007-01-07 02:45 UTC by Martin West
Modified: 2008-01-10 20:00 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.19.1
Tree: Mainline
Regression: Yes


Attachments
Output of dmesg, lsusb -v, lspci -v, dmidecode (15.00 KB, text/plain)
2007-10-23 07:05 UTC, Martin West
Details
Image of console at hang (on ubuntu) (423.14 KB, image/jpeg)
2007-10-23 10:44 UTC, Martin West
Details
dmesg output (9.95 KB, text/plain)
2007-11-08 14:46 UTC, Martin West
Details
Output from lspci -xxxvv (12.71 KB, text/plain)
2007-11-19 14:42 UTC, Martin West
Details
acpidump output (78.91 KB, text/plain)
2007-12-10 00:13 UTC, Martin West
Details
dmesg output (10.42 KB, text/plain)
2007-12-12 10:12 UTC, Martin West
Details
acpi=off (429.77 KB, image/jpeg)
2007-12-18 14:49 UTC, Martin West
Details
no option/pci=routeirq (438.49 KB, image/jpeg)
2007-12-18 14:52 UTC, Martin West
Details
dmesg output from 2.6.23 boot (11.37 KB, text/plain)
2007-12-18 16:02 UTC, Martin West
Details
Attach the output of BIOS PRT and MPS table (6.33 KB, application/x-gzip)
2007-12-18 17:49 UTC, ykzhao
Details
pirq_mps output (808 bytes, text/plain)
2007-12-19 00:23 UTC, Martin West
Details
dmesg output (13.05 KB, application/octet-stream)
2007-12-19 12:10 UTC, Martin West
Details
dmesg output (13.05 KB, text/plain)
2007-12-19 12:12 UTC, Martin West
Details

Description Martin West 2007-01-07 02:45:22 UTC
Most recent kernel where this bug did *NOT* occur:
Distribution: Fedora Core 3 2.6.9-1.667
Hardware Environment:1161-43G
Software Environment:linux
Problem Description:hang on boot

Steps to reproduce: boot on a 1161-43G

See http://www.redhat.com/archives/redhat-install-list/2002-June/msg00337.html

I discovered that this machine will boot up with Fedora Core 3 and successfully
initialise the usb support while trying to resurrect this machine to run pvrusb2.

I tried to build 2.6.19.1 by copying the config from the working image, running
make oldconfig and taking all the defaults but it again hangs again.
Comment 1 Natalie Protasevich 2007-06-13 19:05:55 UTC
Have you had any lack with installation lately? Do you still experience problems that you need to bring up?
Thanks.
Comment 2 Martin West 2007-06-14 00:31:50 UTC
I found I could in install Fedora Core 3 specifying nousb, but obviously the install has no usb support. 
Comment 3 Greg Kroah-Hartman 2007-07-26 23:57:03 UTC
Where does this hang?  Are there any log messages?

Can you enable CONFIG_USB_DEBUG and see if that gives us some more hints?
Comment 4 Martin West 2007-07-27 01:28:07 UTC
I can try but it wont be till next week.
Comment 5 Martin West 2007-07-27 01:45:50 UTC
PS I presume you would like me to try the latest kernel.
Comment 6 Natalie Protasevich 2007-08-05 21:55:31 UTC
Yes please.
Comment 7 Martin West 2007-08-07 11:18:10 UTC
Sorry for the delay, id been trying upgrade it to FC4 and I had broken it. I reinstalled FC3 and the initial kernel is 2.6.9-1.667. I hadnt realised before but the usb works on this version. I ran yum update and the 2.16.12-1.1381_FC3 gets install and then the usb stops working.

Still waiting for the latest kernel to build.
Comment 8 Martin West 2007-08-07 15:26:37 UTC
OK, I built the 2.6.22 kernel with USB_DEBUG=y and booted it. It hung at the same place. Where do I find the debug output?
Comment 9 Natalie Protasevich 2007-10-23 03:14:29 UTC
You should probably use the serial console to get the messages from the failed boot - I suppose the hang happens before you get the prompt. It would be helpful to have your system's data such as lsusb, lspci, dmidecode, dmesg from successful boot, etc.
Comment 10 Martin West 2007-10-23 06:48:04 UTC
Okey doke.
Comment 11 Martin West 2007-10-23 07:05:23 UTC
Created attachment 13253 [details]
Output of dmesg, lsusb -v, lspci -v, dmidecode

dmidecode didnt say a lot.
Comment 12 Martin West 2007-10-23 07:06:52 UTC
Catch 22 - the machine doesnt have a serial port and I dont think the usb/serial adapter will work in this situation.
Comment 13 Martin West 2007-10-23 08:10:29 UTC
PS there is a photo of the console at hang time when booting ubuntu at

http://www.uluga.ubuntuforums.org/showthread.php?t=572716

Just in case there is any info there that will be of help.
Comment 14 Alan Stern 2007-10-23 09:38:51 UTC
I don't have an account on the Ubuntu forum.  Can you just attach the photo to this bug report?

Do you have any USB devices attached or builtin which might interfere with the boot-up?
Comment 15 Martin West 2007-10-23 10:44:34 UTC
Created attachment 13254 [details]
Image of console at hang (on ubuntu)


I tried with and without a usb memory stick attached but same result.

There isnt much builtin on this machine, its pretty basic. No wireless, no lan, no web cam.

This is the spec ...

http://www-307.ibm.com/pc/support/site.wss/document.do?sitestyle=lenovo&lndocid=MIGR-4WMLS5
Comment 16 Alan Stern 2007-10-24 10:29:50 UTC
It looks like this is not a USB problem but rather an APIC or ACPI problem.  According to your screen image, the system guesses the IRQ line used by the USB controller, and apparently the guess is wrong.  That's why it hangs.

Natalie, this bug should be reassigned to someone else.
Comment 17 Martin West 2007-10-24 12:49:27 UTC
K, thanks.
Comment 18 Natalie Protasevich 2007-11-07 22:44:38 UTC
From the logs it appears that this system doesn't have IO-APIC. Can you please attach dmesg from successful boot also, and /proc/interrupts?

I will assign it to ACPI for now.
Martin, have you tried booting with acpi=off or pci=noacpi?
Comment 19 Martin West 2007-11-08 12:18:08 UTC
Ive tried the acpi=off but not pci=noacpi

wilco on the dmesg
Comment 20 Martin West 2007-11-08 14:46:10 UTC
Created attachment 13473 [details]
dmesg output

Tried acpi=off and pci=noacpi on FC6 with a 2.6.22 kernel and xubuntu but still the hang 

Thanks
Comment 21 Fu Michael 2007-11-18 20:51:52 UTC
Martin, would you please attach output of the following :
1) acpidump 
2) lspci -xxxvv

thanks.
Comment 22 Martin West 2007-11-19 14:42:23 UTC
Created attachment 13632 [details]
Output from lspci -xxxvv

acpidump wasnt happy ...
[root@localhost pmtools-20070714]# acpidump -a 0xEAB80
ACPI tables were not found. If you know location of RSD PTR table (from dmesg, etc), supply it with either --addr or -a option

acpidump alone gave the same thing, I used the address from DMESG ...

ACPI: RSDP (v000 IBM                                   ) @ 0x000eab80
ACPI: RSDT (v001 IBM    AXXXXXX4 0x00000004 IBM  0x00000000) @ 0x0b7f0000
ACPI: FADT (v001 IBM    AXXXXXX4 0x00000004 IBM  0x00000000) @ 0x0b7f008c
ACPI: BOOT (v001 IBM    AXXXXXX4 0x00000004 IBM  0x00000000) @ 0x0b7f0030
ACPI: DBGP (v001 IBM    AXXXXXX4 0x00000004 IBM  0x00000000) @ 0x0b7f0058
ACPI: DSDT (v001    IBM AXXXXXX4 0x00000004 MSFT 0x0100000d) @ 0x00000000
ACPI: PM-Timer IO Port: 0xf108

Thanks
Comment 23 Fu Michael 2007-12-06 19:17:34 UTC
Martin, what if you just run the acpidump?
Comment 24 Martin West 2007-12-07 00:25:28 UTC
> acpidump alone gave the same thing, 

You missed the above comment, it was a bit hidden :-)

I ran acpidump first, then tried the suggestion from acpidump. 
Comment 25 Lin Ming 2007-12-09 19:03:46 UTC
Martin, there is a bug of pmtools-20070714, pls try the lastest acpidump at:
http://ftp.ist.utl.pt/pub/kernel/people/lenb/acpi/utils/pmtools-20071116.tar.bz2
Comment 26 Martin West 2007-12-10 00:13:00 UTC
Created attachment 13935 [details]
acpidump output

Worked this time, thanks
Comment 27 ykzhao 2007-12-11 23:21:28 UTC
It seems like a duplicate of bug 5637, please try the patch in commet #15 in bug 5637 and see if it helps. 
Thanks. 
Comment 28 Martin West 2007-12-12 02:30:41 UTC
No didnt help. I applied the patch to 2.6.22 kernel. Tried with no command line options and command line pci=noacpi as per bug 5637 but it hangs initializing the hardware the console displays storage network audio and then hangs.

Thanks
Comment 29 Martin West 2007-12-12 07:50:11 UTC
Just tried with the latest 2.6.22.9 kernel, same problem. However I did notice a new message when booting with out the pci=noacpi, it said something to the affect

DMIBIOS has no date use acpi(force) ....

btw thanks for persisting with this, your efforts much appreciated.
Comment 30 Natalie Protasevich 2007-12-12 08:01:36 UTC
(Martin, for completeness please attach the boot trace like you did in #20, but without "quiet" boot parameter)
Comment 31 Martin West 2007-12-12 10:12:35 UTC
Created attachment 14001 [details]
dmesg output

dmesg output with out quiet set, this from the 2.6.9-1.667 boot
Comment 32 ykzhao 2007-12-13 23:51:19 UTC
Please remove the boot option quite and attach the image of console at hang for 2.6.22.9 just like comment #15 in following four cases:
1.no boot option
2.pci=noacpi
3.acpi=off
4.pci=routeirq
Comment 33 Martin West 2007-12-14 06:09:41 UTC
Unfortunately they all look the same and not very verbose, not like comment #15. That was on ubuntu. Ive removed the quiet option but it doesnt seem to output any more info. I tried debug, that prints out a bit more at the start but the final screen is just same.
Comment 34 Len Brown 2007-12-14 21:40:33 UTC
The screen capture of the failure in comment #15 is in acpi=off mode.
ACPI had nothing to do with PCI guessing IRQ10 for USB.
(though looking at PCI config space, that guess was probably correct)

The 2.6.9 dmesg shows...
> DMI not present.

So probably your Fedora kernel has CONFIG_ACPI_BLACKLIST_YEAR=1999
or some other non-zero value.

Try booting it with "acpi=force", or building a kernel.org kernel
with CONFIG_ACPI_BLACKLIST_YEAR=0.  Either of them should get
you into ACPI mode like your working 2.6.9 kernel.
Comment 35 Martin West 2007-12-17 12:16:37 UTC
Sorry for the delay, been away for the weekend.
yep, that was the message I noticed. There is a 2.6.23 kernel Ill try that.
Comment 36 Martin West 2007-12-18 14:46:24 UTC
Good news and bad news

Good: pci=noacpi system boots
Bad: acpi=off hangs at initializing hardware 
Worse: no option/pci=routeirq hangs earlier 

Thanks

pictures to follow
Comment 37 Martin West 2007-12-18 14:49:46 UTC
Created attachment 14109 [details]
acpi=off
Comment 38 Martin West 2007-12-18 14:52:15 UTC
Created attachment 14110 [details]
no option/pci=routeirq

The last 4/6 messages took 20-30 seconds to appear.
Comment 39 Martin West 2007-12-18 14:55:50 UTC
PS this was on 2.6.23 with apci year set to 0.
Comment 40 Martin West 2007-12-18 16:02:13 UTC
Created attachment 14112 [details]
dmesg output from 2.6.23 boot
Comment 41 ykzhao 2007-12-18 17:46:11 UTC
Hi, Martin
Thanks for the info.
Will you please try the patch in comment #15 of bug5637 and boot with no option?
Thanks.
Comment 42 ykzhao 2007-12-18 17:49:02 UTC
Created attachment 14113 [details]
Attach the output of BIOS PRT and MPS table
Comment 43 ykzhao 2007-12-18 17:51:03 UTC
Hi, Martin
Will you please attach the output using the tool in comment #42? 
Thanks.
Comment 44 Martin West 2007-12-19 00:23:27 UTC
Created attachment 14123 [details]
pirq_mps output
Comment 45 Martin West 2007-12-19 00:58:41 UTC
well done guys, with patch applied to 2.6.23 and no options the machine boots up.
Comment 46 ykzhao 2007-12-19 01:35:15 UTC
Will you please attach the output of dmesg and /proc/interrupts ?
Comment 47 Martin West 2007-12-19 12:09:00 UTC
cat /proc/interrupts
           CPU0
  0:      68535    XT-PIC-XT        timer
  1:        207    XT-PIC-XT        i8042
  2:          0    XT-PIC-XT        cascade
  8:          1    XT-PIC-XT        rtc
  9:          2    XT-PIC-XT        acpi
 10:        327    XT-PIC-XT        ohci_hcd:usb1, yenta, eth0
 11:        902    XT-PIC-XT        ALI 5451
 12:       3899    XT-PIC-XT        i8042
 14:      10722    XT-PIC-XT        ide0
 15:       6178    XT-PIC-XT        ide1
NMI:          0
ERR:          0
Comment 48 Martin West 2007-12-19 12:10:09 UTC
Created attachment 14128 [details]
dmesg output
Comment 49 Martin West 2007-12-19 12:12:18 UTC
Created attachment 14129 [details]
dmesg output
Comment 50 ykzhao 2007-12-19 17:18:53 UTC
It seems that the system can boot after applying the patch in bug 5637. So it is marked as a duplicate of bug5637.

*** This bug has been marked as a duplicate of bug 5637 ***

Note You need to log in before you can comment on or make changes to this bug.