Bug 77371 - ACPI Warning on D2xxx/N2xxx - Resource conflict(s) found affecting gpio_ich
Summary: ACPI Warning on D2xxx/N2xxx - Resource conflict(s) found affecting gpio_ich
Status: CLOSED DUPLICATE of bug 44991
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Video (show other bugs)
Hardware: x86-64 Linux
: P1 high
Assignee: acpi_power-video
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-05 07:42 UTC by HacKurx
Modified: 2014-09-27 17:34 UTC (History)
3 users (show)

See Also:
Kernel Version: Linux 3.14.4
Tree: Mainline
Regression: No


Attachments

Description HacKurx 2014-06-05 07:42:20 UTC
Hi,

I use Ubuntu 14.04 LTS Server and a custom kernel.
Grub is displayed correctly but after I have no display.

lspci -v
00:00.0 Host bridge: Intel Corporation Atom Processor D2xxx/N2xxx DRAM Controller (rev 03)
	Subsystem: Intel Corporation Device 1999
	Flags: bus master, fast devsel, latency 0

dmesg | grep -i warn
[    5.080388] ACPI Warning: SystemIO range 0x0000000000000428-0x000000000000042f conflicts with OpRegion 0x0000000000000400-0x000000000000042f (\SWC1) (20131218/utaddress-258)
[    5.080408] ACPI Warning: SystemIO range 0x0000000000000428-0x000000000000042f conflicts with OpRegion 0x0000000000000400-0x000000000000047f (\PMIO) (20131218/utaddress-258)
[    5.080428] ACPI Warning: SystemIO range 0x0000000000000530-0x000000000000053f conflicts with OpRegion 0x0000000000000500-0x000000000000053b (\GPIO) (20131218/utaddress-258)
[    5.080443] ACPI Warning: SystemIO range 0x0000000000000500-0x000000000000052f conflicts with OpRegion 0x0000000000000500-0x000000000000053b (\GPIO) (20131218/utaddress-258)

This resembles the following problem :
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1290832
https://lists.debian.org/debian-kernel/2013/04/msg00144.html

Thanks, best regards
Comment 1 HacKurx 2014-06-05 07:52:30 UTC
I use a standard VGA cable:

lspci -vvv
00:02.0 VGA compatible controller: Intel Corporation Atom Processor D2xxx/N2xxx Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
	Subsystem: Intel Corporation Device 1999
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin A routed to IRQ 11
	Region 0: Memory at dfb00000 (32-bit, non-prefetchable) [size=1M]
	Region 1: I/O ports at f100 [size=8]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: [d0] Power Management version 2
		Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
	Capabilities: [b0] Vendor Specific Information: Len=07 <?>
	Capabilities: [90] MSI: Enable- Count=1/1 Maskable- 64bit-
		Address: 00000000  Data: 0000

cat /var/log/dmesg | grep -i vga
[    0.396333] vgaarb: device added: PCI:0000:00:02.0,decodes=io+mem,owns=io+mem,locks=none
[    0.396344] vgaarb: loaded
[    0.396348] vgaarb: bridge control possible 0000:00:02.0

Thanks
Comment 2 Aaron Lu 2014-06-11 02:55:14 UTC
What if you add the nomodeset kernel cmdline option?
BTW, do you always have this problem or it starts to appear from some kernel version?
Comment 3 Zhang Rui 2014-06-11 08:41:15 UTC
weird, why do I see this in https://lists.debian.org/debian-kernel/2013/04/msg00144.html, plus, I can not find the 00:02.0 VGA controller in this page?

01:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI
Seymour LP [Radeon HD 6430M] [1002:6761] (prog-if 00 [VGA controller])
        Subsystem: Holco Enterprise Co, Ltd/Shuttle Computer Device [1297:4012]
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort-
<MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 45
        Region 0: Memory at c0000000 (64-bit, prefetchable) [size=256M]
        Region 2: Memory at d0020000 (64-bit, non-prefetchable) [size=128K]
        Region 4: I/O ports at e000 [size=256]
        Expansion ROM at d0000000 [disabled] [size=128K]
        Capabilities: <access denied>
        Kernel driver in use: radeon

Plus, can you please login the machine via ssh, and change the backlight manually by poking /sys/class/backlight/?
Comment 4 HacKurx 2014-06-11 19:27:42 UTC
I add the nomodeset kernel cmdline but identical problem.
No problem with the 3.12.5 release (I used vesa at this version) :
CONFIG_FB_BOOT_VESA_SUPPORT=y
CONFIG_FB_CFB_FILLRECT=y
CONFIG_FB_CFB_COPYAREA=y
CONFIG_FB_CFB_IMAGEBLIT=y
CONFIG_FB_VESA=y
CONFIG_FB_BACKLIGHT=y

Now i use this :
CONFIG_INTEL_GTT=m
CONFIG_DRM_I915=m
CONFIG_DRM_I915_KMS=y
CONFIG_DRM_I915_FBDEV=y
# CONFIG_DRM_I915_PRELIMINARY_HW_SUPPORT is not set
# CONFIG_DRM_I915_UMS is not set

The problem must come here. The Integrated Graphics Controller (Intel Atom CPU D2700) works only with vesa? Or should I use CONFIG_DRM_GMA500?

Thanks
Comment 5 Zhang Rui 2014-06-12 01:07:12 UTC
Well, this could be an ACPI backlight control issue OR graphics problem.
Thus I need your confirmation about the question in comment #3 first.
If it is not a backlight issue, I will assign this bug to the graphics expert.
Comment 6 HacKurx 2014-06-12 18:49:50 UTC
I activated option "CONFIG_DRM_GMA500" and the display is working correctly but I still see errors in the logs.

partial result of the dmesg command :
[    0.451745] pci 0000:00:02.0: Boot video device
[    1.337582] [drm] Initialized drm 1.1.0 20060810
[    1.674684] ata1.00: supports DRM functions and may not be fully accessible
[    1.681157] ata1.00: supports DRM functions and may not be fully accessible
[    4.785781] gma500 0000:00:02.0: irq 50 for MSI/MSI-X
[    4.803618] ACPI: Video Device [GFX0] (multi-head: yes  rom: no  post: no)
[    4.806094] input: Video Bus as /devices/LNXSYSTM:00/device:00/PNP0A08:00/LNXVIDEO:00/input/input12
[    4.806402] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[    4.806409] [drm] No driver support for vblank timestamp query.
[    5.545604] fbcon: psbdrmfb (fb0) is primary device
[    6.211050] Console: switching to colour frame buffer device 170x48
[    6.224843] gma500 0000:00:02.0: fb0: psbdrmfb frame buffer device
[    6.224843] gma500 0000:00:02.0: fb0: psbdrmfb frame buffer device
[    6.224843] gma500 0000:00:02.0: fb0: psbdrmfb frame buffer device
[    6.224847] gma500 0000:00:02.0: registered panic notifier
[    6.224847] gma500 0000:00:02.0: registered panic notifier
[    6.225020] [drm] Initialized gma500 1.0.0 2011-06-06 for 0000:00:02.0 on minor 0
[    6.225020] [drm] Initialized gma500 1.0.0 2011-06-06 for 0000:00:02.0 on minor 0
[    6.225194] ACPI Warning: SystemIO range 0x0000000000000428-0x000000000000042f conflicts with OpRegion 0x0000000000000400-0x000000000000042f (\SWC1) (20131218/utaddress-258)
[    6.225211] ACPI Warning: SystemIO range 0x0000000000000428-0x000000000000042f conflicts with OpRegion 0x0000000000000400-0x000000000000047f (\PMIO) (20131218/utaddress-258)
[    6.225223] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[    6.225231] ACPI Warning: SystemIO range 0x0000000000000530-0x000000000000053f conflicts with OpRegion 0x0000000000000500-0x000000000000053b (\GPIO) (20131218/utaddress-258)
[    6.225242] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[    6.225248] ACPI Warning: SystemIO range 0x0000000000000500-0x000000000000052f conflicts with OpRegion 0x0000000000000500-0x000000000000053b (\GPIO) (20131218/utaddress-258)
[    6.225259] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[    6.225264] lpc_ich: Resource conflict(s) found affecting gpio_ich
[    6.371758] init: failsafe main process (1908) killed by TERM signal
[    6.374103] init: udev-fallback-graphics main process (1931) terminated with status 1

Here is what I have in /sys/class/backlight/ (I had nothing before activate option CONFIG_DRM_GMA500):
ls /sys/class/backlight/*
/sys/class/backlight/acpi_video0:
actual_brightness  bl_power  brightness  device  max_brightness  power  subsystem  type  uevent

/sys/class/backlight/psb-bl:
actual_brightness  bl_power  brightness  max_brightness  power  subsystem  type  uevent

To summarize:
lspci -k
00:02.0 VGA compatible controller: Intel Corporation Atom Processor D2xxx/N2xxx Integrated Graphics Controller (rev 09)
	Subsystem: Intel Corporation Device 1999
	Kernel driver in use: gma500

If you want  test my hardware please tell me the commands directly (It is much more understandable to me ^^), English is not my language and sometimes I have trouble understanding.

Thanks,
Comment 8 HacKurx 2014-06-12 19:10:03 UTC

*** This bug has been marked as a duplicate of bug 44991 ***
Comment 9 Martin Vegter 2014-09-27 17:34:45 UTC
I have this same proble with kernel 3.14.19:

ACPI Warning: SystemIO range 0x000000000000f040-0x000000000000f05f conflicts with OpRegion 0x000000000000f040-0x000000000000f04f (\_SB_.PCI0.SBUS.SMBI) (20131218/utaddress-258)

the "duplicate" bug 44991 has been closed, but the problem still persists.

Note You need to log in before you can comment on or make changes to this bug.