Bug 7679 - RTC IRQ 8 screams unless pnpacpi=off - Intel STL2
Summary: RTC IRQ 8 screams unless pnpacpi=off - Intel STL2
Status: CLOSED DUPLICATE of bug 5243
Alias: None
Product: ACPI
Classification: Unclassified
Component: BIOS (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Len Brown
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-12-14 02:16 UTC by Len Brown
Modified: 2008-01-12 16:02 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.19
Tree: Mainline
Regression: ---


Attachments
acpidump (102.84 KB, text/plain)
2006-12-14 02:18 UTC, Len Brown
Details
2.6.19 dmesg pnpacpi=off (44.78 KB, text/plain)
2006-12-14 02:18 UTC, Len Brown
Details
2.6.19 dmesg (44.81 KB, text/plain)
2006-12-14 02:19 UTC, Len Brown
Details

Description Len Brown 2006-12-14 02:16:38 UTC
did not see in 2.6.7
seen in 2.6.12, 13, 16, 17, 18, 19

Intel STL2 dual Pentium 3 server in default config:

           CPU0       CPU1
  0:      18202       6171   IO-APIC-edge      timer
  1:          4          4   IO-APIC-edge      i8042
  4:        397          8   IO-APIC-edge      serial
  6:          3          2   IO-APIC-edge      floppy
  7:          0          0   IO-APIC-edge      parport0
  8:    3918048    4315513   IO-APIC-fasteoi   rtc
 10:          0          0   IO-APIC-fasteoi   ohci_hcd:usb1
 12:         68         63   IO-APIC-edge      i8042
 14:        127         11   IO-APIC-edge      ide0
 16:        162          1   IO-APIC-fasteoi   eth0
 20:       4553        143   IO-APIC-fasteoi   aic7xxx
 21:         10          5   IO-APIC-fasteoi   aic7xxx
 31:        823        162   IO-APIC-fasteoi   acpi
NMI:          0          0
LOC:      24231      24209
ERR:          0
MIS:          0

Booted with pnpacpi=off
           CPU0       CPU1
  0:      15487       5942   IO-APIC-edge      timer
  1:          0          8   IO-APIC-edge      i8042
  4:        369          1   IO-APIC-edge      serial
  6:          1          4   IO-APIC-edge      floppy
  7:          0          0   IO-APIC-edge      parport0
  8:          0          0   IO-APIC-edge      rtc
 10:          0          0   IO-APIC-fasteoi   ohci_hcd:usb1
 12:         34         97   IO-APIC-edge      i8042
 14:        132         17   IO-APIC-edge      ide0
 16:        120          1   IO-APIC-fasteoi   eth0
 20:       4607         66   IO-APIC-fasteoi   aic7xxx
 21:          0         15   IO-APIC-fasteoi   aic7xxx
 31:        824        161   IO-APIC-fasteoi   acpi
NMI:          0          0
LOC:      21280      21284
ERR:          0
MIS:          0

RTC interrupt is erroneously getting configured as level-triggered.
Comment 1 Len Brown 2006-12-14 02:18:06 UTC
Created attachment 9813 [details]
acpidump
Comment 2 Len Brown 2006-12-14 02:18:55 UTC
Created attachment 9814 [details]
2.6.19 dmesg pnpacpi=off
Comment 3 Len Brown 2006-12-14 02:19:42 UTC
Created attachment 9815 [details]
2.6.19 dmesg
Comment 4 Shaohua 2006-12-14 17:25:15 UTC
This is a BIOS bug. _CRS claims the interrupt is level for RTC. We had a similar
bug report http://bugzilla.kernel.org/show_bug.cgi?id=5243 and a workaround there.
Comment 5 Fu Michael 2007-11-12 17:41:12 UTC
dup of bug# 9153(?)

*** This bug has been marked as a duplicate of bug 9153 ***
Comment 6 Len Brown 2007-11-16 21:52:41 UTC
per Shaohua's comment #4, the DSDT (and thus pnpacpi)
parse the BIOS DSDT, which erroneously sets IRQ8 to level sensitive.

                Device (RTC)
                {
                    Name (_HID, EisaId ("PNP0B00"))
                    Name (RTCD, 0x00)
                    Name (CRSP, ResourceTemplate ()
                    {
                        IO (Decode16, 0x0070, 0x0070, 0x01, 0x02)
                        IRQ (Level, ActiveLow, Exclusive) {8}
                    })
                    Method (_CRS, 0, NotSerialized)
                    {
                        Return (CRSP)
                    }

So technically, this is a BIOS bug, and
a duplicate of bug 5243,
which is has the same fix as bug 9153:-)
Comment 7 Len Brown 2007-11-16 21:53:04 UTC

*** This bug has been marked as a duplicate of bug 5243 ***

Note You need to log in before you can comment on or make changes to this bug.