Bug 7673 - Memory card reader 5-in-1 don't working on Lenovo N100 3000
Memory card reader 5-in-1 don't working on Lenovo N100 3000
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: Drivers
Classification: Unclassified
Component: MMC/SD
i386 Linux
: P2 high
Assigned To: Pierre Ossman
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-12 18:59 UTC by NPetr
Modified: 2007-11-30 00:56 UTC (History)
7 users (show)

See Also:
Kernel Version: 2.6.20
Tree: Mainline
Regression: ---


Attachments
acpidump1.txt (102.19 KB, text/plain)
2007-04-06 18:06 UTC, NPetr
Details
acpidump2.txt (102.19 KB, text/plain)
2007-04-06 18:07 UTC, NPetr
Details
dmesg1.txt (21.82 KB, text/plain)
2007-04-06 18:08 UTC, NPetr
Details
dmesg2.txt (18.91 KB, text/plain)
2007-04-06 18:08 UTC, NPetr
Details
interrupts1.txt (712 bytes, text/plain)
2007-04-06 18:09 UTC, NPetr
Details
interrupts2.txt (750 bytes, text/plain)
2007-04-06 18:09 UTC, NPetr
Details
lspci1.txt (16.89 KB, text/plain)
2007-04-06 18:09 UTC, NPetr
Details
lspci2.txt (16.60 KB, text/plain)
2007-04-06 18:10 UTC, NPetr
Details

Description NPetr 2006-12-12 18:59:47 UTC
Most recent kernel where this bug did *NOT* occur: nothing
Distribution: openSUSE 10.2, Frugalware 0.6 pre 1 (current)
Hardware Environment: Lenovo N100 3000
Software Environment: Linux
Problem Description: Memory card reader 5-in-1 don't working on Lenovo N100 3000

Steps to reproduce:

1.
(Description of Problem)

uname -a

2.6.19-fw1 #1 SMP PREEMPT Thu Nov 30 16:14:02 CET 2006 i686 GNU/Linux

lsmod | grep -i mmc

mmc_block              12040  0 
mmc_core               28672  2 mmc_block,sdhci

dmesg | grep -i mmc

PCI: Using MMCONFIG
sr0: scsi3-mmc drive: 62x/62x writer dvd-ram cd/rw xa/form2 cdda tray
mmc0: SDHCI at 0xb0300400 irq 225 DMA

dmesg | grep -i sdhci

sdhci: Secure Digital Host Controller Interface driver, 0.12
sdhci: Copyright(c) Pierre Ossman
sdhci: SDHCI controller found at 0000:05:06.1 [1180:0822] (rev 19)
mmc0: SDHCI at 0xb0300400 irq 225 DMA

cat /proc/devices

Character devices:
  1 mem
  2 pty
  3 ttyp
  4 /dev/vc/0
  4 tty
  4 ttyS
  5 /dev/tty
  5 /dev/console
  5 /dev/ptmx
  7 vcs
 10 misc
 13 input
 14 sound
 21 sg
 29 fb
116 alsa
128 ptm
136 pts
171 ieee1394
180 usb
189 usb_device
216 rfcomm
226 drm
254 pcmcia

Block devices:
  1 ramdisk
  7 loop
  8 sd
  9 md
 11 sr
 65 sd
 66 sd
 67 sd
 68 sd
 69 sd
 70 sd
 71 sd
128 sd
129 sd
130 sd
131 sd
132 sd
133 sd
134 sd
135 sd
252 mmc
253 device-mapper
254 mdp

lspci

00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS/940GML and 945GT
Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS/940GML
Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/940GML Express
Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition
Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1
(rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2
(rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #1 (rev
02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #2 (rev
02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #3 (rev
02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #4 (rev
02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI
Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge
(rev 02)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) Serial ATA
Storage Controller IDE (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
03:00.0 Network controller: Broadcom Corporation BCM4310 UART (rev 01)
05:01.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
05:04.0 CardBus bridge: ENE Technology Inc CB1410 Cardbus Controller (rev 01)
05:06.0 FireWire (IEEE 1394): Ricoh Co Ltd Unknown device 0832
05:06.1 Generic system peripheral [Class 0805]: Ricoh Co Ltd R5C822
SD/SDIO/MMC/MS/MSPro Host Adapter (rev 19)
05:06.2 System peripheral: Ricoh Co Ltd Unknown device 0843 (rev 01)
05:06.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter
(rev 0a)
05:06.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 05)

lspci -n

00:00.0 Class 0600: 8086:27a0 (rev 03)
00:02.0 Class 0300: 8086:27a2 (rev 03)
00:02.1 Class 0380: 8086:27a6 (rev 03)
00:1b.0 Class 0403: 8086:27d8 (rev 02)
00:1c.0 Class 0604: 8086:27d0 (rev 02)
00:1c.1 Class 0604: 8086:27d2 (rev 02)
00:1d.0 Class 0c03: 8086:27c8 (rev 02)
00:1d.1 Class 0c03: 8086:27c9 (rev 02)
00:1d.2 Class 0c03: 8086:27ca (rev 02)
00:1d.3 Class 0c03: 8086:27cb (rev 02)
00:1d.7 Class 0c03: 8086:27cc (rev 02)
00:1e.0 Class 0604: 8086:2448 (rev e2)
00:1f.0 Class 0601: 8086:27b9 (rev 02)
00:1f.2 Class 0101: 8086:27c4 (rev 02)
00:1f.3 Class 0c05: 8086:27da (rev 02)
03:00.0 Class 0280: 14e4:4312 (rev 01)
05:01.0 Class 0200: 10ec:8139 (rev 10)
05:04.0 Class 0607: 1524:1410 (rev 01)
05:06.0 Class 0c00: 1180:0832
05:06.1 Class 0805: 1180:0822 (rev 19)
05:06.2 Class 0880: 1180:0843 (rev 01)
05:06.3 Class 0880: 1180:0592 (rev 0a)
05:06.4 Class 0880: 1180:0852 (rev 05)

lsusb

Bus 002 Device 001: ID 0000:0000  
Bus 004 Device 001: ID 0000:0000  
Bus 001 Device 003: ID 0a5c:2101 Broadcom Corp. 
Bus 001 Device 001: ID 0000:0000  
Bus 005 Device 006: ID 0ea0:2168 Ours Technology, Inc. Transcend JetFlash 2.0 /
Astone USB Drive
Bus 005 Device 003: ID 0c45:624f Microdia 
Bus 005 Device 001: ID 0000:0000  
Bus 003 Device 002: ID 08ff:2580 AuthenTec, Inc. 
Bus 003 Device 001: ID 0000:0000

2.
(Steps to reproduce the problem)

mknod /dev/mmc b 252 0
mknod /dev/mmc0 b 252 1

3.
(Actual Results)

mount /dev/mmc /mnt

mount: /dev/mmc is not a valid block device.

mount /dev/mmc0 /mnt

mount: /dev/mmc0 is not a valid block device.

4.
(Expected Results)

Mount as flashdisk, automaticly detected by udev, appears in /proc/partitions.

5.
(How often does this happen)

This problem is permanent.

6.
(Additional Information)

On openSUSE 10.2, Frugalware 0.6 pre1 not working.
Comment 1 Pierre Ossman 2006-12-12 21:25:06 UTC
First off, if you use udev then you shouldn't do mknod. If the device nodes
aren't present, then the kernel hasn't found any hardware to talk to.

Could you check if irq 225 in /proc/interrupts increases when you insert a card.
Comment 2 NPetr 2006-12-13 02:12:59 UTC
Before input card:
cat /proc/interrupts

           CPU0       
  0:      44724    IO-APIC-edge  timer
  1:        545    IO-APIC-edge  i8042
  8:         45    IO-APIC-edge  rtc
  9:       1250   IO-APIC-level  acpi
 12:        133    IO-APIC-edge  i8042
 14:      11815    IO-APIC-edge  libata
 15:       1758    IO-APIC-edge  libata
 50:      67481   IO-APIC-level  eth0
177:        859   IO-APIC-level  uhci_hcd:usb4, yenta
209:          0   IO-APIC-level  uhci_hcd:usb2
217:         76   IO-APIC-level  uhci_hcd:usb1, ehci_hcd:usb5, sdhci:slot0
225:         23   IO-APIC-level  uhci_hcd:usb3
233:        261   IO-APIC-level  HDA Intel, ohci1394
NMI:          0 
LOC:      44615 
ERR:          0
MIS:          0

After input card:
cat /proc/interrupts

           CPU0       
  0:      62627    IO-APIC-edge  timer
  1:        914    IO-APIC-edge  i8042
  8:         45    IO-APIC-edge  rtc
  9:       1310   IO-APIC-level  acpi
 12:        133    IO-APIC-edge  i8042
 14:      11889    IO-APIC-edge  libata
 15:       2550    IO-APIC-edge  libata
 50:      98119   IO-APIC-level  eth0
177:        859   IO-APIC-level  uhci_hcd:usb4, yenta
209:          0   IO-APIC-level  uhci_hcd:usb2
217:         76   IO-APIC-level  uhci_hcd:usb1, ehci_hcd:usb5, sdhci:slot0
225:         23   IO-APIC-level  uhci_hcd:usb3
233:        261   IO-APIC-level  HDA Intel, ohci1394
NMI:          0 
LOC:      62519 
ERR:          0
MIS:          0

Before and after input together:
cat /proc/ioports

0000-001f : dma1
0020-0021 : pic1
0040-0043 : timer0
0050-0053 : timer1
0060-006f : keyboard
0070-0077 : rtc
0080-008f : dma page reg
00a0-00a1 : pic2
00c0-00df : dma2
00f0-00ff : fpu
0170-0177 : libata
01f0-01f7 : libata
03c0-03df : vesafb
06a0-06af : pnp 00:07
06b0-06ff : pnp 00:07
1000-107f : motherboard
  1000-1003 : ACPI PM1a_EVT_BLK
  1004-1005 : ACPI PM1a_CNT_BLK
  1008-100b : ACPI PM_TMR
  1010-1015 : ACPI CPU throttle
  1020-1020 : ACPI PM2_CNT_BLK
  1028-102f : ACPI GPE0_BLK
1180-11bf : motherboard
1640-164f : motherboard
1800-1807 : 0000:00:02.0
1820-183f : 0000:00:1d.0
  1820-183f : uhci_hcd
1840-185f : 0000:00:1d.1
  1840-185f : uhci_hcd
1860-187f : 0000:00:1d.2
  1860-187f : uhci_hcd
1880-189f : 0000:00:1d.3
  1880-189f : uhci_hcd
18b0-18bf : 0000:00:1f.2
  18b0-18bf : libata
18c0-18df : 0000:00:1f.3
  18c0-18df : i801_smbus
2000-2fff : PCI Bus #05
  2000-20ff : 0000:05:01.0
    2000-20ff : 8139too
  2400-24ff : PCI CardBus #06
  2800-28ff : PCI CardBus #06
ff00-ff7f : motherboard

Before and after input together:
cat /proc/iomem

00000000-0009f7ff : System RAM
  00000000-00000000 : Crash kernel
0009f800-0009ffff : reserved
000a0000-000bffff : Video RAM area
000c0000-000c7fff : Video ROM
000ce800-000cf7ff : Adapter ROM
000f0000-000fffff : System ROM
00100000-1f68ffff : System RAM
  00100000-002a8585 : Kernel code
  002a8586-0039a7b7 : Kernel data
1f690000-1f69afff : ACPI Tables
1f69b000-1f6fffff : ACPI Non-volatile Storage
1f700000-1fffffff : reserved
30000000-31ffffff : PCI Bus #05
  30000000-31ffffff : PCI CardBus #06
32000000-33ffffff : PCI CardBus #06
b0000000-b0003fff : 0000:00:1b.0
  b0000000-b0003fff : ICH HD audio
b0004000-b00043ff : 0000:00:1d.7
  b0004000-b00043ff : ehci_hcd
b0040000-b007ffff : 0000:00:02.0
b0080000-b00fffff : 0000:00:02.0
b0100000-b017ffff : 0000:00:02.1
b0200000-b02fffff : PCI Bus #03
  b0200000-b0203fff : 0000:03:00.0
b0300000-b03fffff : PCI Bus #05
  b0300000-b03000ff : 0000:05:01.0
    b0300000-b03000ff : 8139too
  b0300400-b03004ff : 0000:05:06.1
    b0300400-b03004ff : sdhci:slot0
  b0300800-b0300fff : 0000:05:06.0
    b0300800-b0300fff : ohci1394
  b0301000-b0301fff : 0000:05:04.0
    b0301000-b0301fff : yenta_socket
  b0302000-b03020ff : 0000:05:06.2
  b0302400-b03024ff : 0000:05:06.3
  b0302800-b03028ff : 0000:05:06.4
c0000000-cfffffff : 0000:00:02.0
  c0000000-c07affff : vesafb
e0000000-efffffff : reserved
fec00000-fec0ffff : reserved
fed00000-fed003ff : reserved
fed14000-fed19fff : reserved
fed1c000-fed8ffff : reserved
fee00000-fee00fff : reserved
ff000000-ffffffff : reserved
Comment 3 NPetr 2006-12-15 13:00:12 UTC
Pierre, do You have all right information from me? Did You analyze this bug
already? See Ya, NPetr.
Comment 4 Pierre Ossman 2006-12-17 10:38:02 UTC
Sorry, I've been a bit swamped so I haven't had time to look at this.

From you report it doesn't seem like the device is generating the card insertion
interrupt. Could you try having a card in the slot when you boot the machine?
Remember to load mmc_block.

It's also a bit odd that your /proc/interrupt doesn't seem to line up with the
irq stated in dmesg. Could you double check that these two really differ?
Comment 5 NPetr 2006-12-18 16:49:03 UTC
After boot with inserted card:
(modules.conf has mmc_core, mmc_block, sdhci)

lsmod | grep -i mmc
mmc_block               9864  0 
mmc_core               25860  2 sdhci,mmc_block

dmesg | grep -i mmc
sdhci: Secure Digital Host Controller Interface driver, 0.12
sdhci: Copyright(c) Pierre Ossman
sdhci: SDHCI controller found at 0000:05:06.1 [1180:0822] (rev 19)
mmc0: SDHCI at 0xb0300400 irq 19 DMA

cat /proc/devices
Character devices:
  1 mem
  2 pty
  3 ttyp
  4 /dev/vc/0
  4 tty
  4 ttyS
  5 /dev/tty
  5 /dev/console
  5 /dev/ptmx
  6 lp
  7 vcs
 10 misc
 13 input
 14 sound
 29 fb
116 alsa
128 ptm
136 pts
171 ieee1394
180 usb
189 usb_device
226 drm

Block devices:
  1 ramdisk
  7 loop
  8 sd
  9 md
 11 sr
 22 ide1
 65 sd
 66 sd
 67 sd
 68 sd
 69 sd
 70 sd
 71 sd
128 sd
129 sd
130 sd
131 sd
132 sd
133 sd
134 sd
135 sd
252 mmc
253 device-mapper
254 mdp

cat /proc/interrupts
After boot with inserted card:
           CPU0       
  0:     133128   IO-APIC-edge      timer
  1:        283   IO-APIC-edge      i8042
  8:          3   IO-APIC-edge      rtc
  9:         16   IO-APIC-fasteoi   acpi
 12:        133   IO-APIC-edge      i8042
 14:       4978   IO-APIC-edge      libata
 15:       1049   IO-APIC-edge      ide1
 17:       1198   IO-APIC-fasteoi   yenta, uhci_hcd:usb5
 18:          0   IO-APIC-fasteoi   uhci_hcd:usb3
 19:         49   IO-APIC-fasteoi   sdhci:slot0, ehci_hcd:usb1, uhci_hcd:usb2
 20:        299   IO-APIC-fasteoi   ohci1394, HDA Intel
 21:      14374   IO-APIC-fasteoi   eth0
 22:         19   IO-APIC-fasteoi   uhci_hcd:usb4
NMI:          0 
LOC:     133062 
ERR:          0
MIS:          0

After remove card in this booted system:
           CPU0       
  0:     227160   IO-APIC-edge      timer
  1:        731   IO-APIC-edge      i8042
  8:          3   IO-APIC-edge      rtc
  9:         16   IO-APIC-fasteoi   acpi
 12:        133   IO-APIC-edge      i8042
 14:       5034   IO-APIC-edge      libata
 15:       1877   IO-APIC-edge      ide1
 17:       1198   IO-APIC-fasteoi   yenta, uhci_hcd:usb5
 18:          0   IO-APIC-fasteoi   uhci_hcd:usb3
 19:         49   IO-APIC-fasteoi   sdhci:slot0, ehci_hcd:usb1, uhci_hcd:usb2
 20:        299   IO-APIC-fasteoi   ohci1394, HDA Intel
 21:      26837   IO-APIC-fasteoi   eth0
 22:         19   IO-APIC-fasteoi   uhci_hcd:usb4
NMI:          0 
LOC:     227098 
ERR:          0
MIS:          0

After move back card in this booted system:
           CPU0       
  0:     365924   IO-APIC-edge      timer
  1:       1428   IO-APIC-edge      i8042
  8:          3   IO-APIC-edge      rtc
  9:         80   IO-APIC-fasteoi   acpi
 12:        133   IO-APIC-edge      i8042
 14:       5229   IO-APIC-edge      libata
 15:       3119   IO-APIC-edge      ide1
 17:       1198   IO-APIC-fasteoi   yenta, uhci_hcd:usb5
 18:          0   IO-APIC-fasteoi   uhci_hcd:usb3
 19:         49   IO-APIC-fasteoi   sdhci:slot0, ehci_hcd:usb1, uhci_hcd:usb2
 20:        299   IO-APIC-fasteoi   ohci1394, HDA Intel
 21:      45261   IO-APIC-fasteoi   eth0
 22:         19   IO-APIC-fasteoi   uhci_hcd:usb4
NMI:          0 
LOC:     365869 
ERR:          0
MIS:          0

* only /proc/interrupts reacts to moving card out or in, that things I reported
Comment 6 NPetr 2006-12-18 16:54:46 UTC
Be carefull, I see, that my /proc/interrupts changig continuously independently
of MMC card. But I guess, that is normal behaviour.
Comment 7 Pierre Ossman 2006-12-18 22:00:22 UTC
Seems you managed to kill off the APIC in that last run.

This looks like some generic irq routing problem, which isn't really my domain.
But I know that people have had success with specifying "irqpoll" on the kernel
command line. Please give that a try and see what happens.
Comment 8 NPetr 2006-12-21 03:29:29 UTC
With boot with irqpoll option:

dmesg:
Linux version 2.6.18.2-34-default (geeko@buildhost) (gcc version 4.1.2 20061115
(prerelease) (SUSE Linux)) #1 SMP Mon Nov 27 11:46:27 UTC 2006
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009f800 (usable)
 BIOS-e820: 000000000009f800 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000dc000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 000000001f690000 (usable)
 BIOS-e820: 000000001f690000 - 000000001f69b000 (ACPI data)
 BIOS-e820: 000000001f69b000 - 000000001f700000 (ACPI NVS)
 BIOS-e820: 000000001f700000 - 0000000020000000 (reserved)
 BIOS-e820: 00000000e0000000 - 00000000f0000000 (reserved)
 BIOS-e820: 00000000fec00000 - 00000000fec10000 (reserved)
 BIOS-e820: 00000000fed00000 - 00000000fed00400 (reserved)
 BIOS-e820: 00000000fed14000 - 00000000fed1a000 (reserved)
 BIOS-e820: 00000000fed1c000 - 00000000fed90000 (reserved)
 BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
 BIOS-e820: 00000000ff000000 - 0000000100000000 (reserved)
0MB HIGHMEM available.
502MB LOWMEM available.
found SMP MP-table at 000f6980
On node 0 totalpages: 128656
  DMA zone: 4096 pages, LIFO batch:0
  Normal zone: 124560 pages, LIFO batch:31
DMI present.
Using APIC driver default
IO/L-APIC allowed because system is MP or new enough
ACPI: RSDP (v000 LENOVO                                ) @ 0x000f68f0
ACPI: RSDT (v001 LENOVO TP-61    0x00000016  LTP 0x00000000) @ 0x1f695850
ACPI: FADT (v001 TOSCPL CALISTGA 0x00000016 LOHR 0x0000005a) @ 0x1f69adfc
ACPI: MADT (v001 INTEL  CALISTGA 0x00000016 LOHR 0x0000005a) @ 0x1f69ae70
ACPI: HPET (v001 INTEL  CALISTGA 0x00000016 LOHR 0x0000005a) @ 0x1f69aed8
ACPI: MCFG (v001 INTEL  CALISTGA 0x00000016 LOHR 0x0000005a) @ 0x1f69af10
ACPI: BOOT (v001 PTLTD  $SBFTBL$ 0x00000016  LTP 0x00000001) @ 0x1f69afd8
ACPI: MADT (v001 PTLTD  	 APIC   0x00000016  LTP 0x00000000) @ 0x1f69af7e
ACPI: SSDT (v001 SataRe  SataPri 0x00001000 INTL 0x20050624) @ 0x1f696648
ACPI: SSDT (v001 SataRe  SataSec 0x00001000 INTL 0x20050624) @ 0x1f695fb6
ACPI: SSDT (v001  PmRef  Cpu0Cst 0x00003001 INTL 0x20050624) @ 0x1f695db4
ACPI: SSDT (v001  PmRef    CpuPm 0x00003000 INTL 0x20050624) @ 0x1f69589c
ACPI: DSDT (v001 LENOVO TP-61    0x00000016 INTL 0x20050624) @ 0x00000000
ACPI: PM-Timer IO Port: 0x1008
ACPI: Local APIC address 0xfee00000
ACPI: 2 duplicate APIC table ignored.
ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
Processor #0 6:14 APIC version 20
ACPI: LAPIC (acpi_id[0x01] lapic_id[0x01] disabled)
ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
ACPI: LAPIC_NMI (acpi_id[0x01] high edge lint[0x1])
ACPI: IOAPIC (id[0x01] address[0xfec00000] gsi_base[0])
IOAPIC[0]: apic_id 1, version 32, address 0xfec00000, GSI 0-23
ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 high level)
ACPI: IRQ0 used by override.
ACPI: IRQ2 used by override.
ACPI: IRQ9 used by override.
Enabling APIC mode:  Flat.  Using 1 I/O APICs
ACPI: HPET id: 0x8086a201 base: 0xfed00000
Using ACPI (MADT) for SMP configuration information
Allocating PCI resources starting at 30000000 (gap: 20000000:c0000000)
Detected 1463.077 MHz processor.
Built 1 zonelists.  Total pages: 128656
Kernel command line: root=/dev/sda5 vga=0x317    resume=/dev/sda7 splash=verbose
irqpoll
bootsplash: verbose mode.
Misrouted IRQ fixup and polling support enabled
This may significantly impact system performance
mapped APIC to ffffd000 (fee00000)
mapped IOAPIC to ffffc000 (fec00000)
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Initializing CPU#0
PID hash table entries: 2048 (order: 11, 8192 bytes)
Console: colour dummy device 80x25
Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
Memory: 503080k/514624k available (1697k kernel code, 10972k reserved, 968k
data, 196k init, 0k highmem)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
hpet0: at MMIO 0xfed00000 (virtual 0xe0000000), IRQs 2, 8, 0
hpet0: 3 64-bit timers, 14318180 Hz
Using HPET for base-timer
Calibrating delay using timer specific routine.. 2938.29 BogoMIPS (lpj=5876581)
Security Framework v1.0.0 initialized
Mount-cache hash table entries: 512
CPU: After generic identify, caps: afe9fbff 00100000 00000000 00000000 0000c109
00000000 00000000
CPU: After vendor identify, caps: afe9fbff 00100000 00000000 00000000 0000c109
00000000 00000000
monitor/mwait feature present.
using mwait in idle threads.
CPU: L1 I cache: 32K, L1 D cache: 32K
CPU: L2 cache: 1024K
CPU: After all inits, caps: afe9fbff 00100000 00000000 00000940 0000c109
00000000 00000000
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
Compat vDSO mapped to ffffe000.
Checking 'hlt' instruction... OK.
SMP alternatives: switching to UP code
Freeing SMP alternatives: 16k freed
checking if image is initramfs... it is
Freeing initrd memory: 3208k freed
ACPI: Core revision 20060707
CPU0: Intel(R) Celeron(R) M CPU        410  @ 1.46GHz stepping 08
Total of 1 processors activated (2938.29 BogoMIPS).
ENABLING IO-APIC IRQs
..TIMER: vector=0x31 apic1=0 pin1=2 apic2=-1 pin2=-1
Brought up 1 CPUs
migration_cost=0
NET: Registered protocol family 16
ACPI: bus type pci registered
PCI: Using MMCONFIG
Setting up standard PCI resources
ACPI: Interpreter enabled
ACPI: Using IOAPIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (0000:00)
PCI: Probing PCI hardware (bus 00)
Boot video device is 0000:00:02.0
PCI: Ignoring BAR0-3 of IDE controller 0000:00:1f.2
PCI: Transparent bridge - 0000:00:1e.0
PCI: Bus #06 (-#09) is hidden behind transparent bridge #05 (-#06) (try
'pci=assign-busses')
Please report the result to linux-kernel to fix this permanently
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.RP01._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.RP02._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.PCIB._PRT]
ACPI: PCI Interrupt Link [LNKA] (IRQs 1 3 4 5 6 *7 10 12 14 15)
ACPI: PCI Interrupt Link [LNKB] (IRQs 1 3 4 5 6 7 *11 12 14 15)
ACPI: PCI Interrupt Link [LNKC] (IRQs 1 3 4 5 6 7 10 12 14 15) *11
ACPI: PCI Interrupt Link [LNKD] (IRQs 1 3 4 5 6 7 11 12 14 15) *10
ACPI: PCI Interrupt Link [LNKE] (IRQs 1 3 4 5 6 7 10 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKF] (IRQs 1 3 4 5 6 7 11 12 14 15) *10
ACPI: PCI Interrupt Link [LNKG] (IRQs 1 3 4 5 6 7 *10 12 14 15)
ACPI: PCI Interrupt Link [LNKH] (IRQs 1 3 4 *5 6 7 11 12 14 15)
ACPI: Embedded Controller [EC0] (gpe 25) interrupt mode.
Linux Plug and Play Support v0.97 (c) Adam Belay
pnp: PnP ACPI init
pnp: PnP ACPI: found 11 devices
PnPBIOS: Disabled by ACPI PNP
PCI: Using ACPI for IRQ routing
PCI: If a device doesn't work, try "pci=routeirq".  If it helps, post a report
pnp: 00:07: ioport range 0x6a0-0x6af has been reserved
pnp: 00:07: ioport range 0x6b0-0x6ff has been reserved
PCI: Ignore bogus resource 6 [0:0] of 0000:00:02.0
PCI: Bridge: 0000:00:1c.0
  IO window: disabled.
  MEM window: disabled.
  PREFETCH window: disabled.
PCI: Bridge: 0000:00:1c.1
  IO window: disabled.
  MEM window: b0200000-b02fffff
  PREFETCH window: disabled.
PCI: Bus 6, cardbus bridge: 0000:05:04.0
  IO window: 00002400-000024ff
  IO window: 00002800-000028ff
  PREFETCH window: 30000000-31ffffff
  MEM window: 32000000-33ffffff
PCI: Bridge: 0000:00:1e.0
  IO window: 2000-2fff
  MEM window: b0300000-b03fffff
  PREFETCH window: 30000000-31ffffff
ACPI: PCI Interrupt 0000:00:1c.0[A] -> GSI 17 (level, low) -> IRQ 169
PCI: Setting latency timer of device 0000:00:1c.0 to 64
ACPI: PCI Interrupt 0000:00:1c.1[B] -> GSI 16 (level, low) -> IRQ 177
PCI: Setting latency timer of device 0000:00:1c.1 to 64
PCI: Enabling device 0000:00:1e.0 (0004 -> 0007)
PCI: Setting latency timer of device 0000:00:1e.0 to 64
ACPI: PCI Interrupt 0000:05:04.0[A] -> GSI 16 (level, low) -> IRQ 177
NET: Registered protocol family 2
IP route cache hash table entries: 4096 (order: 2, 16384 bytes)
TCP established hash table entries: 16384 (order: 5, 131072 bytes)
TCP bind hash table entries: 8192 (order: 4, 65536 bytes)
TCP: Hash tables configured (established 16384 bind 8192)
TCP reno registered
Simple Boot Flag at 0x36 set to 0x1
Machine check exception polling timer started.
apm: BIOS not found.
audit: initializing netlink socket (disabled)
audit(1166620524.820:1): initialized
Total HugeTLB memory allocated, 0
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
Initializing Cryptographic API
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered (default)
PCI: Setting latency timer of device 0000:00:1c.0 to 64
assign_interrupt_mode Found MSI capability
Allocate Port Service[0000:00:1c.0:pcie00]
Allocate Port Service[0000:00:1c.0:pcie02]
Allocate Port Service[0000:00:1c.0:pcie03]
PCI: Setting latency timer of device 0000:00:1c.1 to 64
assign_interrupt_mode Found MSI capability
Allocate Port Service[0000:00:1c.1:pcie00]
Allocate Port Service[0000:00:1c.1:pcie02]
Allocate Port Service[0000:00:1c.1:pcie03]
vesafb: framebuffer at 0xc0000000, mapped to 0xe0080000, using 6144k, total 7872k
vesafb: mode is 1024x768x16, linelength=2048, pages=4
vesafb: protected mode interface info at 00ff:44f0
vesafb: scrolling: redraw
vesafb: Truecolor: size=0:5:6:5, shift=0:11:5:0
bootsplash 3.1.6-2004/03/31: looking for picture...<6> silentjpeg size 81749
bytes,<6>...found (1024x768, 46202 bytes, v3).
Console: switching to colour frame buffer device 124x44
fb0: VESA VGA frame buffer device
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Real Time Clock Driver v1.12ac
hpet_resources: 0xfed00000 is busy
Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled
floppy0: no floppy controllers found
RAMDISK driver initialized: 16 RAM disks of 64000K size 1024 blocksize
PNP: PS/2 Controller [PNP0303:PS2K,PNP0f13:PS2M] at 0x60,0x64 irq 1,12
i8042.c: Detected active multiplexing controller, rev 1.1.
serio: i8042 AUX0 port at 0x60,0x64 irq 12
serio: i8042 AUX1 port at 0x60,0x64 irq 12
serio: i8042 AUX2 port at 0x60,0x64 irq 12
serio: i8042 AUX3 port at 0x60,0x64 irq 12
serio: i8042 KBD port at 0x60,0x64 irq 1
mice: PS/2 mouse device common for all mice
input: PC Speaker as /class/input/input0
md: md driver 0.90.3 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: bitmap version 4.39
NET: Registered protocol family 1
Using IPI No-Shortcut mode
Time: tsc clocksource has been installed.
ACPI: (supports S0 S3 S4 S5)
Freeing unused kernel memory: 196k freed
input: AT Translated Set 2 keyboard as /class/input/input1
SCSI subsystem initialized
ACPI: CPU0 (power states: C1[C1] C2[C2])
ACPI Exception (acpi_processor-0681): AE_NOT_FOUND, Processor Device is not
present [20060707]
ACPI: Getting cpuindex for acpiid 0x1
ACPI Exception (acpi_thermal-0412): AE_NOT_FOUND, Invalid active threshold [0]
[20060707]
ACPI: Thermal Zone [TZ00] (26 C)
libata version 2.00 loaded.
ata_piix 0000:00:1f.2: version 2.00ac7
ata_piix 0000:00:1f.2: MAP [ P0 P2 IDE IDE ]
ACPI: PCI Interrupt 0000:00:1f.2[B] -> GSI 19 (level, low) -> IRQ 209
PCI: Setting latency timer of device 0000:00:1f.2 to 64
ata1: SATA max UDMA/133 cmd 0x1F0 ctl 0x3F6 bmdma 0x18B0 irq 14
ata2: PATA max UDMA/100 cmd 0x170 ctl 0x376 bmdma 0x18B8 irq 15
scsi0 : ata_piix
Time: hpet clocksource has been installed.
ata1.00: ATA-6, max UDMA/100, 156301488 sectors: LBA48 
ata1.00: ata1: dev 0 multi count 16
ata1.00: configured for UDMA/100
scsi1 : ata_piix
Synaptics Touchpad, model: 1, fw: 6.2, id: 0x1a0b1, caps: 0xa04753/0x200000
input: SynPS/2 Synaptics TouchPad as /class/input/input2
ata2.00: ATAPI, max UDMA/33
ata2.00: configured for UDMA/33
  Vendor: ATA       Model: TOSHIBA MK8032GS  Rev: AS11
  Type:   Direct-Access                      ANSI SCSI revision: 05
SCSI device sda: 156301488 512-byte hdwr sectors (80026 MB)
sda: Write Protect is off
sda: Mode Sense: 00 3a 00 00
SCSI device sda: drive cache: write back
SCSI device sda: 156301488 512-byte hdwr sectors (80026 MB)
sda: Write Protect is off
sda: Mode Sense: 00 3a 00 00
SCSI device sda: drive cache: write back
 sda: sda1 sda2 sda3 < sda5 sda6 sda7 > sda4
sd 0:0:0:0: Attached scsi disk sda
  Vendor: HL-DT-ST  Model: DVDRAM GMA-4082N  Rev: HA01
  Type:   CD-ROM                             ANSI SCSI revision: 05
sd 0:0:0:0: Attached scsi generic sg0 type 0
scsi 1:0:0:0: Attached scsi generic sg1 type 5
BIOS EDD facility v0.16 2004-Jun-25, 1 devices found
sr0: scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda tray
Uniform CD-ROM driver Revision: 3.20
sr 1:0:0:0: Attached scsi CD-ROM sr0
Attempting manual resume
kjournald starting.  Commit interval 5 seconds
EXT3 FS on sda5, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
usbcore: registered new driver usbfs
usbcore: registered new driver hub
intel_rng: FWH not detected
ACPI: PCI Interrupt 0000:00:1f.3[B] -> GSI 19 (level, low) -> IRQ 209
USB Universal Host Controller Interface driver v3.0
ACPI: PCI Interrupt 0000:00:1d.0[A] -> GSI 23 (level, low) -> IRQ 217
PCI: Setting latency timer of device 0000:00:1d.0 to 64
uhci_hcd 0000:00:1d.0: UHCI Host Controller
uhci_hcd 0000:00:1d.0: new USB bus registered, assigned bus number 1
uhci_hcd 0000:00:1d.0: irq 217, io base 0x00001820
usb usb1: new device found, idVendor=0000, idProduct=0000
usb usb1: new device strings: Mfr=3, Product=2, SerialNumber=1
usb usb1: Product: UHCI Host Controller
usb usb1: Manufacturer: Linux 2.6.18.2-34-default uhci_hcd
usb usb1: SerialNumber: 0000:00:1d.0
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
ACPI: PCI Interrupt 0000:00:1d.1[B] -> GSI 19 (level, low) -> IRQ 209
PCI: Setting latency timer of device 0000:00:1d.1 to 64
uhci_hcd 0000:00:1d.1: UHCI Host Controller
uhci_hcd 0000:00:1d.1: new USB bus registered, assigned bus number 2
uhci_hcd 0000:00:1d.1: irq 209, io base 0x00001840
usb usb2: new device found, idVendor=0000, idProduct=0000
usb usb2: new device strings: Mfr=3, Product=2, SerialNumber=1
usb usb2: Product: UHCI Host Controller
usb usb2: Manufacturer: Linux 2.6.18.2-34-default uhci_hcd
usb usb2: SerialNumber: 0000:00:1d.1
usb usb2: configuration #1 chosen from 1 choice
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
Linux agpgart interface v0.101 (c) Dave Jones
ACPI: PCI Interrupt 0000:00:1d.2[C] -> GSI 18 (level, low) -> IRQ 225
PCI: Setting latency timer of device 0000:00:1d.2 to 64
uhci_hcd 0000:00:1d.2: UHCI Host Controller
uhci_hcd 0000:00:1d.2: new USB bus registered, assigned bus number 3
uhci_hcd 0000:00:1d.2: irq 225, io base 0x00001860
usb usb3: new device found, idVendor=0000, idProduct=0000
usb usb3: new device strings: Mfr=3, Product=2, SerialNumber=1
usb usb3: Product: UHCI Host Controller
usb usb3: Manufacturer: Linux 2.6.18.2-34-default uhci_hcd
usb usb3: SerialNumber: 0000:00:1d.2
usb usb3: configuration #1 chosen from 1 choice
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 2 ports detected
usb 1-2: new full speed USB device using uhci_hcd and address 2
ACPI: PCI Interrupt 0000:00:1d.3[D] -> GSI 16 (level, low) -> IRQ 177
PCI: Setting latency timer of device 0000:00:1d.3 to 64
uhci_hcd 0000:00:1d.3: UHCI Host Controller
uhci_hcd 0000:00:1d.3: new USB bus registered, assigned bus number 4
uhci_hcd 0000:00:1d.3: irq 177, io base 0x00001880
usb usb4: new device found, idVendor=0000, idProduct=0000
usb usb4: new device strings: Mfr=3, Product=2, SerialNumber=1
usb usb4: Product: UHCI Host Controller
usb usb4: Manufacturer: Linux 2.6.18.2-34-default uhci_hcd
usb usb4: SerialNumber: 0000:00:1d.3
usb usb4: configuration #1 chosen from 1 choice
hub 4-0:1.0: USB hub found
hub 4-0:1.0: 2 ports detected
8139too Fast Ethernet driver 0.9.27
usb 1-2: new device found, idVendor=0a5c, idProduct=2101
usb 1-2: new device strings: Mfr=1, Product=2, SerialNumber=0
usb 1-2: Product: Foxconn Bluetooth 2.0 plus EDR
usb 1-2: Manufacturer: Broadcom Corp
usb 1-2: configuration #1 chosen from 1 choice
ACPI: PCI Interrupt 0000:00:1d.7[A] -> GSI 23 (level, low) -> IRQ 217
PCI: Setting latency timer of device 0000:00:1d.7 to 64
ehci_hcd 0000:00:1d.7: EHCI Host Controller
ehci_hcd 0000:00:1d.7: new USB bus registered, assigned bus number 5
ehci_hcd 0000:00:1d.7: debug port 1
PCI: cache line size of 32 is not supported by device 0000:00:1d.7
ehci_hcd 0000:00:1d.7: irq 217, io mem 0xb0004000
ehci_hcd 0000:00:1d.7: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
usb usb5: new device found, idVendor=0000, idProduct=0000
usb usb5: new device strings: Mfr=3, Product=2, SerialNumber=1
usb usb5: Product: EHCI Host Controller
usb usb5: Manufacturer: Linux 2.6.18.2-34-default ehci_hcd
usb usb5: SerialNumber: 0000:00:1d.7
usb usb5: configuration #1 chosen from 1 choice
hub 5-0:1.0: USB hub found
hub 5-0:1.0: 8 ports detected
ieee1394: Initialized config rom entry `ip1394'
sdhci: Secure Digital Host Controller Interface driver, 0.12
sdhci: Copyright(c) Pierre Ossman
agpgart: Detected an Intel 945GM Chipset.
agpgart: Detected 7932K stolen memory.
agpgart: AGP aperture is 256M @ 0xc0000000
ACPI: PCI Interrupt 0000:00:1b.0[A] -> GSI 22 (level, low) -> IRQ 233
PCI: Setting latency timer of device 0000:00:1b.0 to 64
usb 1-2: USB disconnect, address 2
Bluetooth: Core ver 2.10
NET: Registered protocol family 31
Bluetooth: HCI device and connection manager initialized
Bluetooth: HCI socket layer initialized
Bluetooth: HCI USB driver ver 2.9
usb 5-4: new high speed USB device using ehci_hcd and address 3
usb 5-4: new device found, idVendor=0c45, idProduct=624f
usb 5-4: new device strings: Mfr=0, Product=1, SerialNumber=0
usb 5-4: Product: USB20 Camera    
usb 5-4: configuration #1 chosen from 1 choice
usbcore: registered new driver hci_usb
usb 1-2: new full speed USB device using uhci_hcd and address 3
usb 1-2: new device found, idVendor=0a5c, idProduct=2101
usb 1-2: new device strings: Mfr=1, Product=2, SerialNumber=0
usb 1-2: Product: Foxconn Bluetooth 2.0 plus EDR
usb 1-2: Manufacturer: Broadcom Corp
usb 1-2: configuration #1 chosen from 1 choice
ACPI: PCI Interrupt 0000:05:01.0[A] -> GSI 21 (level, low) -> IRQ 50
PCI: Setting latency timer of device 0000:05:01.0 to 64
eth0: RealTek RTL8139 at 0xe007c000, 00:0f:b0:c9:41:60, IRQ 50
eth0:  Identified 8139 chip type 'RTL-8100B/8139D'
PCI: Enabling device 0000:05:06.0 (0000 -> 0002)
ACPI: PCI Interrupt 0000:05:06.0[A] -> GSI 22 (level, low) -> IRQ 233
PCI: Setting latency timer of device 0000:05:06.0 to 64
usb 3-2: new full speed USB device using uhci_hcd and address 2
ohci1394: fw-host0: OHCI-1394 1.1 (PCI): IRQ=[233]  MMIO=[b0300800-b0300fff] 
Max Packet=[2048]  IR/IT contexts=[4/4]
sdhci: SDHCI controller found at 0000:05:06.1 [1180:0822] (rev 19)
PCI: Enabling device 0000:05:06.1 (0000 -> 0002)
ACPI: PCI Interrupt 0000:05:06.1[B] -> GSI 23 (level, low) -> IRQ 217
PCI: Setting latency timer of device 0000:05:06.1 to 64
mmc0: SDHCI at 0xb0300400 irq 217 DMA
Yenta: CardBus bridge found at 0000:05:04.0 [17aa:2075]
Yenta: Using CSCINT to route CSC interrupts to PCI
Yenta: Routing CardBus interrupts to PCI
Yenta TI: socket 0000:05:04.0, mfunc 0x01111c12, devctl 0x44
usb 3-2: new device found, idVendor=08ff, idProduct=2580
usb 3-2: new device strings: Mfr=0, Product=1, SerialNumber=0
usb 3-2: Product: Fingerprint Sensor
usb 3-2: configuration #1 chosen from 1 choice
Yenta: ISA IRQ mask 0x04f8, PCI irq 177
Socket status: 30000006
Yenta: Raising subordinate bus# of parent bus (#05) from #06 to #09
pcmcia: parent PCI bridge I/O window: 0x2000 - 0x2fff
cs: IO port probe 0x2000-0x2fff: clean.
pcmcia: parent PCI bridge Memory window: 0xb0300000 - 0xb03fffff
pcmcia: parent PCI bridge Memory window: 0x30000000 - 0x31ffffff
Bluetooth: L2CAP ver 2.8
Bluetooth: L2CAP socket layer initialized
Bluetooth: HIDP (Human Interface Emulation) ver 1.1
Bluetooth: RFCOMM socket layer initialized
Bluetooth: RFCOMM TTY layer initialized
Bluetooth: RFCOMM ver 1.8
cs: IO port probe 0x100-0x3af: excluding 0x370-0x377
cs: IO port probe 0x3e0-0x4ff: excluding 0x3f0-0x3f7 0x4d0-0x4d7
cs: IO port probe 0x820-0x8ff: clean.
cs: IO port probe 0xc00-0xcf7: clean.
cs: IO port probe 0xa00-0xaff: clean.
Adding 1421712k swap on /dev/sda7.  Priority:-1 extents:1 across:1421712k
ieee1394: Host added: ID:BUS[0-00:1023]  GUID[00023f649040306e]
device-mapper: ioctl: 4.7.0-ioctl (2006-06-24) initialised: dm-devel@redhat.com
loop: loaded (max 8 devices)
AppArmor: AppArmor initialized
audit(1166620547.589:2): AppArmor initialized

NET: Registered protocol family 10
lo: Disabled Privacy Extensions
IPv6 over IPv4 tunneling driver
ip6_tables: (C) 2000-2006 Netfilter Core Team
ip_tables: (C) 2000-2006 Netfilter Core Team
Netfilter messages via NETLINK v0.30.
ip_conntrack version 2.4 (4020 buckets, 32160 max) - 228 bytes per conntrack
ACPI: AC Adapter [ACAD] (on-line)
ACPI: Battery Slot [BAT1] (battery present)
ACPI: Power Button (FF) [PWRF]
ACPI: Lid Switch [LID0]
ACPI: Power Button (CM) [PWRB]
powernow: This module only works with AMD K7 CPUs
audit(1166616961.188:3): audit_backlog_limit=256 old=64 by auid=4294967295
audit(1166616961.224:4): audit_pid=3295 old=0 by auid=4294967295
IA-32 Microcode Update Driver: v1.14a <tigran@veritas.com>
eth0: link down
ADDRCONF(NETDEV_UP): eth0: link is not ready
NET: Registered protocol family 17
[drm] Initialized drm 1.0.1 20051102
ACPI: PCI Interrupt 0000:00:02.0[A] -> GSI 16 (level, low) -> IRQ 177
[drm] Initialized i915 1.5.0 20060119 on minor 0
SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC= SRC=169.254.213.145 DST=224.0.0.251
LEN=76 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=56 
SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC= SRC=169.254.213.145 DST=224.0.0.251
LEN=76 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=56 
SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC= SRC=169.254.213.145 DST=224.0.0.251
LEN=76 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=56 
SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC= SRC=169.254.213.145 DST=224.0.0.251
LEN=112 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=92 
SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC= SRC=169.254.213.145 DST=224.0.0.251
LEN=112 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=92 
SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC= SRC=169.254.213.145 DST=224.0.0.251
LEN=112 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=92 
SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC= SRC=169.254.213.145 DST=224.0.0.251
LEN=112 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=92 
SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC= SRC=169.254.213.145 DST=224.0.0.251
LEN=112 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=92 
SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC= SRC=169.254.213.145 DST=224.0.0.251
LEN=112 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=92 
SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC= SRC=169.254.213.145 DST=224.0.0.251
LEN=112 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=92 
usb 1-1: new full speed USB device using uhci_hcd and address 4
usb 1-1: new device found, idVendor=1462, idProduct=5512
usb 1-1: new device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-1: Product: <USB PRODUCT>   
usb 1-1: Manufacturer: <USB MF>
usb 1-1: SerialNumber: 00006104E7C98304
usb 1-1: configuration #1 chosen from 1 choice
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
Initializing USB Mass Storage driver...
scsi2 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 4
usb-storage: waiting for device to settle before scanning
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
  Vendor: MSI       Model: MS-551X           Rev: 0100
  Type:   Direct-Access                      ANSI SCSI revision: 04
SCSI device sdb: 250624 512-byte hdwr sectors (128 MB)
sdb: Write Protect is off
sdb: Mode Sense: 03 00 00 00
sdb: assuming drive cache: write through
SCSI device sdb: 250624 512-byte hdwr sectors (128 MB)
sdb: Write Protect is off
sdb: Mode Sense: 03 00 00 00
sdb: assuming drive cache: write through
 sdb: sdb1
sd 2:0:0:0: Attached scsi removable disk sdb
sd 2:0:0:0: Attached scsi generic sg2 type 0
usb-storage: device scan complete

lsmod:
Module                  Size  Used by
nls_iso8859_1           8320  1 
nls_cp437               9984  1 
vfat                   16640  1 
fat                    55324  1 vfat
usb_storage            82112  1 
ide_core              129992  1 usb_storage
mmc_block              12040  0 
i915                   23040  3 
drm                    71316  4 i915
xt_pkttype              6016  3 
ipt_LOG                10624  9 
xt_limit                6912  9 
af_packet              29320  0 
snd_pcm_oss            53376  0 
snd_mixer_oss          21248  1 snd_pcm_oss
snd_seq                60272  0 
snd_seq_device         12812  1 snd_seq
button                 10896  0 
battery                14340  0 
ac                      9476  0 
ip6t_REJECT             9344  3 
xt_tcpudp               7296  5 
ipt_REJECT              9472  3 
xt_state                6272  12 
iptable_mangle          7040  0 
iptable_nat            11524  0 
ip_nat                 21804  1 iptable_nat
iptable_filter          7168  1 
ip6table_mangle         6528  0 
ip_conntrack           52960  3 xt_state,iptable_nat,ip_nat
nfnetlink              11032  2 ip_nat,ip_conntrack
ip_tables              17604  3 iptable_mangle,iptable_nat,iptable_filter
ip6table_filter         7040  1 
ip6_tables             18756  2 ip6table_mangle,ip6table_filter
x_tables               18180  10
xt_pkttype,ipt_LOG,xt_limit,ip6t_REJECT,xt_tcpudp,ipt_REJECT,xt_state,iptable_nat,ip_tables,ip6_tables
ipv6                  263584  17 ip6t_REJECT
apparmor               55572  0 
aamatch_pcre           18304  1 apparmor
loop                   20488  0 
dm_mod                 60184  0 
rfcomm                 45208  0 
hidp                   23680  2 
l2cap                  30976  10 rfcomm,hidp
pcmcia                 40892  0 
firmware_class         14080  1 pcmcia
hci_usb                20636  0 
bluetooth              57188  4 rfcomm,hidp,l2cap,hci_usb
sdhci                  21644  0 
ohci1394               37040  0 
ieee1394              102584  1 ohci1394
snd_hda_intel          23060  0 
snd_hda_codec         164352  1 snd_hda_intel
mmc_core               28672  2 mmc_block,sdhci
snd_pcm                86916  3 snd_pcm_oss,snd_hda_intel,snd_hda_codec
snd_timer              27908  2 snd_seq,snd_pcm
snd                    61188  8
snd_pcm_oss,snd_mixer_oss,snd_seq,snd_seq_device,snd_hda_intel,snd_hda_codec,snd_pcm,snd_timer
8139too                30592  0 
mii                     9600  1 8139too
intel_agp              27804  1 
yenta_socket           30348  1 
rsrc_nonstatic         17024  1 yenta_socket
pcmcia_core            43412  3 pcmcia,yenta_socket,rsrc_nonstatic
soundcore              13792  1 snd
ehci_hcd               34696  0 
agpgart                35528  3 drm,intel_agp
snd_page_alloc         14472  2 snd_hda_intel,snd_pcm
uhci_hcd               26892  0 
i2c_i801               11660  0 
i2c_core               25216  1 i2c_i801
usbcore               114896  4 usb_storage,hci_usb,ehci_hcd,uhci_hcd
ext3                  141192  1 
mbcache                12804  1 ext3
jbd                    70324  1 ext3
sr_mod                 20132  0 
cdrom                  38432  1 sr_mod
edd                    13892  0 
fan                     8964  0 
sg                     38044  0 
ata_piix               19332  2 
libata                119188  1 ata_piix
thermal                18568  0 
processor              34664  1 thermal
sd_mod                 24576  5 
scsi_mod              136712  5 usb_storage,sr_mod,sg,libata,sd_mod

ioports:
0000-001f : dma1
0020-0021 : pic1
0040-0043 : timer0
0050-0053 : timer1
0060-006f : keyboard
0070-0077 : rtc
0080-008f : dma page reg
00a0-00a1 : pic2
00c0-00df : dma2
00f0-00ff : fpu
0170-0177 : libata
01f0-01f7 : libata
03c0-03df : vesafb
06a0-06af : pnp 00:07
06b0-06ff : pnp 00:07
1000-107f : motherboard
  1000-1003 : ACPI PM1a_EVT_BLK
  1004-1005 : ACPI PM1a_CNT_BLK
  1008-100b : ACPI PM_TMR
  1010-1015 : ACPI CPU throttle
  1020-1020 : ACPI PM2_CNT_BLK
  1028-102f : ACPI GPE0_BLK
1180-11bf : motherboard
1640-164f : motherboard
1800-1807 : 0000:00:02.0
1820-183f : 0000:00:1d.0
  1820-183f : uhci_hcd
1840-185f : 0000:00:1d.1
  1840-185f : uhci_hcd
1860-187f : 0000:00:1d.2
  1860-187f : uhci_hcd
1880-189f : 0000:00:1d.3
  1880-189f : uhci_hcd
18b0-18bf : 0000:00:1f.2
  18b0-18bf : libata
18c0-18df : 0000:00:1f.3
  18c0-18df : i801_smbus
2000-2fff : PCI Bus #05
  2000-20ff : 0000:05:01.0
    2000-20ff : 8139too
  2400-24ff : PCI CardBus #06
  2800-28ff : PCI CardBus #06
ff00-ff7f : motherboard

iomem:
00000000-0009f7ff : System RAM
  00000000-00000000 : Crash kernel
0009f800-0009ffff : reserved
000a0000-000bffff : Video RAM area
000c0000-000c7fff : Video ROM
000ce800-000cf7ff : Adapter ROM
000f0000-000fffff : System ROM
00100000-1f68ffff : System RAM
  00100000-002a8585 : Kernel code
  002a8586-0039a7b7 : Kernel data
1f690000-1f69afff : ACPI Tables
1f69b000-1f6fffff : ACPI Non-volatile Storage
1f700000-1fffffff : reserved
30000000-31ffffff : PCI Bus #05
  30000000-31ffffff : PCI CardBus #06
32000000-33ffffff : PCI CardBus #06
b0000000-b0003fff : 0000:00:1b.0
  b0000000-b0003fff : ICH HD audio
b0004000-b00043ff : 0000:00:1d.7
  b0004000-b00043ff : ehci_hcd
b0040000-b007ffff : 0000:00:02.0
b0080000-b00fffff : 0000:00:02.0
b0100000-b017ffff : 0000:00:02.1
b0200000-b02fffff : PCI Bus #03
  b0200000-b0203fff : 0000:03:00.0
b0300000-b03fffff : PCI Bus #05
  b0300000-b03000ff : 0000:05:01.0
    b0300000-b03000ff : 8139too
  b0300400-b03004ff : 0000:05:06.1
    b0300400-b03004ff : sdhci:slot0
  b0300800-b0300fff : 0000:05:06.0
    b0300800-b0300fff : ohci1394
  b0301000-b0301fff : 0000:05:04.0
    b0301000-b0301fff : yenta_socket
  b0302000-b03020ff : 0000:05:06.2
  b0302400-b03024ff : 0000:05:06.3
  b0302800-b03028ff : 0000:05:06.4
c0000000-cfffffff : 0000:00:02.0
  c0000000-c07affff : vesafb
e0000000-efffffff : reserved
fec00000-fec0ffff : reserved
fed00000-fed003ff : reserved
fed14000-fed19fff : reserved
fed1c000-fed8ffff : reserved
fee00000-fee00fff : reserved
ff000000-ffffffff : reserved

devices:
Character devices:
  1 mem
  2 pty
  3 ttyp
  4 /dev/vc/0
  4 tty
  4 ttyS
  5 /dev/tty
  5 /dev/console
  5 /dev/ptmx
  7 vcs
 10 misc
 13 input
 14 sound
 21 sg
 29 fb
116 alsa
128 ptm
136 pts
171 ieee1394
180 usb
189 usb_device
216 rfcomm
226 drm
254 pcmcia

Block devices:
  1 ramdisk
  7 loop
  8 sd
  9 md
 11 sr
 65 sd
 66 sd
 67 sd
 68 sd
 69 sd
 70 sd
 71 sd
128 sd
129 sd
130 sd
131 sd
132 sd
133 sd
134 sd
135 sd
252 mmc
253 device-mapper
254 mdp

interrupts with in card:
           CPU0       
  0:      96406    IO-APIC-edge  timer
  1:       1725    IO-APIC-edge  i8042
  8:         24    IO-APIC-edge  rtc
  9:        641   IO-APIC-level  acpi
 12:       1759    IO-APIC-edge  i8042
 14:      14139    IO-APIC-edge  libata
 15:       3958    IO-APIC-edge  libata
 50:          0   IO-APIC-level  eth0
177:       1526   IO-APIC-level  uhci_hcd:usb4, yenta
209:          0   IO-APIC-level  uhci_hcd:usb2
217:       1402   IO-APIC-level  uhci_hcd:usb1, ehci_hcd:usb5, sdhci:slot0
225:         22   IO-APIC-level  uhci_hcd:usb3
233:        262   IO-APIC-level  HDA Intel, ohci1394
NMI:          0 
LOC:      96296 
ERR:          0
MIS:          5

after remove card:
           CPU0       
  0:      98475    IO-APIC-edge  timer
  1:       1777    IO-APIC-edge  i8042
  8:         24    IO-APIC-edge  rtc
  9:        641   IO-APIC-level  acpi
 12:       1759    IO-APIC-edge  i8042
 14:      14143    IO-APIC-edge  libata
 15:       4046    IO-APIC-edge  libata
 50:          0   IO-APIC-level  eth0
177:       1526   IO-APIC-level  uhci_hcd:usb4, yenta
209:          0   IO-APIC-level  uhci_hcd:usb2
217:       1418   IO-APIC-level  uhci_hcd:usb1, ehci_hcd:usb5, sdhci:slot0
225:         22   IO-APIC-level  uhci_hcd:usb3
233:        262   IO-APIC-level  HDA Intel, ohci1394
NMI:          0 
LOC:      98364 
ERR:          0
MIS:          5

after get back in card:
           CPU0       
  0:     100137    IO-APIC-edge  timer
  1:       1821    IO-APIC-edge  i8042
  8:         24    IO-APIC-edge  rtc
  9:        671   IO-APIC-level  acpi
 12:       1759    IO-APIC-edge  i8042
 14:      14148    IO-APIC-edge  libata
 15:       4112    IO-APIC-edge  libata
 50:          0   IO-APIC-level  eth0
177:       1526   IO-APIC-level  uhci_hcd:usb4, yenta
209:          0   IO-APIC-level  uhci_hcd:usb2
217:       1430   IO-APIC-level  uhci_hcd:usb1, ehci_hcd:usb5, sdhci:slot0
225:         22   IO-APIC-level  uhci_hcd:usb3
233:        262   IO-APIC-level  HDA Intel, ohci1394
NMI:          0 
LOC:     100027 
ERR:          0
MIS:          5

PS: Which reports are usefull for You? Which reports You need not?
Comment 9 NPetr 2006-12-21 03:40:52 UTC
And one important thing:

Still no device in /dev/mmc*
Comment 10 Pierre Ossman 2006-12-22 15:24:45 UTC
What you need to check between each go is if there is any activity in dmesg when
you insert/remove a card and if the interrupt for the controller ticks up (in
/proc/interrupt).

You can also try "pci=routeirq", as suggested in dmesg.
Comment 11 NPetr 2006-12-23 08:23:06 UTC
Now I understand, but no success here. Dmesg do not see any activity during 
removing/inserting card. IRQ in /proc/interrupts next by sdhci module never 
changing during removing/inserting card. I tryed also: noapic nolapic acpi=off 
pci=routeirq irqpoll. No success with them. There must be really some bug. You 
can send some patch on 2.6.19.1 (or If You need on 2.6.20-rc1-mm1), then I can 
test it.
Comment 12 Pierre Ossman 2006-12-23 09:36:25 UTC
I'm reassigning this to PCI as this seems to be some general interrupt delivery
problem.
Comment 13 NPetr 2006-12-28 16:18:03 UTC
Greg, had You time to analyze this bug already? Bye, NPetr.
Comment 14 Greg Kroah-Hartman 2007-01-11 17:21:50 UTC
This is an ACPI interrupt routing issue, not a pci specific one.

Reassigning...
Comment 15 NPetr 2007-01-20 05:26:30 UTC
Hello ACPI config team. Is here some solution?
Comment 16 NPetr 2007-02-06 07:49:13 UTC
Problem still persists in kernel 2.6.20.
Comment 17 NPetr 2007-02-09 12:13:42 UTC
I found one strange thing. In OpenSuSE, Frugalware, ForeSight kernels mmc
appears as:
Block devices:
252 mmc

In ArchLinux appears as:
Block devices:
254 mmc

But Ricoh R5C592 have never been working till now under these all kernels in the
Lenovo N100 3000 notebook.

BTW: I tryed irqpoll or pci=route-irq again.
Comment 18 Pierre Ossman 2007-02-09 12:28:10 UTC
The MMC block number is dynamically allocated, so which number it gets depends
on what other things you have loaded and in which order. udev should sort it out
for you.

But more importantly, why isn't any of the ACPI guys commenting on this? Is
anyone even monitoring these bugs?
Comment 19 NPetr 2007-02-11 13:24:38 UTC
Thank You very much for Your info, Pierre. I found another behaviour on Fedora,
ArchLinux, Mandriva, Ubuntu, ForeSight linux kernels "cat /proc/interrupts"
IRQ on the sdhci line increasing up baldheaded and dmesg never knows, that card
is inserted or removed. With irqpoll or pci=route-irq kernel option, IRQ on the
sdhci line never changed and dmesg also never knows, that card is inserted or
removed. (On openSUSE, Frugalware kernels irq is not increasing madly on the
sdhci line in "cat /proc/interrupts", but also dmesg never knows, that card is
inserted or removed and irq 225 in "cat /proc/interrupts" not increases when you
insert or remove a card.)
Comment 20 Len Brown 2007-03-30 20:27:20 UTC
Did this work with any earlier kernel?

Does it work if you boot with the card inserted and "acpi=off"?

With the card inserted, please boot 2.6.21-rc5 or later,
and attach (do not paste) the output from dmesg -s64000,
the output from acpidump, and the output from lspci -vv.
Please also paste the contents of /proc/interrupts.

Comment 21 NPetr 2007-04-06 18:06:32 UTC
Created attachment 11089 [details]
acpidump1.txt
Comment 22 NPetr 2007-04-06 18:07:36 UTC
Created attachment 11090 [details]
acpidump2.txt
Comment 23 NPetr 2007-04-06 18:08:12 UTC
Created attachment 11091 [details]
dmesg1.txt
Comment 24 NPetr 2007-04-06 18:08:44 UTC
Created attachment 11092 [details]
dmesg2.txt
Comment 25 NPetr 2007-04-06 18:09:09 UTC
Created attachment 11093 [details]
interrupts1.txt
Comment 26 NPetr 2007-04-06 18:09:31 UTC
Created attachment 11094 [details]
interrupts2.txt
Comment 27 NPetr 2007-04-06 18:09:52 UTC
Created attachment 11095 [details]
lspci1.txt
Comment 28 NPetr 2007-04-06 18:10:25 UTC
Created attachment 11096 [details]
lspci2.txt
Comment 29 NPetr 2007-04-06 18:13:14 UTC
Nice to hear You Len! Excuse me for the long delay. I made to experiments. First
(*1.txt) with normal boot and second (*2.txt) with acpi=off. I used fresh
2.6.21-rc6 kernel and booted with inserted card.
Comment 30 PhilA 2007-04-10 12:34:06 UTC
hello guys,

it's good to know you are working on this problem.

i have the same cardreader-revision (06:03.1 Generic system peripheral [0805]:
Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 19)).

For me SD-Cards work, since Ubuntu Edgy, but MMC don't work.

I really hope you get this fixed. Wish you the best, keep on the work!
Comment 31 NPetr 2007-04-15 02:00:22 UTC
Hello, for me still does not work. I have only MMC and MSPRO Duo cards. Booth
have been never worked under Linux :'(.
Comment 32 Natalie Protasevich 2007-06-25 00:10:02 UTC
Petr,
It looks like with you last test the card was configured, and interrupt was assigned (IRQ 7), but no interrupts were generated. Did you try polling again with 2.6.21?

Is any more information needed from card users?
Thanks.
Comment 33 PhilA 2007-07-16 11:11:37 UTC
hi,

is there any progress with this problem?

i still have the problems described above.
Comment 34 Andrew Morton 2007-07-24 13:54:55 UTC
Guys, MMC is changing fast and there's a decent chance that these things have already been fixed.

So could people please retest 2.6.21 and let us know if problems are still there?

(Even better, 2.6.23-rc1 or -rc2)

Thanks.
Comment 35 NPetr 2007-08-07 04:49:40 UTC
Hello men, I was retest cards with current Fugalware kernel 2.6.22-1.

MMC card not working, nothing has changed :-(
SD card (borrowed from friend) work honestly (I can see nicely how interrupts changing during plug/replug the card)
MS Pro Duo card not working (no support for MS Pro Duo in shdhci kernel module :'( )

I will try 2.6.23 kernel soon with MMC card.
Comment 36 PhilA 2007-10-13 10:54:01 UTC
Hello.

I compiled the new 2.6.23 kernel under ubuntu 7.04.
But still no luck with it. SD-Cards are recognized, but MMC-Cards are not. No output to see with "dmesg".

what a pitty, but i hope you are still working on this!?
Comment 37 Pierre Ossman 2007-10-14 11:04:18 UTC
As the problem seems to be related to just MMC cards, I suspect you're all suffering from Ricoh's brain dead design (caused by Microsoft's broken driver that only supports SD).

You need to download the very latest kernel (2.6.23-git5 as of this writing) and enable "Ricoh MMC disabler". Loading that module should fix things for you.
Comment 38 PhilA 2007-10-21 13:34:05 UTC
At least, with Kernel 2.6.23-git16 it works!

I tried it today, and like Pierre Ossman said, with MMC disabler. This works like expected.

I think this bug can be marked as solved.
Comment 39 NPetr 2007-11-30 00:56:50 UTC
Yes men, this bug has been squashed. It works on 2.6.23 with mmc_disabler patch or on 2.6.24-rc3 natively. Thank you very much.

Note You need to log in before you can comment on or make changes to this bug.