Bug 75841 - radeon (radeonsi): GPU crash and resulting kernel problems (hangs etc.)
Summary: radeon (radeonsi): GPU crash and resulting kernel problems (hangs etc.)
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel) (show other bugs)
Hardware: x86-64 Linux
: P1 high
Assignee: drivers_video-dri
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-10 01:31 UTC by Darren Salt
Modified: 2014-05-26 03:03 UTC (History)
2 users (show)

See Also:
Kernel Version: 3.15-rc3
Tree: Mainline
Regression: No


Attachments
Partial kernel log showing many GPU faults and subsequent page table breakage (143.74 KB, text/plain)
2014-05-10 01:31 UTC, Darren Salt
Details

Description Darren Salt 2014-05-10 01:31:47 UTC
Created attachment 135651 [details]
Partial kernel log showing many GPU faults and subsequent page table breakage

I'm reliably able to trigger GPU faults and various subsequent problems. The crash doesn't happen immediately, so far as I can tell.

One known trigger is to start a map then start another map on Unvanquished (http://www.unvanquished.net/). It appears that the heat haze option needs to be enabled (this one seems most reliable), and I think that the motion blur option may also trigger this.

Known effects, other than reams of GPU fault reports, include hard lock-ups and page table corruption; the attached file (gpu-crash-etc.txt) shows the latter (I chose to reboot soon afterwards).

Hardware is Bonaire XTX. Userland is X git (2535b76) with corresponding Radeon DDX, Mesa 10.2 git (e05ceba, built using xorg-edgers packaging), llvm 3.4-2 (Debian). GLAMOR is enabled.
Comment 1 darkbasic 2014-05-10 01:54:02 UTC
The same with TAHITI (HD 7950).
Comment 2 Marek Olšák 2014-05-10 11:39:01 UTC
What's your kernel version?
Comment 3 Marek Olšák 2014-05-10 11:40:13 UTC
Now I see, 3.15-rc3. There is a regression in 3.15 which is being fixed. The 3.14 kernel should work fine.
Comment 4 darkbasic 2014-05-10 12:11:54 UTC
I use drm-fixes-3.15, still not fixed there?
Comment 5 Marek Olšák 2014-05-10 14:13:49 UTC
No, the fix hasn't been made yet.
Comment 6 Darren Salt 2014-05-12 16:18:36 UTC
http://lists.freedesktop.org/archives/dri-devel/2014-May/059365.html

Testing with that patch series applied – no problems noticed so far. Looks like we might have a fix for this bug here.
Comment 7 Darren Salt 2014-05-26 03:03:47 UTC
No further problems were noticed, and it's working fine with 3.15-rc7 (which includes those patches). Closing.

Note You need to log in before you can comment on or make changes to this bug.