Bug 7582 - Repeatable hang on boot with PCMCIA card present
Summary: Repeatable hang on boot with PCMCIA card present
Status: REJECTED UNREPRODUCIBLE
Alias: None
Product: Drivers
Classification: Unclassified
Component: PCMCIA (show other bugs)
Hardware: i386 Linux
: P2 high
Assignee: linux-pcmcia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-11-25 20:43 UTC by Steve Smith
Modified: 2008-04-05 20:42 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.17+
Tree: Mainline
Regression: ---


Attachments
Photo of hung boot (124.65 KB, image/jpeg)
2006-11-25 20:50 UTC, Steve Smith
Details
dmesg output (15.04 KB, text/plain)
2006-12-02 15:48 UTC, Steve Smith
Details
Output of lspcmcia -vvv (1.50 KB, text/plain)
2006-12-02 15:49 UTC, Steve Smith
Details

Description Steve Smith 2006-11-25 20:43:56 UTC
Most recent kernel where this bug did *NOT* occur: 2.6.16.23
Distribution: Ubuntu Edgy
Hardware Environment: Dell Inspiron 8100 + Linksys WPC11

With recent kernel releases I have started seeing consistent hangs during boot
when a PCMCIA card is present in the slot (the card in question is a Linksys
WPC11).  The symptoms are:

    If the card is present during boot an error of "Unknown interrupt or fault
at EIP ..." appears.

    If the card is not present there is no error.

    The card can be plugged-in post-boot without problems.

Using git-bisect I have narrowed down the error to one commit, namely "use
bitfield instead of p_state and state".  The commit# is

    e2d4096365e06b9a3799afbadc28b4519c0b3526

However I am still seeing this problem with the latest -RC releases, including
2.6.19-rc6.
Comment 1 Steve Smith 2006-11-25 20:50:01 UTC
Created attachment 9626 [details]
Photo of hung boot
Comment 3 Steve Smith 2006-12-01 18:24:10 UTC
I've tried the -mm patch with the same result unfortunately.
Comment 4 Dominik Brodowski 2006-12-02 13:20:51 UTC
Could you post the dmesg and the output of lspcmica -vvv when the card is
inserted post-boot, please?
Comment 5 Steve Smith 2006-12-02 15:48:49 UTC
Created attachment 9722 [details]
dmesg output
Comment 6 Steve Smith 2006-12-02 15:49:27 UTC
Created attachment 9723 [details]
Output of lspcmcia -vvv
Comment 7 Steve Smith 2006-12-02 15:50:18 UTC
Attached.  Thanks guys.
Comment 8 Steve Smith 2007-01-05 23:16:13 UTC
This appears to be an interaction with hostap/hostap_cs.  Blacklisting them in
favour of the orinoco driver works.
Comment 9 Natalie Protasevich 2007-07-06 11:29:25 UTC
Has this problem been resolved?
Thanks.
Comment 10 Natalie Protasevich 2008-04-05 20:42:26 UTC
Steve, if you can confirm this problem with latest kernel please reopen.

Note You need to log in before you can comment on or make changes to this bug.