Bug 7581 - hddtemp broke
Summary: hddtemp broke
Status: REJECTED WILL_NOT_FIX
Alias: None
Product: IO/Storage
Classification: Unclassified
Component: Block Layer (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Jens Axboe
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-11-25 05:10 UTC by Nicolas Mailhot
Modified: 2007-01-01 12:56 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.19-rc6-mm1
Tree: Mainline
Regression: ---


Attachments
dmesg (27.22 KB, text/plain)
2006-11-25 05:21 UTC, Nicolas Mailhot
Details
kernel config (42.15 KB, text/plain)
2006-11-25 05:23 UTC, Nicolas Mailhot
Details
Patch for hddtemp (815 bytes, patch)
2006-12-19 04:35 UTC, Jens Axboe
Details | Diff

Description Nicolas Mailhot 2006-11-25 05:10:35 UTC
Most recent kernel where this bug did *NOT* occur: 2.6.19-rc5-mm2

Distribution: Fedora Devel

Hardware Environment: 
- Silicon Image, Inc. SiI 3114 [SATALink/SATARaid] Serial ATA Controller (rev 02)
- nVidia Corporation CK804 Serial ATA Controller (rev f3)
- nVidia Corporation CK804 IDE (rev f2)
Software Environment: hddtemp-0.3-0.9.beta15.fc6

Problem Description:

Starting with 2.6.19-rc6-mm1 hddtemp can not monitor disk temperatures anymore

Steps to reproduce:
# /usr/sbin/hddtemp /dev/sda
/dev/sda: : S.M.A.R.T. not available
[root@rousalka nim]# /usr/sbin/hddtemp /dev/sdb
/dev/sdb: : S.M.A.R.T. not available
[root@rousalka nim]# /usr/sbin/hddtemp /dev/sdc
/dev/sdc: : S.M.A.R.T. not available
[root@rousalka nim]# /usr/sbin/hddtemp /dev/sdd
/dev/sdd: : S.M.A.R.T. not available
Comment 1 Nicolas Mailhot 2006-11-25 05:19:47 UTC
kernel built with patch in attachment #9540 [details] from bug #7538
Comment 2 Nicolas Mailhot 2006-11-25 05:21:45 UTC
Created attachment 9623 [details]
dmesg
Comment 3 Nicolas Mailhot 2006-11-25 05:23:20 UTC
Created attachment 9624 [details]
kernel config
Comment 4 Nicolas Mailhot 2006-12-14 15:24:50 UTC
BTW two of the four disks hang from SiI 3114 so the sata_nv ADMA are not
responsible for hddtemp problems
Comment 5 Alistair Strachan 2006-12-18 17:20:57 UTC
I see this too, in 2.6.20-rc1. I'm fairly sure the problem is caused in 
mainline by 0e75f9063f5c55fb0b0b546a7c356f8ec186825e ("support larger block pc 
requests") and it isn't fixed by 77d172ce ("[PATCH] fix SG_IO bio leak").

I think SATA is off the hook. Works in 2.6.19, but not in 
2.6.19+0e75f9063f5c55fb0b0b546a7c356f8ec186825e.
Comment 6 Jens Axboe 2006-12-18 23:34:46 UTC
I can reproduce this now, am looking at fixing it.
Comment 7 Jens Axboe 2006-12-19 04:35:58 UTC
Created attachment 9883 [details]
Patch for hddtemp

hddtemp includes fragile and wrong sense checks, remove those.
Comment 8 Jens Axboe 2006-12-19 04:37:26 UTC
Also see:

http://lkml.org/lkml/2006/12/19/131

Closing this bug.
Comment 9 Nicolas Mailhot 2007-01-01 12:56:11 UTC
Thanks for looking at this, and happy new year to all

Note You need to log in before you can comment on or make changes to this bug.