Bug 75651 - resume from suspend failing 3.15(rc1,rc2,rc3,rc4) bisected
Summary: resume from suspend failing 3.15(rc1,rc2,rc3,rc4) bisected
Status: RESOLVED PATCH_ALREADY_AVAILABLE
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel) (show other bugs)
Hardware: All Linux
: P1 high
Assignee: drivers_video-dri
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-07 13:17 UTC by William Shuman
Modified: 2014-05-12 13:24 UTC (History)
2 users (show)

See Also:
Kernel Version: 3.15
Tree: Mainline
Regression: No


Attachments
bisect log (2.76 KB, text/x-log)
2014-05-07 13:17 UTC, William Shuman
Details
dmesg (rc5) (78.46 KB, application/octet-stream)
2014-05-10 15:57 UTC, William Shuman
Details
Possible fix (1.85 KB, patch)
2014-05-10 16:40 UTC, Christian König
Details | Diff
dmesg after patch (78.13 KB, application/octet-stream)
2014-05-10 18:30 UTC, William Shuman
Details
Possible fix. (985 bytes, patch)
2014-05-12 12:48 UTC, Christian König
Details | Diff

Description William Shuman 2014-05-07 13:17:16 UTC
Created attachment 135311 [details]
bisect log

resume from suspend is failing for me since 3.15rc1

6d2f2944e95e504a7d33385eeeb9bb7fcca72592 is the first bad commit
commit 6d2f2944e95e504a7d33385eeeb9bb7fcca72592
Author: Christian König <christian.koenig@amd.com>
Date:   Thu Feb 20 13:42:17 2014 +0100

    drm/radeon: use normal BOs for the page tables v4
    
    No need to make it more complicated than necessary,
    just allocate the page tables as normal BO and
    flush whenever the address change.
    
    v2: update comments and function name
    v3: squash bug fixes, page directory and tables patch
    v4: rebased on Mareks changes
    
    Signed-off-by: Christian König <christian.koenig@amd.com>

:040000 040000 c7fa0e5e797db0e3384b2cd1450bf45efdb4c284 b05fc80d14d6a34db744ecee5d89035fa99ce1fe M	drivers
Comment 1 William Shuman 2014-05-10 15:57:12 UTC
3.15rc5 seems to be better I can get into a tty and restart X.  But intially it still fails.  Attaching dmesg.
Comment 2 William Shuman 2014-05-10 15:57:42 UTC
Created attachment 135721 [details]
dmesg (rc5)
Comment 3 Christian König 2014-05-10 16:07:02 UTC
Already working on this, looks like swapping out page tables doesn't work reliable.
Comment 4 Christian König 2014-05-10 16:40:54 UTC
Created attachment 135731 [details]
Possible fix

Complete shoot into the dark, but please give the attached patch a try.
Comment 5 William Shuman 2014-05-10 18:30:22 UTC
Same behavior after patch.
Comment 6 William Shuman 2014-05-10 18:30:43 UTC
Created attachment 135741 [details]
dmesg after patch
Comment 7 Christian König 2014-05-12 12:48:41 UTC
Created attachment 135881 [details]
Possible fix.

Please try this one instead. It fixes an issue with the commit mentioned, so it might fix this one as well.
Comment 8 William Shuman 2014-05-12 13:05:19 UTC
This fixed this issue.  Thanks for your work.
Comment 9 Christian König 2014-05-12 13:21:04 UTC
Thanks for the info, so we can close this bug now?

Note You need to log in before you can comment on or make changes to this bug.