Bug 7562 - 2.6.20.3 -> 2.6.20.4 regression - boot hang on a HP Pavilion DV6000, dv6018, dv6119us
Summary: 2.6.20.3 -> 2.6.20.4 regression - boot hang on a HP Pavilion DV6000, dv6018, ...
Status: CLOSED PATCH_ALREADY_AVAILABLE
Alias: None
Product: Drivers
Classification: Unclassified
Component: PCI (show other bugs)
Hardware: i386 Linux
: P2 blocking
Assignee: Greg Kroah-Hartman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-11-21 13:00 UTC by Patrick Brunier
Modified: 2007-08-03 21:44 UTC (History)
8 users (show)

See Also:
Kernel Version: 2.6.19-6 Generic
Tree: Mainline
Regression: ---


Attachments
dmesg while booted with acpi=noirq and bcm4311 firmware (28.17 KB, text/plain)
2006-12-22 14:15 UTC, Pavel Shevchuk
Details
dmesg -s 64000 (17.04 KB, text/plain)
2006-12-29 05:33 UTC, Pavel Shevchuk
Details

Description Patrick Brunier 2006-11-21 13:00:38 UTC
Most recent kernel where this bug did *NOT* occur: 2.6.19-6
Distribution: Ubuntu Feisty i386
Hardware Environment: HP Pavilion DV6000 (lspci at bottom)
Software Environment:
Problem Description:

Steps to reproduce:
Comment 1 Patrick Brunier 2006-11-21 13:08:21 UTC
Most recent kernel where this bug did *NOT* occur: 2.6.19-6
Distribution: Ubuntu Feisty i386
Hardware Environment: HP Pavilion DV6000 (lspci at bottom)
Software Environment: 
Problem Description: Currently running 2.6.17 with noacpi option. With 2.6.19 I
get a lot of IRQ errors on almost all hardware, with a complete stop on the end.
This counts for the noacpi option. When I boot without noacpi the machine seems
to boot up fine (in contrast what the 2.6.17 does) but he hangs within a few
minutes after bootup.
It
Comment 2 Pavel Shevchuk 2006-11-23 11:58:57 UTC
Same problems here, with dv6018, Turion64-x2 powered. It doesn't hang if i pass 
acpi=noirq, but i get no sound because of shared interrupt:

           CPU0       CPU1       
  0:      74633          0   IO-APIC-edge      timer
  1:          1        141   IO-APIC-edge      i8042
  2:          0          0    XT-PIC-XT        cascade
  5:          4       1121   IO-APIC-edge      libata
  7:          0         18   IO-APIC-edge      ehci_hcd:usb1
  8:          0          0   IO-APIC-edge      rtc
  9:          1         37   IO-APIC-edge      acpi
 10:         34       4733   IO-APIC-edge      eth0
 11:          0         23   IO-APIC-edge      ohci_hcd:usb2, HDA Intel, 
ohci1394, sdhci:slot0
 12:          3        121   IO-APIC-edge      i8042
 14:          0         24   IO-APIC-edge      ide0
NMI:        168         79 
LOC:      74514      74444 
ERR:          0

If i let ACPI assign IRQs it hangs after few minutes or immediately if i try to 
start X11. IRQs assigned by ACPI:
           CPU0       CPU1       
  0:       6636      89847   IO-APIC-edge      timer
  1:          2        151   IO-APIC-edge      i8042
  8:          0          0   IO-APIC-edge      rtc
  9:          1         35   IO-APIC-fasteoi   acpi
 10:          0          0   IO-APIC-fasteoi   sdhci:slot0
 11:          0          3   IO-APIC-fasteoi   ohci1394
 12:         18        104   IO-APIC-edge      i8042
 14:          0         24   IO-APIC-edge      ide0
 19:          1        142   IO-APIC-fasteoi   HDA Intel
 20:          1         22   IO-APIC-fasteoi   ohci_hcd:usb2
 21:          0         20   IO-APIC-fasteoi   ehci_hcd:usb1
 22:         16       1159   IO-APIC-fasteoi   libata
 23:        153       6619   IO-APIC-fasteoi   eth0
NMI:        168         83 
LOC:      96432      96272 
ERR:          0


I'm running 2.6.19-rc5 now, tried different configurations, same result. I want 
to help to fix this bug very, very much, this laptop is awesome, i don't want 
to change it =(
Comment 3 Patrick Brunier 2006-11-23 15:39:53 UTC
My problem has changed a bit. I somehow don
Comment 4 Len Brown 2006-11-23 21:40:20 UTC
Patrick, 
Do you have a failure to report in ACPI mode that does not 
occur with "acpi=off" when the binary nvidia and ndiswrapper 
are not present in the system? 
 
Pavel, 
The "acpi=noirq" debug flag has some limitations which make 
it not reliable in IOAPIC mode.  (in particular, the ACPI 
interrupt itself will unlikely work properly) 
 
Is your system otherwise reliable if you boot and run in ACPI 
mode without X?  What graphics driver are you running? 
 
Comment 5 Pavel Shevchuk 2006-11-24 13:40:28 UTC
As i already mentioned my system was (i switched back to windows because i need
to do homework) rock stable if i disable ACPI. If i enable ACPI devices don't
share interrupts, sound works fine, but system hangs, sooner or later. FreeBSD
doesn't boot too, it stops booting after it shows hard drive info. Ubuntu Dapper
6.06 livecd hangs after "Starting ACPI" message. I checked DSDT table with iasl,
table had only minor bugs, i think problem is deeper. I'm sure it's hardware
bug, but i'd like to get workaround run linux on this laptop someday. :`(

I can make tests, experiment with some livecds and provide you more info on
evenings, you can contact me via jabber (same as email) or IRC (Stalwart @
FreeNode, also #kernel @ FreeNode).

Thank you.
Comment 6 Ron Kuris 2006-12-06 08:44:22 UTC
Same problem on HP dv6119us (see
http://gentoo-wiki.com/HARDWARE_Gentoo_on_HP_Pavillion_dv6119us for hardware
specifics)

One thing I noticed in the AML is that IRQ11 is listed as "shared":
 Scope (\_SB.PCI0)
        {
            Name (BUFA, ResourceTemplate ()
            {
                IRQ (Level, ActiveLow, Shared, )
                    {5,7,9,10,11,14,15}
            })
...
Comment 7 Patrick Brunier 2006-12-07 02:12:04 UTC
IRQ 11 looks here shared to. BCM network + USB.
Isn't it possible to assign another IRQ.
Comment 8 Patrick Brunier 2006-12-07 02:15:46 UTC
Len Brown,

Going to try your suggestions this weekend.
Comment 9 Pavel Shevchuk 2006-12-07 13:19:49 UTC
Great news! I managed to get sound and linux doesn't hang now.

Ubuntu 6.10, kernel 2.6.19 with disabled nvidia timer quirk (probably not
needed, didn't test w/o it) and "noapic" boot parameter.

After i play some music i get error about "nobody cared irq". Here are dmesg and
/proc/interrupts, feel free to contact me for more info.

stalwart@naga:~$ dmesg 
[    0.000000] Linux version 2.6.19 (root@naga) (gcc version 4.1.2 20060928
(prerelease) (Ubuntu 4.1.1-13ubuntu5)) #1 SMP Thu Dec 7 22:48:10 EET 2006
[    0.000000] Command line: root=/dev/sda2 noapic
[    0.000000] BIOS-provided physical RAM map:
[    0.000000]  BIOS-e820: 0000000000000000 - 000000000009dc00 (usable)
[    0.000000]  BIOS-e820: 000000000009dc00 - 00000000000a0000 (reserved)
[    0.000000]  BIOS-e820: 00000000000d2000 - 0000000000100000 (reserved)
[    0.000000]  BIOS-e820: 0000000000100000 - 000000003ff00000 (usable)
[    0.000000]  BIOS-e820: 000000003ff00000 - 000000003ff17000 (ACPI data)
[    0.000000]  BIOS-e820: 000000003ff17000 - 000000003ff80000 (ACPI NVS)
[    0.000000]  BIOS-e820: 000000003ff80000 - 0000000040000000 (reserved)
[    0.000000]  BIOS-e820: 00000000e0000000 - 00000000f0000000 (reserved)
[    0.000000]  BIOS-e820: 00000000fec00000 - 00000000fec10000 (reserved)
[    0.000000]  BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
[    0.000000]  BIOS-e820: 00000000fff80000 - 0000000100000000 (reserved)
[    0.000000] Entering add_active_range(0, 0, 157) 0 entries of 3200 used
[    0.000000] Entering add_active_range(0, 256, 261888) 1 entries of 3200 used
[    0.000000] end_pfn_map = 1048576
[    0.000000] DMI present.
[    0.000000] ACPI: RSDP (v000 HP                                    ) @
0x00000000000f89a0
[    0.000000] ACPI: RSDT (v001 HP       RSDT   0x06040000  LTP 0x00000000) @
0x000000003ff0fb99
[    0.000000] ACPI: FADT (v001 HP     MCP51M   0x06040000 PTL_ 0x000f4240) @
0x000000003ff16d52
[    0.000000] ACPI: SSDT (v001 HP     POWERNOW 0x06040000  LTP 0x00000001) @
0x000000003ff16dc6
[    0.000000] ACPI: MCFG (v001 HP       MCFG   0x06040000  LTP 0x00000000) @
0x000000003ff16f48
[    0.000000] ACPI: MADT (v001 HP       APIC   0x06040000  LTP 0x00000000) @
0x000000003ff16f84
[    0.000000] ACPI: BOOT (v001     HP $SBFTBL$ 0x06040000  LTP 0x00000001) @
0x000000003ff16fd8
[    0.000000] ACPI: DSDT (v001 HP       MCP51M 0x06040000 MSFT 0x0100000e) @
0x0000000000000000
[    0.000000] Scanning NUMA topology in Northbridge 24
[    0.000000] Number of nodes 1
[    0.000000] Node 0 MemBase 0000000000000000 Limit 000000003ff00000
[    0.000000] Entering add_active_range(0, 0, 157) 0 entries of 3200 used
[    0.000000] Entering add_active_range(0, 256, 261888) 1 entries of 3200 used
[    0.000000] NUMA: Using 63 for the hash shift.
[    0.000000] Using node hash shift of 63
[    0.000000] Bootmem setup node 0 0000000000000000-000000003ff00000
[    0.000000] Zone PFN ranges:
[    0.000000]   DMA             0 ->     4096
[    0.000000]   DMA32        4096 ->  1048576
[    0.000000]   Normal    1048576 ->  1048576
[    0.000000] early_node_map[2] active PFN ranges
[    0.000000]     0:        0 ->      157
[    0.000000]     0:      256 ->   261888
[    0.000000] On node 0 totalpages: 261789
[    0.000000]   DMA zone: 56 pages used for memmap
[    0.000000]   DMA zone: 1359 pages reserved
[    0.000000]   DMA zone: 2582 pages, LIFO batch:0
[    0.000000]   DMA32 zone: 3524 pages used for memmap
[    0.000000]   DMA32 zone: 254268 pages, LIFO batch:31
[    0.000000]   Normal zone: 0 pages used for memmap
[    0.000000] ACPI: PM-Timer IO Port: 0x1008
[    0.000000] ACPI: Local APIC address 0xfee00000
[    0.000000] ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
[    0.000000] Processor #0 (Bootup-CPU)
[    0.000000] ACPI: LAPIC (acpi_id[0x01] lapic_id[0x01] enabled)
[    0.000000] Processor #1
[    0.000000] ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
[    0.000000] ACPI: LAPIC_NMI (acpi_id[0x01] high edge lint[0x1])
[    0.000000] ACPI: Skipping IOAPIC probe due to 'noapic' option.
[    0.000000] Using ACPI for processor (LAPIC) configuration information
[    0.000000] Intel MultiProcessor Specification v1.4
[    0.000000] MPTABLE: OEM ID: nVIDIA   MPTABLE: Product ID: C51-MCP51   
MPTABLE: APIC at: 0xFEE00000
[    0.000000] I/O APIC #2 at 0xFEC00000.
[    0.000000] Setting APIC routing to physical flat
[    0.000000] Processors: 2
[    0.000000] Nosave address range: 000000000009d000 - 000000000009e000
[    0.000000] Nosave address range: 000000000009e000 - 00000000000a0000
[    0.000000] Nosave address range: 00000000000a0000 - 00000000000d2000
[    0.000000] Nosave address range: 00000000000d2000 - 0000000000100000
[    0.000000] Allocating PCI resources starting at 50000000 (gap:
40000000:a0000000)
[    0.000000] SMP: Allowing 2 CPUs, 0 hotplug CPUs
[    0.000000] PERCPU: Allocating 33920 bytes of per cpu data
[    0.000000] Built 1 zonelists.  Total pages: 256850
[    0.000000] Kernel command line: root=/dev/sda2 noapic
[    0.000000] Initializing CPU#0
[    0.000000] PID hash table entries: 4096 (order: 12, 32768 bytes)
[   16.936865] Console: colour VGA+ 80x25
[   16.940343] Dentry cache hash table entries: 131072 (order: 8, 1048576 bytes)
[   16.941525] Inode-cache hash table entries: 65536 (order: 7, 524288 bytes)
[   16.941971] Checking aperture...
[   16.942030] CPU 0: aperture @ 340000000 size 32 MB
[   16.942087] Aperture too small (32 MB)
[   16.949116] No AGP bridge found
[   16.961484] Memory: 1025716k/1047552k available (2674k kernel code, 21440k
reserved, 1789k data, 308k init)
[   17.040643] Calibrating delay using timer specific routine.. 3217.76 BogoMIPS
(lpj=6435520)
[   17.040812] Security Framework v1.0.0 initialized
[   17.040871] SELinux:  Disabled at boot.
[   17.040951] Mount-cache hash table entries: 256
[   17.041145] CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
[   17.041206] CPU: L2 Cache: 256K (64 bytes/line)
[   17.041264] CPU 0/0 -> Node 0
[   17.041318] CPU: Physical Processor ID: 0
[   17.041374] CPU: Processor Core ID: 0
[   17.041450] SMP alternatives: switching to UP code
[   17.041635] ACPI: Core revision 20060707
[   17.047820] ACPI: setting ELCR to 0200 (from 0ca0)
[   17.255779] Using local APIC timer interrupts.
[   17.318044] result 12557334
[   17.318098] Detected 12.557 MHz APIC timer.
[   17.320875] SMP alternatives: switching to SMP code
[   17.321061] Booting processor 1/2 APIC 0x1
[   17.331598] Initializing CPU#1
[   17.332849] spurious 8259A interrupt: IRQ7.
[   17.408847] Calibrating delay using timer specific routine.. 3220.87 BogoMIPS
(lpj=6441748)
[   17.408855] CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
[   17.408857] CPU: L2 Cache: 256K (64 bytes/line)
[   17.408860] CPU 1/1 -> Node 0
[   17.408863] CPU: Physical Processor ID: 0
[   17.408864] CPU: Processor Core ID: 1
[   17.408932] AMD Turion(tm) 64 X2 Mobile Technology TL-50 stepping 02
[   17.412871] CPU 1: Syncing TSC to CPU 0.
[   17.412751] CPU 1: synchronized TSC with CPU 0 (last diff -7 cycles, maxerr
480 cycles)
[   17.412767] Brought up 2 CPUs
[   17.413402] testing NMI watchdog ... OK.
[   17.453573] Disabling vsyscall due to use of PM timer
[   17.453631] time.c: Using 3.579545 MHz WALL PM GTOD PM timer.
[   17.453689] time.c: Detected 1607.337 MHz processor.
[   17.461141] migration_cost=62
[   17.461738] NET: Registered protocol family 16
[   17.461888] ACPI: bus type pci registered
[   17.465996] PCI: Using MMCONFIG at e0000000
[   17.466085] PCI: No mmconfig possible on device 00:18
[   17.466325] PCI: No mmconfig possible on device 07:05
[   17.472990] ACPI: Interpreter enabled
[   17.473050] ACPI: Using PIC for interrupt routing
[   17.474230] ACPI: PCI Root Bridge [PCI0] (0000:00)
[   17.474296] PCI: Probing PCI hardware (bus 00)
[   17.474511] ACPI: Assume root bridge [\_SB_.PCI0] bus is 0
[   17.477109] Boot video device is 0000:05:00.0
[   17.477416] PCI: Transparent bridge - 0000:00:10.0
[   17.477507] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
[   17.519613] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P2P0._PRT]
[   17.520803] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.XVR0._PRT]
[   17.521158] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.XVR1._PRT]
[   17.521369] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.XVR2._PRT]
[   17.521788] ACPI: PCI Interrupt Link [LNK1] (IRQs 5 7 9 10 11 14 15) *0,
disabled.
[   17.522671] ACPI: PCI Interrupt Link [LNK2] (IRQs 5 7 9 10 *11 14 15)
[   17.523455] ACPI: PCI Interrupt Link [LNK3] (IRQs 5 7 9 10 *11 14 15)
[   17.524247] ACPI: PCI Interrupt Link [LNK4] (IRQs 5 7 9 10 11 14 15) *0,
disabled.
[   17.525142] ACPI: PCI Interrupt Link [LK1E] (IRQs 5 7 9 10 *11 14 15)
[   17.525926] ACPI: PCI Interrupt Link [LK2E] (IRQs 5 7 9 10 11 14 15) *0,
disabled.
[   17.526798] ACPI: PCI Interrupt Link [LK3E] (IRQs 5 7 9 10 11 14 15) *0,
disabled.
[   17.527673] ACPI: PCI Interrupt Link [LK4E] (IRQs 5 7 9 10 11 14 15) *0,
disabled.
[   17.528547] ACPI: PCI Interrupt Link [LSMB] (IRQs 5 7 9 *10 11 14 15)
[   17.529354] ACPI: PCI Interrupt Link [LPMU] (IRQs 5 7 9 *10 11 14 15)
[   17.530141] ACPI: PCI Interrupt Link [LUS0] (IRQs 5 7 9 10 *11 14 15)
[   17.530926] ACPI: PCI Interrupt Link [LUS2] (IRQs 5 *7 9 10 11 14 15)
[   17.531711] ACPI: PCI Interrupt Link [LMAC] (IRQs 5 7 9 *10 11 14 15)
[   17.532495] ACPI: PCI Interrupt Link [LAZA] (IRQs 5 7 9 10 11 14 15) *0,
disabled.
[   17.533391] ACPI: PCI Interrupt Link [LACI] (IRQs 5 7 9 10 11 14 15) *0,
disabled.
[   17.534266] ACPI: PCI Interrupt Link [LMCI] (IRQs 5 7 9 10 11 14 15) *0,
disabled.
[   17.535139] ACPI: PCI Interrupt Link [LPID] (IRQs 5 7 9 10 11 14 15) *0,
disabled.
[   17.536029] ACPI: PCI Interrupt Link [LTID] (IRQs *5 7 9 10 11 14 15)
[   17.536834] ACPI: PCI Interrupt Link [LSI1] (IRQs 5 7 9 *10 11 14 15), disabled.
[   17.537446] Linux Plug and Play Support v0.97 (c) Adam Belay
[   17.537514] pnp: PnP ACPI init
[   17.540481] pnp: PnP ACPI: found 11 devices
[   17.540778] SCSI subsystem initialized
[   17.540897] libata version 2.00 loaded.
[   17.540942] PCI: Using ACPI for IRQ routing
[   17.541000] PCI: If a device doesn't work, try "pci=routeirq".  If it helps,
post a report
[   17.541232] PCI-DMA: Disabling IOMMU.
[   17.541948] pnp: 00:03: ioport range 0x1000-0x107f could not be reserved
[   17.542009] pnp: 00:03: ioport range 0x1080-0x10ff has been reserved
[   17.542069] pnp: 00:03: ioport range 0x1400-0x147f has been reserved
[   17.542130] pnp: 00:03: ioport range 0x1480-0x14ff could not be reserved
[   17.542190] pnp: 00:03: ioport range 0x1800-0x187f has been reserved
[   17.542250] pnp: 00:03: ioport range 0x1880-0x18ff has been reserved
[   17.542310] pnp: 00:03: ioport range 0x2000-0x203f has been reserved
[   17.542674] PCI: Bridge: 0000:00:02.0
[   17.542730]   IO window: 4000-4fff
[   17.542787]   MEM window: c0200000-c03fffff
[   17.542844]   PREFETCH window: c3200000-c33fffff
[   17.542901] PCI: Bridge: 0000:00:03.0
[   17.542956]   IO window: disabled.
[   17.543012]   MEM window: c0400000-c05fffff
[   17.543068]   PREFETCH window: disabled.
[   17.543127] PCI: Failed to allocate mem resource #6:20000@e0000000 for
0000:05:00.0
[   17.543198] PCI: Bridge: 0000:00:04.0
[   17.543252]   IO window: disabled.
[   17.543308]   MEM window: c1000000-c2ffffff
[   17.543365]   PREFETCH window: d0000000-dfffffff
[   17.543423] PCI: Bridge: 0000:00:10.0
[   17.543478]   IO window: disabled.
[   17.543535]   MEM window: c3000000-c30fffff
[   17.543591]   PREFETCH window: disabled.
[   17.543654] PCI: Setting latency timer of device 0000:00:02.0 to 64
[   17.543661] PCI: Setting latency timer of device 0000:00:03.0 to 64
[   17.543666] PCI: Setting latency timer of device 0000:00:04.0 to 64
[   17.543673] PCI: Setting latency timer of device 0000:00:10.0 to 64
[   17.543772] NET: Registered protocol family 2
[   17.588687] IP route cache hash table entries: 32768 (order: 6, 262144 bytes)
[   17.588972] TCP established hash table entries: 131072 (order: 9, 2097152 bytes)
[   17.590552] TCP bind hash table entries: 65536 (order: 8, 1048576 bytes)
[   17.591307] TCP: Hash tables configured (established 131072 bind 65536)
[   17.591369] TCP reno registered
[   17.591640] Simple Boot Flag at 0x36 set to 0x1
[   17.592354] audit: initializing netlink socket (disabled)
[   17.592429] audit(1165532994.392:1): initialized
[   17.592746] VFS: Disk quotas dquot_6.5.1
[   17.592827] Dquot-cache hash table entries: 512 (order 0, 4096 bytes)
[   17.593000] io scheduler noop registered
[   17.593096] io scheduler anticipatory registered
[   17.593192] io scheduler deadline registered
[   17.593302] io scheduler cfq registered (default)
[   17.809074] PCI: Setting latency timer of device 0000:00:02.0 to 64
[   17.809079] pcie_portdrv_probe->Dev[02fc:10de] has invalid IRQ. Check vendor BIOS
[   17.809166] assign_interrupt_mode Found MSI capability
[   17.809258] Allocate Port Service[0000:00:02.0:pcie00]
[   17.809301] Allocate Port Service[0000:00:02.0:pcie03]
[   17.809359] PCI: Setting latency timer of device 0000:00:03.0 to 64
[   17.809363] pcie_portdrv_probe->Dev[02fd:10de] has invalid IRQ. Check vendor BIOS
[   17.809445] assign_interrupt_mode Found MSI capability
[   17.809516] Allocate Port Service[0000:00:03.0:pcie00]
[   17.809554] Allocate Port Service[0000:00:03.0:pcie03]
[   17.809610] PCI: Setting latency timer of device 0000:00:04.0 to 64
[   17.809613] pcie_portdrv_probe->Dev[02fb:10de] has invalid IRQ. Check vendor BIOS
[   17.809696] assign_interrupt_mode Found MSI capability
[   17.809766] Allocate Port Service[0000:00:04.0:pcie00]
[   17.809801] Allocate Port Service[0000:00:04.0:pcie03]
[   17.843328] Real Time Clock Driver v1.12ac
[   17.843428] Linux agpgart interface v0.101 (c) Dave Jones
[   17.844954] Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing
enabled
[   17.846651] RAMDISK driver initialized: 16 RAM disks of 65536K size 1024
blocksize
[   17.846823] Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
[   17.846884] ide: Assuming 33MHz system bus speed for PIO modes; override with
idebus=xx
[   17.847001] NFORCE-MCP51: IDE controller at PCI slot 0000:00:0d.0
[   17.847075] NFORCE-MCP51: chipset revision 241
[   17.847132] NFORCE-MCP51: not 100% native mode: will probe irqs later
[   17.847192] NFORCE-MCP51: BIOS didn't set cable bits correctly. Enabling
workaround.
[   17.847264] NFORCE-MCP51: 0000:00:0d.0 (rev f1) UDMA133 controller
[   17.847327]     ide0: BM-DMA at 0x3080-0x3087, BIOS settings: hda:DMA, hdb:pio
[   17.847483] Probing IDE interface ide0...
[   18.580643] hda: MATSHITADVD-RAM UJ-850S, ATAPI CD/DVD-ROM drive
[   18.917166] ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
[   18.917591] Probing IDE interface ide1...
[   19.481584] hda: ATAPI 24X DVD-ROM DVD-R-RAM CD-R/RW drive, 2048kB Cache, (U)DMA
[   19.481978] Uniform CD-ROM driver Revision: 3.20
[   19.485458] st: Version 20050830, fixed bufsize 32768, s/g segs 256
[   19.485557] osst :I: Tape driver with OnStream support version 0.99.4
[   19.485559] osst :I: $Id: osst.c,v 1.73 2005/01/01 21:13:34 wriede Exp $
[   19.485782] SCSI Media Changer driver v0.25 
[   19.485945] sata_nv 0000:00:0e.0: version 2.0
[   19.485956] PCI: Enabling device 0000:00:0e.0 (0005 -> 0007)
[   19.486371] ACPI: PCI Interrupt Link [LTID] enabled at IRQ 5
[   19.486430] PCI: setting IRQ 5 as level-triggered
[   19.486435] ACPI: PCI Interrupt 0000:00:0e.0[A] -> Link [LTID] -> GSI 5
(level, low) -> IRQ 5
[   19.486694] PCI: Setting latency timer of device 0000:00:0e.0 to 64
[   19.486771] ata1: SATA max UDMA/133 cmd 0x30C0 ctl 0x30B6 bmdma 0x3090 irq 5
[   19.486860] ata2: SATA max UDMA/133 cmd 0x30B8 ctl 0x30B2 bmdma 0x3098 irq 5
[   19.486930] scsi0 : sata_nv
[   19.952452] ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[   19.953996] ata1.00: ATA-7, max UDMA/100, 195371568 sectors: LBA48 
[   19.954056] ata1.00: ata1: dev 0 multi count 16
[   19.955874] ata1.00: configured for UDMA/100
[   19.955934] scsi1 : sata_nv
[   20.264407] ata2: SATA link down (SStatus 0 SControl 300)
[   20.275080] ATA: abnormal status 0x7F on port 0x30BF
[   20.275237] scsi 0:0:0:0: Direct-Access     ATA      ST9100824AS      7.24
PQ: 0 ANSI: 5
[   20.275417] SCSI device sda: 195371568 512-byte hdwr sectors (100030 MB)
[   20.275488] sda: Write Protect is off
[   20.275543] sda: Mode Sense: 00 3a 00 00
[   20.275562] SCSI device sda: drive cache: write back
[   20.275664] SCSI device sda: 195371568 512-byte hdwr sectors (100030 MB)
[   20.275731] sda: Write Protect is off
[   20.275786] sda: Mode Sense: 00 3a 00 00
[   20.275804] SCSI device sda: drive cache: write back
[   20.275863]  sda: sda1 sda2 sda3
[   20.286828] sd 0:0:0:0: Attached scsi disk sda
[   20.286960] sd 0:0:0:0: Attached scsi generic sg0 type 0
[   20.287105] pd: pd version 1.05, major 45, cluster 64, nice 0
[   20.287201] pda: Autoprobe failed
[   20.287256] pd: no valid drive found
[   20.287322] pcd: pcd version 1.07, major 46, nice 0
[   20.287408] pcd0: Autoprobe failed
[   20.287463] pcd: No CD-ROM drive found
[   20.287527] pf: pf version 1.04, major 47, cluster 64, nice 0
[   20.287585] pf: No ATAPI disk detected
[   20.287643] pg: pg version 1.02, major 97
[   20.287727] pga: Autoprobe failed
[   20.287782] pg: No ATAPI device detected
[   20.287916] PNP: PS/2 Controller [PNP0303:KBC0,PNP0f13:MSE0] at 0x60,0x64 irq
1,12
[   20.304171] serio: i8042 KBD port at 0x60,0x64 irq 1
[   20.304231] serio: i8042 AUX port at 0x60,0x64 irq 12
[   20.304436] mice: PS/2 mouse device common for all mice
[   20.305914] TCP cubic registered
[   20.305977] NET: Registered protocol family 1
[   20.306039] NET: Registered protocol family 8
[   20.306095] NET: Registered protocol family 20
[   20.306272] ACPI: (supports S0 S3 S4 S5)
[   20.306577] drivers/rtc/hctosys.c: unable to open rtc device (rtc0)
[   20.317413] input: AT Translated Set 2 keyboard as /class/input/input0
[   20.451919] kjournald starting.  Commit interval 5 seconds
[   20.451987] EXT3-fs: mounted filesystem with ordered data mode.
[   20.452103] VFS: Mounted root (ext3 filesystem) readonly.
[   20.452245] Freeing unused kernel memory: 308k freed
[   30.931824] usbcore: registered new interface driver usbfs
[   30.932553] usbcore: registered new interface driver hub
[   30.933272] usbcore: registered new device driver usb
[   30.973733] pci_hotplug: PCI Hot Plug PCI Core version: 0.5
[   30.985064] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
[   31.152699] ACPI: PCI Interrupt Link [LUS2] enabled at IRQ 7
[   31.152761] PCI: setting IRQ 7 as level-triggered
[   31.152766] ACPI: PCI Interrupt 0000:00:0b.1[B] -> Link [LUS2] -> GSI 7
(level, low) -> IRQ 7
[   31.153018] PCI: Setting latency timer of device 0000:00:0b.1 to 64
[   31.153024] ehci_hcd 0000:00:0b.1: EHCI Host Controller
[   31.153498] ehci_hcd 0000:00:0b.1: new USB bus registered, assigned bus number 1
[   31.153604] ehci_hcd 0000:00:0b.1: debug port 1
[   31.153662] PCI: cache line size of 64 is not supported by device 0000:00:0b.1
[   31.153672] ehci_hcd 0000:00:0b.1: irq 7, io mem 0xc0005000
[   31.153737] ehci_hcd 0000:00:0b.1: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
[   31.153953] usb usb1: configuration #1 chosen from 1 choice
[   31.154052] hub 1-0:1.0: USB hub found
[   31.154113] hub 1-0:1.0: 8 ports detected
[   31.218092] ohci_hcd: 2006 August 04 USB 1.1 'Open' Host Controller (OHCI)
Driver (PCI)
[   31.259522] ACPI: PCI Interrupt Link [LUS0] enabled at IRQ 11
[   31.259602] PCI: setting IRQ 11 as level-triggered
[   31.259607] ACPI: PCI Interrupt 0000:00:0b.0[A] -> Link [LUS0] -> GSI 11
(level, low) -> IRQ 11
[   31.259867] PCI: Setting latency timer of device 0000:00:0b.0 to 64
[   31.259873] ohci_hcd 0000:00:0b.0: OHCI Host Controller
[   31.260033] ohci_hcd 0000:00:0b.0: new USB bus registered, assigned bus number 2
[   31.260122] ohci_hcd 0000:00:0b.0: irq 11, io mem 0xc0004000
[   31.321037] usb usb2: configuration #1 chosen from 1 choice
[   31.321130] hub 2-0:1.0: USB hub found
[   31.321196] hub 2-0:1.0: 8 ports detected
[   31.371829] input: PC Speaker as /class/input/input1
[   31.392769] forcedeth.c: Reverse Engineered nForce ethernet driver. Version 0.57.
[   31.427187] i2c_adapter i2c-0: nForce2 SMBus adapter at 0x3040
[   31.427275] i2c_adapter i2c-1: nForce2 SMBus adapter at 0x3000
[   31.427758] ACPI: PCI Interrupt Link [LMAC] enabled at IRQ 10
[   31.427822] PCI: setting IRQ 10 as level-triggered
[   31.427827] ACPI: PCI Interrupt 0000:00:14.0[A] -> Link [LMAC] -> GSI 10
(level, low) -> IRQ 10
[   31.427982] PCI: Setting latency timer of device 0000:00:14.0 to 64
[   31.427990] forcedeth: using HIGHDMA
[   31.495543] usb 1-4: new high speed USB device using ehci_hcd and address 2
[   31.637533] usb 1-4: configuration #1 chosen from 1 choice
[   31.682257] sdhci: Secure Digital Host Controller Interface driver, 0.12
[   31.682320] sdhci: Copyright(c) Pierre Ossman
[   31.775659] ieee1394: Initialized config rom entry `ip1394'
[   31.951122] eth0: forcedeth.c: subsystem: 0103c:30b7 bound to 0000:00:14.0
[   31.951909] ACPI: PCI Interrupt Link [LNK1] enabled at IRQ 11
[   31.951974] ACPI: PCI Interrupt 0000:07:05.0[A] -> Link [LNK1] -> GSI 11
(level, low) -> IRQ 11
[   32.004369] ohci1394: fw-host0: OHCI-1394 1.1 (PCI): IRQ=[11] 
MMIO=[c3000000-c30007ff]  Max Packet=[2048]  IR/IT contexts=[4/4]
[   32.009017] ACPI: PCI Interrupt Link [LAZA] enabled at IRQ 10
[   32.009080] ACPI: PCI Interrupt 0000:00:10.1[B] -> Link [LAZA] -> GSI 10
(level, low) -> IRQ 10
[   32.009355] PCI: Setting latency timer of device 0000:00:10.1 to 64
[   32.020595] eth1: no link during initialization.
[   32.379739] sdhci: SDHCI controller found at 0000:07:05.1 [1180:0822] (rev 19)
[   32.380205] ACPI: PCI Interrupt Link [LNK2] enabled at IRQ 11
[   32.380265] ACPI: PCI Interrupt 0000:07:05.1[B] -> Link [LNK2] -> GSI 11
(level, low) -> IRQ 11
[   32.380650] mmc0: SDHCI at 0xc3000800 irq 11 DMA
[   32.560730] lp: driver loaded but no devices found
[   32.566931] Synaptics Touchpad, model: 1, fw: 6.3, id: 0x1a0b1, caps:
0xa04713/0x200000
[   32.589692] ieee1394: sbp2: Driver forced to serialize I/O (serialize_io=1)
[   32.589755] ieee1394: sbp2: Try serialize_io=0 for better performance
[   32.634603] input: SynPS/2 Synaptics TouchPad as /class/input/input2
[   32.812355] EXT3 FS on sda2, internal journal
[   33.050177] NTFS driver 2.1.27 [Flags: R/O MODULE].
[   33.075749] eth1: link up.
[   33.090794] NET: Registered protocol family 17
[   33.156877] NTFS volume version 3.1.
[   33.193673] NTFS volume version 3.1.
[   33.282933] ieee1394: Host added: ID:BUS[0-00:1023]  GUID[009fc000f9cdad00]
[   35.356122] NET: Registered protocol family 10
[   35.356235] lo: Disabled Privacy Extensions
[   35.724722] ACPI: AC Adapter [ACAD] (on-line)
[   35.776287] ACPI: Battery Slot [BAT0] (battery present)
[   35.799290] ACPI: Power Button (FF) [PWRF]
[   35.799302] ACPI: Power Button (CM) [PWRB]
[   35.799310] ACPI: Sleep Button (CM) [SLPB]
[   35.799318] ACPI: Lid Switch [LID]
[   36.558966] Using specific hotkey driver
[   37.024832] ibm_acpi: ec object not found
[   38.589351] ACPI: Thermal Zone [THRM] (55 C)
[   38.601592] toshiba_acpi: Unknown parameter `hotkeys_over_acpi'
[   38.614540] ACPI: Video Device [UVGA] (multi-head: yes  rom: no  post: no)
[   38.614690] ACPI: Video Device [VGA] (multi-head: yes  rom: no  post: no)
[   38.875911] powernow-k8: Found 2 AMD Turion(tm) 64 X2 Mobile Technology TL-50
processors (version 2.00.00)
[   38.876046] powernow-k8:    0 : fid 0x8 (1600 MHz), vid 0x12
[   38.876051] powernow-k8:    1 : fid 0x0 (800 MHz), vid 0x1e
[   44.771650] Bluetooth: Core ver 2.11
[   44.771712] NET: Registered protocol family 31
[   44.771715] Bluetooth: HCI device and connection manager initialized
[   44.771719] Bluetooth: HCI socket layer initialized
[   44.793624] Bluetooth: L2CAP ver 2.8
[   44.793629] Bluetooth: L2CAP socket layer initialized
[   44.863541] Bluetooth: RFCOMM socket layer initialized
[   44.863557] Bluetooth: RFCOMM TTY layer initialized
[   44.863560] Bluetooth: RFCOMM ver 1.8
[   46.306369] eth1: no IPv6 routers present
[  184.539035] irq 7: nobody cared (try booting with the "irqpoll" option)
[  184.539042] 
[  184.539044] Call Trace:
[  184.539047]  <IRQ>  [<ffffffff802c02f5>] __report_bad_irq+0x35/0x90
[  184.539070]  [<ffffffff802c0570>] note_interrupt+0x220/0x280
[  184.539097]  [<ffffffff88007505>] :usbcore:usb_hcd_irq+0x25/0x60
[  184.539105]  [<ffffffff802c1263>] handle_level_irq+0xe3/0x140
[  184.539111]  [<ffffffff8026624c>] call_softirq+0x1c/0x28
[  184.539118]  [<ffffffff8027431a>] do_IRQ+0x8a/0xe0
[  184.539123]  [<ffffffff80272940>] default_idle+0x0/0x50
[  184.539129]  [<ffffffff80265641>] ret_from_intr+0x0/0xa
[  184.539132]  <EOI>  [<ffffffff80272969>] default_idle+0x29/0x50
[  184.539147]  [<ffffffff8024bf5a>] cpu_idle+0x9a/0xd0
[  184.539154]  [<ffffffff8027ea95>] start_secondary+0x4d5/0x4f0
[  184.539172] 
[  184.539173] handlers:
[  184.539176] [<ffffffff880074e0>] (usb_hcd_irq+0x0/0x60 [usbcore])
[  184.539194] Disabling IRQ #7
stalwart@naga:~$ cat /proc/interrupts 
           CPU0       CPU1       
  0:     176820      10158    XT-PIC-XT        timer
  1:       2645         99    XT-PIC-XT        i8042
  2:          0          0    XT-PIC-XT        cascade
  5:       6491        468    XT-PIC-XT        libata
  7:      24310     374010    XT-PIC-XT        ehci_hcd:usb1
  8:          0          0    XT-PIC-XT        rtc
  9:        370         36    XT-PIC-XT        acpi
 10:      76180       5337    XT-PIC-XT        HDA Intel, eth1
 11:          1          2    XT-PIC-XT        ohci_hcd:usb2, ohci1394, sdhci:slot0
 12:     105563       8309    XT-PIC-XT        i8042
 14:       6190        379    XT-PIC-XT        ide0
NMI:        107         80 
LOC:     186954     186933 
ERR:     299041
Comment 10 Patrick Brunier 2006-12-09 01:50:31 UTC
My latest experiences with 2.6.19-7 on Ubuntu 6.10 (HP DV6132)

Options: noapic, with SMP, NDISWRAPPER active ## NO HANG
Options: with SMP,  NDISWRAPPER active ## HANG FEW SECONDS AFTER LOGIN
Options: nosmp, NDISWRAPPER active ## During boot time outs on SATA and IDE
(srtst failed and hda lost interrupt)
Options: noapic, with SMP, NDISWRAPPER active, NVIDIA (from nvidia.com) drivers
active ## NO HANG !!! Unsure why it works now. Maybe because of the later
kernel. Anyways after my last reboot I've lost CPU Freq scaling support. My two
cores are running on 1600 MHZ without the ability to step down. Hmmmm.
Comment 11 Patrick Brunier 2006-12-09 01:52:32 UTC
Aaarrggh no ! Still doesn't work. I've had one good run. But besides the cpu
freq scaling problem I now loose IRQ 9 as well. IRQ 9 is my broadcom.
Heading back to single core right now.
Comment 12 Pavel Shevchuk 2006-12-09 13:09:23 UTC
Updated ubuntu to 7.04 feisty (dev branch). With its 2.6.19 kernel and "noapic 
irqpoll" everything seems to work fine, except wifi (i think it's bcm43xx issue)
Comment 13 Patrick Brunier 2006-12-10 11:00:50 UTC
32-bit version of Feisty is still a problem. 64-bit seems to work just fine.
Except when running smp the cpu's are busy with handling hardware interrupts.
Comment 14 Pavel Shevchuk 2006-12-10 11:51:08 UTC
Patrick, why do you need i386 version of ubuntu if you can run amd64?

I'm installing Gentoo right now
Comment 15 Patrick Brunier 2006-12-10 12:12:04 UTC
He's really busy handling interrupts from IRQ7:

 0:     736804      43456    XT-PIC-XT        timer
  1:       2411        130    XT-PIC-XT        i8042
  2:          0          0    XT-PIC-XT        cascade
  5:      15708       1946    XT-PIC-XT        libata
  7:      88954    1380114    XT-PIC-XT        ehci_hcd:usb1
  8:          0          0    XT-PIC-XT        rtc
  9:      92381       8387    XT-PIC-XT        acpi, eth1
 10:     292463      20624    XT-PIC-XT        eth0, HDA Intel
 11:     215751      11360    XT-PIC-XT        ohci_hcd:usb2, nvidia
 12:        514         79    XT-PIC-XT        i8042
 14:      24498       3257    XT-PIC-XT        ide0
NMI:        206        165 
LOC:     780082     780064 
ERR:    1369549

This only happens on SMP. The first lets say 5 minutes cpu1 is busy for 90%
handling thos interrupts. It slowly goes down to ~0%. With spontaneous peaks to
40% or higher. This makes my system step up to 1600Mhz instead of 800Mhz when
I'm doing nothing. This is bad for the battery life.
Comment 16 Pavel Shevchuk 2006-12-10 12:43:16 UTC
Disable automagic stepping and bind a hotkey to switch between 800 and 1600 mhz.
Most time you don't need such great computing power, you can do most tasks fine
even on single 800mhz core.

However, i'm still waiting for better solution. Don't know what noapic exactly
does, but kernel hanging in default configuration is not the way things should
happen. And afaik this problem is common to all mcp51 motherboards ;[
Comment 17 Pavel Shevchuk 2006-12-22 14:11:32 UTC
My experiments continue. I installed Kubuntu Feisty Herd 1 and updated to 
current, got .20 kernel (-rc or some -git, don't know). When booted 
with "noapic irqpoll" hardware interrupts use 100% cpu and system is almost 
unusable, when i boot with "noapic" only hi floats from 5% to 30% and system 
is responsive.

And then i installed firmware for bcm4311 wifi...
System didn't boot up with different kernel cheatcodes giving me something 
like "BUG: Cpu #x softlock" (didn't write down exact error, i can crash it 
more if needed) or just freezing. The only way to boot was using acpi=noirq. 
bcm43xx was mad about not getting interrupts and flooded ttys, i also had no 
sound and X didn't start because of nvidia =[

I deleted bcm4311 firmware and now system is back to almost normal state (hi 
still uses much cpu time)

I still hope...
Comment 18 Pavel Shevchuk 2006-12-22 14:15:37 UTC
Created attachment 9934 [details]
dmesg while booted with acpi=noirq and bcm4311 firmware

	   CPU0       CPU1	 
  0:	  30251 	 0   IO-APIC-edge      timer
  1:	    330 	 0   IO-APIC-edge      i8042
  2:	      0 	 0    XT-PIC-XT        cascade
  5:	   2916 	 0   IO-APIC-edge      libata
  7:	     22 	 0   IO-APIC-edge      ehci_hcd:usb2
  8:	      0 	 0   IO-APIC-edge      rtc
  9:	    156 	 0   IO-APIC-edge      acpi
 10:	  11031 	 0   IO-APIC-edge      eth0
 11:	     33 	 0   IO-APIC-edge      ohci_hcd:usb1, ohci1394,
sdhci:slot0, HDA Intel
 12:	    124 	 0   IO-APIC-edge      i8042
 14:	    899 	 0   IO-APIC-edge      ide0
NMI:	    102 	38 
LOC:	  30211      30193 
ERR:	      2
Comment 19 Pavel Shevchuk 2006-12-23 09:48:58 UTC
Damn, i was so close to success =[

I was reading nvidia-glx readme and found pci=biosirq cheatcode. With it 
system booted, nothing shared interrupts and system was working awesome (how 
it should) for one hour, then i locked it up while trying to load bcm43xx 
firmware (Soft lockup detected on CPU#0). I deleted firmware again, even 
deleted bcm43xx module from /lib/modules, but system hangs while booting with 
pci=biosirq. It booted fine only once. =( I'll keep trying different kernel 
versions and cheatcodes.

Is anyone reading what i write here?
Comment 20 Patrick Brunier 2006-12-23 11:48:59 UTC
Yep. I can't get my one stable. Only with the NDISWrapper.

On 12/23/06, bugme-daemon@bugzilla.kernel.org
<bugme-daemon@bugzilla.kernel.org> wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=7562
>
>
>
>
>
> ------- Additional Comments From stlwrt@gmail.com  2006-12-23 09:48 -------
> Damn, i was so close to success =[
>
> I was reading nvidia-glx readme and found pci=biosirq cheatcode. With it
> system booted, nothing shared interrupts and system was working awesome (how
> it should) for one hour, then i locked it up while trying to load bcm43xx
> firmware (Soft lockup detected on CPU#0). I deleted firmware again, even
> deleted bcm43xx module from /lib/modules, but system hangs while booting with
> pci=biosirq. It booted fine only once. =( I'll keep trying different kernel
> versions and cheatcodes.
>
> Is anyone reading what i write here?
>
> ------- You are receiving this mail because: -------
> You reported the bug, or are watching the reporter.
>


Comment 21 Pavel Shevchuk 2006-12-23 13:04:19 UTC
To be honest, i think about selling this laptop. I spent a month trying to get 
good OS on it and don't see any point to continue having sex with it if i can 
just buy better notebook.

If anyone is interested in getting technical data about this hardware - 
contact me by email, i hope to sell it during next month.

Sorry for off-topic.
Comment 22 Patrick Brunier 2006-12-24 15:43:06 UTC
Try ubunty "Feisty" (kernel 2.6.20) first before you sell. I got it
stable with ndiswrapper, nvidia.com drivers, smp and all. The only
thing I had to use is the options noapic. bcm43xx still doesn't work.
But ndiswrapper works ok.

On 12/23/06, bugme-daemon@bugzilla.kernel.org
<bugme-daemon@bugzilla.kernel.org> wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=7562
>
>
>
>
>
> ------- Additional Comments From stlwrt@gmail.com  2006-12-23 13:04 -------
> To be honest, i think about selling this laptop. I spent a month trying to get
> good OS on it and don't see any point to continue having sex with it if i can
> just buy better notebook.
>
> If anyone is interested in getting technical data about this hardware -
> contact me by email, i hope to sell it during next month.
>
> Sorry for off-topic.
>
> ------- You are receiving this mail because: -------
> You reported the bug, or are watching the reporter.
>


Comment 23 Pavel Shevchuk 2006-12-25 02:37:33 UTC
I was using exactly feisty with .20 when decided to sell laptop
Comment 24 Ron Kuris 2006-12-25 07:46:02 UTC
I found a workaround; everything is working for me.

Booting with pci=usepirqmask

The order (and perhaps the timing) in which the modules are loaded is critical.
 If I "modprobe snd_hda_intel" first, I am toast.  The order that works for me is:

i2c_core nvidia snd_hda_codec cpufreq_conservative ohci_hcd snd_hda_intel
ndiswrapper

Working interrupts:

kimchee% cat /proc/interrupts
           CPU0       CPU1       
  0:       5657    1208070    IO-APIC-edge  timer
  1:          6        944    IO-APIC-edge  i8042
  8:          0          0    IO-APIC-edge  rtc
  9:          0        226   IO-APIC-level  acpi
 11:          0          3   IO-APIC-level  ohci1394
 12:        106      21276    IO-APIC-edge  i8042
 14:          0        270    IO-APIC-edge  ide0
 50:        292      52725   IO-APIC-level  wlan0
201:       2501     498403   IO-APIC-level  eth0
209:         99      20435   IO-APIC-level  libata
217:       1210     295445   IO-APIC-level  nvidia
225:         99      19055   IO-APIC-level  ohci_hcd:usb1
233:          0        135   IO-APIC-level  HDA Intel
NMI:        242        360 
LOC:    1213743    1213720 
ERR:          0
MIS:          0

I did run into a problem with USB 1.0 devices where I was getting a timeout and
sometimes a hang.  I "fixed" that also by modifying hub.c and changing the
timeout value manually from 1000 to 5000 (around line 2327 on my 2.6.18 kernel).

I suspect the real problem is that things are getting initialized too quickly.
Comment 25 Pavel Shevchuk 2006-12-25 07:59:52 UTC
How can i change module loading order?
Comment 26 Pavel Shevchuk 2006-12-26 13:02:59 UTC
Got Debian Etch.

stalwart@naga:~$ cat /etc/modules
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

i2c_core
nvidia
snd_hda_codec
cpufreq_conservative
ohci_hcd
snd_hda_intel

loop
sbp2

stalwart@naga:~$ cat /proc/interrupts 
           CPU0       CPU1       
  0:    1074707          0    IO-APIC-edge  timer
  1:      16613          0    IO-APIC-edge  i8042
  8:          0          0    IO-APIC-edge  rtc
  9:       1872          0   IO-APIC-level  acpi
 10:          1          0   IO-APIC-level  sdhci:slot0
 11:          5          0   IO-APIC-level  ohci1394
 12:        124          0    IO-APIC-edge  i8042
 14:      37887          0    IO-APIC-edge  ide0
 50:       3256          0   IO-APIC-level  HDA Intel
 58:     270044          0   IO-APIC-level  nvidia
209:     595631          0   IO-APIC-level  eth1
217:         21          0   IO-APIC-level  ehci_hcd:usb1
225:      51975          0   IO-APIC-level  ohci_hcd:usb2
233:      39470          0   IO-APIC-level  libata
NMI:        241        179 
LOC:    1074739    1074715 
ERR:          0
MIS:          0

And it works! So we got solution. Now i think about keeping this laptop =P
Comment 27 Len Brown 2006-12-26 21:44:04 UTC
re: comment #9
> noapic

> [  184.539194] Disabling IRQ #7

>  7:      24310     374010    XT-PIC-XT        ehci_hcd:usb1
> ERR:     299041

Spurious interrupts have disabled IRQ7, and thus EHCI,
in this configuration.  In general, noapic is a bad idea,
and on SMP a very bad idea.

Comment 28 Len Brown 2006-12-26 21:46:47 UTC
> Booting with pci=usepirqmask

This should not make any difference in ACPI mode.
Can you re-test without it?

Please attach the complete dmesg -s 64000 from the success case
using no binary nvidia driver and no ndiswrapper?
Comment 29 Pavel Shevchuk 2006-12-26 23:57:36 UTC
I'm running without any tricky kernel parameters, check my report a wee bit 
higher on this page =]
Comment 30 Pavel Shevchuk 2006-12-29 05:33:12 UTC
Created attachment 9962 [details]
dmesg -s 64000

I was wrong, system is still unstable, even with correct interrupts. It hangs
often if i shut down X (running with nvidia module) and on bootup (probably
because modules load or devices init in wrong order). I attached dmesg running
with pci=usepirqmask (still experimenting)

I'm running ArchLinux x86-64 with default kernel now.

[root@naga stalwart]# uname -a
Linux naga 2.6.19-ARCH #1 SMP PREEMPT Wed Dec 13 21:34:01 UTC 2006 x86_64 AMD
Turion(tm) 64 X2 Mobile Technology TL-50 AuthenticAMD GNU/Linux
[root@naga stalwart]# cat /proc/interrupts 
	   CPU0       CPU1	 
  0:	 139729 	 0   IO-APIC-edge      timer
  1:	   2851 	 0   IO-APIC-edge      i8042
  8:	      0 	 0   IO-APIC-edge      rtc
  9:	     34 	 0   IO-APIC-fasteoi   acpi
 10:	      0 	 0   IO-APIC-fasteoi   sdhci:slot0
 11:	      4 	 0   IO-APIC-fasteoi   ohci1394
 12:	    124 	 0   IO-APIC-edge      i8042
 14:	    173 	 0   IO-APIC-edge      libata
 15:	      0 	 0   IO-APIC-edge      libata
 18:	  56611 	 0   IO-APIC-fasteoi   eth0
 19:	     19 	 0   IO-APIC-fasteoi   ehci_hcd:usb2
 20:	   8932 	 0   IO-APIC-fasteoi   libata
 21:	    164 	 0   IO-APIC-fasteoi   HDA Intel
 22:	   5043 	 0   IO-APIC-fasteoi   ohci_hcd:usb1
 23:	  33833 	 0   IO-APIC-fasteoi   nvidia
NMI:	     89 	44 
LOC:	 139599     139577 
ERR:	      0
Comment 31 Bernhard 2007-01-04 23:06:44 UTC
Hi. I have a pavilion dv9043ea (turion X2) and experiencing exactly the same
problems as described by patrick in comment #1.

I can also confirm that booting with the default Arch-Linux Kernel (on i686
though) and passing pci=usepirqmask results in no irq errors everything seems to
be working ok. 
Comment 32 Pavel Shevchuk 2007-01-05 02:12:12 UTC
Then you have a bit different hardware (or less buggy BIOS). usepirqmask 
doesn't change anything for me, i need to load modules in proper order
Comment 33 Izar Tarandach 2007-01-23 07:44:12 UTC
Adding more info.

izar@izar:~ $ uname -a;cat /proc/interrupts 
Linux izar 2.6.17-10-generic #2 SMP Fri Oct 13 18:45:35 UTC 2006 i686 GNU/Linux
           CPU0       CPU1       
  0:     436579      43440          XT-PIC  timer
  1:          7          4          XT-PIC  i8042
  2:          0          0          XT-PIC  cascade
  5:      17942       2398          XT-PIC  libata
  7:      97214     848136          XT-PIC  ehci_hcd:usb2
  8:          2          1          XT-PIC  rtc
  9:          7          3          XT-PIC  acpi
 10:     193533      27958          XT-PIC  eth0, HDA Intel
 11:     200120      23364          XT-PIC  ohci_hcd:usb1, sdhci:slot0, nvidia
 12:         88         35          XT-PIC  i8042
 14:         52         12          XT-PIC  ide0
NMI:          0          0 
LOC:     479822     479827 
ERR:     845690
MIS:          0

It seems to me that the system is more likely to boot when using simply:

izar@izar:~ $ cat /proc/cmdline 
root=/dev/sda2 ro noapic noacpi

The full output of iasl when trying to recompile the DSDT is:

root@izar:~# iasl dsdt.dsl

Intel ACPI Component Architecture
ASL Optimizing Compiler version 20060608 [Jun 29 2006]
Copyright (C) 2000 - 2006 Intel Corporation
Supports ACPI Specification Revision 3.0a

dsdt.dsl    83:     Method (\_WAK, 1, NotSerialized)
Warning  1079 -                 ^ Reserved method must return a value (_WAK)

dsdt.dsl  4992:                     Method (_EJ0, 0, NotSerialized)
Warning  1076 -                                ^ Reserved method has too few
arguments (_EJ0 requires 1)

ASL Input:  dsdt.dsl - 6510 lines, 225202 bytes, 3233 keywords
AML Output: dsdt.aml - 26501 bytes 665 named objects 2568 executable opcodes

Compilation complete. 0 Errors, 2 Warnings, 0 Remarks, 883 Optimizations

Fixing the errors and booting with the new DSDT doesn't seem to help any.

The BIOS in this machine is F.1A, the latest out from HP. It is an OEM version
of Phoenix 4.0 release 6.1. It has absolutely no configurable options.
Comment 34 Pavel Shevchuk 2007-01-23 07:51:41 UTC
Izar, i found .17 kernel almost unusable on this laptop. Did you try newer 
kernels?
Comment 35 Izar Tarandach 2007-01-27 08:30:49 UTC
2.6.17-10-generic, both x86 and 64, worked pretty well with "noapic noacpi" -
I'd get the "IRQ 7" message, and if i needed anything on usb, just rmmod and
insmod ehci and ohci would solve it.

Now i am running 2.6.20-5 from feisty over edgy, with "noapic
acpi_use_timer_override irqpoll" - since yesterday - and everything seems to be
fine, although i still get the IRQ 7 if an external hard drive i got on is doing
heavy work - and i loose the mount.


           CPU0       CPU1       
  0:      86811       7047    XT-PIC-XT        timer
  1:         24         10    XT-PIC-XT        i8042
  2:          0          0    XT-PIC-XT        cascade
  5:          6          0    XT-PIC-XT        libata
  7:       7309      87848    XT-PIC-XT        ehci_hcd:usb2
  8:          2          1    XT-PIC-XT        rtc
  9:        233          9    XT-PIC-XT        acpi, bcm43xx
 10:        240         33    XT-PIC-XT        eth0, HDA Intel
 11:         54         10    XT-PIC-XT        ohci_hcd:usb1, sdhci:slot0, nvidia
 12:        227        163    XT-PIC-XT        i8042
 14:        318         40    XT-PIC-XT        ide0
NMI:          0          0 
LOC:      93101      93039 
ERR:       1370
MIS:          0

root@izar:/home/izar# cat /proc/acpi/battery/BAT0/info 
present:                 yes
design capacity:         6000 mAh
last full capacity:      3808 mAh
battery technology:      rechargeable
design voltage:          14800 mV
design capacity warning: 197 mAh
design capacity low:     119 mAh
capacity granularity 1:  10 mAh
capacity granularity 2:  25 mAh
model number:            Primary
serial number:            
battery type:            LION
OEM info:                Hewlett-Packard
Comment 36 Izar Tarandach 2007-02-05 07:58:16 UTC
A more recent report. Working beautifully:

Linux izar 2.6.20-5-generic #2 SMP Sat Jan 6 14:50:47 UTC 2007 i686 GNU/Linux

root=/dev/sda2 ro noapic acpi_use_timer_override irqpoll

           CPU0       CPU1       
  0:     986267     129525    XT-PIC-XT        timer
  1:          9          1    XT-PIC-XT        i8042
  2:          0          0    XT-PIC-XT        cascade
  5:        175          7    XT-PIC-XT        libata
  7:     134895     992043    XT-PIC-XT        ehci_hcd:usb1
  8:          3          0    XT-PIC-XT        rtc
  9:        256         75    XT-PIC-XT        acpi
 10:        206         60    XT-PIC-XT        eth0, HDA Intel
 11:        722        336    XT-PIC-XT        ohci_hcd:usb2, sdhci:slot0, nvidia
 12:         85         38    XT-PIC-XT        i8042
 14:        184         30    XT-PIC-XT        ide0
NMI:          0          0 
LOC:    1115697    1115697 
ERR:      10209
MIS:          0

Some problems with wireless (native, not ndiswrapper) but definitely most usable.
Comment 37 Robert Brewer 2007-02-08 22:12:45 UTC
I'm running Ubuntu's kernel 2.6.17-10 on an HP Pavilion dv6000 (dv6125om to be
exact).  It has been running very stable in SMP mode with only "noapic
noirqdebug".  When I boot with just "noapic" it seems stable except for the USB
2.0, which dies within a couple of minutes (the dreaded IRQ 7 nobody cared
message).  I tried booting with "noapic irqpoll" to see what would happen, and
it hung pretty early in the boot sequence.  Since I don't need the wireless
right now, this is pretty good for me.  Note that I also don't have microphone
or headphone support working.  I did get the webcam video capture working with
the separate uvc driver.
Comment 38 Izar Tarandach 2007-02-09 08:50:32 UTC
Whenever I loose the USB, I simply rmmod ehci_hcd then modprobe it again - the
usb comes back until the next boot. That may help you somewhat.
Comment 39 Pavel Shevchuk 2007-02-18 05:44:26 UTC
Updated to 2.6.20. Only nvidia and bcm43xx share interrupts now.

[stalwart@naga ~]$ cat /proc/interrupts 
           CPU0       CPU1       
  0:     869036          0   IO-APIC-edge      timer
  1:       6640          0   IO-APIC-edge      i8042
  8:          0          0   IO-APIC-edge      rtc
  9:         36          0   IO-APIC-fasteoi   acpi
 11:          0          0   IO-APIC-fasteoi   sdhci:slot0
 12:      68043          0   IO-APIC-edge      i8042
 14:        171          0   IO-APIC-edge      libata
 15:          0          0   IO-APIC-edge      libata
 18:     348122          0   IO-APIC-fasteoi   eth1
 19:         24          0   IO-APIC-fasteoi   ehci_hcd:usb2
 20:      31208          0   IO-APIC-fasteoi   libata
 21:     110975          0   IO-APIC-fasteoi   HDA Intel
 22:      27142          0   IO-APIC-fasteoi   ohci_hcd:usb1
 23:     761314          0   IO-APIC-fasteoi   nvidia, bcm43xx
NMI:        736        512 
LOC:     868990     868961 
ERR:          0

Comment 40 Pavel Shevchuk 2007-03-26 08:00:31 UTC
I can't boot 2.6.20.4 on dv6018. It hangs on boot. Last lines (retyped from 
photo of hung laptop):

PCI: Using MMCONFIG at e0000000
PCI: No mmconfig possible on device 00:18
PCI: No mmconfig possible on device 07:05
ACPI: Interpreter enabled
ACPI: Using IOAPIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (0000:00)
ACPI: Assume root bridge [\_SB_.PCI0] bus is 0
0000:00:0d.0: cannot adjust BAR0 (not I/O)

I reverted to 2.6.20.3 which works fine (except it often hangs while setting 
clock)
Comment 41 Bernhard 2007-03-26 08:18:52 UTC
I can confirm the bug-report from Pavel.

same Problem here on Hp pavilion dv9043ea on 2.6.20.4 (Arch). Reverting back to
2.6.20.3 works fine.
Comment 42 Len Brown 2007-03-30 21:09:09 UTC
re: comment #33
Izar: "noacpi" is not a valid option for the upstream kernel,
perhaps you were looking for "acpi=off"?

re: comment #36
noapic acpi_use_timer_override
The options "acpi_use_timer_override" applies only to IOAPIC mode,
which you have disabled by using "noapic".

> ERR:      10209

No, this doesn't qualify as "working beautifully"

Re: comment #41 and comment #41
> I can't boot 2.6.20.4 on dv6018. It hangs on boot
> I reverted to 2.6.20.3 which works fine

This is "bad" -- the stable kernel is not supposed to get _less_ stable...
There are only 33 patches between 2.6.20.3 and 2.6.20.4,
can you get a git tree and bisect which patch caused the regression?

Can you test if the upstream kernel has regressed also --
ie boot 2.6.21-rc5 or later?

Re: the original serious bug -- the run-time hang.
I'll be happy to help you debug the root cause iff you run tests
1. without binary nvidia drivers
2. without ndiswrapper

Please stop posting test results for the "noapic" case, it is
thoroughly uninteresting in the context of debugging the
root cause of this failure and will not help get your system
running in its optimal configuration "out of the box" as it should.

please try booting with "nmi_watchdog=0" and report if it makes
any difference.

Comment 43 Len Brown 2007-03-30 21:29:40 UTC
also, if anybody has an i386 installation,
please try 2.6.21-rc5 with "nolapic_timer"
(this option isn't available on x86_64 or before 2.6.21-rc5)

Comment 44 Pavel Shevchuk 2007-03-31 00:30:01 UTC
I switched from ndiswrapper to bcm43xx since comment #39, but kept nvidia. I'll 
try out newer kernel next week
Comment 45 Izar Tarandach 2007-04-04 14:04:06 UTC
Len:
I get what you're saying about the noapic. Did I mention I am running Ubuntu's
2.6.17-10 kernel? I did not try the upstream kernel.
Comment 46 Bernhard 2007-04-08 04:43:41 UTC
re: Comment 40:  I just tried the 2.6.20.5 and 2.6.20.6 kernels on archlinux and
I want to note that the problem described by Pavel still persists...

re: Comment 42:
Len, thx for your input. Can you give me any link to dokumentation on "getting a
git tree and bisect which patch caused the regression"? Because quite frankly, I
don't know what I should do.

But I'll try to compile the latest 2.6.21rc kernel and report back...
Comment 47 Pavel Shevchuk 2007-04-09 13:10:11 UTC
2.6.21-rc6-git2 hangs with same error, nolapic_timer doesn't help, same 
behaviour
Comment 48 jorma 2007-04-16 11:50:48 UTC
i have dv6103eu and everything above 2.6.20-r3 hangs at 0000:00:0d.0: cannot
adjust BAR0 (not I/O) (same as #40 comment), 2.6.21_rc6-r7 does also
freeze my laptop, although i managed to get it up&running when i had
ndiswrapper, alsa-drivers, fuse built for 2.6.20-r3 kernel, but when i built
them against new kernel it won't boot up. I also noticed that when i did add
noapci to boot line then it freezed near loading alsa drivers where it
said "xxx write TLV". I have 1.0.14_rc3 version of alsa-drive
Comment 50 Len Brown 2007-04-21 18:58:32 UTC
Thanks for isolating this to patch that caused the failure.
Moving to Drivers/PCI
Comment 51 Adrian Bunk 2007-05-18 15:27:00 UTC
Fixed in both 2.6.20.11 and 2.6.21.
Comment 52 Noah P 2007-08-03 21:43:01 UTC
the BAR03 error i got to go away by changing the resolution of the bootup framebuffer. ie. passing vga=791 to the kernel at boot

the random hard locks. i got to go away using the pci=biosirq option. i spentmuch timeon this running a hp dv9k series. everything is fine for me now.hope it helps
Comment 53 Noah P 2007-08-03 21:44:35 UTC
i only got the BAR03 error when i ran ubuntu btw.

i would like to add i was just browsing and stumbled upon this bug report, i have not had lock  ups in a long time. it took me forever to figure it out, and i dontknow why but what i said should work

Note You need to log in before you can comment on or make changes to this bug.