Bug 7556 - Have to reconnect keyboard after s2ram
Have to reconnect keyboard after s2ram
Status: REJECTED DUPLICATE of bug 7216
Product: Drivers
Classification: Unclassified
Component: Input Devices
i386 Linux
: P2 normal
Assigned To: Dmitry Torokhov
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-20 04:59 UTC by Michael Meskes
Modified: 2006-12-03 10:48 UTC (History)
0 users

See Also:
Kernel Version: 2.6.19-rc5
Tree: Mainline
Regression: ---


Attachments
dmesg after setting debug option (30.55 KB, text/plain)
2006-11-27 01:37 UTC, Michael Meskes
Details
New extended dmesg (61.29 KB, text/plain)
2006-12-03 04:59 UTC, Michael Meskes
Details

Description Michael Meskes 2006-11-20 04:59:47 UTC
Distribution: Debian Sid
Hardware Environment: HP NX 7400
Software Environment: 
Problem Description: After resuming from suspend2ram (s2ram -p) my machine is
keyboard less. I have to "echo -n reconnect >
/sys/bus/serio/drivers/atkbd/serio0/drvctl" automaticaly to use it again. This
happens with a stock 2.6.19-rc5 but also with the Debian package of 2.6.18. 

I'm not sure where the problem exactly is, so maybe the category is incorrect.

What additional infos do you need?

Michael
Comment 1 Dmitry Torokhov 2006-11-21 13:01:23 UTC
Please do "echo 1 > /sys/modules/i8042/parameters/debug" before suspending and 
send me dmesg. Thank you!
Comment 2 Michael Meskes 2006-11-27 01:37:12 UTC
Created attachment 9630 [details]
dmesg after setting debug option

Here's the dmesg. I set the debug option, then suspended via "powersave -u" and
reset it again.
Comment 3 Adrian Bunk 2006-11-27 11:38:36 UTC

*** This bug has been marked as a duplicate of 7216 ***
Comment 4 Dmitry Torokhov 2006-11-27 12:09:29 UTC
Hmm, can't quite see what is going on from the log as it is too short. Could 
you please recomplie with CONFIG_PRINTK_TIME=y and also boot 
with "log_buf_len=131072" and repeat the process. Also if you could put a delay 
in your script before forcing atkbd reconnect and bang on the keyboard a few 
times while it is not reconnected that would be great.
Comment 5 Michael Meskes 2006-12-03 04:59:09 UTC
Created attachment 9726 [details]
New extended dmesg

Hopefully this contains the information you need. I did as you asked and hit
the keyboard quite some time before calling reconnect.

BTW. since this bug is marked "rejected duplicate" I wonder if it's correct to
still report here.
Comment 6 Dmitry Torokhov 2006-12-03 10:48:35 UTC
Yes, it is. I will review the dmesg hopefully later tonight.

Note You need to log in before you can comment on or make changes to this bug.