Bug 7555 - Issue with r8169 driver and some applications on a Asus P5B with 8161B PCI-E Controller
Summary: Issue with r8169 driver and some applications on a Asus P5B with 8161B PCI-E ...
Status: CLOSED INVALID
Alias: None
Product: Drivers
Classification: Unclassified
Component: Network (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Francois Romieu
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-11-20 00:08 UTC by Will Trives
Modified: 2007-10-10 14:17 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.19-rc6
Tree: Mainline
Regression: ---


Attachments

Description Will Trives 2006-11-20 00:08:29 UTC
Most recent kernel where this bug did *NOT* occur: happens on all kernels that 
have support for the 8161B
Distribution: Debian Etch
Hardware Environment: Asus P5B motherboard, Core2 DUO processor, Integrated 
Realtek 8161B PCI Express ethernet controller
Software Environment: Debian Etch
Problem Description: Extremely poor speed for some things like Samba, the 
problem does not exist when using the offical Realtek driver.

Steps to reproduce:

Using the r8169 driver 
Dmesg output: http://users.tpg.com.au/renevant/bug.txt
Kernel config: http://users.tpg.com.au/renevant/kernconfig
Screenshot of a download attempt on my Windows box: 
http://users.tpg.com.au/renevant/r8169-driverbad.JPG

Using the Realtek R1000 driver
Dmesg output: http://users.tpg.com.au/renevant/nobug.txt
Screenshot of a download attempt on my Windows box: 
http://users.tpg.com.au/renevant/http://users.tpg.com.au/renevant/r1000-drivergood.JPG

Note the only thing that has changed is the driver, nothing else. I wish I 
could show it better but it doesn't seem to be all that producable doing an FTP 
transfer or in general browsing.

I've tried the 0001-r8169-more-alignment-for-the-0x8168 patch given to me by 
Francois Romieu with no luck.
Comment 1 Will Trives 2006-11-20 00:12:50 UTC
That good URL should be:

http://users.tpg.com.au/renevant/r1000-drivergood.JPG

Sorry.
Comment 2 Francois Romieu 2006-11-21 16:09:34 UTC
Amongst others, I have had a success report from a fedora core user who ran the
patch below against its flavor of 2.6.18:
http://www.fr.zoreil.com/people/francois/misc/20060920-2.6.18-r8169-test.patch 

The motherboard was an Asus P5B-VM with a built-in Intel graphic adapter.

It would provide a nice datapoint if you could give it a try against some 2.6.18
kernel (without binary stuff from nvidia of course).

-- 
Ueimor
Comment 3 Will Trives 2006-11-22 02:10:58 UTC
I have tried with a vanilla compile of 2.6.18.3 the only patch being the one
from the link you provided.

The problem is still there.

Dmesg output:
http://users.tpg.com.au/renevant/bug2.txt

Kernel config:
http://users.tpg.com.au/renevant/kern2config.txt

Screenshot of a filecopy from a Windows XP machine on the network:
http://users.tpg.com.au/renevant/r8169-bad2.JPG

I then went and compiled a the kernel again except I chose not to compile the
r8169 driver as a module or to build it into the kernel.

I then went and compiled the offical realtek driver instead. By the way I
followed the instructions provided in this link in order to get the realtek
driver to compile with recent kernels:

http://gentoo-wiki.com/HARDWARE_RTL8168

Here were my results after booting up with the realtek driver:

http://users.tpg.com.au/renevant/r1000-good2.JPG

Let me know if there is any further testing you would like me to do. I know this
little piece of information may make you sit up in your chair, the system IS
overclocked, I'm happy to set it back to stock speeds if you feel this may have
something to do with the problem but I don't really see that fixing this issue
though. The system is completely stable and there is no corruption whatsoever
when using the realtek driver.

Happy to do any further testing, tcpdump, or any other tests you would like.

Here is an lspci dump as well:

http://users.tpg.com.au/renevant/lspci.txt
Comment 4 Will Trives 2006-12-08 01:45:36 UTC
You better close this one.

With 2.6.19-git7 things seemed fine just lower throughput that the realtek 1.04
driver, however I've been testing with an Intel PCI-E network adapter and I get
roughly the same speed.

Setting read and write raw to "no" seems to restore faster speed. So it seems to
be mostly a samba issue.

Sorry for the trouble. Strange that the Realtek 1.04 driver would be different
like that though.

On a totally unrelated note the new realtek 1.05 driver was buggy for me when
using Xen.
Comment 5 Francois Romieu 2007-10-10 14:17:37 UTC
The problem is probably fixed in 2.6.23 as of:
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=d78ae2dcc2acebb9a1048278f47f762c069db75c

The symptoms really look the same.

-- 
Ueimor

Note You need to log in before you can comment on or make changes to this bug.