Bug 7541 - dhcp + suspend-to-RAM sometimes trashes the NIC
dhcp + suspend-to-RAM sometimes trashes the NIC
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: Networking
Classification: Unclassified
Component: IPV4
i386 Linux
: P2 normal
Assigned To: Stephen Hemminger
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2006-11-16 23:35 UTC by Joshua N Pritikin
Modified: 2007-09-03 21:48 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.17.7
Tree: Mainline
Regression: ---


Attachments

Description Joshua N Pritikin 2006-11-16 23:35:52 UTC
Most recent kernel where this bug did *NOT* occur: Sorry, dunno
Distribution: Debian
Hardware Environment: Fujitsu P-2040 laptop
Software Environment: dhcp-client 2.0pl5-19.4 (debian)
Problem Description:

I have hit this bug ever since I started using DHCP. Prior to DHCP, I never had
a problem with suspend to RAM.

Steps to reproduce:

My laptop travels from home to work and back. Every time I switch on, I run
"ifdown eth0" and "ifup eth0" to switch to the appropriate network configured
using DHCP. Usually, this works fine. Here's my ethernet chipset:

00:12.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)

Anyway, sometimes, maybe once a week, something goes wrong and I get this error:

SIOCSIFFLAGS: No such device

The NIC still exists, see:

emit:/home/joshua# ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:E0:00:8C:8B:8E
          inet addr:192.168.0.4  Bcast:192.168.0.255  Mask:255.255.255.0
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:739959 errors:4 dropped:5 overruns:3 frame:0
          TX packets:441931 errors:0 dropped:0 overruns:2 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1059867013 (1010.7 MiB)  TX bytes:37902281 (36.1 MiB)
          Interrupt:9 Base address:0x4800

However, it's impossible to configure:

emit:/home/joshua# ifconfig eth0 132.147.1.109 up
SIOCSIFFLAGS: No such device
SIOCSIFFLAGS: No such device

Weird, huh?
Comment 1 Andrew Morton 2006-11-17 00:17:20 UTC
On Thu, 16 Nov 2006 23:37:18 -0800
bugme-daemon@bugzilla.kernel.org wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=7541
> 
>            Summary: dhcp + suspend-to-RAM sometimes trashes the NIC
>     Kernel Version: 2.6.17.7
>             Status: NEW
>           Severity: normal
>              Owner: shemminger@osdl.org
>          Submitter: joshua@openheartlogic.org
> 
> 
> Most recent kernel where this bug did *NOT* occur: Sorry, dunno
> Distribution: Debian
> Hardware Environment: Fujitsu P-2040 laptop
> Software Environment: dhcp-client 2.0pl5-19.4 (debian)
> Problem Description:
> 
> I have hit this bug ever since I started using DHCP. Prior to DHCP, I never had
> a problem with suspend to RAM.
> 
> Steps to reproduce:
> 
> My laptop travels from home to work and back. Every time I switch on, I run
> "ifdown eth0" and "ifup eth0" to switch to the appropriate network configured
> using DHCP. Usually, this works fine. Here's my ethernet chipset:
> 
> 00:12.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
> RTL-8139/8139C/8139C+ (rev 10)
> 
> Anyway, sometimes, maybe once a week, something goes wrong and I get this error:
> 
> SIOCSIFFLAGS: No such device
> 
> The NIC still exists, see:
> 
> emit:/home/joshua# ifconfig eth0
> eth0      Link encap:Ethernet  HWaddr 00:E0:00:8C:8B:8E
>           inet addr:192.168.0.4  Bcast:192.168.0.255  Mask:255.255.255.0
>           BROADCAST MULTICAST  MTU:1500  Metric:1
>           RX packets:739959 errors:4 dropped:5 overruns:3 frame:0
>           TX packets:441931 errors:0 dropped:0 overruns:2 carrier:0
>           collisions:0 txqueuelen:1000
>           RX bytes:1059867013 (1010.7 MiB)  TX bytes:37902281 (36.1 MiB)
>           Interrupt:9 Base address:0x4800
> 
> However, it's impossible to configure:
> 
> emit:/home/joshua# ifconfig eth0 132.147.1.109 up
> SIOCSIFFLAGS: No such device
> SIOCSIFFLAGS: No such device
> 
> Weird, huh?

Comment 2 Stephen Hemminger 2006-11-17 14:35:47 UTC
When it happens, please capture kernel console log output (ie. dmesg)

It could be that the device did not successfully resume so it was removed.
Does the device show up with 'ifconfig -a'?

Are you using a tool or script to reassign network devices. It could be that
the device did not get renamed. On debian this is enabled by /etc/iftab

Lastly, how are you doing the suspend? The GUI tools for many distributions
unloads all the network modules, then reloads them. Since the network modules
get reloaded, either the module load can fail or the name might be different.


Comment 3 Joshua N Pritikin 2006-11-17 23:35:16 UTC
> It could be that the device did not successfully resume so it was removed.
> Does the device show up with 'ifconfig -a'?

Yes, the device shows up in ifconfig -a.

> Are you using a tool or script to reassign network devices. It could be that
> the device did not get renamed. On debian this is enabled by /etc/iftab

I am well aware of iftab. I am not using it.

> Lastly, how are you doing the suspend?

ACPI never worked on my laptop. I am using APM to suspend to RAM.

> When it happens, please capture kernel console log output (ie. dmesg)

OK. I'll have to wait until it happens again. I'll let you know.
Comment 4 Joshua N Pritikin 2006-11-18 19:44:23 UTC
Here it the kernel log since the last reboot. The last suspect/resume cycle in
this series trashed the nic.

2006-11-17_06:24:10.86424 kern.notice: Linux version 2.6.17.7-b1
(root@emit.local) (gcc version 4.0.4 20060507 (prerelease) (Debian 4.0.3-3)) #14
Thu Jul 27 13:30:04 IST 2006
2006-11-17_06:24:10.99055 kern.info: BIOS-provided physical RAM map:
2006-11-17_06:24:11.03989 kern.warn:  BIOS-e820: 0000000000000000 -
000000000009c000 (usable)
2006-11-17_06:24:11.04035 kern.warn:  BIOS-e820: 000000000009c000 -
00000000000a0000 (reserved)
2006-11-17_06:24:11.04041 kern.warn:  BIOS-e820: 00000000000e7400 -
0000000000100000 (reserved)
2006-11-17_06:24:11.04047 kern.warn:  BIOS-e820: 0000000000100000 -
000000000efe0000 (usable)
2006-11-17_06:24:11.04052 kern.warn:  BIOS-e820: 000000000efe0000 -
000000000efefc00 (ACPI data)
2006-11-17_06:24:11.04088 kern.warn:  BIOS-e820: 000000000efefc00 -
000000000eff0000 (ACPI NVS)
2006-11-17_06:24:11.04120 kern.warn:  BIOS-e820: 000000000eff0000 -
000000000f100000 (reserved)
2006-11-17_06:24:11.04224 kern.warn:  BIOS-e820: 00000000fff00000 -
0000000100000000 (reserved)
2006-11-17_06:24:11.04274 kern.notice: 239MB LOWMEM available.
2006-11-17_06:24:11.04562 kern.debug: On node 0 totalpages: 61408
2006-11-17_06:24:11.04630 kern.debug:   DMA zone: 4096 pages, LIFO batch:0
2006-11-17_06:24:11.04638 kern.debug:   Normal zone: 57312 pages, LIFO batch:15
2006-11-17_06:24:11.04661 kern.info: DMI 2.3 present.
2006-11-17_06:24:11.04706 kern.warn: Allocating PCI resources starting at
10000000 (gap: 0f100000:f0e00000)
2006-11-17_06:24:11.04758 kern.warn: Built 1 zonelists
2006-11-17_06:24:11.04762 kern.notice: Kernel command line: root=/dev/hda8 ro
vga=3842 
2006-11-17_06:24:11.04764 kern.warn: No local APIC present or hardware disabled
2006-11-17_06:24:11.04787 <7>mapped APIC to ffffd000 (011e1000)
2006-11-17_06:24:11.04795 kern.info: Initializing CPU#0
2006-11-17_06:24:11.04852 kern.warn: PID hash table entries: 1024 (order: 10,
4096 bytes)
2006-11-17_06:24:11.04872 kern.warn: Detected 793.242 MHz processor.
2006-11-17_06:24:11.04896 kern.info: Using tsc for high-res timesource
2006-11-17_06:24:11.04898 kern.warn: Console: colour VGA+ 80x25
2006-11-17_06:24:11.04900 kern.warn: Dentry cache hash table entries: 32768
(order: 5, 131072 bytes)
2006-11-17_06:24:11.04905 kern.warn: Inode-cache hash table entries: 16384
(order: 4, 65536 bytes)
2006-11-17_06:24:11.04908 kern.info: Memory: 240112k/245632k available (1852k
kernel code, 5080k reserved, 751k data, 164k init, 0k highmem)
2006-11-17_06:24:11.04910 kern.warn: Checking if this processor honours the WP
bit even in supervisor mode... Ok.
2006-11-17_06:24:11.04911 kern.warn: Calibrating delay using timer specific
routine.. 1618.95 BogoMIPS (lpj=8094757)
2006-11-17_06:24:11.04913 kern.warn: Mount-cache hash table entries: 512
2006-11-17_06:24:11.04915 kern.debug: CPU: After generic identify, caps:
0080893f 0081813f 00000000 00000000 00000000 00000000 00000000
2006-11-17_06:24:11.04925 kern.debug: CPU: After vendor identify, caps: 0080893f
0081813f 0000000e 00000000 00000000 00000000 00000000
2006-11-17_06:24:11.04927 kern.info: CPU: L1 I Cache: 64K (64 bytes/line), D
cache 64K (32 bytes/line)
2006-11-17_06:24:11.04943 kern.info: CPU: L2 Cache: 512K (128 bytes/line)
2006-11-17_06:24:11.04945 kern.info: CPU: Processor revision 1.4.1.0, 800 MHz
2006-11-17_06:24:11.04946 kern.info: CPU: Code Morphing Software revision
4.2.6-8-168
2006-11-17_06:24:11.04948 kern.info: CPU: 20010703 00:29 official release 4.2.6#2
2006-11-17_06:24:11.04949 kern.debug: CPU: After all inits, caps: 0080893f
0081813f 0000000e 00000000 00000000 00000000 00000000
2006-11-17_06:24:11.04951 kern.warn: CPU: Transmeta(tm) Crusoe(tm) Processor
TM5800 stepping 03
2006-11-17_06:24:11.04953 kern.info: Checking 'hlt' instruction... OK.
2006-11-17_06:24:11.04954 kern.info: SMP alternatives: switching to UP code
2006-11-17_06:24:11.04958 kern.info: Freeing SMP alternatives: 0k freed
2006-11-17_06:24:11.04960 kern.info: NET: Registered protocol family 16
2006-11-17_06:24:11.04961 kern.info: PCI: PCI BIOS revision 2.10 entry at
0xfd88e, last bus=1
2006-11-17_06:24:11.04963 kern.warn: Setting up standard PCI resources
2006-11-17_06:24:11.04964 kern.info: usbcore: registered new driver usbfs
2006-11-17_06:24:11.04966 kern.info: usbcore: registered new driver hub
2006-11-17_06:24:11.04967 kern.warn: PCI: Probing PCI hardware
2006-11-17_06:24:11.04969 kern.debug: PCI: Probing PCI hardware (bus 00)
2006-11-17_06:24:11.04970 kern.warn: PCI quirk: region ff00-ff3f claimed by
ali7101 ACPI
2006-11-17_06:24:11.04972 kern.warn: PCI quirk: region ff80-ff9f claimed by
ali7101 SMB
2006-11-17_06:24:11.04973 kern.debug: Boot video device is 0000:00:14.0
2006-11-17_06:24:11.05014 kern.debug: PCI: Using ALI IRQ Router
2006-11-17_06:24:11.05016 kern.info: PCI: Using IRQ router ALI [10b9/1533] at
0000:00:07.0
2006-11-17_06:24:11.05018 kern.warn: PCI: Bus 1, cardbus bridge: 0000:00:0c.0
2006-11-17_06:24:11.05022 kern.warn:   IO window: 00001c00-00001cff
2006-11-17_06:24:11.05024 kern.warn:   IO window: 00002000-000020ff
2006-11-17_06:24:11.05025 kern.warn:   PREFETCH window: 10000000-11ffffff
2006-11-17_06:24:11.05027 kern.warn:   MEM window: 12000000-13ffffff
2006-11-17_06:24:11.05028 kern.info: PCI: Found IRQ 9 for device 0000:00:0c.0
2006-11-17_06:24:11.05030 kern.info: NET: Registered protocol family 2
2006-11-17_06:24:11.05031 kern.warn: IP route cache hash table entries: 2048
(order: 1, 8192 bytes)
2006-11-17_06:24:11.05033 kern.warn: TCP established hash table entries: 8192
(order: 3, 32768 bytes)
2006-11-17_06:24:11.05034 kern.warn: TCP bind hash table entries: 4096 (order:
2, 16384 bytes)
2006-11-17_06:24:11.05036 kern.info: TCP: Hash tables configured (established
8192 bind 4096)
2006-11-17_06:24:11.05037 kern.info: TCP reno registered
2006-11-17_06:24:11.05039 kern.info: apm: BIOS version 1.2 Flags 0x03 (Driver
version 1.16ac)
2006-11-17_06:24:11.05042 kern.info: Initializing Cryptographic API
2006-11-17_06:24:11.05044 kern.info: io scheduler noop registered
2006-11-17_06:24:11.05045 kern.info: io scheduler anticipatory registered (default)
2006-11-17_06:24:11.05047 kern.info: Activating ISA DMA hang workarounds.
2006-11-17_06:24:11.05183 kern.info: Serial: 8250/16550 driver $Revision: 1.90 $
4 ports, IRQ sharing disabled
2006-11-17_06:24:11.05186 kern.warn: RAMDISK driver initialized: 16 RAM disks of
4096K size 1024 blocksize
2006-11-17_06:24:11.05188 kern.info: loop: loaded (max 8 devices)
2006-11-17_06:24:11.05190 kern.info: Uniform Multi-Platform E-IDE driver
Revision: 7.00alpha2
2006-11-17_06:24:11.05191 kern.info: ide: Assuming 33MHz system bus speed for
PIO modes; override with idebus=xx
2006-11-17_06:24:11.05193 kern.info: ALI15X3: IDE controller at PCI slot
0000:00:0f.0
2006-11-17_06:24:11.05194 kern.warn: PCI: No IRQ known for interrupt pin A of
device 0000:00:0f.0. Please try using pci=biosirq.
2006-11-17_06:24:11.05196 kern.info: ALI15X3: chipset revision 195
2006-11-17_06:24:11.05205 kern.info: ALI15X3: not 100% native mode: will probe
irqs later
2006-11-17_06:24:11.05207 kern.info:     ide0: BM-DMA at 0x1800-0x1807, BIOS
settings: hda:DMA, hdb:pio
2006-11-17_06:24:11.05209 kern.info: ALI15X3: simplex device: DMA forced
2006-11-17_06:24:11.05211 kern.info:     ide1: BM-DMA at 0x1808-0x180f, BIOS
settings: hdc:DMA, hdd:DMA
2006-11-17_06:24:11.05212 kern.debug: Probing IDE interface ide0...
2006-11-17_06:24:11.05214 kern.warn: hda: ST92011A, ATA DISK drive
2006-11-17_06:24:11.05215 kern.warn: ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
2006-11-17_06:24:11.05217 kern.debug: Probing IDE interface ide1...
2006-11-17_06:24:11.05326 kern.debug: Probing IDE interface ide1...
2006-11-17_06:24:11.05328 kern.info: hda: max request size: 128KiB
2006-11-17_06:24:11.05330 kern.info: hda: 39070080 sectors (20003 MB) w/2048KiB
Cache, CHS=16383/255/63, UDMA(66)
2006-11-17_06:24:11.05331 kern.info: hda: cache flushes supported
2006-11-17_06:24:11.05333 kern.info:  hda: hda1 hda3 < hda5 hda6 hda7 hda8 hda9 >
2006-11-17_06:24:11.05339 kern.info: usbcore: registered new driver usbhid
2006-11-17_06:24:11.05341 kern.info: drivers/usb/input/hid-core.c: v2.6:USB HID
core driver
2006-11-17_06:24:11.05342 kern.info: serio: i8042 AUX port at 0x60,0x64 irq 12
2006-11-17_06:24:11.05344 kern.info: serio: i8042 KBD port at 0x60,0x64 irq 1
2006-11-17_06:24:11.05346 kern.info: mice: PS/2 mouse device common for all mice
2006-11-17_06:24:11.05347 kern.info: device-mapper: 4.6.0-ioctl (2006-02-17)
initialised: dm-devel@redhat.com
2006-11-17_06:24:11.05349 kern.info: TCP bic registered
2006-11-17_06:24:11.05350 kern.info: NET: Registered protocol family 1
2006-11-17_06:24:11.05352 kern.info: NET: Registered protocol family 17
2006-11-17_06:24:11.05353 kern.warn: Using IPI Shortcut mode
2006-11-17_06:24:11.05355 kern.info: kjournald starting.  Commit interval 5 seconds
2006-11-17_06:24:11.05356 kern.info: EXT3-fs: mounted filesystem with ordered
data mode.
2006-11-17_06:24:11.05362 kern.warn: VFS: Mounted root (ext3 filesystem) readonly.
2006-11-17_06:24:11.05364 kern.info: Freeing unused kernel memory: 164k freed
2006-11-17_06:24:11.05365 kern.info: input: AT Translated Set 2 keyboard as
/class/input/input0
2006-11-17_06:24:11.05505 kern.info: PCI: Found IRQ 9 for device 0000:00:0c.0
2006-11-17_06:24:11.05507 kern.info: Yenta: CardBus bridge found at 0000:00:0c.0
[10cf:10c6]
2006-11-17_06:24:11.05509 kern.info: Yenta: adjusting diagnostic: 41 -> 61
2006-11-17_06:24:11.05511 kern.info: Yenta: Using CSCINT to route CSC interrupts
to PCI
2006-11-17_06:24:11.05512 kern.info: Yenta: Routing CardBus interrupts to PCI
2006-11-17_06:24:11.05514 kern.info: Yenta TI: socket 0000:00:0c.0, mfunc
0x00c61d22, devctl 0x46
2006-11-17_06:24:11.05515 kern.info: Yenta: ISA IRQ mask 0x0cf8, PCI irq 9
2006-11-17_06:24:11.05517 kern.info: Socket status: 30000006
2006-11-17_06:24:11.05518 kern.debug: ohci_hcd: 2005 April 22 USB 1.1 'Open'
Host Controller (OHCI) Driver (PCI)
2006-11-17_06:24:11.05520 kern.debug: ohci_hcd: block sizes: ed 64 td 64
2006-11-17_06:24:11.05532 kern.info: PCI: Found IRQ 11 for device 0000:00:02.0
2006-11-17_06:24:11.05534 kern.info: ohci_hcd 0000:00:02.0: OHCI Host Controller
2006-11-17_06:24:11.05536 kern.debug: drivers/usb/core/inode.c: creating file
'devices'
2006-11-17_06:24:11.05538 kern.debug: drivers/usb/core/inode.c: creating file '001'
2006-11-17_06:24:11.05539 kern.info: ohci_hcd 0000:00:02.0: new USB bus
registered, assigned bus number 1
2006-11-17_06:24:11.05541 kern.debug: ohci_hcd 0000:00:02.0: created debug files
2006-11-17_06:24:11.05542 kern.info: ohci_hcd 0000:00:02.0: irq 11, io mem
0xfc004000
2006-11-17_06:24:11.05581 kern.debug: ohci_hcd 0000:00:02.0: resetting from
state 'reset', control = 0x97
2006-11-17_06:24:11.05583 kern.debug: ohci_hcd 0000:00:02.0: OHCI controller state
2006-11-17_06:24:11.05585 kern.debug: ohci_hcd 0000:00:02.0: OHCI 1.0, NO legacy
support registers
2006-11-17_06:24:11.05587 kern.debug: ohci_hcd 0000:00:02.0: control 0x083
HCFS=operational CBSR=3
2006-11-17_06:24:11.05655 kern.debug: ohci_hcd 0000:00:02.0: cmdstatus 0x00000 SOC=0
2006-11-17_06:24:11.05659 kern.debug: ohci_hcd 0000:00:02.0: intrstatus
0x00000004 SF
2006-11-17_06:24:11.05661 kern.debug: ohci_hcd 0000:00:02.0: intrenable
0x8000000a MIE RD WDH
2006-11-17_06:24:11.05662 kern.debug: ohci_hcd 0000:00:02.0: hcca frame #0003
2006-11-17_06:24:11.05664 kern.debug: ohci_hcd 0000:00:02.0: roothub.a 01000202
POTPGT=1 NPS NDP=2(2)
2006-11-17_06:24:11.05666 kern.debug: ohci_hcd 0000:00:02.0: roothub.b 00000000
PPCM=0000 DR=0000
2006-11-17_06:24:11.05667 kern.debug: ohci_hcd 0000:00:02.0: roothub.status
00008000 DRWE
2006-11-17_06:24:11.05669 kern.debug: ohci_hcd 0000:00:02.0: roothub.portstatus
[0] 0x00000100 PPS
2006-11-17_06:24:11.05670 kern.debug: ohci_hcd 0000:00:02.0: roothub.portstatus
[1] 0x00000100 PPS
2006-11-17_06:24:11.05672 kern.debug: usb usb1: default language 0x0409
2006-11-17_06:24:11.05674 kern.debug: usb usb1: new device strings: Mfr=3,
Product=2, SerialNumber=1
2006-11-17_06:24:11.05689 kern.info: usb usb1: Product: OHCI Host Controller
2006-11-17_06:24:11.05691 kern.info: usb usb1: Manufacturer: Linux 2.6.17.7-b1
ohci_hcd
2006-11-17_06:24:11.05693 kern.info: usb usb1: SerialNumber: 0000:00:02.0
2006-11-17_06:24:11.05694 kern.debug: usb usb1: uevent
2006-11-17_06:24:11.05696 kern.info: usb usb1: configuration #1 chosen from 1 choice
2006-11-17_06:24:11.05697 kern.debug: usb usb1: adding 1-0:1.0 (config #1,
interface 0)
2006-11-17_06:24:11.05699 kern.debug: usb 1-0:1.0: uevent
2006-11-17_06:24:11.05700 kern.debug: hub 1-0:1.0: usb_probe_interface
2006-11-17_06:24:11.05702 kern.debug: hub 1-0:1.0: usb_probe_interface - got id
2006-11-17_06:24:11.05703 kern.info: hub 1-0:1.0: USB hub found
2006-11-17_06:24:11.05705 kern.info: hub 1-0:1.0: 2 ports detected
2006-11-17_06:24:11.05706 kern.debug: hub 1-0:1.0: standalone hub
2006-11-17_06:24:11.05708 kern.debug: hub 1-0:1.0: no power switching (usb 1.0)
2006-11-17_06:24:11.05709 kern.debug: hub 1-0:1.0: global over-current protection
2006-11-17_06:24:11.05712 kern.debug: hub 1-0:1.0: power on to power good time: 2ms
2006-11-17_06:24:11.05714 kern.debug: hub 1-0:1.0: local power source is good
2006-11-17_06:24:11.05716 kern.debug: hub 1-0:1.0: no over-current condition exists
2006-11-17_06:24:11.05717 kern.info: 8139too Fast Ethernet driver 0.9.27
2006-11-17_06:24:11.05719 kern.debug: drivers/usb/core/inode.c: creating file '001'
2006-11-17_06:24:11.05720 kern.debug: hub 1-0:1.0: state 7 ports 2 chg 0000 evt 0000
2006-11-17_06:24:11.05722 kern.err: ali15x3_smbus 0000:00:06.0: ALI15X3_smb
region uninitialized - upgrade BIOS or use force_addr=0xaddr
2006-11-17_06:24:11.05782 kern.err: ali15x3_smbus 0000:00:06.0: ALI15X3 not
detected, module not inserted.
2006-11-17_06:24:11.05784 kern.info: PCI: Found IRQ 9 for device 0000:00:12.0
2006-11-17_06:24:11.05786 kern.info: eth0: RealTek RTL8139 at 0xcf82a800,
00:e0:00:8c:8b:8e, IRQ 9
2006-11-17_06:24:11.05788 kern.debug: eth0:  Identified 8139 chip type 'RTL-8139C'
2006-11-17_06:24:11.05789 kern.debug: i2c_adapter i2c-0: adapter [SMBus ALI1535
adapter at ff80] registered
2006-11-17_06:24:11.05794 kern.info: PCI: Found IRQ 9 for device 0000:00:04.0
2006-11-17_06:24:11.05796 kern.info: IBM TrackPoint firmware: 0x0e, buttons: 3/3
2006-11-17_06:24:11.05797 kern.info: input: TPPS/2 IBM TrackPoint as
/class/input/input1
2006-11-17_06:24:11.05799 kern.debug: ohci_hcd 0000:00:02.0: suspend root hub
2006-11-17_06:24:11.05801 kern.info: PCI: Found IRQ 9 for device 0000:00:13.0
2006-11-17_06:24:11.05802 kern.info: ohci1394: fw-host0: OHCI-1394 1.1 (PCI):
IRQ=[9]  MMIO=[fc007000-fc0077ff]  Max Packet=[2048]  IR/IT contexts=[4/8]
2006-11-17_06:24:11.05804 kern.debug: ieee1394: Host added: ID:BUS[0-00:1023] 
GUID[00000e1000904036]
2006-11-17_06:24:11.05805 kern.info: EXT3 FS on hda8, internal journal
2006-11-17_06:24:11.05807 kern.info: Real Time Clock Driver v1.12ac
2006-11-17_06:24:11.05808 kern.info: Non-volatile memory driver v1.2
2006-11-17_06:24:11.05814 kern.info: kjournald starting.  Commit interval 5 seconds
2006-11-17_06:24:11.05821 kern.info: EXT3 FS on dm-3, internal journal
2006-11-17_06:24:11.05823 kern.info: EXT3-fs: mounted filesystem with ordered
data mode.
2006-11-17_06:24:11.05824 kern.info: kjournald starting.  Commit interval 5 seconds
2006-11-17_06:24:11.05826 kern.info: EXT3 FS on dm-1, internal journal
2006-11-17_06:24:11.05827 kern.info: EXT3-fs: mounted filesystem with ordered
data mode.
2006-11-17_06:24:11.05829 kern.info: kjournald starting.  Commit interval 5 seconds
2006-11-17_06:24:11.05830 kern.info: EXT3 FS on dm-4, internal journal
2006-11-17_06:24:11.05832 kern.info: EXT3-fs: mounted filesystem with ordered
data mode.
2006-11-17_06:24:11.05833 kern.info: kjournald starting.  Commit interval 5 seconds
2006-11-17_06:24:11.05835 kern.info: EXT3 FS on dm-0, internal journal
2006-11-17_06:24:11.05836 kern.info: EXT3-fs: mounted filesystem with ordered
data mode.
2006-11-17_06:24:11.05838 kern.info: kjournald starting.  Commit interval 5 seconds
2006-11-17_06:24:11.05840 kern.info: EXT3 FS on dm-2, internal journal
2006-11-17_06:24:11.05843 kern.info: EXT3-fs: mounted filesystem with ordered
data mode.
2006-11-17_06:24:11.05845 kern.info: Adding 1048568k swap on /dev/myvg/swap. 
Priority:-1 extents:1 across:1048568k
2006-11-17_06:24:11.05846 kern.info: eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
2006-11-17_06:24:11.05848 kern.info: eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
2006-11-17_06:24:11.05854 kern.info: eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
2006-11-17_06:24:11.05856 kern.info: nbd: registered device at major 43
2006-11-17_11:47:43.24555 kern.debug: ohci_hcd 0000:00:02.0: --> PCI D3
2006-11-17_11:47:45.31414 kern.debug: ohci_hcd 0000:00:02.0: resume from PCI D3
2006-11-17_11:47:45.31582 kern.info: PCI: Found IRQ 11 for device 0000:00:02.0
2006-11-17_11:47:45.31616 kern.debug: PM: Writing back config space on device
0000:00:04.0 at offset 1 (was 2900003, writing c2900003)
2006-11-17_11:47:45.31640 kern.info: PCI: Found IRQ 9 for device 0000:00:04.0
2006-11-17_11:47:45.31736 kern.debug: hub 1-0:1.0: state 7 ports 2 chg 0000 evt
0000, resume root
2006-11-17_11:47:45.31747 kern.err: ali_stimer_read: stimer is not ready.
2006-11-17_11:47:45.31797 kern.debug: PM: Writing back config space on device
0000:00:0c.0 at offset 1 (was 2100003, writing 2100007)
2006-11-17_11:47:45.31835 kern.info: PCI: Found IRQ 9 for device 0000:00:0c.0
2006-11-17_11:47:45.31925 kern.warn: PCI: No IRQ known for interrupt pin A of
device 0000:00:0f.0. Please try using pci=biosirq.
2006-11-17_11:47:45.32064 kern.info: eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
2006-11-17_11:47:45.32484 kern.info: PCI: Found IRQ 9 for device 0000:00:13.0
2006-11-17_11:47:45.32536 kern.debug: usb usb1: finish resume
2006-11-17_11:47:45.32816 kern.debug: ohci_hcd 0000:00:02.0: lost power
2006-11-17_11:47:45.32838 kern.warn: usb usb1: root hub lost power or was reset
2006-11-17_11:47:45.32854 kern.debug: ohci_hcd 0000:00:02.0: resetting from
state 'reset', control = 0x0
2006-11-17_11:47:45.32874 kern.debug: ohci_hcd 0000:00:02.0: OHCI controller state
2006-11-17_11:47:45.32901 kern.debug: ohci_hcd 0000:00:02.0: OHCI 1.0, NO legacy
support registers
2006-11-17_11:47:45.32979 kern.debug: ohci_hcd 0000:00:02.0: control 0x083
HCFS=operational CBSR=3
2006-11-17_11:47:45.32984 kern.debug: ohci_hcd 0000:00:02.0: cmdstatus 0x00000 SOC=0
2006-11-17_11:47:45.32987 kern.debug: ohci_hcd 0000:00:02.0: intrstatus
0x00000004 SF
2006-11-17_11:47:45.32990 kern.debug: ohci_hcd 0000:00:02.0: intrenable
0x8000000a MIE RD WDH
2006-11-17_11:47:45.32993 kern.debug: ohci_hcd 0000:00:02.0: hcca frame #0007
2006-11-17_11:47:45.33028 kern.debug: ohci_hcd 0000:00:02.0: roothub.a 01000202
POTPGT=1 NPS NDP=2(2)
2006-11-17_11:47:45.33083 kern.debug: ohci_hcd 0000:00:02.0: roothub.b 00000000
PPCM=0000 DR=0000
2006-11-17_11:47:45.33088 kern.debug: ohci_hcd 0000:00:02.0: roothub.status
00008000 DRWE
2006-11-17_11:47:45.33092 kern.debug: ohci_hcd 0000:00:02.0: roothub.portstatus
[0] 0x00000100 PPS
2006-11-17_11:47:45.33095 kern.debug: ohci_hcd 0000:00:02.0: roothub.portstatus
[1] 0x00000100 PPS
2006-11-17_11:47:45.33108 kern.debug: ohci_hcd 0000:00:02.0: restart complete
2006-11-17_11:47:45.34060 kern.debug: hub 1-0:1.0: state 7 ports 2 chg 0000 evt 0000
2006-11-17_11:47:45.34072 kern.debug: ohci_hcd 0000:00:02.0: GetStatus
roothub.portstatus [0] = 0x00010100 CSC PPS
2006-11-17_11:47:45.34076 kern.debug: hub 1-0:1.0: port 1, status 0100, change
0001, 12 Mb/s
2006-11-17_11:47:45.49387 kern.debug: hub 1-0:1.0: debounce: port 1: total 100ms
stable 100ms status 0x100
2006-11-17_11:47:45.49400 kern.debug: ohci_hcd 0000:00:02.0: GetStatus
roothub.portstatus [1] = 0x00010100 CSC PPS
2006-11-17_11:47:45.49402 kern.debug: hub 1-0:1.0: port 2, status 0100, change
0001, 12 Mb/s
2006-11-17_11:47:45.65497 kern.debug: hub 1-0:1.0: debounce: port 2: total 100ms
stable 100ms status 0x100
2006-11-17_11:47:45.83065 kern.debug: ohci_hcd 0000:00:02.0: suspend root hub
2006-11-17_12:03:35.43247 kern.info: eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
2006-11-17_13:15:03.83655 kern.info: eth0: link down
2006-11-17_15:10:45.08213 kern.info: eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
2006-11-18_06:03:22.15739 kern.debug: ohci_hcd 0000:00:02.0: --> PCI D3
2006-11-18_06:03:22.15826 kern.debug: ohci_hcd 0000:00:02.0: resume from PCI D3
2006-11-18_06:03:22.22488 kern.info: PCI: Found IRQ 11 for device 0000:00:02.0
2006-11-18_06:03:22.22578 kern.debug: PM: Writing back config space on device
0000:00:04.0 at offset 1 (was 2900003, writing c2900003)
2006-11-18_06:03:22.22586 kern.info: PCI: Found IRQ 9 for device 0000:00:04.0
2006-11-18_06:03:22.22609 kern.debug: hub 1-0:1.0: state 7 ports 2 chg 0000 evt
0000, resume root
2006-11-18_06:03:23.35374 kern.debug: PM: Writing back config space on device
0000:00:0c.0 at offset 1 (was 2100003, writing 2100007)
2006-11-18_06:03:23.35464 kern.info: PCI: Found IRQ 9 for device 0000:00:0c.0
2006-11-18_06:03:23.39377 kern.warn: PCI: No IRQ known for interrupt pin A of
device 0000:00:0f.0. Please try using pci=biosirq.
2006-11-18_06:03:23.41520 kern.info: eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
2006-11-18_06:03:23.73341 kern.info: PCI: Found IRQ 9 for device 0000:00:13.0
2006-11-18_06:03:23.87924 kern.debug: usb usb1: finish resume
2006-11-18_06:03:23.87938 kern.debug: ohci_hcd 0000:00:02.0: lost power
2006-11-18_06:03:23.87941 kern.warn: usb usb1: root hub lost power or was reset
2006-11-18_06:03:23.87944 kern.debug: ohci_hcd 0000:00:02.0: resetting from
state 'reset', control = 0x0
2006-11-18_06:03:23.93859 kern.debug: ohci_hcd 0000:00:02.0: OHCI controller state
2006-11-18_06:03:23.93874 kern.debug: ohci_hcd 0000:00:02.0: OHCI 1.0, NO legacy
support registers
2006-11-18_06:03:23.93879 kern.debug: ohci_hcd 0000:00:02.0: control 0x083
HCFS=operational CBSR=3
2006-11-18_06:03:23.93882 kern.debug: ohci_hcd 0000:00:02.0: cmdstatus 0x00000 SOC=0
2006-11-18_06:03:23.93884 kern.debug: ohci_hcd 0000:00:02.0: intrstatus
0x00000004 SF
2006-11-18_06:03:23.93908 kern.debug: ohci_hcd 0000:00:02.0: intrenable
0x8000000a MIE RD WDH
2006-11-18_06:03:23.93913 kern.debug: ohci_hcd 0000:00:02.0: hcca frame #0005
2006-11-18_06:03:23.93925 kern.debug: ohci_hcd 0000:00:02.0: roothub.a 01000202
POTPGT=1 NPS NDP=2(2)
2006-11-18_06:03:23.93928 kern.debug: ohci_hcd 0000:00:02.0: roothub.b 00000000
PPCM=0000 DR=0000
2006-11-18_06:03:23.93951 kern.debug: ohci_hcd 0000:00:02.0: roothub.status
00008000 DRWE
2006-11-18_06:03:23.93962 kern.debug: ohci_hcd 0000:00:02.0: roothub.portstatus
[0] 0x00000100 PPS
2006-11-18_06:03:23.94044 kern.debug: ohci_hcd 0000:00:02.0: roothub.portstatus
[1] 0x00000100 PPS
2006-11-18_06:03:23.94048 kern.debug: ohci_hcd 0000:00:02.0: restart complete
2006-11-18_06:03:23.95179 kern.debug: hub 1-0:1.0: state 7 ports 2 chg 0000 evt 0000
2006-11-18_06:03:23.95191 kern.debug: ohci_hcd 0000:00:02.0: GetStatus
roothub.portstatus [0] = 0x00010100 CSC PPS
2006-11-18_06:03:23.95231 kern.debug: hub 1-0:1.0: port 1, status 0100, change
0001, 12 Mb/s
2006-11-18_06:03:24.11115 kern.debug: hub 1-0:1.0: debounce: port 1: total 100ms
stable 100ms status 0x100
2006-11-18_06:03:24.11142 kern.debug: ohci_hcd 0000:00:02.0: GetStatus
roothub.portstatus [1] = 0x00010100 CSC PPS
2006-11-18_06:03:24.11145 kern.debug: hub 1-0:1.0: port 2, status 0100, change
0001, 12 Mb/s
2006-11-18_06:03:24.27256 kern.debug: hub 1-0:1.0: debounce: port 2: total 100ms
stable 100ms status 0x100
2006-11-18_06:03:24.44404 kern.info: eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
2006-11-18_06:03:24.45068 kern.debug: ohci_hcd 0000:00:02.0: suspend root hub
2006-11-18_06:20:59.09948 kern.info: eth0: link down
2006-11-18_07:13:28.00927 kern.debug: ohci_hcd 0000:00:02.0: --> PCI D3
2006-11-18_07:13:28.00953 kern.debug: ohci_hcd 0000:00:02.0: resume from PCI D3
2006-11-18_07:13:28.06872 kern.info: PCI: Found IRQ 11 for device 0000:00:02.0
2006-11-18_07:13:28.06974 kern.debug: PM: Writing back config space on device
0000:00:04.0 at offset 1 (was 2900003, writing c2900003)
2006-11-18_07:13:28.06981 kern.info: PCI: Found IRQ 9 for device 0000:00:04.0
2006-11-18_07:13:28.06985 kern.debug: hub 1-0:1.0: state 7 ports 2 chg 0000 evt
0000, resume root
2006-11-18_07:13:29.16458 kern.debug: PM: Writing back config space on device
0000:00:0c.0 at offset 1 (was 2100003, writing 2100007)
2006-11-18_07:13:29.16519 kern.info: PCI: Found IRQ 9 for device 0000:00:0c.0
2006-11-18_07:13:29.20415 kern.warn: PCI: No IRQ known for interrupt pin A of
device 0000:00:0f.0. Please try using pci=biosirq.
2006-11-18_07:13:29.22932 kern.info: eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
2006-11-18_07:13:29.22996 kern.info: PCI: Found IRQ 9 for device 0000:00:13.0
2006-11-18_07:13:29.66716 kern.debug: usb usb1: finish resume
2006-11-18_07:13:29.66738 kern.debug: ohci_hcd 0000:00:02.0: lost power
2006-11-18_07:13:29.66744 kern.warn: usb usb1: root hub lost power or was reset
2006-11-18_07:13:29.66749 kern.debug: ohci_hcd 0000:00:02.0: resetting from
state 'reset', control = 0x0
2006-11-18_07:13:29.73273 kern.debug: ohci_hcd 0000:00:02.0: OHCI controller state
2006-11-18_07:13:29.73291 kern.debug: ohci_hcd 0000:00:02.0: OHCI 1.0, NO legacy
support registers
2006-11-18_07:13:29.73310 kern.debug: ohci_hcd 0000:00:02.0: control 0x083
HCFS=operational CBSR=3
2006-11-18_07:13:29.73335 kern.debug: ohci_hcd 0000:00:02.0: cmdstatus 0x00000 SOC=0
2006-11-18_07:13:29.73340 kern.debug: ohci_hcd 0000:00:02.0: intrstatus
0x00000004 SF
2006-11-18_07:13:29.73345 kern.debug: ohci_hcd 0000:00:02.0: intrenable
0x8000000a MIE RD WDH
2006-11-18_07:13:29.73349 kern.debug: ohci_hcd 0000:00:02.0: hcca frame #0007
2006-11-18_07:13:29.73354 kern.debug: ohci_hcd 0000:00:02.0: roothub.a 01000202
POTPGT=1 NPS NDP=2(2)
2006-11-18_07:13:29.73358 kern.debug: ohci_hcd 0000:00:02.0: roothub.b 00000000
PPCM=0000 DR=0000
2006-11-18_07:13:29.73363 kern.debug: ohci_hcd 0000:00:02.0: roothub.status
00008000 DRWE
2006-11-18_07:13:29.73367 kern.debug: ohci_hcd 0000:00:02.0: roothub.portstatus
[0] 0x00000100 PPS
2006-11-18_07:13:29.73371 kern.debug: ohci_hcd 0000:00:02.0: roothub.portstatus
[1] 0x00000100 PPS
2006-11-18_07:13:29.73376 kern.debug: ohci_hcd 0000:00:02.0: restart complete
2006-11-18_07:13:29.75281 kern.debug: hub 1-0:1.0: state 7 ports 2 chg 0000 evt 0000
2006-11-18_07:13:29.75296 kern.debug: ohci_hcd 0000:00:02.0: GetStatus
roothub.portstatus [0] = 0x00010100 CSC PPS
2006-11-18_07:13:29.75302 kern.debug: hub 1-0:1.0: port 1, status 0100, change
0001, 12 Mb/s
2006-11-18_07:13:29.92037 kern.debug: hub 1-0:1.0: debounce: port 1: total 100ms
stable 100ms status 0x100
2006-11-18_07:13:29.92049 kern.debug: ohci_hcd 0000:00:02.0: GetStatus
roothub.portstatus [1] = 0x00010100 CSC PPS
2006-11-18_07:13:29.92052 kern.debug: hub 1-0:1.0: port 2, status 0100, change
0001, 12 Mb/s
2006-11-18_07:13:30.07362 kern.debug: hub 1-0:1.0: debounce: port 2: total 100ms
stable 100ms status 0x100
2006-11-18_07:13:31.07202 kern.debug: ohci_hcd 0000:00:02.0: suspend root hub
2006-11-18_07:27:27.20433 kern.info: eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
2006-11-18_11:34:37.59538 kern.info: eth0: link down
2006-11-18_17:20:13.17687 kern.debug: ohci_hcd 0000:00:02.0: --> PCI D3
2006-11-18_17:20:14.86516 kern.debug: ohci_hcd 0000:00:02.0: resume from PCI D3
2006-11-18_17:20:14.86572 kern.info: PCI: Found IRQ 11 for device 0000:00:02.0
2006-11-18_17:20:14.86587 kern.debug: PM: Writing back config space on device
0000:00:04.0 at offset 1 (was 2900003, writing c2900003)
2006-11-18_17:20:14.86599 kern.info: PCI: Found IRQ 9 for device 0000:00:04.0
2006-11-18_17:20:14.86611 kern.debug: hub 1-0:1.0: state 7 ports 2 chg 0000 evt
0000, resume root
2006-11-18_17:20:14.86675 kern.debug: PM: Writing back config space on device
0000:00:0c.0 at offset 1 (was 2100003, writing 2100007)
2006-11-18_17:20:14.86773 kern.info: PCI: Found IRQ 9 for device 0000:00:0c.0
2006-11-18_17:20:14.86785 kern.warn: PCI: No IRQ known for interrupt pin A of
device 0000:00:0f.0. Please try using pci=biosirq.
2006-11-18_17:20:14.86797 kern.info: eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
2006-11-18_17:20:14.86807 kern.info: PCI: Found IRQ 9 for device 0000:00:13.0
2006-11-18_17:20:15.05235 kern.debug: usb usb1: finish resume
2006-11-18_17:20:15.06562 kern.debug: ohci_hcd 0000:00:02.0: lost power
2006-11-18_17:20:15.06635 kern.warn: usb usb1: root hub lost power or was reset
2006-11-18_17:20:15.06649 kern.debug: ohci_hcd 0000:00:02.0: resetting from
state 'reset', control = 0x0
2006-11-18_17:20:15.11655 kern.debug: ohci_hcd 0000:00:02.0: OHCI controller state
2006-11-18_17:20:15.11669 kern.debug: ohci_hcd 0000:00:02.0: OHCI 1.0, NO legacy
support registers
2006-11-18_17:20:15.11673 kern.debug: ohci_hcd 0000:00:02.0: control 0x083
HCFS=operational CBSR=3
2006-11-18_17:20:15.11709 kern.debug: ohci_hcd 0000:00:02.0: cmdstatus 0x00000 SOC=0
2006-11-18_17:20:15.11715 kern.debug: ohci_hcd 0000:00:02.0: intrstatus
0x00000004 SF
2006-11-18_17:20:15.11718 kern.debug: ohci_hcd 0000:00:02.0: intrenable
0x8000000a MIE RD WDH
2006-11-18_17:20:15.11721 kern.debug: ohci_hcd 0000:00:02.0: hcca frame #0007
2006-11-18_17:20:15.11724 kern.debug: ohci_hcd 0000:00:02.0: roothub.a 01000202
POTPGT=1 NPS NDP=2(2)
2006-11-18_17:20:15.11726 kern.debug: ohci_hcd 0000:00:02.0: roothub.b 00000000
PPCM=0000 DR=0000
2006-11-18_17:20:15.11737 kern.debug: ohci_hcd 0000:00:02.0: roothub.status
00008000 DRWE
2006-11-18_17:20:15.11740 kern.debug: ohci_hcd 0000:00:02.0: roothub.portstatus
[0] 0x00000100 PPS
2006-11-18_17:20:15.11765 kern.debug: ohci_hcd 0000:00:02.0: roothub.portstatus
[1] 0x00000100 PPS
2006-11-18_17:20:15.11768 kern.debug: ohci_hcd 0000:00:02.0: restart complete
2006-11-18_17:20:15.13324 kern.debug: hub 1-0:1.0: state 7 ports 2 chg 0000 evt 0000
2006-11-18_17:20:15.13342 kern.debug: ohci_hcd 0000:00:02.0: GetStatus
roothub.portstatus [0] = 0x00010100 CSC PPS
2006-11-18_17:20:15.13348 kern.debug: hub 1-0:1.0: port 1, status 0100, change
0001, 12 Mb/s
2006-11-18_17:20:15.29276 kern.debug: hub 1-0:1.0: debounce: port 1: total 100ms
stable 100ms status 0x100
2006-11-18_17:20:15.29288 kern.debug: ohci_hcd 0000:00:02.0: GetStatus
roothub.portstatus [1] = 0x00010100 CSC PPS
2006-11-18_17:20:15.29291 kern.debug: hub 1-0:1.0: port 2, status 0100, change
0001, 12 Mb/s
2006-11-18_17:20:15.45551 kern.debug: hub 1-0:1.0: debounce: port 2: total 100ms
stable 100ms status 0x100
2006-11-18_17:20:15.63053 kern.debug: ohci_hcd 0000:00:02.0: suspend root hub
2006-11-18_17:20:15.78937 kern.info: eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
2006-11-18_17:20:18.91421 kern.info: eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
2006-11-18_17:20:24.49970 kern.info: eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
2006-11-19_03:20:41.17698 kern.debug: ohci_hcd 0000:00:02.0: --> PCI D3
2006-11-19_03:20:41.17801 kern.info: psmouse.c: TrackPoint at
isa0060/serio1/input0 lost synchronization, throwing 1 bytes away.
2006-11-19_03:20:41.17867 kern.debug: ohci_hcd 0000:00:02.0: resume from PCI D3
2006-11-19_03:20:41.20669 kern.info: PCI: Found IRQ 11 for device 0000:00:02.0
2006-11-19_03:20:41.20693 kern.debug: PM: Writing back config space on device
0000:00:04.0 at offset 1 (was 2900003, writing c2900003)
2006-11-19_03:20:41.20779 kern.info: PCI: Found IRQ 9 for device 0000:00:04.0
2006-11-19_03:20:41.20827 kern.debug: hub 1-0:1.0: state 7 ports 2 chg 0000 evt
0000, resume root
2006-11-19_03:20:42.53223 kern.debug: PM: Writing back config space on device
0000:00:0c.0 at offset 1 (was 2100003, writing 2100007)
2006-11-19_03:20:42.53263 kern.info: PCI: Found IRQ 9 for device 0000:00:0c.0
2006-11-19_03:20:42.57467 kern.warn: PCI: No IRQ known for interrupt pin A of
device 0000:00:0f.0. Please try using pci=biosirq.
2006-11-19_03:20:42.57485 kern.info: PCI: Found IRQ 9 for device 0000:00:13.0
2006-11-19_03:20:43.01656 kern.debug: usb usb1: finish resume
2006-11-19_03:20:43.01698 kern.debug: ohci_hcd 0000:00:02.0: lost power
2006-11-19_03:20:43.01704 kern.warn: usb usb1: root hub lost power or was reset
2006-11-19_03:20:43.01734 kern.debug: ohci_hcd 0000:00:02.0: resetting from
state 'reset', control = 0x0
2006-11-19_03:20:43.07958 kern.debug: ohci_hcd 0000:00:02.0: OHCI controller state
2006-11-19_03:20:43.07997 kern.debug: ohci_hcd 0000:00:02.0: OHCI 1.0, NO legacy
support registers
2006-11-19_03:20:43.08016 kern.debug: ohci_hcd 0000:00:02.0: control 0x083
HCFS=operational CBSR=3
2006-11-19_03:20:43.08045 kern.debug: ohci_hcd 0000:00:02.0: cmdstatus 0x00000 SOC=0
2006-11-19_03:20:43.08075 kern.debug: ohci_hcd 0000:00:02.0: intrstatus
0x00000004 SF
2006-11-19_03:20:43.08079 kern.debug: ohci_hcd 0000:00:02.0: intrenable
0x8000000a MIE RD WDH
2006-11-19_03:20:43.08082 kern.debug: ohci_hcd 0000:00:02.0: hcca frame #0005
2006-11-19_03:20:43.08154 kern.debug: ohci_hcd 0000:00:02.0: roothub.a 01000202
POTPGT=1 NPS NDP=2(2)
2006-11-19_03:20:43.08159 kern.debug: ohci_hcd 0000:00:02.0: roothub.b 00000000
PPCM=0000 DR=0000
2006-11-19_03:20:43.08162 kern.debug: ohci_hcd 0000:00:02.0: roothub.status
00008000 DRWE
2006-11-19_03:20:43.08183 kern.debug: ohci_hcd 0000:00:02.0: roothub.portstatus
[0] 0x00000100 PPS
2006-11-19_03:20:43.08231 kern.debug: ohci_hcd 0000:00:02.0: roothub.portstatus
[1] 0x00000100 PPS
2006-11-19_03:20:43.08234 kern.debug: ohci_hcd 0000:00:02.0: restart complete
2006-11-19_03:20:43.09661 kern.debug: hub 1-0:1.0: state 7 ports 2 chg 0000 evt 0000
2006-11-19_03:20:43.09683 kern.debug: ohci_hcd 0000:00:02.0: GetStatus
roothub.portstatus [0] = 0x00010100 CSC PPS
2006-11-19_03:20:43.09686 kern.debug: hub 1-0:1.0: port 1, status 0100, change
0001, 12 Mb/s
2006-11-19_03:20:43.27033 kern.debug: hub 1-0:1.0: debounce: port 1: total 100ms
stable 100ms status 0x100
2006-11-19_03:20:43.27097 kern.debug: ohci_hcd 0000:00:02.0: GetStatus
roothub.portstatus [1] = 0x00010100 CSC PPS
2006-11-19_03:20:43.27102 kern.debug: hub 1-0:1.0: port 2, status 0100, change
0001, 12 Mb/s
2006-11-19_03:20:43.43091 kern.debug: hub 1-0:1.0: debounce: port 2: total 100ms
stable 100ms status 0x100
2006-11-19_03:20:43.59150 kern.debug: ohci_hcd 0000:00:02.0: suspend root hub
Comment 5 Joshua N Pritikin 2006-11-22 00:46:31 UTC
Any other info I can provide?
Comment 6 Joshua N Pritikin 2006-12-30 20:00:34 UTC
Today I saw the same problem with kernel 2.6.19.1.
Comment 7 Stephen Hemminger 2007-02-23 15:28:50 UTC
Can you get the following before and after the failure:

cat /proc/net/dev
cat /proc/interrupts
ls /sys/class/net

Also check the dmesg log, it may be that on resume the device loses it's
interrupt.

2006-11-18_07:13:29.20415 kern.warn: PCI: No IRQ known for interrupt pin A of
device 0000:00:0f.0. Please try using pci=biosirq.
2006-11-18_07:13:29.22932 kern.info: eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
Comment 8 Joshua N Pritikin 2007-02-24 00:42:04 UTC
Here is the before picture:

emit:~# cat /proc/net/dev
Inter-|   Receive                                                |  Transmit
 face |bytes    packets errs drop fifo frame compressed multicast|bytes   
packets errs drop fifo colls carrier compressed
    lo:26515036  104636    0    0    0     0          0         0 26515036 
104636    0    0    0     0       0          0
  eth0:1087356091 4837807   10 4294967214    5     0          0         0
2936634825 3382968    0    0   32     0       0          0
emit:~# cat /proc/interrupts
           CPU0
  0:   42823919    XT-PIC-XT        timer
  1:     334827    XT-PIC-XT        i8042
  2:          0    XT-PIC-XT        cascade
  8:         86    XT-PIC-XT        rtc
  9:    9723736    XT-PIC-XT        ohci1394, yenta, ALI 5451, eth0
 11:      10205    XT-PIC-XT        ohci_hcd:usb1
 12:    4194946    XT-PIC-XT        i8042
 14:    3174192    XT-PIC-XT        ide0
NMI:          0
LOC:          0
ERR:          0
MIS:          0
emit:~# ls /sys/class/net
eth0  lo
emit:~# lspci
00:00.0 Host bridge: Transmeta Corporation LongRun Northbridge (rev 01)
00:00.1 RAM memory: Transmeta Corporation SDRAM controller
00:00.2 RAM memory: Transmeta Corporation BIOS scratchpad
00:02.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:04.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link
Controller Audio Device (rev 01)
00:06.0 Bridge: ALi Corporation M7101 Power Management Controller [PMU]
00:07.0 ISA bridge: ALi Corporation M1533/M1535 PCI to ISA Bridge [Aladdin IV/V/V+]
00:0c.0 CardBus bridge: Texas Instruments PCI1410 PC card Cardbus Controller
(rev 01)
00:0f.0 IDE interface: ALi Corporation M5229 IDE (rev c3)
00:12.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
00:13.0 FireWire (IEEE 1394): Texas Instruments TSB43AB21 IEEE-1394a-2000
Controller (PHY/Link)
00:14.0 VGA compatible controller: ATI Technologies Inc Rage Mobility P/M (rev 64)

As you can see, 00:0f.0 is the IDE controller.

I'll provide the same info after I loose the device. The failure is very
infrequent so it might take a while. It seems like the failure was more frequent
when my DHCP server was slow.
Comment 9 Joshua N Pritikin 2007-03-20 22:45:49 UTC
Here is the after picture:

emit:~# cat /proc/net/dev
Inter-|   Receive                                                |  Transmit
 face |bytes    packets errs drop fifo frame compressed multicast|bytes   
packets errs drop fifo colls carrier compressed
    lo:26786206   88166    0    0    0     0          0         0 26786206  
88166    0    0    0     0       0          0
  eth0:2079921116 7782180   28   21   22     0          0         0 1624281476
3391719    0    0   20     0       0          0
emit:~# cat /proc/interrupts
           CPU0       
  0:   35721001    XT-PIC-XT        timer
  1:     249691    XT-PIC-XT        i8042
  2:          0    XT-PIC-XT        cascade
  8:         87    XT-PIC-XT        rtc
  9:   12070994    XT-PIC-XT        ohci1394, yenta, ALI 5451
 11:       7808    XT-PIC-XT        ohci_hcd:usb1
 12:    3017063    XT-PIC-XT        i8042
 14:    2427117    XT-PIC-XT        ide0
NMI:          0 
LOC:          0 
ERR:          0
MIS:          0
emit:~# ls /sys/class/net
eth0  lo

This failure happened when I resumed without any network connection on eth0. It
seems like there is some problem with DHCP teardown.
Comment 10 Joshua N Pritikin 2007-04-09 11:09:40 UTC
I upgraded to Linux 2.6.20.4. I hit the same problem again today. Gosh, I hope
this problem is specific to my quirky hardware.
Comment 11 Rafael J. Wysocki 2007-06-18 10:17:46 UTC
Can you please test 2.6.22-rc5?
Comment 12 Stephen Hemminger 2007-07-13 10:28:49 UTC
2.6.22 changed the order of ACPI/BIOS during resume and may have solved the problem.
Comment 13 Joshua N Pritikin 2007-07-14 04:37:51 UTC
I've never gotten ACPI working on this laptop so I am using APM, not ACPI. I upgraded to 2.6.22.1. I'll let you know what happens.
Comment 14 Rafael J. Wysocki 2007-08-08 10:40:56 UTC
So, how does 2.6.22.1 behave on your machine?
Comment 15 Joshua N Pritikin 2007-08-08 22:03:00 UTC
I have not seen the problem since I upgraded to 2.6.22.1. It is not easy to reproduce so we better wait at least one more month before closing this bug.
Comment 16 Joshua N Pritikin 2007-09-03 21:48:27 UTC
I just cannot reproduce the old bad behavior. I have tested many times since August. It just doesn't happen. Great job guys!

Note You need to log in before you can comment on or make changes to this bug.