Bug 75141 - Intel Corporation WiFi Link 5100 AGN adapter - connection drops
Summary: Intel Corporation WiFi Link 5100 AGN adapter - connection drops
Status: CLOSED WILL_NOT_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: network-wireless (show other bugs)
Hardware: x86-64 Linux
: P1 normal
Assignee: drivers_network-wireless@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-30 09:18 UTC by Eugene A. Shatokhin
Modified: 2014-07-10 18:05 UTC (History)
2 users (show)

See Also:
Kernel Version: 3.13.11
Tree: Mainline
Regression: No


Attachments
System log (230.35 KB, text/plain)
2014-04-30 09:18 UTC, Eugene A. Shatokhin
Details
Output of lspci -vvxxx (43.22 KB, text/plain)
2014-04-30 09:19 UTC, Eugene A. Shatokhin
Details

Description Eugene A. Shatokhin 2014-04-30 09:18:38 UTC
Created attachment 134411 [details]
System log

One of our users experiences frequent WiFi connection drops, only disabling and reenabling wireless in hardware (or a reboot) helps.

Hardware: 
03:00.0 Network controller: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection
	Subsystem: Intel Corporation WiFi Link 5100 AGN

OS: ROSA Desktop Fresh R2, x64
Kernel: 3.13.11; the problem happens with the kernels 3.10.x too.

iwlwifi reports the following in the system log: 
"iwlwifi 0000:03:00.0: Microcode SW error detected.  Restarting 0x82000000"
(the full log and the output of lspci -vvxxx are attached below).

We tried both the firmware (iwlwifi-5000-5.ucode) recommended at http://www.intel.com/support/wireless/wlan/sb/CS-034398.htm and the one provided in linux-firmware git repo (surprisingly, they were different). The results were the same in both cases, same errors.

Looks like the device should have been automatically restarted after the error, right? But it seems, it did not restart, only reboot or manual disable/enable helped.

If it is a problem in the firmware, are there any known workarounds for that?

If you need other information, please let me know.
Comment 1 Eugene A. Shatokhin 2014-04-30 09:19:20 UTC
Created attachment 134421 [details]
Output of lspci -vvxxx
Comment 2 Emmanuel Grumbach 2014-07-10 18:05:00 UTC
This is most likely a firmware bug and unfortunately, we don't provide support for firmware for these old devices.

Note You need to log in before you can comment on or make changes to this bug.