Bug 7471 - DVB-T Pluto2: Unable to change MUX
DVB-T Pluto2: Unable to change MUX
Status: CLOSED OBSOLETE
Product: v4l-dvb
Classification: Unclassified
Component: dvb-other
i386 Linux
: P2 high
Assigned To: Andreas Oberritter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-08 12:46 UTC by Cijoml Cijomlovic Cijomlov
Modified: 2012-05-12 01:45 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.23.11
Tree: Mainline
Regression: No


Attachments

Description Cijoml Cijomlovic Cijomlov 2006-11-08 12:46:14 UTC
Most recent kernel where this bug did not occur:
Distribution: Debian Testing
Hardware Environment: Acer TravelMate 242
Software Environment: Kaffeine, Mplayer
Problem Description:

Unable to change to channel located in MUX2 when playing channel from MUX1

Steps to reproduce:

plug in card, let it play with kaffeine etc...
Comment 1 Cijoml Cijomlovic Cijomlov 2007-04-03 06:17:25 UTC
Hi Obi,

just tested with 2.6.20-mh1 and today's SVN version v4l-dvb-f21b24ec4e8f
and I have to reopen this bug.

pccard: CardBus card inserted into slot 0
PCI: Enabling device 0000:02:00.0 (0000 -> 0002)
ACPI: PCI Interrupt 0000:02:00.0[A] -> Link [LNKF] -> GSI 10 (level, low) -> IRQ 10
PCI: Setting latency timer of device 0000:02:00.0 to 64
DVB: registering new adapter (pluto2).
pluto2 0000:02:00.0: board revision 2.15
pluto2 0000:02:00.0: S/N 13320420103842
pluto2 0000:02:00.0: MAC 00:d0:16:01:5c:0c
DVB: registering frontend 0 (Philips TDA10046H DVB-T)...
tda1004x: setting up plls for 53MHz sampling clock
tda1004x: timeout waiting for DSP ready
tda1004x: found firmware revision 0 -- invalid
tda1004x: trying to boot from eeprom
tda1004x: timeout waiting for DSP ready
tda1004x: found firmware revision 0 -- invalid
tda1004x: waiting for firmware upload...
tda1004x: found firmware revision 29 -- ok
tda1004x: setting up plls for 53MHz sampling clock
tda1004x: found firmware revision 29 -- ok
spurious 8259A interrupt: IRQ7.
pluto2 0000:02:00.0: overflow irq (1)
pluto2 0000:02:00.0: overflow irq (1)
pluto2 0000:02:00.0: overflow irq (1)
pluto2 0000:02:00.0: overflow irq (1)
pluto2 0000:02:00.0: overflow irq (1)
pluto2 0000:02:00.0: overflow irq (1)
pluto2 0000:02:00.0: overflow irq (1)
pluto2 0000:02:00.0: overflow irq (1)
pluto2 0000:02:00.0: overflow irq (1)
pluto2 0000:02:00.0: overflow irq (1)
tda1004x: setting up plls for 53MHz sampling clock
tda1004x: found firmware revision 29 -- ok
pluto2 0000:02:00.0: overflow irq (1)
pluto2 0000:02:00.0: overflow irq (1)
pluto2 0000:02:00.0: overflow irq (1)

Now behavior is little bit different. I still see unable tune dvb, but when I
press channel button again, firmware loads again and MUX is tuned. This is now
everytime, but 3x from 10 tries. Can you verify?

Please ignore overflow irq, there exist different bug opened for this issue.

Michal
Comment 2 Natalie Protasevich 2007-06-21 21:15:23 UTC
There were multiple DVB fixes picked upt from Mauro's tree around 2.6.22-rc5.
Can you please try it and see if problem was addressed?
Thanks.
Comment 3 Cijoml Cijomlovic Cijomlov 2007-06-23 23:26:14 UTC
Tested with dvb-Mercurial-b03a5545f8e1 and problem is still present :(
Comment 4 Cijoml Cijomlovic Cijomlov 2007-12-28 02:38:00 UTC
Still present in latest vanilla 2.6.23.11

Note You need to log in before you can comment on or make changes to this bug.