Bug 7455 - ipath driver MCEs system on load when HT chip present
ipath driver MCEs system on load when HT chip present
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Network
i386 Linux
: P2 normal
Assigned To: Bryan O'Sullivan
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-03 08:51 UTC by Bryan O'Sullivan
Modified: 2006-11-09 07:53 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.19-rc4
Tree: Mainline
Regression: ---


Attachments

Description Bryan O'Sullivan 2006-11-03 08:51:04 UTC
Most recent kernel where this bug did not occur: 2.6.18
Hardware Environment: x86_64, QLogic IBA6110 chips
Problem Description:

The ipath driver causes an MCE after Eric's genirq and HT irq changes in early
October.  I'm filing this bug to track the issue.  We don't seem to have an
Infiniband category, so this will have to do.
Comment 1 Eric W. Biederman 2006-11-03 09:28:20 UTC
Yep.  The problem was that the driver never properly handled interrupts and I
broke the hack it was using.  Hopefully we can find a way to handle this
properly soon.
Comment 2 Bryan O'Sullivan 2006-11-09 07:53:53 UTC
Fixed in git.

Note You need to log in before you can comment on or make changes to this bug.