Bug 7454 - 3c59x (3cSOHO100-TX Hurricane) slow network bug
Summary: 3c59x (3cSOHO100-TX Hurricane) slow network bug
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Network (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Steffen Klassert
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-11-03 06:21 UTC by Jonas
Modified: 2007-09-18 00:16 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.18.1
Tree: Mainline
Regression: ---


Attachments

Description Jonas 2006-11-03 06:21:50 UTC
Most recent kernel where this bug did not occur: 2.6.15.6 (there could be a
later kernel which it works well with too). If you really need this information,
 just mail me (jonassa@gmail.com) and I will try every kernel and find the
latest working for you.
Distribution: Debian 
Hardware Environment:
00:00.0 Host bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333]
00:01.0 PCI bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333 AGP]
00:05.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
00:0d.0 Ethernet controller: 3Com Corporation 3cSOHO100-TX Hurricane (rev 30)
00:0f.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 08)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8233 PCI to ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:11.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 1b)
00:11.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 1b)
00:11.4 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 1b)
01:00.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200 PRO]
(rev 01)
01:00.1 Display controller: ATI Technologies Inc RV280 [Radeon 9200 PRO]
(Secondary) (rev 01)

Software Environment:
X11, firefox

Problem Description:
Comparing linux kernel 2.6.15.6 and 2.6.18 or 2.6.18.1,  the former works fine
while the latter ones do not. The problem is that the network is simply very
slow. I can never reach high download speeds, browsing is slow etc etc. If I
take the 2.6.15.6 kernel source code module and put it in the 2.6.18.1 tree and
compile a new kernel, I can run with a non-problematic network. Otherwise, I
have to run a 2.6.15.6 kernel in order to have a non-slow network. I think
12kB/ssecond was the faster download speed I had with the 2.6.18 kernel. With
the 2.6.15.6, I get my regular 900kb/s. 

Steps to reproduce:
- Use a computer with the 3c59x network card
- Notice the download speed with a 2.6.15.6 kernel
- Notice the download speed with a 2.6.18 kernel
Comment 1 Natalie Protasevich 2007-07-19 22:19:50 UTC
Is it working any better with 2.6.22+, or is the problem still there?
Thanks.
Comment 2 Jonas 2007-07-20 04:05:25 UTC
Hi,

I thought the author already fixed this bug???

Speak to the driver maintainer, not me, I do not use the network card
anymore..

Cheers

tor 2007-07-19 klockan 22:14 -0700 skrev
bugme-daemon@bugzilla.kernel.org:
> http://bugzilla.kernel.org/show_bug.cgi?id=7454
> 
> 
> protasnb@gmail.com changed:
> 
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                  CC|                            |protasnb@gmail.com
> 
> 
> 
> 
> ------- Comment #1 from protasnb@gmail.com  2007-07-19 22:19 -------
> Is it working any better with 2.6.22+, or is the problem still there?
> Thanks.
> 
> 
Comment 3 Steffen Klassert 2007-09-18 00:05:03 UTC
Fixed in 2.6.22.
Comment 4 Steffen Klassert 2007-09-18 00:16:32 UTC
Correction: Fixed in 2.6.23-rc1

Note You need to log in before you can comment on or make changes to this bug.