Bug 74131 - Kernel 3.14 ACPICA changes prevent kernel from booting on some motherboards
Kernel 3.14 ACPICA changes prevent kernel from booting on some motherboards
Status: CLOSED DUPLICATE of bug 73911
Product: ACPI
Classification: Unclassified
Component: ACPICA-Core
x86-64 Linux
: P1 normal
Assigned To: Lv Zheng
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-04-15 09:44 UTC by Spyros Stathopoulos
Modified: 2014-06-24 04:30 UTC (History)
2 users (show)

See Also:
Kernel Version: 3.14
Tree: Mainline
Regression: Yes


Attachments
Revert commits 671cc68-c14ced0 (46.43 KB, patch)
2014-04-15 09:44 UTC, Spyros Stathopoulos
Details | Diff
dmidecode output for Gigabyte B85-HD3 (21.25 KB, text/plain)
2014-04-15 09:47 UTC, Spyros Stathopoulos
Details

Description Spyros Stathopoulos 2014-04-15 09:44:03 UTC
Created attachment 132341 [details]
Revert commits 671cc68-c14ced0

Changes related to ACPICA that have been integrated in 3.14 break boot for some socket 1150/1155 motherboards. Archlinux (pretty much vanilla) kernel fails to boot after decompressing the image on select hardware.

This is probably related to BIOS issues as well as discussed in [1].

Non exhaustive affected hardware list:
Gigabyte B85-HD3
Gigabyte B85M-D3H
Gigabyte Z87P-D3
Gigabyte Z87X
Gigabyte Z87-HD3
Supermicro X9SAE-V

First problematic commit is 671cc68 [2]. Reverting commits 671cc68-c14ced0 makes booting possible again. Attached is the (crude) reverting patch against tag v3.14.

[1]: https://bugs.archlinux.org/task/39811
[2]: https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=671cc68dc61f029d44b43a681356078e02d8dab8
Comment 1 Spyros Stathopoulos 2014-04-15 09:47:13 UTC
Created attachment 132351 [details]
dmidecode output for Gigabyte B85-HD3
Comment 2 Lv Zheng 2014-04-16 00:34:56 UTC
Please track 73911, I'll post fix patch there.

*** This bug has been marked as a duplicate of bug 73911 ***
Comment 3 Lv Zheng 2014-04-16 02:06:42 UTC
Could you also help to do the tests listed in the following link:

https://bugzilla.kernel.org/show_bug.cgi?id=73911#c8
https://bugzilla.kernel.org/show_bug.cgi?id=73911#c13

This bug is urgent, we need your test result to track the root cause.

Thanks in advance.
Comment 4 Lv Zheng 2014-06-11 00:16:40 UTC
Shipped in Linux v3.15-rc7.
Closing.

Note You need to log in before you can comment on or make changes to this bug.