Bug 7408 - T60 stops triggering any ACPI events
T60 stops triggering any ACPI events
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: Drivers
Classification: Unclassified
Component: Platform
i386 Linux
: P2 normal
Assigned To: acpi_acpica-core@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-24 11:50 UTC by mst
Modified: 2010-10-08 18:18 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.19-rc3
Tree: Mainline
Regression: ---


Attachments
Here's my .config for 2.6.19 (43.20 KB, text/plain)
2006-10-24 11:52 UTC, mst
Details
Here's the config for 2.6.18.1 that works well (42.61 KB, text/plain)
2006-10-24 11:53 UTC, mst
Details
patch to ibm_acpi.c (962 bytes, patch)
2006-11-02 23:53 UTC, Len Brown
Details | Diff

Description mst 2006-10-24 11:50:08 UTC
Most recent kernel where this bug did not occur:2.6.18.1 + patch
http://lkml.org/lkml/2006/7/20/56

Distribution:kubuntu 6.06 LTS
Hardware Environment: T60 with intel graphics. See
                      http://www.thinkwiki.org/wiki/Hardware_Specifications
                      BIOS at default setting - disk running in ahci mode
                      (this is why I need a patch for 2.6.18).
Software Environment:
Not sure what to put here. Seems to happen both with and without X running.
Problem Description:

after I do a full kernel compile, my T60 stops triggering any ACPI events:
tail -f /var/log/acpid does not show anything, even on Fn/F4 which is supposed
to be always enabled.  Restarting the acpid doesn't do anything either - ACPI
starts working again, for a while, only after reboot.

Works fine in 2.6.18 ( + this patch http://lkml.org/lkml/2006/7/20/56).


Steps to reproduce:
cd tmp
git clone -s ~/scm/linux-2.6
cd linux-2.6

make oldconfig
make -j 4

no new ACPI events reported after this.
Comment 1 mst 2006-10-24 11:52:19 UTC
Created attachment 9338 [details]
Here's my .config for 2.6.19

I attached the .config for 2.6.19-rc3 with which I see the problem
Comment 2 mst 2006-10-24 11:53:36 UTC
Created attachment 9339 [details]
Here's the config for 2.6.18.1 that works well

I attached the .config for 2.6.18 (that works well) for reference
Comment 3 Martin Lorenz 2006-10-25 00:06:28 UTC
I see on my X60s too but triggered by suspend-to-ram/resume. kernel compiling
did not yet show this behaviour (but I diden't really check for I usually reboot
rather quickly after compiling/installing a new kernel)

the problem is there since the first post 2.6.18 version that I compiled a few
weeks ago.

currently I run 2.6.18 with some patches, which suspends/resumes fine.
Comment 4 mst 2006-10-25 23:52:29 UTC
Yes, I see this too if I do not enable
IB thinkpad laptop extras under PM/ACPI -
in that case, kernel compile does not trigger the bug,
but suspend/resume does.
Comment 5 Len Brown 2006-10-29 20:11:02 UTC
> Yes, I see this too if I do not enable
> IB thinkpad laptop extras under PM/ACPI -
> in that case, kernel compile does not trigger the bug

So the "no ACPI events after kernel build" regression
happens only if ibm_acpi is loaded?

> but suspend/resume does.

So ACPI events used to work in 2.6.18 after suspend/resume,
but do not work after suspend/resume in 2.6.19 -- and
this is true not matter if ibm_acpi is loaded or not?
Comment 6 mst 2006-10-30 05:27:49 UTC
> > Yes, I see this too if I do not enable
> > IB thinkpad laptop extras under PM/ACPI -
> > in that case, kernel compile does not trigger the bug
> 
> So the "no ACPI events after kernel build" regression
> happens only if ibm_acpi is loaded?

Yes, it seems so.

> > but suspend/resume does.
> 
> So ACPI events used to work in 2.6.18 after suspend/resume,
> but do not work after suspend/resume in 2.6.19 -- and
> this is true not matter if ibm_acpi is loaded or not?

This is true if ibm_acpi is not loaded. I did not test this with
ibm_acpi loaded.
Comment 7 Len Brown 2006-11-02 23:53:40 UTC
Created attachment 9401 [details]
patch to ibm_acpi.c

There has been only 1 small patch to ibm_acpi.c between 2.6.18.1
and now.  If you patch -Rp1 this commit, you'll be backing that
driver down to the version that worked in 2.6.18,
and the 2.6.19 run-time issue with ibm_acpi should go away -- yes?

However, it isn't clear that this simple patch to clear the experimental
flag could be the root of the run-time errors; and maybe we need to
re-confirm the assertion that the run-time (not the suspend-time) failure...
1. does not happen in 2.6.18 with ibm_acpi loaded
2. does not happen in 2.6.19 with ibm_acpi unloaded
3. only happens in 2.6.19 with ibm_acpi loaded
Comment 8 mst 2006-11-05 05:21:26 UTC
OK, it seems Linus has zeroed in on the bug:
http://lkml.org/lkml/2006/11/1/84

I am running f9dadfa71bc594df09044da61d1c72701121d802
and no issues yet in several days of use.

Note You need to log in before you can comment on or make changes to this bug.