Bug 7367 - Touchpad does not wake up after resuming
Touchpad does not wake up after resuming
Status: REJECTED DUPLICATE of bug 7977
Product: Drivers
Classification: Unclassified
Component: Input Devices
i386 Linux
: P2 normal
Assigned To: Dmitry Torokhov
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-15 20:53 UTC by Zak Peirce
Modified: 2007-02-18 09:54 UTC (History)
0 users

See Also:
Kernel Version: vanilla 2.6.19-rc2, beyond-sources 2.6.16, gentoo-sources 2.6.13
Tree: Mainline
Regression: ---


Attachments

Description Zak Peirce 2006-10-15 20:53:24 UTC
Most recent kernel where this bug did not occur:
Distribution: Gentoo
Hardware Environment: Gayeway 8510 GZ
Software Environment:
Problem Description:
After resuming from S3 suspending my touchpad does not resume.

Before i suspend i can see the touchpad

slacktop ~ #  cat /proc/bus/input/devices
I: Bus=0003 Vendor=045e Product=00e1 Version=0007
N: Name="Microsoft Microsoft Wireless Optical Mouse� 1.00"
P: Phys=usb-0000:00:1d.1-1/input0
S: Sysfs=/class/input/input0
H: Handlers=mouse0 event0 
B: EV=7
B: KEY=1f0000 0 0 0 0 0 0 0 0
B: REL=1c3

I: Bus=0011 Vendor=0001 Product=0001 Version=ab41
N: Name="AT Translated Set 2 keyboard"
P: Phys=isa0060/serio0/input0
S: Sysfs=/class/input/input1
H: Handlers=kbd event1 
B: EV=120013
B: KEY=4 2000000 3802078 f840d001 f2ffffdf ffefffff ffffffff fffffffe
B: MSC=10
B: LED=7

I: Bus=0011 Vendor=0002 Product=0007 Version=0000
N: Name="SynPS/2 Synaptics TouchPad"
P: Phys=isa0060/serio1/input0
S: Sysfs=/class/input/input2
H: Handlers=mouse1 event2 
B: EV=b
B: KEY=6420 0 70000 0 0 0 0 0 0 0 0
B: ABS=11000003

slacktop ~ # 

After resume i do not see the touchpad

slacktop ~ #  cat /proc/bus/input/devices
I: Bus=0011 Vendor=0001 Product=0001 Version=ab41
N: Name="AT Translated Set 2 keyboard"
P: Phys=isa0060/serio0/input0
S: Sysfs=/class/input/input1
H: Handlers=kbd event1 
B: EV=120013
B: KEY=4 2000000 3802078 f840d001 f2ffffdf ffefffff ffffffff fffffffe
B: MSC=10
B: LED=7

I: Bus=0003 Vendor=045e Product=00e1 Version=0007
N: Name="Microsoft Microsoft Wireless Optical Mouse� 1.00"
P: Phys=usb-0000:00:1d.1-1/input0
S: Sysfs=/class/input/input3
H: Handlers=mouse0 event0 
B: EV=7
B: KEY=1f0000 0 0 0 0 0 0 0 0
B: REL=1c3

slacktop ~ # 

I can see in dmesg that there is a notice saying that the device could not wake up

Oct 15 13:31:20 slacktop pnp: Device 00:06 does not supported activation.
Oct 15 13:31:20 slacktop pnp: Device 00:07 does not supported activation.

I have spoken to the developers of suspend2 and they say that it is a kernel
issue.  This issue occurs with Suspend 1 and with Suspend 2

Steps to reproduce:
1 - Use a Gateway 8510 GZ
2 - Configure a kernel with support for suspendin
3 - Issue the command to Suspend echo mem > /sys/power/state
4 - Resume

Expected result - The system resumes and every thing works

Actual Result - The system resumes but the touchpad does not work
Comment 1 Dmitry Torokhov 2007-02-18 09:54:38 UTC
Please apply all 3 patches from bug 7977 and let me know if it fixes your
touchpad. Thanks!

*** This bug has been marked as a duplicate of 7977 ***

Note You need to log in before you can comment on or make changes to this bug.