Bug 73491 - old root filesystem is not an initramfs: SUCCESS
Summary: old root filesystem is not an initramfs: SUCCESS
Status: RESOLVED INVALID
Alias: None
Product: Other
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: other_other
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-03 23:13 UTC by Peter Weber
Modified: 2014-04-08 09:56 UTC (History)
1 user (show)

See Also:
Kernel Version: 3.14
Tree: Mainline
Regression: No


Attachments

Description Peter Weber 2014-04-03 23:13:32 UTC
Hello!
The implementation of switch_root.c inside util-linux prints a warning caused by a check, most likely because it looks for the device number and not the filesystem type. As result some memory will be wasted for the initramfs, which is not needed after booting-up is completed.

Additional info:
* package version(s): util-linux <= 2.24.1-5 and linux >= 3.14
* discussion: https://bbs.archlinux.org/viewtopic.php?id=179422
* proposed patch by Dave Reisner: http://www.spinics.net/lists/util-linux-ng/msg09062.html


Reproduce:
Boot system with the implementation of switch_root.c from util-linux

Workarounds:
Use implementations from Systemd or BusyBox. Which work in a similiar way like the proposed patch.

Thank you
Bye
Comment 1 Peter Weber 2014-04-04 07:58:28 UTC
Bugreport (Downstream): https://bugs.archlinux.org/task/39734
Comment 2 Alan 2014-04-08 09:56:00 UTC
This doesn't appear to be kernel related

Note You need to log in before you can comment on or make changes to this bug.