Bug 7279 - sym2 still claims the 53C1510 integrated storage raid
Summary: sym2 still claims the 53C1510 integrated storage raid
Status: CLOSED CODE_FIX
Alias: None
Product: SCSI Drivers
Classification: Unclassified
Component: sym53c8xx (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Matthew Wilcox
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-10-06 18:34 UTC by Yanko Kaneti
Modified: 2007-08-01 00:44 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.18
Tree: Mainline
Regression: ---


Attachments
proposed additional fix (545 bytes, patch)
2006-10-13 16:29 UTC, Yanko Kaneti
Details | Diff

Description Yanko Kaneti 2006-10-06 18:34:33 UTC
In reference to http://bugs.debian.org/380272 about sym2 incorrectly claiming
the integrated storage raid of some compaq servers instead leaving it to cpqarray.

The fix thats already in the tree
http://www.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=b2b3c121076961333977f485f0d54c22121df920
is about PCI_DEVICE_ID_LSI_53C1510 0x000a but the bug report is about
PCI_DEVICE_ID_NCR_53C1510 0x0010. 
I have one such compaq here and sym2 still claims it with the latest post 2.6.18
kernel tree.

Perhaps the proper fix is to apply the same PCI_DEVICE_ID_LSI_53C1510 tweak to
PCI_DEVICE_ID_NCR_53C1510
Comment 1 Yanko Kaneti 2006-10-13 16:29:49 UTC
Created attachment 9246 [details]
proposed additional fix

The proposed additional fix that works for me here, as far as sym53c8xx_2
doesn't claim the cpqarray raid.
Comment 2 Natalie Protasevich 2007-07-23 23:58:50 UTC
It looks like the patch is in, the bug can be closed.
Thanks.
Comment 3 Yanko Kaneti 2007-07-24 00:45:21 UTC
Still not in the linus tree AFAICS
Comment 4 Natalie Protasevich 2007-07-24 08:09:07 UTC
Hmmm I see this in the latest git tree:


static struct pci_device_id sym2_id_table[] __devinitdata = {
        { PCI_VENDOR_ID_LSI_LOGIC, PCI_DEVICE_ID_NCR_53C810,
          PCI_ANY_ID, PCI_ANY_ID, 0, 0, 0UL },
        ...
        { PCI_VENDOR_ID_LSI_LOGIC, PCI_DEVICE_ID_NCR_53C815,
          PCI_ANY_ID, PCI_ANY_ID, 0, 0, 0UL },
        { PCI_VENDOR_ID_LSI_LOGIC, PCI_DEVICE_ID_LSI_53C810AP,
          PCI_ANY_ID, PCI_ANY_ID, 0, 0, 0UL }, /* new */
        { PCI_VENDOR_ID_LSI_LOGIC, PCI_DEVICE_ID_NCR_53C860,
          PCI_ANY_ID, PCI_ANY_ID, 0, 0, 0UL },
        { PCI_VENDOR_ID_LSI_LOGIC, PCI_DEVICE_ID_LSI_53C1510,
          PCI_ANY_ID, PCI_ANY_ID, PCI_CLASS_STORAGE_SCSI<<8,  0xffff00, 0UL },
         ...

I thought you were referring to this part for 53C1510?
Comment 5 Yanko Kaneti 2007-07-24 09:04:10 UTC
As my first comment explains this bug is about PCI_DEVICE_ID_NCR_53C1510 not PCI_DEVICE_ID_LSI_53C1510.

This patch is already in jejb's "Pending (but not finalised)" tree, still not in linus' tree. 
I can't really see what might be "not finalised" about this trivial one-liner which has been sitting on various mailing lists and bugzillas for 8-9 months now.
Comment 6 Andrew Morton 2007-07-24 13:06:12 UTC
The same patch has patch has been in my tree as sym53c8xx_2-claims-cpqarray-device.patch
for over a year.  It has been submitted to the maintainers ten times
and nothing has happened.

I'll aim to get this into 2.6.23.
Comment 7 Yanko Kaneti 2007-08-01 00:44:58 UTC
This finally landed. Thanks.

Note You need to log in before you can comment on or make changes to this bug.