Bug 7273 - X lockups when X is using AGP.
X lockups when X is using AGP.
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
i386 Linux
: P2 normal
Assigned To: drivers_video-dri
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-06 08:04 UTC by Andrew Clayton
Modified: 2007-01-31 08:55 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.18
Tree: Mainline
Regression: ---


Attachments
working xorg.conf (2.98 KB, text/plain)
2006-10-06 08:07 UTC, Andrew Clayton
Details
2.6.18 kernel config (23.60 KB, text/plain)
2006-10-06 08:08 UTC, Andrew Clayton
Details
MSI K8T Master2-Far (VIA K8T8000) testgart output (dual Opteron 244s) (283 bytes, text/plain)
2006-10-06 10:19 UTC, Stephen Olander Waters
Details

Description Andrew Clayton 2006-10-06 08:04:22 UTC
Most recent kernel where this bug did not occur:

Unknown, it's happened as long as I've had this machine, a year or so.

Distribution:

Fedora Core 5 (64bit)

Hardware Environment:

Single proc AMD64 3500 with 1GBRAM. AGP Radeon 9200SE using Xorg (7.0) radeon
driver.

Software Environment:

Kernel 2.6.18, Xorg 7.0 (latest update from FC 5)

Problem Description:

When using agp and DRI the X will lock up after a few minutes, Logging in over
the network and trying to kill/restart X generally results in the machine hanging.

Steps to reproduce:

With the above configuration X will lockup within minutes.


This problem has been discussed on LKML and has a Xorg bugzilla entry.

http://www.ussg.iu.edu/hypermail/linux/kernel/0609.2/1706.html
https://bugs.freedesktop.org/show_bug.cgi?id=6111

Today I tried the BusType PCI workaround and that seems to have stopped the hangs.

I'll attach my current working xorg.conf and kernel .config

If I was to comment out the Option "BusType" "PCI" I would get the hangs.
 
Really just putting this here to help track this issue...



Cheers,

Andrew
Comment 1 Andrew Clayton 2006-10-06 08:07:00 UTC
Created attachment 9171 [details]
working xorg.conf
Comment 2 Andrew Clayton 2006-10-06 08:08:53 UTC
Created attachment 9172 [details]
2.6.18 kernel config
Comment 3 Dave Jones 2006-10-06 08:13:22 UTC
Can you get http://www.codemonkey.org.uk/projects/agp/testgart.c and run that as
root, and paste the output ?
Comment 4 Andrew Clayton 2006-10-06 08:21:08 UTC
Sure, here you go.

version: 0.101
bridge id: 0x2821106
agp_mode: 0x1f000a09
aper_base: 0xe4000000
aper_size: 64
pg_total: 240896
pg_system: 240896
pg_used: 0
Setting up MTRR at base=0xe4000000 for 64MB.
entry.key : 0
entry.key : 1
Allocated 8 megs of GART memory
MemoryBenchmark: 1064 MB/s
MemoryBenchmark: 1008 MB/s
MemoryBenchmark: 1080 MB/s
Average speed: 1050 MB/s
Testing data integrity (1st pass): passed on first pass.
Testing data integrity (2nd pass): passed on second pass.
Comment 5 Dave Jones 2006-10-06 08:30:20 UTC
looks sane, punting to DRI
Comment 6 Stephen Olander Waters 2006-10-06 10:19:05 UTC
Created attachment 9173 [details]
MSI K8T Master2-Far (VIA K8T8000) testgart output (dual Opteron 244s)
Comment 7 Stephen Olander Waters 2006-10-06 13:11:05 UTC
$ cat /proc/mtrr
reg00: base=0x00000000 (   0MB), size=2048MB: write-back, count=1
reg01: base=0x7ff00000 (2047MB), size=   1MB: uncachable, count=1
reg02: base=0xf8000000 (3968MB), size=  32MB: write-combining, count=1
reg03: base=0xe8000000 (3712MB), size= 128MB: write-combining, count=2
Comment 8 Stephen Olander Waters 2006-10-26 07:04:37 UTC
The debian 2.6.18 kernel gave me a nice message yesterday stating that the AGP
aperture was too small. So, I went into the BIOS and made the aperture 64MB. X
now works with DRI over AGP. Yay.

-s
Comment 9 Andrew Morton 2007-01-30 23:53:11 UTC
Dave, is there something we can go here which is a bit more user-friendly
than just hanging up?

How come Debian manages to print that message and we don't?
Comment 10 Andrew Clayton 2007-01-31 02:46:02 UTC
I've revisited this. Although a few things have changed since I last tested,
including updated (from Fedora Core 6 updates) libdrm, Mesa,
xorg-x11-server-Xorg, xorg-x11-drv-ati, the kernel and my card has gone from a
9200 SE to a 9200 PRO. Unfortunately I can't remember exactly when I last tested
and which of the above components would have been in use.

The good news is that the current setup (with the AGP aperture size at 64MB, the
same as before), seems to be stable. AGP/DRI/Compiz, the 2.6.20-rc6 kernel
seemed OK and am currently testing the 2.6.19-1.2895.fc6 Fedora kernel (as
that's what most of the workstations are using around here).
Comment 11 Andrew Morton 2007-01-31 02:55:20 UTC
OK, thanks.  Can you please close off the bug if/when you think that's appropriate?
Comment 12 Andrew Clayton 2007-01-31 03:18:41 UTC
Sure, I'll give it to the end of the day.
Comment 13 Andrew Clayton 2007-01-31 08:55:18 UTC
OK this seems stable.

Note You need to log in before you can comment on or make changes to this bug.