Bug 7227 - fan stops working after one suspend/resume cycle
fan stops working after one suspend/resume cycle
Status: REJECTED DUPLICATE of bug 7122
Product: ACPI
Classification: Unclassified
Component: Power-Fan
i386 Linux
: P2 high
Assigned To: Konstantin Karasyov
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-29 02:08 UTC by john terragon
Modified: 2006-10-20 10:03 UTC (History)
0 users

See Also:
Kernel Version: 2.6.18
Tree: Mainline
Regression: ---


Attachments

Description john terragon 2006-09-29 02:08:53 UTC
Most recent kernel where this bug did not occur: 2.6.16.1

Distribution: Debian unstable

Hardware Environment: Compaq Presario 2800

Software Environment:

Problem Description:
The fan is ACPI driven and has
four levels of speed. After the bootstrap (but before
the first suspend/resume cycle) the fan works fine,
that is it goes up to the maximum level of speed as
the processor heats up. When I start the suspension
something strange happens: right when the atomic copy phase 
begins, the fan speeds up to the 4th level of speed all 
of a sudden and for no apparent
reason (this has never happened before). Apart from that, the
suspension seems to end regularly, but after the
resume the fan doesn't get past the 1st level of speed. The
peculiar thing is that everything seems to work (the
thermal zones register the temperature correctly, the
trippoints react to the variations of the
temperature....) but the speed of the fan that doesn't
pass the 1st level.

I noticed one difference between the
drivers/acpi/fan.c file of the kernel 2.6.16.1 and the
one of the kernel 2.6.18: acpi_fan_suspend and 
acpi_fan_resume functions have been added.
I modified fan.c so that these two functions don't do 
anything and the fan starts working again after any 
suspend/resume cycle.  

Steps to reproduce:
Just suspend to disk, when acpi_fan_suspend function in 
fan.c is called the fan speeds up to the maximum speed and 
never work again. (at least this is what happens on my laptop)
Comment 1 Konstantin Karasyov 2006-10-16 06:06:26 UTC
John,
Could you try patches from comments ## 37, 38 
http://bugzilla.kernel.org/show_bug.cgi?id=7122
These patches are against 2.6.18-rc6.
Comment 2 Konstantin Karasyov 2006-10-20 10:03:26 UTC

*** This bug has been marked as a duplicate of 7122 ***

Note You need to log in before you can comment on or make changes to this bug.