Bug 7225 - Video-related problems after S3 resume
Video-related problems after S3 resume
Status: CLOSED DOCUMENTED
Product: Power Management
Classification: Unclassified
Component: Other
i386 Linux
: P2 normal
Assigned To: Rafael J. Wysocki
:
: 2250 3203 3800 4123 4542 4919 6265 6784 6955 7015 7147 7857 9705 10988 11220 (view as bug list)
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2006-09-28 10:21 UTC by Rafael J. Wysocki
Modified: 2010-12-29 23:42 UTC (History)
16 users (show)

See Also:
Kernel Version: any
Tree: Mainline
Regression: No


Attachments

Description Rafael J. Wysocki 2006-09-28 10:21:29 UTC
It is impossible to make video work after a resume from RAM (S3 resume) on all
herdware configurations at the kernel level.  However, there is a userland tool
for that called s2ram (see http://en.opensuse.org/S2ram).  Please try to use it.
Comment 1 Rafael J. Wysocki 2006-09-28 10:23:29 UTC
*** Bug 3800 has been marked as a duplicate of this bug. ***
Comment 2 Rafael J. Wysocki 2006-09-28 10:25:53 UTC
*** Bug 2250 has been marked as a duplicate of this bug. ***
Comment 3 Rafael J. Wysocki 2006-09-28 10:31:51 UTC
*** Bug 3203 has been marked as a duplicate of this bug. ***
Comment 4 Rafael J. Wysocki 2006-09-28 16:14:43 UTC
*** Bug 4123 has been marked as a duplicate of this bug. ***
Comment 5 Rafael J. Wysocki 2006-09-28 16:31:10 UTC
*** Bug 4542 has been marked as a duplicate of this bug. ***
Comment 6 Rafael J. Wysocki 2006-09-29 09:39:57 UTC
*** Bug 6784 has been marked as a duplicate of this bug. ***
Comment 7 Rafael J. Wysocki 2006-09-29 09:51:24 UTC
*** Bug 6955 has been marked as a duplicate of this bug. ***
Comment 8 Rafael J. Wysocki 2006-09-29 09:55:40 UTC
*** Bug 7015 has been marked as a duplicate of this bug. ***
Comment 9 Pavel Machek 2006-10-08 13:29:06 UTC
*** Bug 7147 has been marked as a duplicate of this bug. ***
Comment 10 Daniel Drake 2006-10-11 20:08:49 UTC
Needs a s2ram patch to add me to the whitelist (will send in right now), works
great with my Dell Insipiron 640m, thanks!
Comment 11 Rafael J. Wysocki 2006-10-25 09:58:48 UTC
*** Bug 4919 has been marked as a duplicate of this bug. ***
Comment 12 Rafael J. Wysocki 2006-11-13 10:38:30 UTC
*** Bug 6265 has been marked as a duplicate of this bug. ***
Comment 13 Rafael J. Wysocki 2007-09-23 12:48:29 UTC
*** Bug 7857 has been marked as a duplicate of this bug. ***
Comment 14 Rafael J. Wysocki 2008-01-13 15:51:19 UTC
*** Bug 9705 has been marked as a duplicate of this bug. ***
Comment 15 Rafael J. Wysocki 2008-06-26 10:59:33 UTC
*** Bug 10988 has been marked as a duplicate of this bug. ***
Comment 16 Rafael J. Wysocki 2008-11-09 13:22:48 UTC
*** Bug 11220 has been marked as a duplicate of this bug. ***
Comment 17 Rafael J. Wysocki 2010-12-29 23:41:36 UTC
Time to update.

The original description is not valid any more.  It is possible to handle
suspend/resume of the graphics from the kernel if a KMS driver is used.

For KMS drivers, please report resume problems to their developers.

If you have hardware there's no KMS driver for, you may try s2ram, but this
is not guaranteed to work.

Closing.

Note You need to log in before you can comment on or make changes to this bug.