Bug 7195 - pc doesn't correctly shut down because of hda_intel
Summary: pc doesn't correctly shut down because of hda_intel
Status: CLOSED OBSOLETE
Alias: None
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA) (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Jaroslav Kysela
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-09-24 04:43 UTC by Mauro Sacchetto
Modified: 2012-05-12 01:42 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.24
Tree: Mainline
Regression: No


Attachments

Description Mauro Sacchetto 2006-09-24 04:43:31 UTC
Most recent kernel where this bug did not occur: [no t able to determinate]
Distribution: Slackware 10.2
Hardware Environment: Pentium 4 3200 - MOBO GigaByte 8AECXPD i925XE
Software Environment: KDE 3.5.4
Problem Description: I use Slackware 10.2 and current with different kernel of
2.6 branch. In both these cases, I'm not able to shut down correctly my pc, but
if and only if I use KDE. With other DE (as Fluxbox) or if I use only the
console, it works fine. But, if I enter in KDE, when I try to shut down my pc, I
receive the message: "Power down. Acpi_power_off called" and it's possibile
to turn the pc off only turnin' off the elettricity too. The on/off button 
doesn't work.
After a lot of investigations and recompilations of kernel, finally I discovered
the cause of this trouble. The origin of all is the module hda_intel, for my
sound card. If it's disabled, the pc shuts down correctly. If loaded, the pc
doesn't halt. I don't know if this is due to alsa modules or to KDE, but, in any
case, I've no problems If I use other DE as Fluxbox or if I work in console. So,
IMHO, there must be something hurting in the relationship between the hda_intel
module and the audio management in KDE (I mean aRTS).
I wrote do Bugzilla KDE (BUG no. 134480), bit having this answer:

------- Additional Comment #6 From Stephan Kulow 2006-09-24 11:07 -------
nope, it just means your kernel module is buggy indeed

I wrote to alsa-devel too.

Steps to reproduce: enter in KDE, and shutdown the pc with any command (halt,
poweroff, shutdown -h now)

Thanx
MS
Comment 1 Mauro Sacchetto 2006-09-25 07:34:35 UTC
Today I wrote to Alsa team too:
bug no. 2475.
Comment 2 Dan Carpenter 2006-11-25 00:41:02 UTC
Could you give one of the 2.6.19-rc kernels a test?  There were some changes
that might make a difference on this.

If that still doesn't work, could you post your attach your dmesg out?
Comment 3 Mauro Sacchetto 2006-12-01 05:00:36 UTC
Alle 09:43, sabato 25 novembre 2006, hai scritto:
> http://bugzilla.kernel.org/show_bug.cgi?id=7195
> ------- Additional Comments From error27@gmail.com  2006-11-25 00:41
> ------- Could you give one of the 2.6.19-rc kernels a test?  There were
> some changes that might make a difference on this.
> If that still doesn't work, could you post your attach your dmesg out?

I just installed the definite release of 2.6.19,
but I0ve the same problem. As temporary solution
to shut down fisically my pc. I put in rc.local_shutdown
the following lines:
rmmod -f snd_hda_intel
rmmod -f snd_hda_codec
I remember you that, if I work only in console 
or use a different WM that KDe, all works properly.
Only if I load KDE, after I'm not able to shutdown
properly my pc


Comment 4 Natalie Protasevich 2007-06-19 00:21:02 UTC
Mauro,
OK, you should definitely give it a shot with 2.6.22-rc4 and above. 
If you still have a problem, can you please get a trace with alt-sysrq-t - while the system is supposedly in shutdown - and attach it to the report.
Thanks.
Comment 5 Alexander Fieroch 2007-07-18 12:47:57 UTC
I've got the same problem with the hdaudio module still in kernel 2.6.22.
It's not a problem with kde. I'm running windowmaker with that problem, too. Unloading snd_hda_intel and snd_hda_codec before shutting down is a workaround for me.

Hardware environment: Pentium 4 3000 EM64T - Asus P5GD2 Premium mainboard
Software environment: Windowmaker 0.92.0 (debian SID)
Comment 6 Takashi Iwai 2007-07-23 03:26:35 UTC
The hardwares with such problems are usually the unknown devices, and the driver tries to probe it according to the BIOS information.  And, as you know, BIOS is often broken.

Check /proc/asound/card0/codec#* file to see what codec chip is there, and try various model module option for snd-hda-intel module as listed in ALSA-Configuration.txt.  Some of these presets may match better than BIOS setting.
Comment 7 Natalie Protasevich 2008-03-30 12:08:42 UTC
Does anyone have an update on this? Did you have chance to try suggested in #6?
Comment 8 Mauro Sacchetto 2008-03-30 12:09:13 UTC
   Questo account sar
Comment 9 Alexander Fieroch 2008-04-02 13:21:56 UTC
I have got the C-Media CMI9880 codec chip and added the line 'snd-hda-intel model=full_dig' to /etc/modules, but that doesn't work for me (kernel 2.6.24). rmmod before shutting down is working.

Note You need to log in before you can comment on or make changes to this bug.