Bug 7194 - ACPI related problems (Thermal, Fan, BIOS Bad State) with recent HP Laptops
ACPI related problems (Thermal, Fan, BIOS Bad State) with recent HP Laptops
Status: REJECTED DUPLICATE of bug 7122
Product: ACPI
Classification: Unclassified
Component: Power-Thermal
i386 Linux
: P2 high
Assigned To: Konstantin Karasyov
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-24 01:38 UTC by Christian Wache
Modified: 2007-02-15 22:52 UTC (History)
0 users

See Also:
Kernel Version: 2.6.18-suspend2
Tree: Mainline
Regression: ---


Attachments
dmesg output (24.81 KB, text/plain)
2006-09-24 01:43 UTC, Christian Wache
Details
dmidecode output (6.60 KB, text/plain)
2006-09-24 01:43 UTC, Christian Wache
Details
lspci -vv output (18.76 KB, text/plain)
2006-09-24 01:44 UTC, Christian Wache
Details
cat thermal zones (918 bytes, text/plain)
2006-09-24 01:44 UTC, Christian Wache
Details
acpidump (281.35 KB, text/plain)
2006-09-24 01:47 UTC, Christian Wache
Details
interrupts (698 bytes, text/plain)
2006-09-24 01:47 UTC, Christian Wache
Details

Description Christian Wache 2006-09-24 01:38:00 UTC
Most recent kernel where this bug did not occur: none AFAICT
Distribution: Gentoo
Hardware Environment: HP nx6325, AMD Turion X2, latest F.02 BIOS
Software Environment: 32-bit, SMP, preempt Kernel

Problem Description: 

This is meant as a collection of different bugs to have it all in one place. I
hope that's ok.
 
http://bugzilla.kernel.org/show_bug.cgi?id=6978
http://bugzilla.kernel.org/show_bug.cgi?id=7122
http://bugzilla.kernel.org/show_bug.cgi?id=5534
https://bugzilla.novell.com/show_bug.cgi?id=179702

wich are all related and fit exactly my problems. Which are:

- Thermal events won't get processed. Running CPU hogs won't result in higher
fan speed due to rising temperature. Thermal events won't get processed because
there simply are none until I do a cat /proc/acpi/thermal_zone/TZ*/*. Battery
state does trigger events and does get processed. So do lid switch and power botton.

Doing an echo 1 > /proc/acpi/thermal_zone/TZ1/polling_frequency results in no
updates of temps and fan state at all anymore.

The original F.00 BIOS had many DSDT related problems that showed during iasl
-dc but F.02 is much better with 0 errors and warnings (only a disassemble problem).

In 2.6.16 and ealier 2.6.17 kernels, without patching the only trip point that
got processed was the 105
Comment 1 Christian Wache 2006-09-24 01:43:04 UTC
Created attachment 9085 [details]
dmesg output
Comment 2 Christian Wache 2006-09-24 01:43:49 UTC
Created attachment 9086 [details]
dmidecode output
Comment 3 Christian Wache 2006-09-24 01:44:22 UTC
Created attachment 9087 [details]
lspci -vv output
Comment 4 Christian Wache 2006-09-24 01:44:49 UTC
Created attachment 9088 [details]
cat thermal zones
Comment 5 Christian Wache 2006-09-24 01:47:14 UTC
Created attachment 9089 [details]
acpidump
Comment 6 Christian Wache 2006-09-24 01:47:49 UTC
Created attachment 9090 [details]
interrupts
Comment 7 Konstantin Karasyov 2006-10-16 06:17:11 UTC
Pointing to thermal and fan:
Do the thermal/fan related problems persist with the patches in comments #159 
and #160 from bug #5534 and in comments #37 and #38 from bug #7122?
Comment 8 Christian Wache 2006-10-17 10:03:50 UTC
Thermal / fans are ok with patches in comments #159 and #160 from bug #5534.
Changed back to non-suspend kernel. So didn't test comments #37 and #38 from bug
#7122.
Comment 9 Konstantin Karasyov 2006-10-20 10:07:04 UTC
Did you have any luck trying suspend/resume patches from bug #7122
Comment 10 Christian Wache 2006-10-20 11:15:44 UTC
Sorry, no. Quite busy. I'll see if I can try it tomorrow.
Comment 11 Konstantin Karasyov 2006-10-25 01:51:07 UTC
Please note, that there were several updates for that bug. The patches you'll 
need are the following:
http://bugzilla.kernel.org/attachment.cgi?id=9255&action=view
http://bugzilla.kernel.org/attachment.cgi?id=9337&action=view
Comment 12 Konstantin Karasyov 2006-12-13 06:00:39 UTC
Since there is no responce from submitter, and patches are already available 
for described problems (refer to bug #7122, #7570), I'm setting the status of 
this bug to RESOLVED.
Please, re-open if problem persists with the patches from the above bugs 
applied.
Comment 13 Len Brown 2007-02-15 22:52:33 UTC

*** This bug has been marked as a duplicate of 7122 ***

Note You need to log in before you can comment on or make changes to this bug.