Bug 7188 - acpi_cpufreq causes 'swsusp' to fail
acpi_cpufreq causes 'swsusp' to fail
Status: CLOSED CODE_FIX
Product: ACPI
Classification: Unclassified
Component: Config-Processors
i386 Linux
: P2 normal
Assigned To: Rafael J. Wysocki
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-22 13:20 UTC by Ben Okopnik
Modified: 2007-04-28 12:49 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.18
Tree: Mainline
Regression: ---


Attachments
2.6.18 kernel .config (50.25 KB, text/plain)
2006-09-27 01:38 UTC, Mike Galbraith
Details
2.6.18 config file (after problem fix) (42.12 KB, text/plain)
2006-09-27 08:39 UTC, Ben Okopnik
Details

Description Ben Okopnik 2006-09-22 13:20:31 UTC
Most recent kernel where this bug did not occur:
Unknown ('swsusp' has not worked for me until now)

Distribution:
Debian unstable

Hardware Environment:
Acer Aspire 2010 laptop, Pentium M 1.5Ghz

Software Environment:
2.6.18 kernel

Problem Description:
When 'acpi_cpufreq' is loaded, issuing 'echo disk>/sys/power/state' results in
the following console message (among normal usb-related messages):
"Could not power down device `
Comment 1 Pavel Machek 2006-09-23 04:14:01 UTC
It seems that cpufreq has some problems with driver model... Name of device is
set incorrectly, at least. Strange thing is that it seems to work here..? I'd
like to cc gregkh, but gregkh@suse.de is unknown by bugzilla :-(.
Comment 2 Louis Garcia 2006-09-26 15:54:55 UTC
Am also experiencing this problem on FC6 with kernel-2.6.18
Comment 3 Greg Kroah-Hartman 2006-09-26 19:42:37 UTC
Pavel, <greg@kroah.com> works just fine here :)
Comment 4 Mike Galbraith 2006-09-27 01:38:40 UTC
Created attachment 9110 [details]
2.6.18 kernel .config
Comment 5 Ben Okopnik 2006-09-27 08:39:59 UTC
Created attachment 9112 [details]
2.6.18 config file (after problem fix)

Current (non-problem) config; the old one had CONFIG_CPU_FREQ set.
Comment 6 Pavel Troller 2006-09-29 06:16:50 UTC
The Clevo D610SU (known under many brands, here in CR it is Mironet 9610) 
notebook (P-4/2.4G, SIS chipset, Phoenix BIOS 4.06 dated 11/29/2002) exhibits 
the same behaviour. In addition, the following message occurs during boot:
acpi_processor-0742 [00] processor_preregister_: Error while parsing _PSD 
domain information. Assuming no coordination
There is no _PSD object in my DSDT.
Making the cpufreq driver modular and unloading it before the suspend attempt 
fixes the problem and the machine can be suspended.
It worked in 2.6.15, not tried anything between .15 and .18.
Comment 7 Rafael J. Wysocki 2006-10-30 10:18:32 UTC
Can you please test the 2.6.19-rc2-mm2 kernel?
Comment 8 Ben Okopnik 2006-11-09 05:03:48 UTC
On Mon, Oct 30, 2006 at 10:32:05AM -0800, bugme-daemon@bugzilla.kernel.org wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=7188
> 
> ------- Additional Comments From rjwysocki@sisk.pl  2006-10-30 10:18 -------
> Can you please test the 2.6.19-rc2-mm2 kernel?

I'm sorry, but I've come to hate patching kernels; I end up wandering
away from the main tree and being unable to just download a new kernel
and install it without major problems. :(  I'll wait for the next full
kernel release and give it a shot then, and will follow up here with the
results.

Comment 9 Rafael J. Wysocki 2006-11-15 04:55:29 UTC
This issue has been fixed in the Linus' tree and I'm unable to reproduce it on
my test boxes any more.

Note You need to log in before you can comment on or make changes to this bug.