Bug 7176 - Mach64 framebuffer console hangs when compiled with gcc 4.1
Mach64 framebuffer console hangs when compiled with gcc 4.1
Status: REJECTED UNREPRODUCIBLE
Product: Drivers
Classification: Unclassified
Component: Console/Framebuffers
i386 Linux
: P2 normal
Assigned To: James Simmons
:
Depends on:
Blocks: 7966
  Show dependency treegraph
 
Reported: 2006-09-21 05:41 UTC by Jernej Simončič
Modified: 2008-03-29 23:54 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.18
Tree: Mainline
Regression: ---


Attachments

Description Jernej Simončič 2006-09-21 05:41:22 UTC
Most recent kernel where this bug did not occur: ?
Distribution: Gentoo
Hardware Environment: 1) Compaq ProLiant ML330 G2 server [Pentium III 1066MHz] 
2) HP ML350G4 [Xeon 3GHz EM64T]
Software Environment:
Problem Description: I first noticed the problem with Gentoo's 2.6.16-r8 kernel 
on ML330 server (running Debian Etch, but with Gentoo kernel) - kernel compiled 
with GCC 4.0, worked fine, but when I recompiled the same kernel with gcc 
4.1.2, the kernel locks up at bootup, when it's supposed to switch to graphic 
console. I confirmed the same lockup with vanilla 2.6.18 kernel (which is why 
I'm reporting here).
The same thing also happens on ML350G4 server with kernel 2.6.17-gentoo-r8 
[running in 64bit mode] (previous kernel, compiled with gcc 3.4.6 works, but 
when recompiled with gcc 4.1.1, it too locks up in apparently the same way; 
unfortunately I'm not able to test with a vanilla kernel there).

Steps to reproduce: Enable Device Drivers -> Graphics support -> <*> Support 
for frame buffer devices -> <*> ATI Mach64 display support, [*]   Mach64 CT/VT/
GT/LT (incl. 3D RAGE) support, [*]   Mach64 GX support; compile with gcc 4.1.1 
or 4.1.2, boot.
Comment 1 Antonino Daplas 2007-04-28 16:53:27 UTC
Hmm, is this more of a compiler problem?  Have you reported this to the Gentoo
maintainers.

Anyway, do you have more information on this?
Comment 2 Natalie Protasevich 2007-07-04 12:03:10 UTC
Any updates on this problem?
I ran into several ones going to the gcc 4.1.1. Solutions mostly came down to removing certain flags that didn't work anymore or were causing problems with produced binaries.
Thanks.
Comment 3 Natalie Protasevich 2008-03-29 23:54:44 UTC
Closing the bug. Please reopen if shows up with latest kernels.

Note You need to log in before you can comment on or make changes to this bug.