Bug 7167 - Sky2 driver hangs when heavy load
Summary: Sky2 driver hangs when heavy load
Status: REJECTED DUPLICATE of bug 6839
Alias: None
Product: Drivers
Classification: Unclassified
Component: Network (show other bugs)
Hardware: i386 Linux
: P2 high
Assignee: Stephen Hemminger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-09-19 02:14 UTC by sebastien
Modified: 2006-09-20 10:21 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.17.1
Tree: Mainline
Regression: ---


Attachments

Description sebastien 2006-09-19 02:14:15 UTC
Hi everybody

My network card (pci-express marvell yukon 88E8053) use the new sky2 network driver.
The driver works fine when the load is not so huge but when the traffic
increases (ftp download...), the card hangs.

I just need to stop and restart the network service to use the network card again.

here is the output of dmesg when the card freezes

sky2 eth1: tx timeout
sky2 eth1: transmit ring 397 .. 356 report=399 done 399
sky2 status report lost?

Have you got an idea about the problem ?

seb.
Comment 1 Stephen Hemminger 2006-09-20 10:21:16 UTC
Same problem as earlier bug.
Most likely due to transmit flow control (see patch in other bug report)

*** This bug has been marked as a duplicate of 6839 ***

Note You need to log in before you can comment on or make changes to this bug.