Bug 7164 - ehci_hcd fails to init on warm reboot
ehci_hcd fails to init on warm reboot
Status: REJECTED UNREPRODUCIBLE
Product: Drivers
Classification: Unclassified
Component: USB
i386 Linux
: P2 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: USB
  Show dependency treegraph
 
Reported: 2006-09-17 08:26 UTC by Andy Wang
Modified: 2007-09-09 10:23 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.17.13 (gentoo 2.6.17-r8)
Tree: Mainline
Regression: ---


Attachments
dmesg output with CONFIG_USB_DEBUG during failure (24.66 KB, text/plain)
2006-09-19 18:55 UTC, Andy Wang
Details
dmesg output with debug on successful init (23.90 KB, application/octet-stream)
2006-09-19 19:11 UTC, Andy Wang
Details

Description Andy Wang 2006-09-17 08:26:03 UTC
Most recent kernel where this bug did not occur: 2.6.15.x
Distribution: Gentoo
Hardware Environment: 
   lspci output:
00:00.0 Host bridge: Advanced Micro Devices [AMD] AMD-760 MP [IGD4-2P] System
Controller (rev 11)
00:01.0 PCI bridge: Advanced Micro Devices [AMD] AMD-760 MP [IGD4-2P] AGP Bridge
00:07.0 ISA bridge: Advanced Micro Devices [AMD] AMD-766 [ViperPlus] ISA (rev 02)
00:07.1 IDE interface: Advanced Micro Devices [AMD] AMD-766 [ViperPlus] IDE (rev 01)
00:07.3 Bridge: Advanced Micro Devices [AMD] AMD-766 [ViperPlus] ACPI (rev 01)
00:07.4 USB Controller: Advanced Micro Devices [AMD] AMD-766 [ViperPlus] USB
(rev 07)
00:09.0 SCSI storage controller: LSI Logic / Symbios Logic 53c875 (rev 26)
00:0b.0 Ethernet controller: ADMtek NC100 Network Everywhere Fast Ethernet
10/100 (rev 11)
00:0c.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
00:0d.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:0d.1 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:0d.2 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:0d.3 USB Controller: ALi Corporation USB 2.0 Controller (rev 01)
01:05.0 VGA compatible controller: nVidia Corporation NV4 [RIVA TNT] (rev 04)

Dual Athlon MP 1600+ CPUs, 1GB RAM

Problem Description:
00:0d.3 USB Controller: ALi Corporation USB 2.0 Controller (rev 01)
  This is a PCI USB 2.0 card.  On a cold start (system powered off, the ehci_hcd
driver has no problems initializing it.  On a warm start (reboot, shutdown -r
for example) it fails to initialize with the following kernel errors:

ACPI: PCI Interrupt 0000:00:0d.3[A] -> GSI 17 (level, low) -> IRQ 16
ehci_hcd 0000:00:0d.3: EHCI Host Controller
ehci_hcd 0000:00:0d.3: new USB bus registered, assigned bus number 5
ehci_hcd 0000:00:0d.3: can't setup
ehci_hcd 0000:00:0d.3: USB bus 5 deregistered
ehci_hcd 0000:00:0d.3: init 0000:00:0d.3 fail, -110
ehci_hcd: probe of 0000:00:0d.3 failed with error -110
Comment 1 David Brownell 2006-09-19 12:53:29 UTC
The FAQ will remind you to report USB problems with CONFIG_USB_DEBUG 
set, so that interesting debug status gets reported.  :) 
 
FWIW I had an AMD 760-MPX system for a while, with an ALI card; 
it came up just fine in that situation, I rebooted it rather 
often when debugging. 
Comment 2 Andy Wang 2006-09-19 18:55:29 UTC
Created attachment 9052 [details]
dmesg output with CONFIG_USB_DEBUG during failure

Thanks for reminding me to enable debugging.  dmesg output with
CONFIG_USB_DEBUG enabled.  I'm assuming the relevant section begins at line
446.

I was able to reboot without any problems until sometime during the 2.6.16.x
kernels.
Comment 3 Andy Wang 2006-09-19 19:11:15 UTC
Created attachment 9053 [details]
dmesg output with debug on successful init

diffing the two outputs shows some differences, but I don't know how
significant they are.
Comment 4 Natalie Protasevich 2007-06-13 17:22:35 UTC
Andy,
Are you willing to try 2.6.22-rc4? There were fixes specifically in the USB shutdown area. Please use debug mode as before in case it is still a problem.
Thanks,
--Natalie
Comment 5 Andy Wang 2007-09-05 21:39:25 UTC
Sorry for not commenting on this earlier.  Unfortunately, I can't test this anymore.  I retired the server that had this problem and it's replacement has onboard USB 2.0 and I haven't seen this problem since then.  It's been about 9 months since I replaced the system.

Note You need to log in before you can comment on or make changes to this bug.