Bug 7147 - garbled video after resume from suspend on Dell Inspiron 4150 - ATI Radeon
garbled video after resume from suspend on Dell Inspiron 4150 - ATI Radeon
Status: REJECTED DUPLICATE of bug 7225
Product: Drivers
Classification: Unclassified
Component: Video(Other)
i386 Linux
: P2 high
Assigned To: drivers_video-other
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-11 09:07 UTC by Tyler Kinkade
Modified: 2007-04-28 12:49 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.15-26-386
Tree: Mainline
Regression: ---


Attachments
dmesg -s40000 output (21.64 KB, text/plain)
2006-09-11 09:09 UTC, Tyler Kinkade
Details
dmidecode output (14.77 KB, text/plain)
2006-09-11 09:09 UTC, Tyler Kinkade
Details
lspci -vv output (7.24 KB, text/plain)
2006-09-11 09:10 UTC, Tyler Kinkade
Details
cat /proc/interrupts output (575 bytes, text/plain)
2006-09-11 09:12 UTC, Tyler Kinkade
Details

Description Tyler Kinkade 2006-09-11 09:07:37 UTC
Most recent kernel where this bug did not occur: N/A
Distribution: Ubuntu 6.6
Hardware Environment: Dell Inspiron 4150 (laptop)
Software Environment: Ubuntu
Problem Description: Garbled video, large square mouse cursor, or no video
output at all after resume from suspend. Only option is to power-down by pulling
power.

Steps to reproduce: 
Suspend via log-off/quit menu, close lid, resume by opening lid.
Comment 1 Tyler Kinkade 2006-09-11 09:09:00 UTC
Created attachment 8986 [details]
dmesg -s40000 output
Comment 2 Tyler Kinkade 2006-09-11 09:09:46 UTC
Created attachment 8987 [details]
dmidecode output
Comment 3 Tyler Kinkade 2006-09-11 09:10:25 UTC
Created attachment 8988 [details]
lspci -vv output
Comment 4 Tyler Kinkade 2006-09-11 09:12:10 UTC
Created attachment 8989 [details]
cat /proc/interrupts output
Comment 5 Len Brown 2006-09-11 11:18:20 UTC
Video restore on resume is not part of ACPI.
The BIOS is responible for re-enabling the back-light,
and the graphics driver is responsible for re-enabling the video mode.


> 0000:01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility 
M7 LW [Radeon Mobility 7500] (prog-if 00 [VGA])

On this system, you want ty try the latest ATI Radeon driver.
Comment 6 Matthew Garrett 2006-09-27 16:17:28 UTC
This isn't a kernel issue at the moment, though I must disagree with Len's claim
that it's the BIOS's job to reenable the backlight - the spec doesn't require that.
Comment 7 Len Brown 2006-09-27 17:37:10 UTC
Matthew, 
The ACPI spec does not mention restoring the LCD backlight 
and video modes on resume from S3 because those functions 
have nothing at all to do with ACPI. 
 
However, independent of the ACPI spec, Intel's official guidance to 
BIOS writers is that they should restore the video backlight 
on resume form S3.  Windows doesn't require this because 
it always has a graphics driver.  Linux, however, does 
require this, since it may or may not have a graphics 
driver running. 
 
Vendors are welcome to listen or ignore Intel's guidance. 
However, if they want to ship Linux with a Centrino logo, 
they must listen, else they'll fail the brand compliance test. 
Of course, the number of laptop vendors that actually ship Linux 
installed at the factory and get the logo today is very small -- 
but hopefully it will grow. 
 
 
 
 
Comment 8 Tyler Kinkade 2006-09-28 10:06:09 UTC
Len,

Thank you for your suggestion re: graphic driver/bios. I believe I have the most
recent ati radeon driver for my card installed: xserver-xorg-driver-ati
1:6.5.7.3-0ubuntu7. (I have read that the ati fglrx does not support my video
card.) And I have the most recent vendor (DELL) supplied BIOS.

I was able to resume successfully from suspend via a shell script that employs
vbetool; however, I have no idea how to incorporate that into the existing acpi
suspend/resume scripts due to my noobishness.

Where is the most appropriate place to file a bug for this issue please? Is this
a graphic driver issue? An acpi issue? A distro issue?

Thank you in advance.
Comment 9 Rafael J. Wysocki 2006-09-29 10:02:56 UTC
You may want to try the s2ram tool (see http://en.opensuse.org/S2ram).
Comment 10 Pavel Machek 2006-10-08 13:17:28 UTC
If vbetool helps, s2ram should work. If not, contact suspend-devel@sf...
Comment 11 Pavel Machek 2006-10-08 13:28:50 UTC

*** This bug has been marked as a duplicate of 7225 ***

Note You need to log in before you can comment on or make changes to this bug.