Bug 7136 - Ide driver piix.c does not implement suspend/resume. Resume from ram suspend takes 30 seconds waiting for HD to spin up - piix.c doesn't implement resume/suspend.
Ide driver piix.c does not implement suspend/resume. Resume from ram suspend ...
Status: REJECTED DUPLICATE of bug 7135
Product: IO/Storage
Classification: Unclassified
Component: IDE
i386 Linux
: P2 normal
Assigned To: Alexey Dobriyan
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-09 17:21 UTC by Sheer
Modified: 2006-09-10 08:27 UTC (History)
0 users

See Also:
Kernel Version: 2.6.16 and 2.6.18 (probably all)
Tree: Mainline
Regression: ---


Attachments

Description Sheer 2006-09-09 17:21:03 UTC
Most recent kernel where this bug did not occur: 2.6.18-rc3
Distribution: Suse Linux Enterprise Desktop 10 
Hardware Environment: Sony Vaio A-190 Laptop (686)
Software Environment:
Problem Description:

I can suspend to ram either using Suse's powersave daemon or from the
commandline using s2ram.  As a specific example I can use 's2ram -r -f' to
suspend my machine.  When I hit a key to wake it the screen comes back to life
and (when using powersave) some text is displayed (saying processes will be
restarted).  The machine then sits there for 30 seconds before coming back to
life.  Also, even after it comes back to life I can use the disk for a few
seconds but then suddenly all disk access stalls for another period (10-30 secs,
never timed it) and then I can hear the disk whir up and respond again.  From
the suspend-devel mailing list I found out that most machines resume from a
suspend to ram in 2-4 seconds which is definately much more desirable.

I have discussed this at length on the suspend mailing list and the developers
there believe it is a problem with the piix.c driver and my particular ide
chipset (??):

http://sourceforge.net/mailarchive/message.php?msg_id=36301041

I tried using 2.6.18-rc3 with a single patch from the mm2 tree:

ftp://ftp.kernel.org/pub/linux/kernel/people/akpm/patches/2.6/2.6.18-rc3/2.6.18-rc3-mm2/broken-out/ide-reprogram-disk-pio-timings-on-resume.patch

This was supposed to add suspend/resume support at the level of the general ide
drivers but it did not resolve my issue.

The consensus on the suspend-devel mailing list that this is an ide timeout issue.


Steps to reproduce:

Run 's2ram -r -f' only any kernel using the piix driver.  This might be a bios
issue.  It might be that my bios is not good at restarting the ide subsystem
while others are so this might not show up for every card using the piix driver
but it does so on mine.

I would be glad to help test any fixes.
Comment 1 Alexey Dobriyan 2006-09-10 08:27:15 UTC

*** This bug has been marked as a duplicate of 7135 ***

Note You need to log in before you can comment on or make changes to this bug.