Bug 71001 - Battery not charging (Asus EeePC 1015PW)
Battery not charging (Asus EeePC 1015PW)
Status: CLOSED INVALID
Product: ACPI
Classification: Unclassified
Component: Power-Battery
i386 Linux
: P1 high
Assigned To: acpi_power-battery
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-22 17:27 UTC by thibaut.verron
Modified: 2014-06-16 16:57 UTC (History)
2 users (show)

See Also:
Kernel Version: 3.13
Tree: Mainline
Regression: Yes


Attachments
cat /sys/class/power_supply/BAT0/uevent (455 bytes, text/plain)
2014-02-22 17:27 UTC, thibaut.verron
Details
cat /sys/class/power_supply/AC0/uevent (44 bytes, text/plain)
2014-02-22 17:28 UTC, thibaut.verron
Details
acpidump (232.30 KB, text/plain)
2014-02-22 17:29 UTC, thibaut.verron
Details
BAT0/uevent 29 december 2013 (461 bytes, text/plain)
2014-02-22 19:13 UTC, thibaut.verron
Details
BAT0/uevent from mid feb 2014 (last before the battery stopped charging) (455 bytes, text/plain)
2014-02-22 19:14 UTC, thibaut.verron
Details

Description thibaut.verron 2014-02-22 17:27:31 UTC
Created attachment 127041 [details]
cat /sys/class/power_supply/BAT0/uevent

Hi,

Since a few days now, my battery isn't charging when plugged. The AC adapter is detected (at least I suppose it is... there is basically no way I can test with the adapter unplugged), and the battery appears to be "charging", both in the KDE power management applet and in /sys/class/BAT0.

The load level doesn't change though, and while it is non zero (15% in the GUI applet), unplugging the AC adapter turns the computer off immediately. It is then impossible to turn it back on without replugging the AC adapter (nothing moves when pressing the button).

The problem seems to have appeared with some update in kernel 3.13, sadly I cannot be more precise: I remember using the computer on battery a few times, but I don't usually check that it charges correctly. And to complicate things more, I didn't use the computer much this week.

However, I can state with 99% certitude that the battery successfully went from 0 (sudden power-off) to almost full (reported 95%) less than 10 days ago.

I cannot rule out hardware failure, however from what I can find in various place, battery failures usually don't happen all of a sudden. I still had good to decent autonomy a few weeks ago. Also, would the battery still provide values if it was dead?

Thank you,

Thibaut
Comment 1 thibaut.verron 2014-02-22 17:28:56 UTC
Created attachment 127051 [details]
cat /sys/class/power_supply/AC0/uevent
Comment 2 thibaut.verron 2014-02-22 17:29:22 UTC
Created attachment 127061 [details]
acpidump
Comment 3 thibaut.verron 2014-02-22 19:13:26 UTC
Created attachment 127091 [details]
BAT0/uevent 29 december 2013

Hm, sorry. After rereading the info from BAT0, it looks like the battery has gone below its minimal voltage, and thus cannot recharge.

In this case, the problem would have occurred in the last few days, after adding acpi_osi=\"\" to my kernel parameters (to fix another issue with backlight). This change increased my autonomy by a lot (60-90 minutes), but the computer ended shutting down at 30% reported charge.
However, it did recharge correctly afterwards, and started showing the current behavior in the following days.

I attach a snapshot of BAT0/uevent from the end of december 2013, for comparison. The CHARGE_FULL was lower, and the VOLTAGE_CURRENT higher.
Comment 4 thibaut.verron 2014-02-22 19:14:47 UTC
Created attachment 127101 [details]
BAT0/uevent from mid feb 2014 (last before the battery stopped charging)

And this one is a snapshot I took just after the computer powered-off last week, and after a full recharge.
Comment 5 thibaut.verron 2014-02-23 21:36:03 UTC
After further investigation, it looks like a purely hardware failure.

Sorry for the useless report.

Note You need to log in before you can comment on or make changes to this bug.